Support » Allgemeine Fragen » Nachfrage: Wie lässt sich eine CSS Datei einer externen Seite entfernen?

  • Gelöst lasse0815

    (@lasse0815)


    Hallo zusammen,

    das Thema wurde im Forum hier schon als gelöst gekennzeichnet. Es geht um das Entfernen der Google-Fonts aus OceanWP. Vielleicht erinnert ihr euch noch @ebody und @pixolin.

    Wie im Link beschrieben habe ich im Customizer die google-fonts deaktiviert. Leider verwies die Seite an zwei Stellen immer noch auf fonts.googleapis.com. Einen Verweis habe ich gefunden, der resultierte daraus, dass unter „OceanWP-Settings“ -> Menu -> Typography die „Font Family“ auf „Default“ war. Das habe ich auf Arial umgestellt.

    Nur den letzten Verweis finde ich nicht.

    Kann mir bitte jemand helfen??

    Danke, Lasse

    • Dieses Thema wurde geändert vor 1 Monat, 1 Woche von lasse0815.

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 18)
  • Ganz simple Frage: hast du nach den Anpassungen mal den Cache deines Cache-Plugins geleert?

    Anscheinend wird noch der Link zum Stylesheet eingebunden, ohne dass die Schriftart Roboto aber genutzt wird.

    Thread-Ersteller lasse0815

    (@lasse0815)

    Ja, danke, habe ich schon gemacht. Habe nun sogar mal das Cache Enabler-Plugin deaktiviert. Hilft nichts…

    Ich vermute, dass das von Elementor eingefügt wird.

    Probier doch mal bitte folgenden Code aus (entweder in der functions.php eines Child-Themes oder mit dem Plugin Code Snippets):

    add_filter( 'elementor/frontend/print_google_fonts', '__return_false');
    (Quelle: Elementor)

    wenn das nicht klappt, probier mal das hier;

    add_action( 'wp_enqueue_scripts', 'remove_google_font' );
    function remove_google_font() {
      wp_dequeue_style( 'google-fonts-1-css' );
    }

    Hm, jetzt wird wieder vom Theme ein Font eingebunden.

    add_action( 'wp_enqueue_scripts', 'remove_google_font' );
    function remove_google_font() {
      wp_dequeue_style( 'google-fonts-1-css' );
      wp_dequeue_style( 'oceanwp-google-font-roboto-css' );
    }
    Thread-Ersteller lasse0815

    (@lasse0815)

    Habe beides versucht. Durch den Code 2 wird sogar noch eine zweite css?family=Roboto hinzugefügt.

    Von ELementor hatte ich ursprünglich auch für zwei verschiedene Schriftarten Verweise drin (War nicht zu googleapis sondern eine andere Google Quelle). Durch mühevolle Kleinarbeit habe ich alle Google-Schriften in Arial geändert. Daher kann es also eigentlich nicht kommen.

    Irgendwie muss das aus den Untiefen von OceanWP kommen…

    Wie du die Wigets formatierst, hat nichts damit zu tun, welche Stylesheets Elementor einbindet: https://plugins.trac.wordpress.org/browser/elementor/trunk/includes/frontend.php#L879

    Meine letzte Antwort hast du gesehen?

    Thread-Ersteller lasse0815

    (@lasse0815)

    Oh, da haben wir uns überschnitten. Jetzt habe ich auch die letzte Antwort versucht. Es bleibt bei 2 Verweisen.

    Was mich wundert, ist, dass im Quellcode Zeile 49 steht:
    <link rel=’stylesheet‘ id=’oceanwp-google-font-roboto-css‘ href=’//fonts.googleapis.com/css?family=Roboto%3A100%2C200%…

    und in Zeile 9:

    <meta name=“viewport“ content=“width=device-width, initial-scale=1″><link rel=’dns-prefetch‘ href=’//fonts.googleapis.com‘ />

    Aber ehrlich gesagt, kann ich damit nichts anfangen.

    Ich bin übrigens im Child-Theme. Nur zur Sicherheit: Die Änderungen in der functions.php mache ich dort, richtig? Also unter …/wp-content/themes/oceanwp-child-theme-master/functions.php

    • Diese Antwort wurde geändert vor 1 Monat, 1 Woche von lasse0815.

    Ja, genau.

    Die Zeile mit dem Link zum Stylesheet wird von OceanWP hier eingebunden:

    https://themes.trac.wordpress.org/browser/oceanwp/3.0.7/inc/customizer/controls/typography/webfonts.php#L114

    Thread-Ersteller lasse0815

    (@lasse0815)

    Vielen Dank schonmal für deine Mühe. Ich check es einfach nicht. Hab jetzt alles wieder rausgeschmissen aus der functions.php. Es bleibt bei einem Verweis zu Roboto (fonts.googleapis.com).

    Wenn ich auch bei Elementor wieder eine Google-Schriftart nehme, dann kommt ein neuer Verweis unter zu „fonts.gstatic.com“ zusätzlich zu „fonts.googleapis.com“.

    Ich hab ja auch schon versucht, die Schriften lokal einzubinden. Aber dadurch ändert sich auch nichts.

    Hier eine korrigierte Fassung:

    add_action( 'wp_enqueue_scripts', 'remove_google_font', 9999 );
    function remove_google_font() {
      wp_dequeue_style( 'google-fonts-1' );
      wp_dequeue_style( 'oceanwp-google-font-roboto' );
    }

    Das -css wird wohl automatisch angehängt.

    Thread-Ersteller lasse0815

    (@lasse0815)

    Es hat sich was getan, die ehem. Zeile 9 ist korrigiert.

    Aber Zeile 49 (jetzt Zeile 77) verweist immer noch auf fonts.googleapis.com

    Das hätte eigentlich schon durch
    add_filter( 'elementor/frontend/print_google_fonts', '__return_false');
    verschwinden sollen.

    Wenn alle Stricke reißen: Es gibt auch Plugins für diesen Zweck.

    Zum Beispiel:

    https://de.wordpress.org/plugins/disable-remove-google-fonts/
    https://de.wordpress.org/plugins/host-webfonts-local/

    Thread-Ersteller lasse0815

    (@lasse0815)

    Wooohoooo! Großartig! Mit dem
    add_filter( 'elementor/frontend/print_google_fonts', '__return_false');
    geht es!!! Tausend, ach was Hunderttausend Dank!!!

    Noch eine Ergänzung: Ich brauche in Elementor (kein Pro) als einziges „Amatic SC bold“ aus den Google-Fonts. Ich kann die aber nicht lokal mit @font-face in der style.css einbinden. Ist das nun nicht mehr möglich oder mache ich da noch einen Fehler?

    Danke nochmal,
    Lasse

    Thread-Ersteller lasse0815

    (@lasse0815)

    @la-geek Vielen Dank für deinen Hinweis. Tatsächlich hatte ich beide Plugins schon als allererstes versucht. Ohne Erfolg.

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 18)