Support » Allgemeine Fragen » Netzwerkverwaltung nicht mehr erreichbar

  • Hallo,

    ich habe eine Multisite erstellt mit 2 Subdomains. Ich kann mich seit heute plötzlich nicht mehr in meiner Netzwerkverwaltung anmelden. WordPress will ständig mein Benutzername und PW, aber trotzdem komme ich dort nicht rein. Ich habe das Plugin-Verzeichnis zwischendurch auf meinem ftp Server auch mal auf no.plugins geändert, trotzdem geht es nicht. Ich kann weder auf meine themes noch auf meine plugins.

    Das ist meine .htaccess:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]

    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ – [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]

    Ist hier irgendwas falsch?

    Danke schonmal für eure Vorschläge.

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 22)
  • Wahrscheinlich gibt es da Probleme mit der Art und Weise, wie WordPress die Cookies setzt. Probier mal, die Cookies deiner Website zu löschen und zusätzlich zum Multisite-Block in der wp-config.php folgendes einzutragen:

    define( 'ADMIN_COOKIE_PATH', '/' );
    define( 'COOKIEPATH', '' );
    define( 'SITECOOKIEPATH', '' );

    Schau mal, ob du dich danach im Backend anmelden kannst und ob weiterhin Änderungen im Customizer möglich sind, ohne dass zu Meldungen zu einer fehlenden Berechtigung erhältst.

    Leider hat das nicht funktioniert. Gibt es noch eine andere Möglichkeit? Hier auch mal meine wp-config.php ab dem Multisite-Block, ist hier vielleicht etwas falsch eingetragen?

    define( 'WP_DEBUG', false );
    define('WP_ALLOW_MULTISITE', true);
    
    define('MULTISITE', true);
    define('SUBDOMAIN_INSTALL', false);
    define('DOMAIN_CURRENT_SITE', 'hesse-media.com');
    define('PATH_CURRENT_SITE', '/');
    define('SITE_ID_CURRENT_SITE', 1);
    define('BLOG_ID_CURRENT_SITE', 1);
    define('COOKIE_DOMAIN', '');
    define( 'ADMIN_COOKIE_PATH', '/' );
    define( 'COOKIEPATH', '' );
    define( 'SITECOOKIEPATH', '' );
    
    /* Das war’s, Schluss mit dem Bearbeiten! Viel Spaß. */
    /* That's all, stop editing! Happy publishing. */
    
    define('WP_HOME','https://hesse-media.com');
    define('WP_SITEURL','https://hesse-media.com');
    
    /** Der absolute Pfad zum WordPress-Verzeichnis. */
    if ( ! defined( 'ABSPATH' ) ) {
    	define( 'ABSPATH', dirname( __FILE__ ) . '/' );
    }
    
    /** Definiert WordPress-Variablen und fügt Dateien ein.  */
    require_once( ABSPATH . 'wp-settings.php' );
    • Diese Antwort wurde geändert vor 8 Monaten, 3 Wochen von Bego Mario Garde. Grund: Bitte künftig Code formatieren

    Nimm mal die beiden Zeilen

    define('WP_HOME','https://example.com');
    define('WP_SITEURL','https://example.com');

    raus. Grundsätzlich bitte die Zeilen

    /* Das war’s, Schluss mit dem Bearbeiten! Viel Spaß. */
    /* That’s all, stop editing! Happy publishing. */

    beherzigen, sonst erschwerst du unnötig die Wartung.

    Hattest du die Cookies im Browser gelöscht?

    Die Zeilen habe ich entfernt, Cookies immer wieder gelöscht, trotzdem komme ich nicht in die Netzwerkverwaltung. 🙁

    OK. Ergänz mal die Einträge in der wp-config.php mit einer weiteren Zeile:

    define( 'WP_ALLOW_REPAIR', true );

    Danach rufst du bitte folgende Seite (mit deiner Domain) auf:

    https://example.com/wp-admin/maint/repair.php

    Dort klickst du auf den unteren Button „Reparieren und Optimieren“.

    Ideal wäre, wenn du vorher ein Backup der Datenbank machst.

    Ich hab jetzt nochmal rasch bei einer anderen Website nachgeschaut. Dort hatte ich nach ähnlichen Problemen statt

    define('COOKIE_DOMAIN', '');
    define( 'ADMIN_COOKIE_PATH', '/' );
    define( 'COOKIEPATH', '' );
    define( 'SITECOOKIEPATH', '' );

    nur folgendes eingetragen:
    define( 'COOKIE_DOMAIN', $_SERVER['HTTP_HOST'] );

    Sollte das auch nicht weiterhelfen, könntest du mal probieren, die Plugins durch Umbenennen des Verzeichnisses wp-content/plugins zu deaktivieren (du musst sie dann später nach erneutem Umbenennen des Verzeichnisses in wp-content/plugins wieder einzeln aktivieren).

    Ich habe jetzt zunächst den 2 Teil deiner Lösungsvorschläge versucht, leider kein Erfolg.
    Dann habe ich versucht die Datenbank zu reparieren und zu optimieren. Hier hat er sofort bei sämtlichen Tabellen herausgegeben, dass diese in Ordnung sind und eine Optimierung nicht erfolgen kann: „Fehler: Table does not support optimize, doing recreate + analyze instead“

    Jetzt verzweifel ich dann aber…

    Wie sieht’s denn mit den Plugins aus?
    Die hast du offensichtlich noch nicht deaktiviert?

    Diese „Fehlermeldung“ kannst du getrost vergessen.

    „Fehler: Table does not support optimize, doing recreate + analyze instead“

    =

    Tabelle unterstützt keine Optimierung, stattdessen wird „Neu erstellen + Analysieren“ ausgeführt

    Deine Datenbank benutzt die „InnoDB storage engine“, damit kann man kein Optimize auführen. Statt dessen wird eine Kopie der Tabelle erzeugt, diese geprüft und wenn kein Fehler vorliegt, wird die alte Tabelle gelöscht. Bei deiner Datenbank ist also alles ok.

    Doch Plugins sind deaktiviert und die Zeile
    define( ‚COOKIE_DOMAIN‘, $_SERVER[‚HTTP_HOST‘] );
    ist in der wp-config.
    Soll ich nun nochmal den Schritt mit dem reparieren versuchen? Das hatte ich vorhin zuerst versucht.

    Soll ich nun nochmal den Schritt mit dem reparieren versuchen?

    Nein, siehe 2 Beiträge vorher

    Zur Datenbank hat dir @bscu gerade schon was geschrieben. Die scheint dann ja soweit in Ordnung zu sein.

    Interessant wäre, ob WordPress etwas in den Error-Log schreibt.
    Füg doch mal in der wp-config.php oberhalb von „stop editing …“ folgendes ein:

    define( 'WP_DEBUG', true );
    define( 'WP_DEBUG_DISPLAY', false );
    define( 'WP_DEBUG_LOG', true );

    Schau dann mal bitte nach, ob nach einer erfolglosen Anmeldung etwas in die Datei wp-content/debug.log geschrieben wird.

    Über welche URL meldest du dich an?

    Es wird in der Datei wp-content keine debug.log erzeugt.

    Ich melde mich zunächst über diese URL an:
    https://www.hesse-media.com/wp-login.php

    Nachdem ich dann auf Netzwerkverwaltung klicke, öffnet sich diese URL:
    https://www.hesse-media.com/wp-login.php?redirect_to=https%3A%2F%2Fhesse-media.com%2Fwp-admin%2Fnetwork%2F&reauth=1

    und ich muss ich nochmals anmelden – vergeblich.

    In dieser URL stimmt was nicht:

    https://www.example.com/wp-login.php
    … melde dich über www an

    redirect_to=https%3A%2F%2Fexample.com%2Fwp-admin%2Fnetwork%2F&reauth=1
    … ich wurde weitergeschickt von der Adresse ohne www

    Schau mal in der Datenbank nach, was dort in wp_options unter siteurl und home eingetragen ist.

    Hast du in der .htaccess Weiterleitungsregeln eingetragen oder ist das, was du in deine ursprüngliche Frage kopiert hast alles?

    Unter options und home ist jeweils meine Seite mit www eingetragen. In der .htaccess habe ich keine Weiterleitungsregeln eingetragen, dass was ich kopiert habe war alles.

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 22)
  • Das Thema „Netzwerkverwaltung nicht mehr erreichbar“ ist für neue Antworten geschlossen.