Support » Allgemeine Fragen » Neue Frage: Umstellung Website PHP7.4 auf PHP 8.0 –> Leere Seite

  • Hallo,
    ich habe leider ein ähnliches Problem mit Strato und (aktuelle 7.4. –> Umstellung auf höhere Version z. B. 8.0 Seite nicht aufrufbar ;-(

    Habe alles wie hier beschrieben geändert, leider ohne Erfolg.
    ———
    `Hallo,
    noch ein Versuch: Hast du evtl. eine wp-config-sample.php?

    Wenn ja, dann

    lade die wp-config.php auf deinen lokalen Rechner,
    benenne diese aktuelle wp-config.php in wp-config_sik.php um,
    trage in die wp-config-sample.php die Zugangsdaten ein,
    erstelle die SALT-Keys neu,
    trage die geänderten SALT-Keys in die wp-config-sample.php
    und benenne diese Datei in wp-config.php um.

    Da ich davon ausgehe, dass du die gerade geänderten Änderungen lokal durchgeführt hast, musst du die wp-config.php noch hochladen.

    Viele Grüße
    Hans-Gerd`

    ———————–

    Habe auch ein wp-config-sample.php,
    aber wenn ich es richtig verstehe müsste ich in der alten
    wp-config.php nur die SALT-Keys
    neu erstellen und tauschen und wieder auf den Serverladen, oder?
    oder habe ich da was Mißverstanden?

    Stelle ich bei meinem Hoster vorher auf PHP 8.0 mit aktivierten Boost um?

    Kann ich in der wp-config den alten von mir erstellten Datenbanktabellen-Präfix behalten oder muss ich den auch wenn erneuern?

    /**
    * WordPress Datenbanktabellen-Präfix
    *
    * Wenn du verschiedene Präfixe benutzt, kannst du innerhalb einer Datenbank
    * verschiedene WordPress-Installationen betreiben.
    * Bitte verwende nur Zahlen, Buchstaben und Unterstriche!
    */
    $table_prefix = ‚wp_XYZ ‚;

    Vielen Dank für Eure Hilfe!

    • Dieses Thema wurde geändert vor 1 Woche, 1 Tag von Angelika Reisiger.
    • Dieses Thema wurde geändert vor 1 Woche, 1 Tag von cmuc.
    • Dieses Thema wurde geändert vor 1 Woche, 1 Tag von cmuc.
    • Dieses Thema wurde geändert vor 1 Woche, 1 Tag von cmuc.
    • Dieses Thema wurde geändert vor 1 Woche, 1 Tag von cmuc.
Ansicht von 5 Antworten - 1 bis 5 (von insgesamt 5)
  • Moderator Angelika Reisiger

    (@la-geek)

    Abgetrennt von https://de.wordpress.org/support/topic/wp-6-1-1-laeuft-nicht-mit-php-8-0-minimalinstallation/

    @cmuc
    Aus unseren Foren-Regeln:

    Punkt A) 8.

    Eine Frage = Ein Thread (Thema)
    Bitte nutzt einen eigenen Thread für neue Fragen. Auch wenn das Thema gleich erscheint. Es gibt nur ein „Gelöst“ pro Thread.

    Moderator Bego Mario Garde

    (@pixolin)

    Die Datei wp-config-sample.php soll dann als Vorlage dienen, wenn die Konfigurationsdatei wp-config.php neu angelegt werden muss. Ansonsten hat sie keine Bedeutung.

    Woran es bei deiner Website liegt, dass du bei einer Umstellung auf PHP 8.0 nur noch eine leere Seite angezeigt bekommst, lässt sich nur anhand der Fehlermeldungen bestimmen. Es kann an einer fehlerhaften Einstellung in der wp-config.php liegen, es kann aber auch ein Dutzend anderer Gründe haben. Poste bitte mal den Inhalt der wp-config.php (vor dem Absenden löschst du bitte aus der Antwort die Zugangsdaten und SALT-Keys, damit wir niemanden einladen, deine Website zu hacken) und soweit vorhanden die Fehlermeldungen.

    Hallo,
    hilfreich könnte auch die Aktivierung des Debug-Modus sein. Damit Fehler ausgelesen werden können, müssen die Fehler in eine Log-Datei auf dem Server geschrieben werden, auf die man dann per FTP (oder auch SSH) zugreifen kann.
    Sichere bitte zunächst die wp-config.php auf deinem lokalen Rechner.
    Gib dann bitte mit einem geeigneten Programmier-Editor (z. B. Notepad++) in der wp-config.php oberhalb von /* That’s all, stop editing! Happy blogging. */ folgendes ein:

    define( 'WP_DEBUG', true );
    define( 'WP_DEBUG_DISPLAY', false);
    define( 'WP_DEBUG_LOG', true );

    Achte darauf, dass du define('WP_DEBUG', false); überschreibst, falls die Zeile bereits in der wp-config.php steht. Wenn versucht wird, diese Konstante ein zweites mal zu definieren, gibt es einen Fehler, der deine Seite lahmlegen würde.
    Mit diesen drei Codezeilen sagen wir WordPress, dass der Debug-Modus aktiviert werden soll. Die Fehlermeldungen sollen aber nicht direkt angezeigt werden, sondern in die Datei /wp-content/debug.log geschrieben werden.
    Wenn der Fehler gefunden wurde bzw. wenn die Fehler nicht mehr in die debug.log geschrieben werden sollen, dann musst du daran denken, die Variable
    define( 'WP_DEBUG_LOG', true );
    wieder auf false zu setzen:
    define( 'WP_DEBUG_LOG', false);

    Einen entsprechenden Beitrag, wie man das auch mit Verwendung eines Plugins macht, findest du hier.

    Viele Grüße
    Hans-Gerd

    • Diese Antwort wurde geändert vor 1 Woche, 1 Tag von Hans-Gerd Gerhards. Grund: Tippfehler
    Thread-Starter cmuc

    (@cmuc)

    Hallo zusammen, vielen vielen Dank, schaut aus, dass es funktioniert hat 😉

    Am Schluß wenn alles funktioniert hat, müsste die Einstellung dann in wp-config so eingestellt sein richtig?

    define( ‚WP_DEBUG‘, true );
    define( ‚WP_DEBUG_DISPLAY‘, false);
    define( ‚WP_DEBUG_LOG‘, false);

    Beim Webhoster
    ist es am Besten auf 8.0 – Empfohle Version umzustellen, oder?

    Denn es gibt auch noch die Auswahl 8.1. oder 8.2. welche ebenfalls funktionieren würden.

    Vielen Herzlichen Dank und schönen Abend

    Hallo,

    Am Schluß wenn alles funktioniert hat, müsste die Einstellung dann in wp-config so eingestellt sein richtig?

    nein, richtig ist in dem Fall:

    define( 'WP_DEBUG', false );
    define( 'WP_DEBUG_DISPLAY', false );
    define( 'WP_DEBUG_LOG', false );

    Damit wird Debug deaktiviert. Alternative: Auskommentieren.

    Ich würde erst mal auf PHP8.0.x einstellen.

    Kannst du das Thema dann bitte als gelöst markieren, wenn das Problem damit für dich behoben ist:
    Gelöst
    Die Option findest du rechts in der Sidebar. Danke.

    Viele Grüße
    Hans-Gerd

Ansicht von 5 Antworten - 1 bis 5 (von insgesamt 5)