Support » Allgemeine Fragen » Neuinstallation WordPress/WooCommerce und PHP Upgrade

  • Hallo zusammen, guten Morgen,

    also, neues Produkt gebucht gestern, bei meinem Provider, und nun installiere ich WordPress und WooCommerce (4.8.1) durch den Installer und ändere dann PHP von 7.2 auf 8.0 und erhalte diese Fehlermeldung:

    Fatal error: Uncaught ValueError: Missing format specifier at end of string in /var/www/web28942246/html/lifimude/wp-content/plugins/woocommerce/includes/class-wc-post-types.php:223 Stack trace: #0 /var/www/web28942246/html/lifimude/wp-content/plugins/woocommerce/includes/class-wc-post-types.php(223): sprintf(‚Alle %‘, ‚Marke‘) #1 /var/www/web28942246/html/lifimude/wp-includes/class-wp-hook.php(288): WC_Post_Types::register_taxonomies(“) #2 /var/www/web28942246/html/lifimude/wp-includes/class-wp-hook.php(312): WP_Hook->apply_filters(NULL, Array) #3 /var/www/web28942246/html/lifimude/wp-includes/plugin.php(478): WP_Hook->do_action(Array) #4 /var/www/web28942246/html/lifimude/wp-settings.php(523): do_action(‚init‘) #5 /var/www/web28942246/html/lifimude/wp-config.php(116): require_once(‚/var/www/web289…‘) #6 /var/www/web28942246/html/lifimude/wp-load.php(37): require_once(‚/var/www/web289…‘) #7 /var/www/web28942246/html/lifimude/wp-blog-header.php(13): require_once(‚/var/www/web289…‘) #8 /var/www/web28942246/html/lifimude/index.php(17): require(‚/var/www/web289…‘) #9 {main} thrown in /var/www/web28942246/html/lifimude/wp-content/plugins/woocommerce/includes/class-wc-post-types.php on line 223

    Bin überfragt.

    Wisst ihr weiter?

    Vielen Dank.
    Viele Grüße
    Thomas

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 6 Antworten - 1 bis 6 (von insgesamt 6)
  • Hallo,
    hilfreich für eine Analyse wäre der Website-Bericht:
    Du findest unter Werkzeuge > Websitezustand > Info einen Bericht zur Website. Warte bitte einen Moment bis die Ladeanzeige ganz oben abgeschlossen ist und kopiere dann per Button den Website-Bericht in deine Zwischenablage. Über den Button „Bericht in die Zwischenablage kopieren“ kannst du den Bericht unverändert (bitte mit den Akzentzeichen am Anfang und Ende) einfügen und anschließend hier posten. Evtl. ergeben sich dann weitere Anhaltspunkte, ob und wo das Problem liegt.
    Hier ein Screenshot dazu (bei Klick auf das Bild, wird das Bild vergrößert):
    Website-Bericht

    Und mit z. B. STRG V in die Antwort bei diesem Thema einfügen.

    Hilfreich könnte auch die Aktivierung des Debug-Modus sein. Damit Fehler ausgelesen werden können, müssen die Fehler in eine Log-Datei auf dem Server geschrieben werden, auf die man dann per FTP (oder auch SSH) zugreifen kann.
    Sichere bitte zunächst die wp-config.php auf deinem lokalen Rechner.
    Gib dann bitte mit einem geeigneten Programmier-Editor (z. B. Notepad++) in der wp-config.php oberhalb von /* That's all, stop editing! Happy blogging. */ folgendes ein:

    define( 'WP_DEBUG', true );
    define( 'WP_DEBUG_DISPLAY', false);
    define( 'WP_DEBUG_LOG', true );

    Achte darauf, dass du define('WP_DEBUG', false); überschreibst, falls die Zeile bereits in der wp-config.php steht. Wenn versucht wird, diese Konstante ein zweites mal zu definieren, gibt es einen Fehler, der deine Seite lahmlegen würde.
    Mit diesen drei Codezeilen sagen wir WordPress, dass der Debug-Modus aktiviert werden soll. Die Fehlermeldungen sollen aber nicht direkt angezeigt werden, sondern in die Datei /wp-content/debug.log geschrieben werden.
    Wenn der Fehler gefunden wurde bzw. wenn die Fehler nicht mehr in die debug.log geschrieben werden sollen, dann musst du daran denken, die Variable
    define( 'WP_DEBUG_LOG', true );
    wieder auf false zu setzen:
    define( 'WP_DEBUG_LOG', false);

    Schau bitte auch im Error-Log des Webservers nach, ob es Fehlermeldungen gibt. In die error-log kannst du über den Kundenaccount bei deinem Hoster reinschauen.

    Nachtrag: Es gibt da wohl auch noch eine Problem mit der Website. Da kommt offensichtlich keine Website von dir.

    Viele Grüße
    Hans-Gerd

    Moderator Michi91

    (@michi91)

    Hi, das Problem tritt bei fehlerhaften Übersetzungen auf. Hast du weitere Plugins im Einsatz? Eventuell müssten die Sprachdateien ausgetauscht werden, ich denke bei aktuellen Versionen der Sprachdateien für Woo dufte das Problem nicht bestehen.

    Thread-Starter neighbourtom

    (@neighbourtom)

    Danke für eure schnellen Antworten, aber ich hatte das Backend noch gar nicht besucht, sondern direkt nach der Installation die php Version geändert, weil beim ersten Mal WooCommerce angekündigt hatte, dass mit der PH Version 7.4 das Update nicht funktionieren würde.

    Errorlogs habe ich nun einmal aktiviert.

    Thread-Starter neighbourtom

    (@neighbourtom)

    Neue Fehlermeldung beziehungsweise Warnung:

    Warning: The magic method Automattic\WooCommerce\RestApi\Utilities\SingletonTrait::__wakeup() must have public visibility in /var/www/web28942246/html/lifimude/wp-content/plugins/woocommerce/packages/woocommerce-rest-api/src/Utilities/SingletonTrait.php on line 48

    Fatal error: Uncaught ValueError: Missing format specifier at end of string in /var/www/web28942246/html/lifimude/wp-content/plugins/woocommerce/includes/class-wc-post-types.php:223 Stack trace: #0 /var/www/web28942246/html/lifimude/wp-content/plugins/woocommerce/includes/class-wc-post-types.php(223): sprintf(‚Alle %‘, ‚Marke‘) #1 /var/www/web28942246/html/lifimude/wp-includes/class-wp-hook.php(288): WC_Post_Types::register_taxonomies(“) #2 /var/www/web28942246/html/lifimude/wp-includes/class-wp-hook.php(312): WP_Hook->apply_filters(NULL, Array) #3 /var/www/web28942246/html/lifimude/wp-includes/plugin.php(478): WP_Hook->do_action(Array) #4 /var/www/web28942246/html/lifimude/wp-settings.php(523): do_action(‚init‘) #5 /var/www/web28942246/html/lifimude/wp-config.php(116): require_once(‚/var/www/web289…‘) #6 /var/www/web28942246/html/lifimude/wp-load.php(37): require_once(‚/var/www/web289…‘) #7 /var/www/web28942246/html/lifimude/wp-blog-header.php(13): require_once(‚/var/www/web289…‘) #8 /var/www/web28942246/html/lifimude/index.php(17): require(‚/var/www/web289…‘) #9 {main} thrown in /var/www/web28942246/html/lifimude/wp-content/plugins/woocommerce/includes/class-wc-post-types.php on line 223

    Wieso nutzt Du ein so altes WooCommerce bei einer Neuinstallation? Aktuell ist Version 8.7. Die von dir genutzte ist offenbar nicht mit der eingesetzten PHP-Version kompatibel.

    Thread-Starter neighbourtom

    (@neighbourtom)

    Ja, das liegt an der Vorgabe meines Webhosters, aber das bringt mich auf die Idee, zuerst WooCommerce zu aktualisieren, und dann php. Vielleicht klappt’s so.

Ansicht von 6 Antworten - 1 bis 6 (von insgesamt 6)