Support » Plugins » Newsletter plugin

  • hisven

    (@hisven)


    Hi,

    vor einiger Zeit habe ich das Plugin „Newsletter“ installiert, um personalisierte Rundmails zu verschicken. Die Test-Mails landen auch brav dort, wo sie sollen, aber die Endversion scheint nicht anzukommen (auch nicht im Spamordner der Empfänger).
    Habe schon verschiedenes versucht, um das Problem zu lösen:

    1. Ich habe zusätzlich das Plugin „WP Mail SMTP“ VERSUCHT zu installieren, was daran scheiterte, dass es offenbar keinen Kontakt mit meinem Server (Strato) aufnehmen kann.

    2. Habe an den Support von Strato geschrieben, die mir empfohlen haben, meine Frage im WordPress-Forum zu stellen – was ich hiermit getan habe.

    Kennt jemand dieses Problem?

    Herzlich,
    Sven

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 13 Antworten - 1 bis 13 (von insgesamt 13)
  • Moderator Bego Mario Garde

    (@pixolin)

    Existiert die E-Mail-Adresse, die du als Absender angegeben hast? Würde eine E-Mail, die ich dorthin sende, bei dir ankommen? Die Frage bezieht sich darauf, dass wohl inzwischen einige E-Mail-Provider bei unbekannten E-Mail-Adressen kurz eine Prüfung vornehmen, ob es diese E-Mail-Adresse gibt und die E-Mail sonst gar nicht erst duchstellen – nicht einmal in den Spam-Filter des Empfängers.

    Wenn du das Plugin Health Check installierst, kannst du unter Werkzeuge > Website-Zustand > Werkzeuge einen E-Mail-Test vornehmen und schauen, ob die E-Mail an eine bestimmte E-Mail-Adresse durchgeht. Falls nicht, solltest du einen Blick in die Error-Logs des Servers werfen.

    Ich habe zusätzlich das Plugin „WP Mail SMTP“ VERSUCHT zu installieren, was daran scheiterte, dass es offenbar keinen Kontakt mit meinem Server (Strato) aufnehmen kann.

    Dann hast du irgendwas bei den Zugangsdaten falsch eingegeben. Das Plugin funktioniert eigentlich so ähnlich wie ein E-Mail-Programm und sorgt dafür, dass die Mails nicht über die PHP-Mail-Erweiterung des Servers (und den im Server eingerichteten E-Mail-Dienst), sondern über ein bestimmtes E-Mail-Account verschickt werden.

    Webhoster und E-Mail-Provider möchten natürlich nicht gerne als Spam-Schleuder missbraucht und entsprechend gekennzeichnet werden, was dann auf alle Kunden zurückfallen würde. Üblicherweise erlaubt ein Webhoster nur einen Versand einer bestimmten Anzahl von E-Mail pro Stunde und stuft alles darüber hinaus als Spam ein. Dazu gibt es im Plugin auch eine Einstellung, über die du die Anzahl regeln kannst. Hier solltest du nochmal beim Support des Webhosters nachfragen, wie die das handhaben.

    Habe an den Support von Strato geschrieben, die mir empfohlen haben, meine Frage im WordPress-Forum zu stellen …

    Muß toll sein, Geld zu verdienen, aber Support auf die ehrenamtlich Helfenden eines OpenSource-Projekts abzuschieben. Aber OK … viele Webhoster argumentieren, dass sie nur für den Betrieb des Webservers bezahlt werden und für Kundenfreundlichkeit kein Geld übrig bleibt. Das sind dann so Momente, in denen man mal über einen Wechsel des Anbieters nachdenken könnte (vor allem, wenn von einem ganz bestimmten Webhoster auffallend viele Support-Anfrage hier aufschlagen). Wie auch immer …

    Zusammengefasst:

    • Neues E-Mail-Postfach bei Strato anlegen, z.B. newsletter@example.com. Gerne sicheres Passwort (ausreichend lang und komplex) verwenden, weil du das nur bei der Einrichtung des SMTP-Accounts per Copy/Paste einmal einfügen musst.
    • Mit dem SMTP-Plugin und dem Plugin Health Check einen E-Mail-Test durchführen. Vielleicht kannst du jemand, der sich beschwert hat dass nichts ankommt, dabei einbinden? Schlägt der Test fehl, Error-Logs prüfen.
    • Einstellungen des Plugins zur Menge von E-Mails pro Stunde prüfen und ggf. anpassen.
    Thread-Ersteller hisven

    (@hisven)

    Hallo Mario,
    danke für die schnelle und sehr ausführliche Antwort!
    Habe nun wie empfohlen Plugin Health Care installiert. Für WP Mail SMTP werden keine Fehler angezeigt, er behauptet, die Konfiguration zum Server sei abgeschlossen.

    Habe bei Strato ein Postfach angelegt (newsletter@klangsignale.com), und bei WP Mail angegeben. Die Fehlermeldung nach dem Versuch, eine Testmail zu senden, ist diese hier:

    Versions:
    WordPress: 5.7.2
    WordPress MS: No
    PHP: 7.3.28
    WP Mail SMTP: 2.8.0

    Params:
    Mailer: smtp
    Constants: No
    ErrorInfo: SMTP connect() failed. https://github.com/PHPMailer/PHPMailer/wiki/Troubleshooting
    Host: smtp.strato.de
    Port: 465
    SMTPSecure: tls
    SMTPAutoTLS: bool(true)
    SMTPAuth: bool(true)

    Server:
    OpenSSL: OpenSSL 1.1.1k 25 Mar 2021

    Debug:
    Mailer: Andere SMTP-Verbindung
    SMTP connect() failed. https://github.com/PHPMailer/PHPMailer/wiki/Troubleshooting

    SMTP Debug:
    2021-06-06 19:39:27 Connection: opening to smtp.strato.de:465, timeout=300, options=array()

    2021-06-06 19:39:27 Connection: opened

    2021-06-06 19:40:27 SERVER -> CLIENT:

    2021-06-06 19:40:27 Connection: closing due to error

    2021-06-06 19:40:27 Connection: closed

    SMTP connect() failed. https://github.com/PHPMailer/PHPMailer/wiki/Troubleshooting

    Kannst Du damit was anfangen?

    Herzlich,
    Sven

    Hast du den richtigen SMTP-Benutzernamen und Passwort eingegeben?

    Zur E-Mail-Konfiguration können wir dir hier nicht weiterhelfen. Da solltest du dich an den Support von Strato wenden.

    was daran scheiterte, dass es offenbar keinen Kontakt mit meinem Server

    Hast du versucht, andere Zugangsdaten einzugeben? Funktioniert es damit?

    Thread-Ersteller hisven

    (@hisven)

    Lieber Mario,
    lieber Souri,

    ich habe denselben Benutzernamen und Passwort verwendet, wie sonst auch beim Anmelden in meinem Postfach. Klappt trotzdem nicht. Der Support von Strato hat mir noch empfohlen, einen alternativen Port zu benutzen (587), was aber genauso in die Wüste führt.

    Wie stellt man es an, personalisierte Newsletter zu versenden? Das muss doch irgendwie möglich sein, das macht doch alle Welt. Und wie schon gesagt, wenn ich im eigentlichen Newsletter-Plugin Testmail versende, dann kommen sie auch alle an. Das macht mich verrückt.

    Wenn Ihr hierzu vielleicht noch einen Tipp hättet – besseres Newsletter-Plugin oder so?

    Herzlich,
    Sven

    ich habe denselben Benutzernamen und Passwort verwendet, wie sonst auch beim Anmelden in meinem Postfach.

    Du verwendest für mehrere E-Mail-Postfächer das gleiche Passwort?
    Keine gute Idee.

    Der Support von Strato hat mir noch empfohlen, einen alternativen Port zu benutzen

    Ich hätte jetzt auch mal versucht, die Verschlüsselungsmethode auf TLS zu ändern.

    Übrigens ist es gar nicht so schwer, die Website zu einem passenderen Webhoster umzuziehen.

    Wie stellt man es an, personalisierte Newsletter zu versenden? Das muss doch irgendwie möglich sein, das macht doch alle Welt.

    Ja, und alle Welt berichtet uns hier täglich von Problemen mit deinem Webhoster. Das Plugin ist schon OK.

    Thread-Ersteller hisven

    (@hisven)

    „Übrigens ist es gar nicht so schwer, die Website zu einem passenderen Webhoster umzuziehen.“

    Ok, allmählich komme ich auch zu diesem Schluss – egal welche Einstellung ich benutze, welchen Port, welche Mailadresse – es gibt immer dasselbe Problem.

    1. Welchen Webhoster würdest Du mir empfehlen (welche gibt es überhaupt so?)
    2. Wie macht man einen solchen Umzug?

    HG
    Sven

    ad 1) Kann Hetzner sehr ans Herz legen! Deutsche Firma, Ökostrom und gutes P/L Verhältnis.

    ad 2) Gibt mehrere Wege! zb kannst du mit WP selbst alle Inhalte exportieren.
    Geht auch mit WP CLI
    Oder mit Plugins, zb https://wordpress.org/plugins/duplicator/

    Thread-Ersteller hisven

    (@hisven)

    Ok, danke! Habe mal Hetzner kontaktiert. Den Duplikator hab ich sogar schon 🙂

    LG,
    Sven

    Wär toll, wenn du uns dann teilhaben lässt, wie es ausgegangen ist.
    Also wie es dir beim (eventuell) Umzug und bei deinen Erfahrungen gegangen ist!

    Thread-Ersteller hisven

    (@hisven)

    Mach ich! 🙂
    Grüßle,
    Sven

    Thread-Ersteller hisven

    (@hisven)

    Wie es ausgegangen ist: Niemand ist vor der eigenen Blödheit sicher! 🙂 Die Rundmails sind deshalb nicht angekommen, weil ich nicht alle Adressen, die ich nach einer bestimmten thematischen Liste beschicken wollte, gar nicht in diese Liste eingetragen hatte… Das ist nun geschehen, und ich hab bereits viele Rückmeldungen erhalten, dass die Mail angekommen sei.
    Von einem Umzug weg von Strato zu einem anderen Hoster sehe ich jetzt erstmal wieder ab, denn abgesehen der von der eigenen Blödheit verursachten Fehler läuft die Homepage insgesamt sehr gut. Never change a running system!

    Liebe Grüße,
    Sven (der jetzt ein Stück weniger blöd ist 🙂

    Oooooooooooooooooooooooooooookeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeee……………

    Zumindest danke fürs Feedback :p

Ansicht von 13 Antworten - 1 bis 13 (von insgesamt 13)