Support » Plugins » Newsup – Vorschaubild verkleinern?

  • Hallo,

    ich würde gerne die Größe des Bildes von meinem Beitrag verringern, also das neben der „Headline“.

    Ich finde dazu nichts im Customizer und auch nicht auf der Seite von themeansar (Von denen das Theme ist).

    Wäre echt super wenn mir da jemand helfen könnte.

    LG

    Tim

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 16)
  • Hallo,
    mir ist unklar, was genau Du meinst.
    Erstelle doch bitte mal einen Screenshot, damit das deutlicher wird, was du meinst:
    Wie kann man hier Bilder in einen Forenbeitrag einfügen?.

    Viele Grüße
    Hans-Gerd

    Ich nehme an, dass es um die Beitragsbilder der Beiträge geht?
    Das ist hier etwas schlecht zu ändern, weil das Beitragsbild als Hintergrund für den Bereich eines Raster-Layouts (Bootstrap) verwendet wird. Dabei nimmt das Bild 6 von 12 Spalten ein, also eine Breite von 50%:

    Bild gelöscht

    Die Breite für den CSS-Selektor .col-md-6 zu ändern ist keine gute Idee, weil sich das auf andere Elemente der Seite auswirkt. Vielleicht klappt es aber, wenn man den Selektor etwas enger fasst:

    @media (min-width: 768px) {
      .home #post-91 .col-md-6 {
        max-width: 30%;
      }
    }
    .home #post-91 .mg-post-thumb.md {
      height: 200px;
    }
    

    Wie schön, dass hier Fragen zu CSS off topic sind. 😉

    • Diese Antwort wurde geändert vor 1 Jahr, 3 Monaten von Bego Mario Garde. Grund: Bild auf Wunsch des Fragestellenden gelöscht
    Thread-Starter kenshigo

    (@kenshigo)

    @hage

    Tut mir Leid, das war natürlich blöd. Werde ich das nächste mal machen.

    @pixolin

    Meine Frage dazu, müsste ich wenn das so klappt, dass bei jedem einzelnen Post machen?

    Das wäre dann nämlich zu umständlich 🙁

    Echt nicht einfach ein gutes Theme zu finden „wo alles passt“ xD

    Aber danke schonmal

    • Diese Antwort wurde geändert vor 1 Jahr, 3 Monaten von kenshigo.

    Der Sinn eines Cascading Style Sheet ist, der gesamten Website Formatierungsanweisungen hinzuzufügen. Das lässt sich zwar eingrenzen, wenn du ausdrücklich nur für einen Beitrag eine andere Darstellung möchtest, gilt aber sonst allgemein.

    Probier’s einfach mal aus.

    Thread-Starter kenshigo

    (@kenshigo)

    @pixolin

    Vielen Dank für die Erklärung, werde es einfach mal testen 🙂

    LG

    Tim

    Thread-Starter kenshigo

    (@kenshigo)

    @pixolin

    Hab es in die additional css vom Theme eingefügt, hat auch direkt das Bild verkleinert. Dann hab ich zum Test einen neuen Beitrag gemacht und es ist wieder größer, also auch das alte Bild. Funktioniert auch nicht mehr bei löschen-publish-erneut eingeben-publish.

    Hab ich was falsch gemacht, müsste bei post-91 ne Zahl für „alle“ stehen? Oder klappt es leider einfach nicht?

    Wollte nur Rückmeldung geben, danke trotzdem natürlich 🙂

    Hallo,
    wenn ich das richtig sehe, ist zumindest das Plugin Autoptimize aktiviert.
    Während der Entwicklung bzw. bei Änderungen oder Korrekturen an der Website solltest du das Plugin erst mal deaktivieren.

    Solltest du noch weitere Cache-Plugins verwenden, solltest du auch diese Plugins deaktivieren.
    Teste dann bitte, ob das Problem behoben ist.

    Evtl. ist auch ein Website-Bericht für uns hilfreich: Du findest unter Werkzeuge > Websitezustand > Info einen Bericht zur Website. Warte bitte einen Moment bis die Ladeanzeige ganz oben abgeschlossen ist und kopiere dann per Button den Website-Bericht in deine Zwischenablage. Über den Button „Bericht in die Zwischenablage kopieren“ kannst du den Bericht unverändert (bitte mit den Akzentzeichen am Anfang und Ende) einfügen und anschließend hier posten. Evtl. ergeben sich dann weitere Anhaltspunkte, ob und wo das Problem liegt.

    Viele Grüße
    Hans-Gerd

    Thread-Starter kenshigo

    (@kenshigo)

    Also, hab mal nach und nach die plugins deaktiviert (Autoptimize, eww image optimizer, Ionos Performance und webcraftic clearfy) und es jedes mal erneut versucht. Auch wenn alle deaktiviert waren, hat es leider dennoch nicht geklappt.

    Site Health Bericht (hoffe das stimmt so. Copy site info geklickt und strg V hier) :

    wp-core
    
    version: 6.1.1
    site_language: en_US
    user_language: en_US
    timezone: Europe/Berlin
    permalink: /%postname%/
    https_status: true
    multisite: false
    user_registration: 0
    blog_public: 1
    default_comment_status: open
    environment_type: production
    user_count: 1
    dotorg_communication: true wp-paths-sizes wordpress_path: /homepages/19/d4297048621/htdocs/wordpress
    wordpress_size: 76.90 MB (80638406 bytes)
    uploads_path: /homepages/19/d4297048621/htdocs/wordpress/wp-content/uploads
    uploads_size: 741.66 KB (759462 bytes)
    themes_path: /homepages/19/d4297048621/htdocs/wordpress/wp-content/themes
    themes_size: 28.80 MB (30203365 bytes)
    plugins_path: /homepages/19/d4297048621/htdocs/wordpress/wp-content/plugins
    plugins_size: 2.01 MB (2110963 bytes)
    database_size: 11.50 MB (12058624 bytes)
    total_size: 119.94 MB (125770820 bytes) wp-active-theme name: Newsup (newsup)
    version: 3.0.0.69
    author: Themeansar
    author_website: https://themeansar.com
    parent_theme: none
    theme_features: core-block-patterns, editor-style, widgets-block-editor, automatic-feed-links, title-tag, align-wide, post-thumbnails, menus, html5, post-formats, custom-background, woocommerce, wc-product-gallery-zoom, wc-product-gallery-lightbox, wc-product-gallery-slider, customize-selective-refresh-widgets, responsive-embeds, custom-logo, custom-header, widgets
    theme_path: /homepages/19/d4297048621/htdocs/wordpress/wp-content/themes/newsup
    auto_update: Disabled wp-themes-inactive (7) Cream Magazine: version: 2.1.0, author: themebeez, Auto-updates disabled
    HitMag: version: 1.3.4, author: ThemezHut, Auto-updates disabled
    MH Magazine lite: version: 2.9.2, author: MH Themes, Auto-updates disabled
    News Way: version: 1.9, author: Themeansar, Auto-updates disabled
    Twenty Twenty-One: version: 1.7, author: the WordPress team, Auto-updates enabled
    Twenty Twenty-Three: version: 1.0, author: the WordPress team, Auto-updates enabled
    Twenty Twenty-Two: version: 1.3, author: the WordPress team, Auto-updates enabled wp-mu-plugins (2) IONOS Marketplace: version: 1.1.5, author: IONOS
    WordPress automation by Installatron: author: (undefined), version: (undefined) wp-plugins-active (18) Autoptimize: version: 3.1.5, author: Frank Goossens (futtta), Auto-updates disabled
    Disable & Remove Google Fonts: version: 1.5.2, author: Fonts Plugin, Auto-updates disabled
    EWWW Image Optimizer: version: 6.9.3, author: Exactly WWW, Auto-updates disabled
    Header Footer Code Manager: version: 1.1.32, author: 99robots, Auto-updates disabled
    IONOS Assistant: version: 8.4.5, author: IONOS, Auto-updates enabled
    IONOS Help: version: 2.2.1, author: IONOS, Auto-updates enabled
    IONOS Journey: version: 1.0.2, author: IONOS, Auto-updates enabled
    IONOS Login: version: 2.2.1, author: IONOS, Auto-updates enabled
    IONOS Navigation: version: 1.0.7, author: IONOS, Auto-updates enabled
    IONOS Performance: version: 2.0.3, author: IONOS, Auto-updates enabled
    Rank Math SEO: version: 1.0.108, author: Rank Math, Auto-updates enabled
    Real Cookie Banner (Free): version: 3.5.1, author: devowl.io, Auto-updates enabled
    Remove Footer Credit: version: 1.0.13, author: WPChill, Auto-updates disabled
    Shariff Wrapper: version: 4.6.9, author: Jan-Peter Lambeck & 3UU, Auto-updates disabled
    The Events Calendar: version: 6.0.9, author: The Events Calendar, Auto-updates disabled
    Webcraftic Clearfy – WordPress optimization plugin: version: 2.1.4, author: Creative Motion info@cm-wp.com, Auto-updates disabled
    wpDiscuz: version: 7.5.3, author: gVectors Team, Auto-updates enabled
    WP YouTube Lyte: version: 1.7.22, author: Frank Goossens (futtta), Auto-updates enabled wp-plugins-inactive (5) All-in-One WP Migration: version: 7.71, author: ServMask, Auto-updates disabled
    Hummingbird: version: 3.4.2, author: WPMU DEV, Auto-updates disabled
    Internal Link Juicer: version: 2.1.2, author: Internal Link Juicer, Auto-updates disabled
    Optimum Gravatar Cache: version: 1.4.8, author: José Miguel Silva Caldeira, Auto-updates disabled
    UpdraftPlus - Backup/Restore: version: 1.22.24, author: UpdraftPlus.Com, DavidAnderson, Auto-updates disabled wp-media image_editor: EWWWIO_GD_Editor
    imagick_module_version: Not available
    imagemagick_version: Not available
    imagick_version: Not available
    file_uploads: File uploads is turned off
    post_max_size: 64M
    upload_max_filesize: 64M
    max_effective_size: 64 MB
    max_file_uploads: 20
    gd_version: 2.2.5
    gd_formats: GIF, JPEG, PNG, WebP, BMP, XPM
    ghostscript_version: 9.27 wp-server server_architecture: Linux 4.4.302-icpu-088 x86_64
    httpd_software: Apache
    php_version: 8.0.28 64bit
    php_sapi: cgi-fcgi
    max_input_variables: 5000
    time_limit: 50000
    memory_limit: -1
    max_input_time: -1
    upload_max_filesize: 64M
    php_post_max_size: 64M
    curl_version: 7.64.0 OpenSSL/1.1.1n
    suhosin: false
    imagick_availability: false
    pretty_permalinks: true
    htaccess_extra_rules: true wp-database extension: mysqli
    server_version: 10.6.10-MariaDB-1:10.6.10+maria~deb11-log
    client_version: mysqlnd 8.0.28
    max_allowed_packet: 67108864
    max_connections: 3000 wp-constants WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /homepages/19/d4297048621/htdocs/wordpress/wp-content
    WP_PLUGIN_DIR: /homepages/19/d4297048621/htdocs/wordpress/wp-content/plugins
    WP_MEMORY_LIMIT: 40M
    WP_MAX_MEMORY_LIMIT: -1
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_ENVIRONMENT_TYPE: Undefined
    DB_CHARSET: utf8
    DB_COLLATE: undefined wp-filesystem wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    mu-plugins: writable

    ich hatte zu deiner Frage geschrieben:

    Die Breite für den CSS-Selektor .col-md-6 zu ändern ist keine gute Idee, weil sich das auf andere Elemente der Seite auswirkt. Vielleicht klappt es aber, wenn man den Selektor etwas enger fasst

    Ich versuche es nochmal anders zu erklären: Dein Theme verwendete ein Raster aus zwölf Spalten( → Grid-System).
    Möchte der Webentwickler, dass ein Vorschaubild eine Breite von 50% einnimmt, gibt er das nicht so an, sondern verwendet eine CSS-Klasse .col-md-6 . Das bedeutet umgangssprachlich ausgedrückt soviel wie „nimm für Bildschirme mit mittlerer display-Größe eine Spalte (column), die eine Breite von 6 von 12 Spalten einnimmt. Das sind dann 50%.

    Nun könntest du die CSS-Klasse ändern und festlegen, dass der Klasse eine Breite von 30% zugewiesen wird. Leider wirkt sich das dann aber auf das gesamte Layout aus und die Wahrscheinlichkeit, dass du damit das Design verschießt, ist relativ groß.

    Mein Vorschlag war, diese Änderung auf einen bestimmten Abschnitt zu beschränken – in meinem Fall mit dem Selektor #post-91, den WordPress automatisch für den Beitrag mit der ID 91 einfügt. Dann gilt das aber auch (wie du selbst festgestellt hast) nur für diesen einen Beitrag. Du müsstest also einen anderen Selektor finden, um das weiter einzugrenzen. Wobei: ist das überhaupt sinnvoll?

    Du hast dich aus Gründen für ein bestimmtes Theme entschieden, in dem der Entwickler Vorgaben zur Gestaltung gemacht hat. Bei manchen Themes kannst du diese Vorgaben durch Einstellungen im Customizer anpassen – vorrausgesetzt, der Entwickler stellt dafür Einstellungsmöglichkeiten bereit. Wenn nicht, kannst du dir höchstens mit eigenen CSS-Regeln helfen, wobei wir uns hier im Forum nicht über CSS austauschen wollen – dafür gibt es andere Foren, die besser geeignet sind. Die Helfenden hier möchten auch nicht die Zeit damit verbringen, auf Zuruf Änderungen an einem Theme vorzunehmen, dass dir schon kostenlos zur Verfügung gestellt wurde.

    Wenn dir das Theme auf einmal doch nicht gefällt, solltest du überlegen, ein anderes Theme zu nutzen oder Kompromisse eingehen, solange du dich damit wohlfühlst.

    Stell dir vor, du kaufst ein Smartphone. Bei der Nutzung stellst du fest, dass dir eine Funktion fehlt, die Luftfeuchtigkeit zu messen. Das hat der Hersteller so auch gar nicht vorgesehen. Natürlich kannst du das Smartphone auseinanderschrauben, den Lötkolben auspacken und – technische Kenntnisse vorausgesetzt – ein Bauteil zur Messung der Luftfeuchtigkeit anbauen. Wenn du allerdings an den Hersteller schreibst und wissen möchtest, wo du den Lötkolben ansetzt, wirst du eher einsilbige Antworten bekommen, weil das so nicht vorgesehen ist.

    Ein Theme-Entwickler, der sich für die (inzwischen technisch wohl überholte) Nutzung eines Grid-System entscheidet, möchte nicht, dass die Anwender das Layout ändern. Mit technischem Knowhow (CSS, hier off topic) lässt sich das vielleicht bewerkstelligen, aber vorgesehen ist es nicht.

    Thread-Starter kenshigo

    (@kenshigo)

    @pixolin

    ok, habe verstanden.

    • Diese Antwort wurde geändert vor 1 Jahr, 3 Monaten von kenshigo.
    Thread-Starter kenshigo

    (@kenshigo)

    @pixolin

    ist es möglich dass sie das Bild mit der Erklärung löschen?

    Wenn man meine Seite in einer Suchmaschine sucht, taucht dieses Bild auf.

    Wäre dafür sehr dankbar,

    LG

    Der Thread ist nicht mal als „gelöst“ markiert, aber deinen persönlichen Wünschen soll ich nachkommen?

    Bild ist gelöscht. Dauert aber wohl ein bisschen, bis es aus den Suchergebnissen verschwindet.

    Da das für @kenshigo – warum auch immer – offensichtlich schwierig zu sein scheint, hier noch eine kurze Erläuterung: Denkst du bitte beim nächsten Mal daran, das Thema dann auch als gelöst zu markieren, wenn das Thema für dich erledigt ist. Danke.
    Gelöst
    Die Option findest du rechts in der Sidebar. Das habe ich jetzt schon gemacht.

    Thread-Starter kenshigo

    (@kenshigo)

    Warum seid ihr 2 @pixolin @hage eigentlich so extrem angefressen und unhöflich?

    Kommt euch nicht in den Sinn dass es Leute gibt die sich 0,0 mit dem ganzen auskennen, oder etwas das erste mal machen. Man könnte ja auch freundlich darauf hinweisen dass man das machen soll, auch wenn ihr das Problem NICHT lösen könntet. Also ernsthaft. Find es wirklich Hammer dass es Leute gibt die einem bei so etwas helfen können, aber kommt mal von eurem hohem Ross runter und zeigt ein bisschen Menschlichkeit!

    • Diese Antwort wurde geändert vor 1 Jahr, 3 Monaten von kenshigo.

    Hallo @kenshigo,
    Ich wüsste nicht, was an unseren Aussagen so „extrem angefressen und unhöflich“ sein soll.
    Ist dir eigentlich klar, dass wir hier freiwillig in unserer Freizeit versuchen, Anwendern zu helfen und ist es da zu viel verlangt, einen Thread, bei dem insbesondere Bego sehr umfangreich geantwortet hat, als gelöst zu markieren oder alternativ darauf zu verweisen, dass das Problem nicht erledigt ist? – Anstatt dessen äußerst du den Wunsch, dass das Bild gelöscht wird (was Bego ja auch gemacht hat). Insofern gehen wir logischerweise davon aus, dass das Problem gelöst ist.

    Übrigens bieten wir hier Hilfe zur Selbsthilfe. Wir sitzen nicht hinter dir und können dir nicht über die Schulter schauen, was du da machst. Wir haben dir verschiedene Ansätze genannt, mit denen du das Problem lösen kannst. Wenn du diese Ansätze nicht umsetzen kannst, dann können wir da leider verständlicherweise auch nichts machen.

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 16)
  • Das Thema „Newsup – Vorschaubild verkleinern?“ ist für neue Antworten geschlossen.