Support » Themes » Out of memory

  • Hallo
    Ich bekomme diese fehlermeldung: Ein Fehler vom Typ E_ERROR wurde in der Zeile 129 der Datei /home/www/public_html/wordpress/wp-content/plugins/woocommerce/packages/woocommerce-blocks/src/Assets.php verursacht. Fehlermeldung: Out of memory (allocated 14680064) (tried to allocate 892928 bytes)

    Im Front und Backend, nicht durchgehend sonder nur hier und da mal.
    Habe keine Neuen Plugins oder ähnliches installiert. Die fehlermeldung wird im Plugin von Woocommerce angezeigt, kann dann woocommerce Deaktivieren oder Fortsetzten.

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 7 Antworten - 1 bis 7 (von insgesamt 7)
  • Hallo,
    das könnte mit memory_limit zusammenhängen und beispielsweise durch eine Änderung in der wp-config.php geändert werden:
    define('WP_MEMORY_LIMIT', '256M');

    Wie das genau bei Dir eingestellt ist, kann man über Werkzeuge > Website-Zustand > Info feststellen. Du findest unter „Info“ einen Bericht zur Website und kannst den Bericht über den Button „Bericht in die Zwischenablage kopieren“ und anschließend hier posten.
    Weitere Infos findest Du z. B. hier
    Viele Grüße
    Hans-Gerd

    Hallo

    Das müsste dann wohl das hier sein:

    
    ### wp-core ###
    
    version: 5.3.1
    site_language: de_DE
    user_language: de_DE
    timezone: +00:00
    permalink: undefined
    https_status: false
    user_registration: 1
    default_comment_status: open
    multisite: false
    user_count: 1
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /home/www/public_html/wordpress
    wordpress_size: 150,57 MB (157884655 bytes)
    uploads_path: /home/www/public_html/wordpress/wp-content/uploads
    uploads_size: 241,68 MB (253421406 bytes)
    themes_path: /home/www/public_html/wordpress/wp-content/themes
    themes_size: 13,81 MB (14478811 bytes)
    plugins_path: /home/www/public_html/wordpress/wp-content/plugins
    plugins_size: 78,39 MB (82196375 bytes)
    database_size: 14,08 MB (14764032 bytes)
    total_size: 498,53 MB (522745279 bytes)
    
    ### wp-dropins (1) ###
    
    advanced-cache.php: true
    
    ### wp-active-theme ###
    
    name: Easy Store (easy-store)
    version: 1.0.15
    author: Mystery Themes
    author_website: https://mysterythemes.com/
    parent_theme: none
    theme_features: post-thumbnails, automatic-feed-links, title-tag, menus, html5, custom-background, customize-selective-refresh-widgets, custom-logo, custom-header, infinite-scroll, jetpack-responsive-videos, jetpack-content-options, woocommerce, wc-product-gallery-zoom, wc-product-gallery-lightbox, wc-product-gallery-slider, widgets
    theme_path: /home/www/public_html/wordpress/wp-content/themes/easy-store
    
    ### wp-themes-inactive (7) ###
    
    Agency Ecommerce: version: 2.0.10, author: mantrabrain
    Easy Shop: version: 1.0.1, author: Mystery Themes
    Online Shop: version: 2.0.2, author: acmethemes
    Twenty Nineteen: version: 1.4, author: WordPress-Team
    Twenty Seventeen: version: 2.2, author: WordPress-Team
    Twenty Sixteen: version: 2.0, author: WordPress-Team
    Twenty Twenty: version: 1.0, author: WordPress-Team (latest version: 1.1)
    
    ### wp-plugins-active (10) ###
    
    Booster for WooCommerce: version: 4.6.1, author: Algoritmika Ltd
    Jetpack by WordPress.com: version: 8.0, author: Automattic
    Simple YouTube Embed: version: 1.0.7, author: naa986
    Social Shop for WooCommerce: version: 2.6, author: StoreYa
    VVAme chat: version: 3.1.4, author: Creame
    W3 Total Cache: version: 0.11.0, author: BoldGrid
    WooCommerce: version: 3.8.1, author: Automattic
    WooCommerce Admin: version: 0.23.1, author: WooCommerce
    WooCommerce PayPal Checkout Gateway: version: 1.6.18, author: WooCommerce
    WooCommerce Services: version: 1.22.2, author: Automattic
    
    ### wp-plugins-inactive (1) ###
    
    Germanized for WooCommerce: version: 3.0.7, author: Vendidero
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_Imagick
    imagick_module_version: 1687
    imagemagick_version: ImageMagick 6.9.7-4 Q16 x86_64 20170114 http://www.imagemagick.org
    imagick_limits: 
    	imagick::RESOURCETYPE_AREA: 122 MB
    	imagick::RESOURCETYPE_DISK: 1073741824
    	imagick::RESOURCETYPE_FILE: 192
    	imagick::RESOURCETYPE_MAP: 512 MB
    	imagick::RESOURCETYPE_MEMORY: 256 MB
    	imagick::RESOURCETYPE_THREAD: 48
    gd_version: 2.2.4
    ghostscript_version: 9.26
    
    ### wp-server ###
    
    server_architecture: Linux 5.3.11-cmag1-th+ x86_64
    httpd_software: Apache
    php_version: 7.0.33-0+deb9u3 64bit
    php_sapi: cgi-fcgi
    max_input_variables: 1000
    time_limit: 30
    memory_limit: 256M
    max_input_time: 60
    upload_max_size: 16M
    php_post_max_size: 1024M
    curl_version: 7.52.1 OpenSSL/1.0.2s
    suhosin: false
    imagick_availability: true
    htaccess_extra_rules: true
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 10.3.12-MariaDB-1:10.3.12+maria~stretch-log
    client_version: mysqlnd 5.0.12-dev - 20150407 - $Id: b5c5906d452ec590732a93b051f3827e02749b83 $
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /home/www/public_html/wordpress/wp-content
    WP_PLUGIN_DIR: /home/www/public_html/wordpress/wp-content/plugins
    WP_MAX_MEMORY_LIMIT: 256M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: true
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_LOCAL_DEV: undefined
    DB_CHARSET: utf8
    DB_COLLATE: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    
    ### jetpack ###
    
    site_id: 169978713
    ssl_cert: No
    time_diff: undefined
    version_option: 8.0:1575387027
    old_version: 8.0:1575387027
    public: Public
    master_user: #1 Playgamesnow (playgamesnow@t-online.de)
    current_user: #1 Playgamesnow (playgamesnow@t-online.de)
    tokens_set: Blog User
    blog_token: R6SrJ19jz)1prLu@h0#*2*UNc2@0qLBz
    user_token: d5ptaYe#!9aj*Enw^$8^R^zh*B!ipMB5
    version: 8.0
    jp_plugin_dir: /home/www/public_html/wordpress/wp-content/plugins/jetpack/
    plan: free
    HTTP_HOST: i-playgames.homepage.t-online.de
    SERVER_PORT: 80
    REMOTE_ADDR: 2003:e7:6f24:8de8:8967:7e7e:61c0:6ce3
    protect_header: {"trusted_header":"REMOTE_ADDR","segments":1,"reverse":false}
    full_sync: {"started":"Tue, 03 Dec 2019 15:53:23 +0000","queue_finished":"Tue, 03 Dec 2019 15:53:24 +0000","send_started":"Tue, 03 Dec 2019 15:53:27 +0000","finished":"Tue, 03 Dec 2019 15:53:27 +0000","sent":{"constants":1,"functions":1,"options":1,"users":1},"sent_total":{"constants":-1,"functions":-1,"options":-1,"users":1},"queue":{"constants":1,"functions":1,"options":1,"users":1},"config":{"options":true,"functions":true,"constants":true,"users":[1]},"total":{"constants":1,"functions":1,"options":1,"users":1}}
    sync_size: undefined
    sync_lag: 0 seconds
    full_sync_size: undefined
    full_sync_lag: 0 seconds
    idc_urls: {"home":"http:\/\/i-playgames.homepage.t-online.de\/wordpress","siteurl":"http:\/\/i-playgames.homepage.t-online.de\/wordpress","WP_HOME":"","WP_SITEURL":""}
    idc_error_option: false
    idc_optin: true
    cxn_tests: All Pass.
    
    

    Gruss un danke
    Günther

    Hallo,
    wie gesagt: Du kannst in die wp-config.php die o. g. Direktive eintragen (wenn sie nicht schon drin ist) und den Wert ggfs. erhöhen. Die Höhe des Werts hängt allerdings davon ab, wie hoch das von Deinem Hoster gesetzt ist.
    Dementsprechend ist es sinnvoll, das vorher zu prüfen.
    Ansonsten findest Du einige Infos dazu unter dem o. g. Link.
    Oder Du stellst die Frage mal an die Entwickler von Woocommerce
    Viele Grüße
    Hans-Gerd

    Dank, ich probiere es, ist es egal wo ich es da einfüge?
    Gruss Günter

    am besten relativ weit oben, siehe Infos unter dem Link

    Ich befürchte, das wird nichts bringen, siehe

    memory_limit: 256M

    Für mich ist das ein Server-Problem

    (allocated 14680064) (tried to allocate 892928 bytes)

    14 MB werden schon benutzt und knapp 1 MB soll noch allociert werden und das klappt schon nicht. Da sind wir weit von 256 MB entfernt.

    Ok, checke das mit der Telekom, danke für deine Super hilfe.
    Gruss Günther

Ansicht von 7 Antworten - 1 bis 7 (von insgesamt 7)