Support » Allgemeine Fragen » Paginierung bei Abfrage-Loop macht Probleme

  • Hallo zusammen,

    auf meiner Seite funktioniert die Paginierung der Abfrage-Loop nicht: Sobald man sich auf Seite 2 oder 3 der Beiträge befindet, kommt man nichtmehr auf Seite 1 zurück. Beim Klick auf den „1-Button“ wird man nämlich wieder auf die aktuelle Seite bzw. überhaupt nicht weitergeleitet, da dessen href-Attribut leer ist.

    Mit dem TwentyTwentyOne-Theme kommt es zum gleichen Problem, weshalb ich denke, dass der WordPress Core und nicht mein Theme (Blocksy) dafür verantwortlich ist.

    Wo könnte der Fehler liegen?

    Grüße, Valentin

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 3 Antworten - 1 bis 3 (von insgesamt 3)
  • Hallo,
    hast du den Abfrage-Block verwendet?
    Es könnte evtl. auch sein, dass das Problem durch einen Konflikt zwischen Plugins verursacht wird.
    Du kannst ja mal nach einer Sicherung das plugin Health Check & Troubleshooting installieren. Wenn du auf den Button „Problembehandlungsmodus aktivieren“ unter Problembehandlung klickst, werden alle plugins deaktiviert und als Standardtheme (wenn vorhanden) twenty twenty oder Twenty Twenty-One aktiviert. Dann kannst du sehen, ob die beschriebenen Probleme noch weiterhin auftauchen. Aktiviere dann Plugin für Plugin im Problembehandlungsmodus und schaue jeweils nach Aktivierung eines Plugins, ob das Problem noch besteht. Auf diese Weise kannst du möglicherweise ein Plugin finden, dass das Problem verursacht. Vorteil dabei ist, dass Besucher deine Webseite mit allen Infos und plugins sehen, während nur für dich alle plugins deaktiviert sind.
    Lies dir dazu bitte auch mal die Informationen in dem Beitrag zu Health Check durch.
    Viele Grüße
    Hans-Gerd

    Thread-Ersteller vlntn

    (@vlntn)

    Hallo Hans-Gerd,

    vielen Dank für die Antwort. Ja ich verwende den Abfrage-Block. Ich habe eine Staging-Seite eingerichtet und alle Plugins deaktiviert. Dabei habe ich zufällig herausgefunden, dass die Permalink-Struktur (nicht aber ein Plugin) das Problem ist.
    Wählt man dort „Einfach“ funktioniert die Paginierung nämlich. Jedoch möchte ich die Permalink-Struktur „Beitragsname“ beibehalten. Hat dafür vielleicht noch jemand einen Tipp?

    Grüße, Valentin

    Moderator Bego Mario Garde

    (@pixolin)

    Scheint sich um einen Bug zu handeln. Aktiviere ich das Plugin Gutenberg mit einer neueren Version des Block-Editors, scheint es mit der Paginierung zu klappen.

Ansicht von 3 Antworten - 1 bis 3 (von insgesamt 3)