Support » Allgemeine Fragen » Passwortgeschützter Bereich wird fehlerhaft angezeigt

  • Gelöst doktorsteb

    (@stefanbraun)


    Wenn ich eine Seite in WordPress mit einem Passwort verstehen will (Fensterbereich „Veröffentlichen“, Bereich Sichtbarkeit >> Passwortgeschützt) erscheint die dafür vorgegebene Seite im Frontend mit dem Standardsatz von WordPress, allerdings zusammen mit den html-Zeichen <p></p>

    <p>Dieser Beitrag ist passwortgeschützt. Um ihn anzusehen, gib bitte dein Passwort unten ein:</p>

    Ich habe einen zweiten WP Blog, dort ist das ganz genauso. Deaktivieren aller Plugins bringt keine Abhilfe, auch andere Themes, zB einfache WP Standardthemes beheben das Problem nicht.

    Ich habe ein Plugin gefunden (Change Password Protected Message), mit dem die Standard Message geändert werden kann, in der Hoffnung, dass damit die html Zeichen verschwinden. Aber leider Fehlanzeige. Mit dem PLugin werden dann beide Texte angezeigt. Die von WP und die des Plugins. Das Plugin ist aber so ausgelegt, dass der Standardtext von WP verschwinden müsste.

    WP version 5.7.2, alles aktuell upgedated. Auch ein erneutes Überschreiben der aktuellen Version 5.7.2 auf dem Server brachte keine Abhilfe. Php Version derzeit noch 7.2.18. Der andere Blog mit gleichem Problem läuft aber auf 7.4.18 bei anderem Hoster, dort mit gleichem Problem

    Wer kennt das Problem und weiß Abhilfe? Vielen Dank.

    • Dieses Thema wurde geändert vor 1 Jahr, 6 Monaten von doktorsteb.

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 10 Antworten - 1 bis 10 (von insgesamt 10)
  • Hallo,
    ich habe das gerade mal lokal getestet und konnte das Problem hier mit dem Standard-Theme Twenty Twenty nicht reproduzieren.
    Du kannst ja mal nach einer Sicherung das plugin Health Check & Troubleshooting installieren. Wenn du auf den Button „Problembehandlungsmodus aktivieren“ unter Problembehandlung klickst, werden alle plugins deaktiviert und als Standardtheme (wenn vorhanden) twenty twenty oder Twenty Twenty-One aktiviert. Teste dann trotzdem mal, ob das Problem noch auftaucht, auch wenn du das schon getestet hast. Dann aktivierst du zunächst das Theme von dir und kannst dann sehen, ob das Problem da noch auftaucht.
    Aktiviere danach Plugin für Plugin im Problembehandlungsmodus und schaue jeweils nach Aktivierung, ob das Problem noch besteht. Auf diese Weise kannst du möglicherweise herausfinden, ob es an einem Plugin liegt (was ich nicht glaube).
    Vorteil dabei ist, dass Nutzer die Webseite weiter mit allen Infos und plugins sehen, während nur für dich alle plugins deaktiviert sind.
    Lies dir dazu bitte auch mal die Informationen in dem Beitrag zu Health Check durch.
    Viele Grüße
    Hans-Gerd

    Das war ein Fehler in der Übersetzung des Themes. Ich hab’s rasch korrigiert. Der Fehler sollte mit dem nächsten Update der Sprachdateien deiner Website behoben sein.

    Thread-Starter doktorsteb

    (@stefanbraun)

    Ich habe mich gerade durch das troubleshouting Plugin durchgearbeitet und ebenso festgestellt, dass es einen Fehler in der Sprachdatei gibt.
    Ich hatte hierzu einen Forumeintrag gefunden,
    https://forums.colorlib.com/t/password-protected-page-not-rendering-html/8022/2
    der aber leider bei mir nicht geholfen hat. Vielen Dank für die Hilfestellung und das kommende Update.

    Ich habe mich gerade durch das troubleshouting Plugin durchgearbeitet…

    Können wir das, ohne irgendwelche Schadenfreude, unter „gute Übung“ verbuchen?
    Das Plugin ist tatsächlich recht hilfreich bei der Fehlersuche.

    Die Übersetzerin, die sich übrigens auch seit Jahren ganz außerordentlich um die deutsche Übersetzung von WordPress bemüht, hat da versehentlich ein <p>-Tag eingefügt, das dort nicht hingehört:

    Screenshot Einstellungen
    (zum Vergrößern anklicken)

    Denkst du bitte noch daran, den Thread als „gelöst“ zu markieren, wenn die Website die Seite richtig ausgibt?

    Thread-Starter doktorsteb

    (@stefanbraun)

    Das Tool hat jetzt nicht direkt angezeigt, dass ein Fehler im Sparkling Theme ist, jedoch durch die automatische Wahl des Standard Themes, in dem der Fehler nicht war, war klar, dass es am Theme liegen muss. Praktisch am Tool ist, dass trotz Deaktivierung der Plugins alle Einstellungen danach wieder da sind. Ohne dieses Feature ist es immer sehr nervig, alle Justierungen wieder so vorzunehmen, dass es passt.

    Wie muss ich den obigen Hinweis verstehen? Soll ich das selbst korrigieren? Dann bitte ich freundlich um Hinweis, wo und wie ich das machen muss. Oder kommt doch noch ein automatisches Update? Mit Sprachdateien habe ich mich bisher noch nicht auseinander gesetzt.

    Wie muss ich den obigen Hinweis verstehen? Soll ich das selbst korrigieren?

    Du brauchst nur abwarten, bis unter Dashboard > Aktualisierungen > Übersetzungen eine Aktualisierung angezeigt wird. Nach dem Update sollte alles richtig sein.
    Hier im Forum wäre es schön, wenn du den Thread dann als „gelöst“ markierst, damit andere wissen, dass sie nicht mehr helfen müssen.

    Screenshot gelöst
    (zum Vergrößern anklicken)

    Thread-Starter doktorsteb

    (@stefanbraun)

    Ok. Vielen Dank für die schnelle Hilfe.

    Ja bist du gelehmt! DAS NENN ICH MAL SUPPORT DER SONDERKLASSE!

    Darauf muss man auch mal kommen, dass das Problem von der Übersetzung kommt.

    Und dann auch noch jemanden parat haben, der sich mit den Übersetzungstools auskennt und das behebt.

    Hach, sehr nice!

    Thread-Starter doktorsteb

    (@stefanbraun)

    ja voll cool.

    He! Du bist seit 2006….ZWEITAUSEND SECHS! Dabei?

    Du Methusalem!
    Wie kams? Was….hast du bisher mit WordPress gemacht?
    Wie bist du zu WordPress gekommen?
    Usw Usf.
    2006 is sehr heftig!

Ansicht von 10 Antworten - 1 bis 10 (von insgesamt 10)
  • Das Thema „Passwortgeschützter Bereich wird fehlerhaft angezeigt“ ist für neue Antworten geschlossen.