Support » Themes » Passwortschutz für Seiten in TheFour ausgehebelt?

  • Gelöst danielmarsch

    (@danielmarsch)


    Ich habe für eine Seite einen normalen WP-Passwortschutz eingerichtet und – er funktioniert einfach nicht, wird völlig ignoriert. Es liegt nicht an Cookies oder Cache, auch auf einem anderen Rechner oder mit einem anderen Browser: trotz Passwortschutz öffnet sich die Seite einfach so.

    Nach vielem Suchen und Probieren bin ich drauf gekommen, dass es am Theme liegt – mit einem anderen Theme funktioniert alles problemlos. Kann denn ein Theme eine WordPress-Core-Funktion aushebeln? Kann ich dem Theme das vielleicht ausreden? In welcher Datei müßte ich nach welchem Code gucken?

    Das Theme ist TheFour Lite.

    Oder gibt es stattdessen ein Plugin? Ich habe da keins gefunden, macht ja auch eigentlich keinen Sinn, ein Plugin zu schreiben für eine Funktion, die WP an sich schon gut beherrscht…

Ansicht von 8 Antworten - 1 bis 8 (von insgesamt 8)
  • Was ist denn ein „normaler WP-Passwortschutz“? Wie hast du den erstellt?

    Edit/Nachtrag:
    Ah, daran hatte ich nicht gedacht: Meinst du den Passwortschutz für Beiträge?

    • Diese Antwort wurde geändert vor 7 Jahren, 2 Monaten von Angelika Reisiger.
    • Diese Antwort wurde geändert vor 7 Jahren, 2 Monaten von Angelika Reisiger. Grund: nachtrag
    Thread-Starter danielmarsch

    (@danielmarsch)

    Genau, den Passwortschutz den man für jede Seite und jeden Beitrag oben rechts unter „Veröffentlichen/Sichtbarkeit“ einstellen kann.

    Hast du mehrere Seiten mit demselben Passwort geschützt?

    Gruß, Torsten

    Habe das Theme mal getestet. Das Passwort funktioniert bei Seiten und Beiträgen tadellos.

    Gruß, Torsten

    Wird dein Passwort eventuell nicht akzeptiet, verwendest du nicht valide Sonderzeichen?
    Teste doch mal mit

    A1c2def#

    Thread-Starter danielmarsch

    (@danielmarsch)

    Hallo Torsten und Angelika,

    nein, nur eine Seite. Und nein, keine nicht validen Sonderzeichen. Mit dem anderen vorgeschlagenen Passwort geht es auch nicht.

    Es kann auch nicht am Passwort selber liegen: wenn ich das Theme wechsele, funktioniert alles tadellos, daher meine Schlussfolgerung, dass es nur am Theme liegen kann. Dass es bei dir, Torsten, funktioniert, hinterläßt mich jetzt ziemlich ratlos…

    Gruß,
    Daniel

    Hm, ich weiß nicht, wie solide meine Ideen dazu jetzt tatsächlich sind. Mir fällt dazu ein, dass die entsprechenden Seiten, entweder einen fehlerhaften HTML-Aufbau haben, oder JavaScript-Fehler existieren könnten.

    Ob jetzt allerdings verkehrt verschachtelte HTML-Container solch eine Auswirkung haben könnten? Und ob JavaScript irgendwie die Funktionalität des Passwortschutzes beeinflussen, keine Ahnung.

    Schaden kann es aber nicht, mal eine in Frage kommende Seite durch den W3C-Validator zu jagen.

    Thread-Starter danielmarsch

    (@danielmarsch)

    Dank euch Torsten und Angelika.

    Die scheinen beim TheFour Lite Theme noch ziemlich in der Entwicklung zu sein: nach einem früheren Update waren plötzlich einige Features weg. Nach einem neuerlichen Update jetzt funktionierte das mit dem Passwortschutz auf einmal wieder, dafür war das Layout völlig zerschossen (ja, ich arbeite mit einem Child Theme).

    Das war mir jetzt doch zu dumm. Habe auf 4.7 geupdated und „Twentyseventeen“ installiert. Und alles nochmal neu eingerichtet und gestylt…

Ansicht von 8 Antworten - 1 bis 8 (von insgesamt 8)
  • Das Thema „Passwortschutz für Seiten in TheFour ausgehebelt?“ ist für neue Antworten geschlossen.