Support » Installation » Permalink auf Beitragsname führt zu 404 (Multisite)

  • Liebe Community,

    ich benötige mal wieder eure Hilfe für ein Problem welches zwar schon häufiger in Foren angesprochen wird, ich aber bisher nicht für meinen Anwendungsfall lösen konnte.
    Ausgangssituation: Ich habe eine WordPress Anwendung mit 2 unterschiedlichen Domains laufen, also eine Multisite. Ich möchte auf einer dieser Seiten meine Permalink Struktur von Tag auf Beitragsnamen ändern.

    Problem: Sobald ich die Änderung im System übernehme und speichere, sind die Seiten nicht mehr erreichbar und ich erhalte einen 404 Fehler. Egal ob ich die Seiten vorher oder hinterher erstellt habe.

    Bisherige Lösungsversuche: Ich habe meine Rewrite Conditions in der htaccess angepasst, das sollte funktionieren der Inhalt sieht wie folgt aus:

    # BEGIN WordPress
    # Die Anweisungen (Zeilen) zwischen „BEGIN WordPress“ und „END WordPress“ sind
    # dynamisch generiert und sollten nur über WordPress-Filter geändert werden.
    # Alle Änderungen an den Anweisungen zwischen diesen Markierungen werden überschrieben.
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{HTTP_HOST} ^isg-vogtland.de [NC]
    RewriteRule (.*) http://www.isg-vogtland.de/$1 [R=301,L]
    RewriteCond %{HTTP_HOST} ^www\.(.*)$ [NC] RewriteRule ^(.*)$ https://%1/$1 [R=301,L]
    RewriteCond %{ENV:HTTPS} !on
    RewriteRule ^(.*)$ https://%{HTTP_HOST}%{REQUEST_URI} [R=301,L]
    RewriteRule ^index\.php$ - [L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^wp-admin$ wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} !-f [OR]
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule ^ - [L]
    RewriteRule ^(wp-(content|admin|includes).*) $1 [L]
    RewriteRule ^(.*\.php)$ $1 [L]
    RewriteRule . /index.php [L]
    
    </IfModule>
    
    # END WordPress

    Bei einem anderen Blog-Post habe ich gelesen dass es sein kann, dass man im Apache2 Veränderungen an der Config vornehmen müsste…. da habe ich aber das Problem dass ich über FileZille zwar Zugriff zum Lesen bekomme, aber keine Veränderungen vornehmen kann. Ist das so normal?

    Welche weiteren Lösungsschritte könnt ihr mir empfehlen? Wo habe ich einen Denkfehler?

    Ich danke für eure Unterstützung.

    • Dieses Thema wurde geändert vor 2 Wochen, 2 Tage von newnewbie.

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 10 Antworten - 1 bis 10 (von insgesamt 10)
  • Was ist an

    # Die Anweisungen (Zeilen) zwischen „BEGIN WordPress“ und „END WordPress“ sind
    # dynamisch generiert und sollten nur über WordPress-Filter geändert werden.
    # Alle Änderungen an den Anweisungen zwischen diesen Markierungen werden überschrieben.

    so missverständlich beschrieben, dass du trotzdem manuelle Änderungen vornimmst? 😀

    Leider fehlt auch hier wiedermal die URL der Websites, um sich das anzuschauen (FAQ-Beitrag: Warum ein Link zu deiner Website wichtig ist).

    Dass du bei einem Shared Webhosting über Einträge in der .htaccess hinaus keine Änderungen an der Serverkonfiguration vornehmen kannst, ist völlig normal. Ich weiß nicht, welche „Config“ du meinst und kann deshalb auch nicht beurteilen, ob du darauf Schreibrechte haben solltest.

    Wo habe ich einen Denkfehler?

    Du erwartest scheinbar, dass wir übersinnliche Fähigkeiten besitzen und „meinedomain.de“ ohne Website-Bericht und mit vagen Schilderungen beurteilen können.

    Thread-Starter newnewbie

    (@newnewbie)

    Hallo Bego Mario Garde,

    danke für diene schnelle Antwort, ich habe die fehlenden Infos zur Website hinzugefügt, in der Hoffnung dass dies die vermeintliche Erwartungshaltung nach übersinnlichen Fähigkeiten nicht mehr als Vermutung gelten lässt.

    Die Anpassungen in der htaccess erfolgte im Rahmen der Multisite Erstellung. Zumindest laut der Anleitung mit welcher ich das gemacht habe… kann ja durchaus falsch sein.

    Sind weitere Informationen zur Lösungsfindung notwendig?

    LG

    Du kannst in einer Multisite verschiedene Permalink-Einstellungen pro Website vornehmen (jeweils unter Einstellungen > Permalinks im Backend der jeweiligen Website) und brauchst dafür keine Änderungen an der .htaccess vornehmen.

    Die .htaccess enthält eigentlich nur diesen Code:

    RewriteEngine On
    RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^wp-admin$ wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^(wp-(content|admin|includes).*) $1 [L]
    RewriteRule ^(.*\.php)$ $1 [L]
    RewriteRule . index.php [L]

    Übrigens haben wir in einem angehefteten Beitrag Bevor du ein neues Thema (Thread) erstellst genau beschrieben, welche Informationen wir benötigen, um helfen zu können.

    Thread-Starter newnewbie

    (@newnewbie)

    Okay, ich habe gelernt einen Forenbeitrag nicht „schnell“ zu erstellen sondern mit etwas mehr Zeit. Sorry dafür… Hier der Website-Zustandsbericht:

    
    ### wp-core ###
    
    version: 6.0.1
    site_language: de_DE
    user_language: de_DE
    timezone: Europe/Berlin
    permalink: /%postname%/
    https_status: true
    multisite: true
    user_registration: true
    blog_public: 1
    default_comment_status: open
    environment_type: production
    site_count: 2
    network_count: 1
    user_count: 6
    dotorg_communication: true
    
    ### wp-dropins (1) ###
    
    db.php: true
    
    ### wp-active-theme ###
    
    name: Divi Child-Theme (Divi-Child)
    version: 1.0.0
    parent_theme: Divi (Divi)
    theme_features: core-block-patterns, block-templates, widgets-block-editor, custom-background, automatic-feed-links, post-thumbnails, menus, title-tag, post-formats, woocommerce, wc-product-gallery-zoom, wc-product-gallery-lightbox, wc-product-gallery-slider, customize-selective-refresh-widgets, wp-block-styles, editor-style, widgets
    theme_path: /home/www/public_html/wp-content/themes/Divi-Child
    auto_update: Aktiviert
    
    ### wp-parent-theme ###
    
    name: Divi (Divi)
    version: 4.17.6
    author: Elegant Themes
    author_website: http://www.elegantthemes.com
    theme_path: /home/www/public_html/wp-content/themes/Divi
    auto_update: Aktiviert
    
    ### wp-mu-plugins (1) ###
    
    Elementor Safe Mode: version: 1.0.0, author: Elementor.com
    
    ### wp-plugins-active (12) ###
    
    Classic Editor: version: 1.6.2, author: WordPress Contributors, Automatische Aktualisierungen deaktiviert
    Debug Bar: version: 1.1.3, author: wordpressdotorg, Automatische Aktualisierungen aktiviert
    Disable & Remove Google Fonts: version: 1.4.0, author: Fonts Plugin, Automatische Aktualisierungen deaktiviert
    DSGVO All in one for WP: version: 4.1, author: Michael Leithold, Automatische Aktualisierungen deaktiviert
    Password Protected: version: 2.5.3, author: WPExperts, Automatische Aktualisierungen deaktiviert
    Query Monitor: version: 3.9.0, author: John Blackbourn, Automatische Aktualisierungen aktiviert
    Real Cookie Banner (Free): version: 3.0.1, author: devowl.io, Automatische Aktualisierungen aktiviert
    Safe SVG: version: 2.0.2, author: 10up, Automatische Aktualisierungen aktiviert
    Simple Membership After Login Redirection: version: v1.4, author: smp7, wp.insider, Automatische Aktualisierungen deaktiviert
    Simple WordPress Membership: version: 4.1.5, author: smp7, wp.insider (latest version: 4.1.6), Automatische Aktualisierungen deaktiviert
    UpdraftPlus - Backup/Restore: version: 1.22.14, author: UpdraftPlus.Com, DavidAnderson, Automatische Aktualisierungen aktiviert
    WP Debugging: version: 2.11.14, author: Andy Fragen, Automatische Aktualisierungen aktiviert
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_Imagick
    imagick_module_version: 1691
    imagemagick_version: ImageMagick 6.9.11-60 Q16 x86_64 2021-01-25 https://imagemagick.org
    imagick_version: 3.6.0
    file_uploads: File uploads is turned off
    post_max_size: 1024M
    upload_max_filesize: 16M
    max_effective_size: 16 MB
    max_file_uploads: 20
    imagick_limits: 
    	imagick::RESOURCETYPE_AREA: 122 MB
    	imagick::RESOURCETYPE_DISK: 1073741824
    	imagick::RESOURCETYPE_FILE: 768
    	imagick::RESOURCETYPE_MAP: 512 MB
    	imagick::RESOURCETYPE_MEMORY: 256 MB
    	imagick::RESOURCETYPE_THREAD: 1
    imagemagick_file_formats: 3FR, 3G2, 3GP, AAI, AI, APNG, ART, ARW, AVI, AVIF, AVS, BGR, BGRA, BGRO, BIE, BMP, BMP2, BMP3, BRF, CAL, CALS, CANVAS, CAPTION, CIN, CIP, CLIP, CMYK, CMYKA, CR2, CR3, CRW, CUR, CUT, DATA, DCM, DCR, DCX, DDS, DFONT, DNG, DPX, DXT1, DXT5, EPDF, EPI, EPS, EPS2, EPS3, EPSF, EPSI, EPT, EPT2, EPT3, ERF, FAX, FILE, FITS, FRACTAL, FTP, FTS, G3, G4, GIF, GIF87, GRADIENT, GRAY, GRAYA, GROUP4, H, HALD, HDR, HEIC, HISTOGRAM, HRZ, HTM, HTML, HTTP, HTTPS, ICB, ICO, ICON, IIQ, INFO, INLINE, IPL, ISOBRL, ISOBRL6, J2C, J2K, JBG, JBIG, JNG, JNX, JP2, JPC, JPE, JPEG, JPG, JPM, JPS, JPT, JSON, K25, KDC, LABEL, M2V, M4V, MAC, MAGICK, MAP, MASK, MAT, MATTE, MEF, MIFF, MKV, MNG, MONO, MOV, MP4, MPC, MPG, MRW, MSL, MTV, MVG, NEF, NRW, NULL, ORF, OTB, OTF, PAL, PALM, PAM, PATTERN, PBM, PCD, PCDS, PCL, PCT, PCX, PDB, PDF, PDFA, PEF, PES, PFA, PFB, PFM, PGM, PGX, PICON, PICT, PIX, PJPEG, PLASMA, PNG, PNG00, PNG24, PNG32, PNG48, PNG64, PNG8, PNM, POCKETMOD, PPM, PREVIEW, PS, PS2, PS3, PSB, PSD, PTIF, PWP, RADIAL-GRADIENT, RAF, RAS, RAW, RGB, RGBA, RGBO, RGF, RLA, RLE, RMF, RW2, SCR, SCT, SFW, SGI, SHTML, SIX, SIXEL, SPARSE-COLOR, SR2, SRF, STEGANO, SUN, TEXT, TGA, THUMBNAIL, TIFF, TIFF64, TILE, TIM, TTC, TTF, TXT, UBRL, UBRL6, UIL, UYVY, VDA, VICAR, VID, VIDEO, VIFF, VIPS, VST, WBMP, WEBM, WEBP, WMV, WPG, X, X3F, XBM, XC, XCF, XPM, XPS, XV, XWD, YCbCr, YCbCrA, YUV
    gd_version: 2.3.3
    gd_formats: GIF, JPEG, PNG, WebP, BMP, XPM
    ghostscript_version: 9.53.3
    
    ### wp-server ###
    
    server_architecture: Linux 5.18.11-cm4all1-hp+ x86_64
    httpd_software: Apache
    php_version: 8.0.21 64bit
    php_sapi: cgi-fcgi
    max_input_variables: 1000
    time_limit: 30
    memory_limit: 256M
    max_input_time: 60
    upload_max_filesize: 16M
    php_post_max_size: 1024M
    curl_version: 7.74.0 OpenSSL/1.1.1n
    suhosin: false
    imagick_availability: true
    pretty_permalinks: true
    htaccess_extra_rules: false
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 10.3.12-MariaDB-1:10.3.12+maria~stretch-log
    client_version: mysqlnd 8.0.21
    max_allowed_packet: 16777216
    max_connections: 1024
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /home/www/public_html/wp-content
    WP_PLUGIN_DIR: /home/www/public_html/wp-content/plugins
    WP_MEMORY_LIMIT: 64M
    WP_MAX_MEMORY_LIMIT: 256M
    WP_DEBUG: true
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: true
    SCRIPT_DEBUG: true
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_ENVIRONMENT_TYPE: Nicht definiert
    DB_CHARSET: utf8mb4
    DB_COLLATE: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    mu-plugins: writable
    
    

    Ich würde jetzt erstmal die .htaccess zurücksetzen und dann schauen, ob sich die Permalinkeinstellungen mit den Einträgen im Navigationsmenü vertragen.

    Zu gekauften Themes (Divi) können wir hier nicht weiterhelfen, weil sie uns für kostenlosen Support nicht zur Verfügung stehen – aber das weißt du ja inzwischen.

    Thread-Starter newnewbie

    (@newnewbie)

    Okay, ich habe die htaccess mit dem vorgeschlagenen Inhalt überschrieben.
    Aktuell funktionieren beide Websiten. Der Fehler mit dem Permalink besteht noch immer.
    Habe nachdem ich die htaccess geändert habe auch nochmal neu den Permalink im WP Menü auf beitragsname gestellt und gespeichert. Jetzt hat die htaccess diesen Inhalt:

    # BEGIN WordPress
    # Die Anweisungen (Zeilen) zwischen „BEGIN WordPress“ und „END WordPress“ sind
    # dynamisch generiert und sollten nur über WordPress-Filter geändert werden.
    # Alle Änderungen an den Anweisungen zwischen diesen Markierungen werden überschrieben.
    
    RewriteEngine On
    RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^wp-admin$ wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^(wp-(content|admin|includes).*) $1 [L]
    RewriteRule ^(.*\.php)$ $1 [L]
    RewriteRule . index.php [L]
    
    # END WordPress

    Das mit dem Theme ist mir mittlerweile bekannt, das Problem bestand aber schon vor dem Theme 🙂

    Ich kann dir nicht weiterhelfen. Die einzige Website zur URL, die du angegeben hast, ist mit einem Passwort geschützt. Übersinnliche Fähigkeiten und so …

    Thread-Starter newnewbie

    (@newnewbie)

    Das sollte eigentlich nicht mehr der Fall sein, könntest du bitte noch einmal schauen?

    Moderator Bego Mario Garde

    (@pixolin)

    Prima, jetzt sehe ich eine Website mit einem Theme, das mir nicht zur Verfügung steht und ohne Inhalte, die ich prüfen könnte.

    Wer ist denn Webhoster? T-Online? Da gibt es Besonderheiten bei Permalinks. (vgl. T-Online & WordPress)

    Thread-Starter newnewbie

    (@newnewbie)

    Jap, T-Online ist Webhoster…
    Danke für den Link, ich habe die darin empfohlenen Schritte sorgfältig durchgeführt und alles entsprechend angepasst. Leider komme ich noch nicht zu dem gewünschten Ergebnis. Ich habe die Befürchtung dass es etwas mit der Multi-Domain Seite zu tun hat.
    Als ich die Permalink Struktur auf /index.php/%postname% angepasst habe konnte ich die Seiten finden. Nach Anpassung der htaccess und httpd.conf und darauffolgender Veränderung der Permalink Struktur bekomme ich wieder die 404.
    Es gibt lediglich einen Unterschied zwischen meiner WP Installation und dem Vorgehen auf der verlinkten Seite. Ich habe mein WordPress nicht in einem zweiten Unterverzeichnis von public_html sondern direkt danach. Also nicht so (/public_html/wordpress/) sonder so (/public_html/).
    Die entsprechende Anpassung in der httpd.conf habe ich aber vorgenommen.

    Habt ihr weitere Ideen was ich falsch mache?

Ansicht von 10 Antworten - 1 bis 10 (von insgesamt 10)