Support » Allgemeine Fragen » Permalink bei Child-Seiten rätselhaft

  • Gelöst klaus_hh

    (@klaus_hh)


    Hallo,

    auf einer Seite in Entwicklung besteht das Problem, dass Seiten, die als Parent auf die Frontpage verweisen, einen Permalink domain.com/48-2/seitenname haben.
    Das passiert nur bei der Homepage. Wenn ich die Seite umhänge unter eine andere Seite sehe ich ganz korrekt domain.com/parentseite/seitenname.
    Es liegt wohl nicht am Theme, denn unter DIVI tritt es ebenso auf wie unter Twenty Nineteen.

    Hat jemand eine Idee, wo ich suchen müsste?

    Danke

    Klaus

    • Dieses Thema wurde geändert vor 2 Jahre, 2 Monaten von klaus_hh.
Ansicht von 6 Antworten - 1 bis 6 (von insgesamt 6)
  • Zu gekauften Themes (Divi) können wir dir nicht weiterhelfen und die Beschreibung ist außerdem kaum nachvollziehbar. Ich kann mir unter „Wenn ich die Seite umhänge“ nichts vorstellen. Ohne URL können wir uns das auch nicht anschauen.

    Permalink-Einstellungen hast du nochmal geprüft und gespeichert?
    Verwendest du Seitennamen, die nur aus einer Zahl bestehen?

    Thread-Ersteller klaus_hh

    (@klaus_hh)

    Hallo Bego,
    es tut mir leid, wenn meine Frage Dir (und anderen evtl.) auf die Nerven ging.

    Wie ich schrieb tritt das Problem unter dem Standardtheme Twenty Nineteen ebenso auf. Daher verweist der DIVI-Support auf WordPress (bzw. den Provider).

    Mit „Umhängen einer Seite“ meine ich: „Ändern der Parent-Seite“. Momentan ist die Startseite die Parentseite von https://www2.bonn-greeters.org/48-2/feedback-archive/
    Wenn ich dagegen https://www2.bonn-greeters.org/spende/ als Parentseite eintrage lautet der Permalink https://www2.bonn-greeters.org/spende/feedback-archive.

    Die Startseite hat keinen Slug 48-2 und eine Seite dieses Namens (oder mit anderen Ziffern) gibt es auch nicht.

    Die Permalink-Einstellung /%postname habe ich neu abgespeichert.

    So sieht es aus.

    es tut mir leid, wenn meine Frage Dir (und anderen evtl.) auf die Nerven ging.

    Das habe ich nicht geschrieben und es auch nicht so empfunden.

    Ein paar zusätzliche Informationen zu deiner Website wären hilfreich: Geh bitte auf Werkzeuge > Website-Zustand > Bericht, warte einen Moment bis alles geladen ist und kopiere dann per Button den Website-Bericht in deine Zwischenablage. Den kannst du dann bitte hier als neue Antwort unverändert (also mit den Akzentzeichen am Anfang und Ende) einfügen. So erfahren wir ein bisschen mehr über deine Website und können den Fehler besser einschätzen.

    Thread-Ersteller klaus_hh

    (@klaus_hh)

    
    ### wp-core ###
    
    version: 5.4.1
    site_language: en_US
    user_language: en_US
    timezone: +00:00
    permalink: /%postname%/
    https_status: true
    user_registration: 0
    default_comment_status: closed
    multisite: false
    user_count: 7
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /home/thegreeters/public_html
    wordpress_size: 1,002.82 MB (1051532641 bytes)
    uploads_path: /home/thegreeters/public_html/wp-content/uploads
    uploads_size: 135.09 MB (141649082 bytes)
    themes_path: /home/thegreeters/public_html/wp-content/themes
    themes_size: 38.32 MB (40184640 bytes)
    plugins_path: /home/thegreeters/public_html/wp-content/plugins
    plugins_size: 43.13 MB (45222087 bytes)
    database_size: 10.32 MB (10826256 bytes)
    total_size: 1.20 GB (1289414706 bytes)
    
    ### wp-active-theme ###
    
    name: Divi (Divi)
    version: 4.4.7
    author: Elegant Themes
    author_website: http://www.elegantthemes.com
    parent_theme: none
    theme_features: custom-background, automatic-feed-links, post-thumbnails, menus, title-tag, post-formats, woocommerce, wc-product-gallery-zoom, wc-product-gallery-lightbox, wc-product-gallery-slider, customize-selective-refresh-widgets, editor-style, widgets
    theme_path: /home/thegreeters/public_html/wp-content/themes/Divi
    
    ### wp-themes-inactive (3) ###
    
    Twenty Nineteen: version: 1.5, author: the WordPress team
    Twenty Seventeen: version: 2.3, author: the WordPress team
    Twenty Twenty: version: 1.3, author: the WordPress team
    
    ### wp-plugins-active (3) ###
    
    Caldera Forms: version: 1.8.11, author: Caldera Labs
    Contact Form DB: version: 2.10.36, author: Michael Simpson
    UpdraftPlus - Backup/Restore: version: 1.16.25, author: UpdraftPlus.Com, DavidAnderson
    
    ### wp-plugins-inactive (1) ###
    
    Akismet Anti-Spam: version: 4.1.5, author: Automattic
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_GD
    imagick_module_version: Not available
    imagemagick_version: Not available
    gd_version: bundled (2.1.0 compatible)
    ghostscript_version: 8.70
    
    ### wp-server ###
    
    server_architecture: Linux 2.6.32-754.28.1.el6.x86_64 x86_64
    httpd_software: Apache
    php_version: 5.6.40 64bit
    php_sapi: cgi-fcgi
    max_input_variables: 1000
    time_limit: 30
    memory_limit: 256M
    max_input_time: 60
    upload_max_size: 256M
    php_post_max_size: 256M
    curl_version: 7.70.0 OpenSSL/1.1.1g
    suhosin: false
    imagick_availability: false
    htaccess_extra_rules: false
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 5.6.47
    client_version: mysqlnd 5.0.11-dev - 20120503 - $Id: 76b08b24596e12d4553bd41fc93cccd5bac2fe7a $
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /home/thegreeters/public_html/wp-content
    WP_PLUGIN_DIR: /home/thegreeters/public_html/wp-content/plugins
    WP_MAX_MEMORY_LIMIT: 256M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_LOCAL_DEV: undefined
    DB_CHARSET: utf8
    DB_COLLATE: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    mu-plugins: writable
    
    

    Danke für die Informationen, obwohl das leider entgegen meinen Erwartungen auch nicht weiterhilft. Ich hatte erwartet, dass irgendein Plugin eine Rolle spielt, aber das ist ja bei deiner Website alles sehr überschaubar. Die PHP-Version solltest du kurzfristig mal aktualisieren, 5.6 ist wirklich schon sehr betagt und normalerweise solltest du im Kundenmenü des Webhosters eine („Experten“-)Einstellung finden, bei der du aus einem Drop-Down-Menü eine aktueller Version auswählst. Aktuell gibt es PHP 7.4, bei manchen Webhostern nur 7.2.

    Bei der Parent-Seite würde ich mir nochmal den Permalink anschauen (Seite bearbeiten, rechte Spalte im Tab Dokument unter Permalinks).

    Sonst fällt mir dazu im Moment leider auch nicht mehr ein.

    Thread-Ersteller klaus_hh

    (@klaus_hh)

    Danke auf alle Fälle.

    Ja, PHP muss auf dem späteren live-Server dann sicher up to date sein.

    Beim Schreiben dieser Antwort kam mir noch eine andere Idee: was wenn ich mal eine andere Seite in den WP-Settings als Homepage angebe? Und siehe da: DANN zeigt die Startseite ihren Permalink /48-2.
    Nach Änderung des Permalink und Wiedereinsetzen als Homepage sehe ich nun wie gewünscht https://www2.bonn-greeters.org/start/feedback-archive/

    War mir nicht bewusst, musste ich erstmal drauf kommen, wieder was gelernt. 🙂

Ansicht von 6 Antworten - 1 bis 6 (von insgesamt 6)
  • Das Thema „Permalink bei Child-Seiten rätselhaft“ ist für neue Antworten geschlossen.