Support » Allgemeine Fragen » Permalink geändert, Seite zerschossen :( – Wer kann helfen?

  • Gelöst libellengeist

    (@libellengeist)


    Hallo zusammen!
    ich hoffe, Ihr können mir helfen – über jeden Tipp und Unterstützung bin ich sehr dankbar!

    Zu folgendem Problem:
    ich habe für einen Bekannten unter seiner Domain eine WP Seite im Unterverzeichnis ‚wordpress‘ erstellt
    (via FTP und der bekannten WP 5 Min. Installation – manuell; also keine WP installation über Domainanbieter)

    Zu dem Zeitpunkt befand sich im Hauptverzeichnis noch eine andere Seite, die online war.
    An der WP Seite im Unterverzeichnis /wordpress/ wurde neu gearbeitet und auf diese dann anschließend über die index.php mit Weiterleitung gelinkt.

    (Kann man auch eleganter über die direkte Domainweiterleitung im Kundenaccount des Webproviders lösen …)

    …hat aber auch alles so funktioniert.

    Nun hat mein Bekannter der die WP Seite über das WP Dashboard pflegt, leider den haupt Permalink über das WP Login System insofern abgeändert, dass er das ‚/wordpress/‘ hinter dem Pfad entfernt und anschließend bestätigt/gespeichert hat.
    (Er dachte, so würden die Suchmaschinen die Seite besser finden…ggg*)

    Danach waren alle Seiten natürlich zerschossen. 🙁

    Man konnte zwar die Seite unter der Domain noch zum Teil (zerschossen) aufrufen, aber sich nicht mehr in das WP-Backend (WP-Dashboard) über wp-admin einloggen. 🙁

    Also über:
    http://www.domain.de/wordpress/wp-admin

    Nun habe ich einige User-Ratschläge aus diversen Online-Foren ‚durchgespielt‘, doch bisher noch keine Lösung für mein Problem gefunden – denn ich möchte den Ursprung der Seite gerne wiederherstellen.

    Im Moment kann die WP Seite nur Mithilfe einer Änderung in der
    .htaccess
    in ihrem Ursprung angezeigt werden.

    Hier ist der Inhalt:

    <FilesMatch \.php$>
    SetHandler x-httpd-php5.6
    </FilesMatch>

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /wordpress/
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /wordpress/index.php [L]
    </IfModule>

    # END WordPress

    statt:

    <FilesMatch \.php$>
    SetHandler x-httpd-php5.6
    </FilesMatch>

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

    (vergleiche RewriteBase und RewriteRule … es verweist jetzt direkt auf das Unterverzeichnis ‚wordpress‘ wo die WP Seite liegt.)

    Und in der
    wp_config.php
    habe ich die folgenden Zeilen hinzugefügt:

    define(‚WP_SITEURL‘, ‚/wordpress/index.php‘);
    define(‚WP_HOME‘, ‚/wordpress/‘);

    (das waren Usertipps aus diversen Foren, die zumindest schon mal die visuelle Darstellung der Seite wieder gut behoben haben.)

    Doch ein Login ins Backend auf das WP-Dashboard über http://www.domain.de/wordpress/wp-admin ist weiterhin nicht möglich. Somit auch keine Bearbeitung und Pflege der Seite

    🙁 🙁 🙁

    Jetzt habe ich mich in das Domain Kundencenter eingeloggt und habe dort auch eine Änderung Vorgenommen, damit die index.php nicht mehr weiterleiten muss.
    Habe dort eine direkte Weiterleitung eingerichtet, so dass man über http://www.domain.de direkt auf das Unterverzeichnis /wordpress/index.php geleitet wird.

    Quasi die Weiterleitung der Domain von:
    http://www.domain.de/
    auf
    http://www.domain.de/wordpress/
    im geändert.

    Doch dann wurde die Seite überhaupt nicht mehr angezeigt.
    (Nur noch der Fehler Server-Forbidden etc. Zugriff auf Apache verweigert …)

    Die Änderungen habe ich wieder rückgängig gemacht.

    Letztendlich auch egal, denn es trägt auch nicht zur Lösung des Permalink-Problems bei.

    Nun zum jetzigen Stand 11.01.18 – so sieht es aus:

    Hauptverzeichnis:
    index.php
    mit Weiterleitung auf Unterverzeichnis
    /wordpress/

    sowie in .htaccess und wp_config.php oben genannte Änderungen.

    Unterverzeichnis:
    Ordner ‚wordpress‘
    in dem Ordner liegt die WordPress Seite, wie Sie derzeit (relativ unzerstürt) abgerufen werden kann.

    Dabei ist es möglich über
    http://www.domain.de/wordpress/wp-admin
    auf das WP Login zu kommen, welches dann aber unformatiert ausschaut (ohne korrekten Pfad auf css?)

    …und nach der Eingabe der WP Login Daten kommt die typische WP 404 Fehler Meldung. Login in das Backend-System von WP ist damit also auch nicht möglich! 🙁 🙁

    Das bedeutet, auch so erreicht man das WordPress-Dashbord der jetzigen Seite nicht.

    Ich habe auch im Quelltext der weiterleitenden index.php von
    /wordpress/
    auf
    /wordpress/index.php
    getestet, und auch mit direkter Domainweiterleitung auf das Unterverzeichnis ohne die Änderungen der .htaccess und wp_config.php
    kam aber auch nicht weiter.

    Bin auch leider kein Spezi…mehr designerin/Webdesignerin als Webentwicklerin… mit Freude am Coding und WP

    Hilfe, was kann man da jetzt tun?…..

    In erster Linie möchte ich den Ursprung wiederherstellen.
    Oder mich in das WP Backend einloggen können, um den Permalink wieder mit /wordpress/ zu ergänzen.
    Sofern etwas davon noch möglich ist???

    Anschließend würde ich dann die Weiterleitung über die index.php entfernen und dafür dann direkt auf das Unterverzeichnis /wordpress/ die Domain leiten – sofern auch das dann geht…

    Doch dazu muss die oben beschriebene Problematik mit WordPress wieder behoben sein.

    Von Permalinks und Verschiebungen auf das Hauptverzeichnis nehme ich gerne Abstand, da ich mir damit in der Vergangenheit schon einige WP Seiten zerschossen habe…

    Tue mich daher auch schwer damit eine WP Seite erst auf einer Testumgebung zu erstellen, um sie dann auf den Online Server zu verschieben…um mit Permalinks nicht zu konfrontieren *ggg
    Wahrscheinlich ist meine Angst unbegründet. egal…

    Könnt ihr mir weiterhelfen? Jeder Tipp ist ein Segen!
    Danke im Voraus!

Ansicht von 13 Antworten - 16 bis 28 (von insgesamt 28)
  • @mario:
    „Mit define( ‚RELOCATE‘, true ); in der wp-config.php sorgst du dafür, dass bei der Anmeldung die bisher gesetzten Adressen für WordPress und Website ignoriert werden und du dich erneut anmelden kannst. (…)“

    Muss ich dann meine Login Daten dennoch eingeben, oder die Felder leer lassen und nur auf Login klicken? (…jetzt wo Du das schreibst!)

    Moderator Bego Mario Garde

    (@pixolin)

    @libellengeist
    Ich hab’s doch nun mehrfach beschrieben:
    Wenn die WordPress-Dateien nicht im Web-Stammverzeichnis liegen, muss das Verzeichnis in der „WordPress-Adresse“ angehängt werden.

    Den Code für die .htaccess gibt WordPress vor. Copy/Paste, fertig.

    Zu Frage 3
    define(‚WP_SITEURL‘, ‚/wordpress/index.php‘);
    define(‚WP_HOME‘, ‚/wordpress/‘);

    Das ist völlig verkehrt. Wenn, gehören dort absolute URLs rein, keine relativen, also z.B.

    define( 'WP_SITEURL', 'http://example.com/wordpress' );
    define( 'WP_HOME', 'http://example.com' );

    wenn WordPress über das Web-Stammverzeichnis htdocserreichbar sein soll und die WordPress-Dateien im Verzeichnis wordpress liegen.

    Wenn du ohne Login eingeben ins Backend kommst, dann hast ein echtes Problem.

    ich bekomme teilweise Fehler von wegen ‚to many Redirections‘.

    @radarin
    auf der obersten Ebene im Webspace liegt die index.php mit der Weiterleitung auf den Unterordner ‚wordpress‘.
    Im Unterordner ‚wordpress‘ ist die WP Installation.

    ja, es gibt ein child theme

    Hier die Ordnerstruktur der obersten Ebene (Web-Stammverzeichnis):
    – Ordner ‚wordpress‘ (mit wp Installation inkl. child theme)
    – index.php (mit Weiterleitung)

    in der Konfiguration verweist die Domain auf die erste Ebene
    wenn man http://www.domain.de aufruft, kommt dann die Weiterleitung auf http://www.domain.de/wordpress/index.php

    Moderator Bego Mario Garde

    (@pixolin)

    @radarin
    Solche einzeiligen „Zwischenrufe“ sind wenig hilfreich.
    Können wir uns darauf beschränken, Lösungen anzubieten?

    @libellengeist
    Muss ich dann meine Login Daten dennoch eingeben, oder die Felder leer lassen und nur auf Login klicken? (…jetzt wo Du das schreibst!)
    Natürlich musst du dich mit deinem Benutzernamen und deinem Passwort anmelden. Es geht darum, wohin du anschließend weitergeleitet wirst. Probier’s doch einfach mal aus?

    19 Beiträge zu so einem kleinen Problem (normalerweise in ein paar Minuten behoben) ist reichlich übertrieben, zumal du eine ausführliche, schrittweise Anleitung erhalten hast. Probier die Sachen aus, halte dich an die Anleitung, wenn es dann Probleme gibt, schildere was du gemacht hast („bis Schritt 3“) und wo es hakt („Fehlermeldung …“) und mach dann nicht irgendwelche weiteren, nicht nachvollziehbaren Schritte („und dann hab ich noch [irgendwas ganz anderes]“), die nicht in der Anleitung vorgegeben waren. Von define('WP_SITEURL', '/wordpress/index.php'); war nie die Rede.

    Ihr dürft gerne meinen WordPress-Usernamen @pixolin verwenden, ansonsten Bego, es sei denn, Ihr wollt mir eine Vorladung schicken – dann bitte Mario.

    Es hat geklappt – DANKE! 🙂

    Ich habe allerdings irgendwann den „cash“ von allen Browsern komplett löschen müssen, damit es Wirkung zeigte. Nur den Cookie Verlauf zu löschen reichte dabei nicht!

    Zudem habe ich im Ausgangs-Fallbeispiel bei der wp_config.php noch das hier stehen gehabt:
    define(‚WP_SITEURL‘, ‚/wordpress/index.php‘);
    define(‚WP_HOME‘, ‚/wordpress/‘);

    Das musste natürlich raus!

    Das sind so mega nervigen Sachen, über die man stolpert, wenn man eben kein Spezi ist.

    Danke für den Tipp mit „Atom“ und auch generell!

    Moderator Bego Mario Garde

    (@pixolin)

    Prima, dass es jetzt klappt. Ich setze den Thread dann mal auf „gelöst“. 🙂

    Ich muss mich nochmal zurück melden.

    Zum oben genannten Problem habe ich nach genauer Überprüfung noch weiterhin das Problem, dass:
    – die Bilder nicht angezeigt werden (Mediathek ist im Backend nicht mehr da, Bilder sind im upload Ordner aber alle da)
    – bei der dynamische Navigation geht das Dropdown Menue nicht mehr
    – Die meisten Inhaltsseiten werden mit 404 Fehler ausgegeben

    Hier nochmal die Struktur:
    Stammverzeichnis:
    index.php
    wp-config.php
    htaccess

    Unterverzeichniss wordpress:
    alles andere

    Irgendwo muss noch der Pfad zu den Bildern, den Scripten und den Unterseiten nicht richtig stimmen…als ob die wp_settings.php nicht weiter verknüpfen könnte …

    Hat jemand eine Idee, was man da noch machen kann? (Bin WP-Autodidakt)

    Moderator Bego Mario Garde

    (@pixolin)

    Wo können wir uns das denn mal anschauen?
    (Link zur Website?)

    http://www.mentel-immobilien-service.de/beispiel-seite/expose/

    http://www.mentel-immobilien-service.de/home/haeuser/

    – und das Dropdown Menu geht eben nicht
    – die gesamten Exposés werden nicht mehr angezeigt
    – Bilder fehlen…wie z.B. die wechselnden Panorama Bilder auf der Startseite usw.

    soll ich den quellcode der wp-settings.php posten?
    vielleicht hilft das irgendwie weiter? (habe keine Ahnung…evtl sind da noch die Links nicht korrekt gesetzt oder so…)

    Ausschnitt:

    
    define( 'WPINC', 'wp-includes' );
    
    // Include files required for initialization.
    /**require( dirname(__FILE__) . '/' . WPINC . '/load.php' );*/
    require( ABSPATH . WPINC . '/load.php' );
    require( ABSPATH . WPINC . '/default-constants.php' );
    require_once( ABSPATH . WPINC . '/plugin.php' );
    ...
    
    require( ABSPATH . WPINC . '/class-wp-http-streams.php' );
    require( ABSPATH . WPINC . '/class-wp-http-curl.php' );
    require( ABSPATH . WPINC . '/class-wp-http-proxy.php' );
    require( ABSPATH . WPINC . '/class-wp-http-cookie.php' );
    require( ABSPATH . WPINC . '/class-wp-http-encoding.php' );
    require( ABSPATH . WPINC . '/class-wp-http-response.php' );
    ...
    

    An die Datenbank habe ich mich (noch) nicht getraut!
    Da habe ich auch wenig Ahnung von!

    das Problem mit den Bildern konnte ich beheben. Die Rechte waren auf 640 gesetzt. Sind jetzt auf 644 und wurden prompt angezeigt.

    Die anderen Probleme mit 404 Fehler, fehlendem Dropdown in der Navi usw sind noch da.
    hm….

Ansicht von 13 Antworten - 16 bis 28 (von insgesamt 28)
  • Das Thema „Permalink geändert, Seite zerschossen :( – Wer kann helfen?“ ist für neue Antworten geschlossen.