Support » Allgemeine Fragen » Personenbezogene Daten exportieren / löschen

  • Gelöst ZoXx1991

    (@zoxx1991)


    Hallo zusammen,
    ich habe folgendes Problem.

    Wir haben die WordPress Version 5.0.3 installiert.
    Zeitgleich arbeiten wir mit dem „User Role Editor“.

    Nun kommen wir zum Problem. Wir haben die User Gruppe „Editor“ mit dem Rechten:
    – Manage privacy options
    – Erase others personal data
    – Export others personal data
    ausgestattet. Das Problem ist, dass weder unter Werkzeuge die Punkte auftauchen noch die Seite selbst aufrufbar ist (tools.php?page=remove_personal_data). Beim aufrufen der Seite erscheint: Du bist leider nicht berechtigt, auf diese Seite zuzugreifen.

    Wir haben alles weitere durchsucht und finden nicht den richtigen Anhaltspunkt, da auf den anderen WordPress Seiten das ganze sauber funktioniert.

    Kann da wer helfen?

Ansicht von 7 Antworten - 1 bis 7 (von insgesamt 7)
  • Hallo @zoxx1991 ,
    leider ist die Rechtevergabe nicht ganz so granular, wie man es vielleicht gerne hätte. Ich bin mir nicht 100% sicher aber ich glaube dass die von Dir gewünschten Tätigkeiten nur mit der Capability „manage_options“ machbar sind.
    Dann hat man aber natürlich auch noch Zugriff auf diverse andere Dinge, was ja nicht sein soll.
    Da würde ich dann noch das Plugin „Admin Menu Editor“ o.Ä. nutzen, um die anderen, nicht gewünschten Menüpunkte auszublenden. Oder etwas Code in der functions.php:
    Menüpunkte ausblenden
    Vielleicht hat aber noch jemand anders eine bessere Idee…
    Gruß
    Anja

    Moin netzmaedchen,
    exakt so haben wir es auch gemacht. Also wir benutzen den „Admin Menu Editor“ und blenden damit die anderen Punkte aus. Ich habe gerade mal geschaut, die Berechtigung „manage_options“ fehlt. Als Admin kann ich problemlos auf die Seiten zugreifen. Jedoch ist die Berechtigung auch bei mir nicht sichtbar?

    Du meinst im Menu Editor? Da kannst Du sie einfach manuell bei „Extra Capability“ eingeben.

    Nein ich meine das die Capability in dem user role editor nicht auftaucht.

    • Diese Antwort wurde geändert vor 1 Jahr, 10 Monaten von ZoXx1991.

    Könnte sein, dass es „eingedeutscht“ ist… also „Einstellungen verwalten“ oder so? Es gibt da ein Häkchen um die Einstellungen in „humanly readable format“ anzuzeigen. Mach das mal weg falls es da ist.
    Ansonsten ist das natürlich schwer zu sagen ohne es zu sehen. Aber die Option IST DA 😉

    Netzmaedchen ich danke dir! Die Kiste war eingedeutscht. Aktiviert und siehe da es klappt!

    Vielen vielen Dank!!!

    Super! Gerne!

Ansicht von 7 Antworten - 1 bis 7 (von insgesamt 7)
  • Das Thema „Personenbezogene Daten exportieren / löschen“ ist für neue Antworten geschlossen.