Support » Allgemeine Fragen » pfade + redirects

  • Gelöst vanbrel

    (@vanbrel)


    Hallo

    Mein Kunde hat im backend gewütet und ich kriegs nicht hin.
    das sind die Fakten:
    1. Frontend ist erreichbar und mit eingeschaltetem Maintenance Mode sieht alles normal aus.

    2. Bei ausgeschaltetem Maintenance-Mode ist alles ohne Theme/Design da; die links funktionieren nicht, da diese immer umgeleitet werden zu xyz.de/home/site.

    3. Ich komme auch partout nicht ins backend;
    bis zur Anmeldemaske (auch ohne Theme) ist alles normal; nach dem Anmeldeversuch wird die Site von xyz.de/wp-admin weitergeleitet zu xyz.de/home/wp-login.php

    UNd das verursacht natürlich einen 404-Fehler, da es dort eben keine Site gibt.

    Wie kriege ich die Umleitung raus? Ich habe bislang polylang deaktiviert – dann kommt sofort auch im frontend eine Umleitung zu xyz.de/home, was ebenfalls zu einem 404-Fehler führt.

    .htaccess – habe Standard-Datei geladen.

    Jemand eine Ideeeee????
    Grüße

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 5 Antworten - 1 bis 5 (von insgesamt 5)
  • Moderator Hans-Gerd Gerhards

    (@hage)

    Hallo,
    nur mal zur Info: Und es gibt keine Sicherung, die Du wiederherstellen könntest ?
    Außerdem: Das Frontend sieht auch eher so aus, dass zumindest keine CSS-Regeln umgesetzt werden.
    Nachtrag: Ich könnte mich offenbar anmelden, wenn ich direkt http://dies-ist-eine-beispielseite.de/wp-login.php eingebe.
    Viele Grüße
    Hans-Gerd

    vanbrel

    (@vanbrel)

    Hi

    danke für die Antwort; nö leider hat der Kunde schnell alles vergessen, was ich ihm zu updraftplus erzählt habe.

    Und nö, du könntest dich nicht anmelden; denn:
    http://dies-ist-eine-beispielseite.de/wp-login.php wird umgeleitet zu:
    http://dies-ist-eine-beispielseite.de/home/wp-login.php und die gibt’s eben nicht.

    noch ne idee?
    GRüße

    Moderator Bego Mario Garde

    (@pixolin)

    Anscheinend ist in die WordPress-URL ein home reingerutscht, was auch die genannte Umleitung nach Anmeldung per wp-login.php erklären sollte.
    Eigentlich sollte es reichen, die URL zu korrigieren – entweder durch eine direkte Änderung in der Datenbanktabelle wp_options per phpMyAdmin (oder ein anderes Datenbankverwaltungstool deines Webhosters) oder indem du in der wp-config.php oberhalb von /* That's all, stop editing! Happy blogging. */ eine Zeile define( 'RELOCATE', true ); einfügst, dich erneut anmeldest und dann in Einstellungen > Allgemein die URLs korrigierst.

    Übrigens: In einem Support-Forum zu fragen „Jemand eine Ideeeee????“ ist in etwa so sinnvoll, wie in einer Eck-Kneipe zu fragen, ob man dort auch ein Bier bestellen kann. Klar, kann man machen, aber es steigert nicht unbedingt die Laune!!!1! 😉

    Moderator Hans-Gerd Gerhards

    (@hage)

    Und nö, du könntest dich nicht anmelden; denn:
    http://dies-ist-eine-beispielseite.de/wp-login.php wird umgeleitet zu:

    und doch – ich könnte mich durchaus anmelden. Einfach mal probieren. Ich schreibe hier ja nicht sowas in das Forum, wenn ich es nicht getestet habe.
    Bei mir wird da nichts umgeleitet. Und bezogen auf

    noch ne idee?

    sehe ich das genau wie @pixolin

    vanbrel

    (@vanbrel)

    o.k. so sorry, war schräg formuliert;

    aber danke für die Idee: Über die Datenbank hab ich alles wieder hinbekommen;
    Grüße

Ansicht von 5 Antworten - 1 bis 5 (von insgesamt 5)