Support » Allgemeine Fragen » „PHP Fatal error: Out of memory“ – aber nur meine Startseite betreffend

  • Werte WordPress’er,

    wenn ich bei meiner bei Strato liegenden Website versuche, im Backend die Startseite bearbeiten zu wollen, ist dies nicht möglich und es wird „Es gab einen kritischen Fehler auf deiner Website.“ angezeigt. Das Seltsame: Alle anderen Seiten / Unterseiten lassen sich problemlos bearbeiten bzw. kann ich mich problemlos via „Bearbeiten“ in diese „rein klicken“. Der Fehler erscheint nur beim Versuch, die Startseite bearbeiten zu wollen.
    Ein Blick auf die Errorlogfiles verrät:

    AH01215: 12] Not enough space: /home/strato/http/power/rid/73/87/58947387/htdocs/WordPress_SecureMode_01/wp-admin/post.php

    AH01215: : /home/strato/http/power/rid/73/87/58947387/htdocs/WordPress_SecureMode_01/wp-admin/post.php

    AH01215: mmap() failed: [12] Not enough space: /home/strato/http/power/rid/73/87/58947387/htdocs/WordPress_SecureMode_01/wp-admin/post.php

    AH01215: PHP Fatal error: Out of memory (allocated 158859264) (tried to allocate 36864 bytes) in /mnt/web311/b1/87/58947387/htdocs/WordPress_SecureMode_01/wp-includes/wp-db.php on line 1989: /home/strato/http/power/rid/73/87/58947387/htdocs/WordPress_SecureMode_01/wp-admin/post.php

    Ich hatte zuvor nichts an der Startseite verändert, keine neuen, speicherintensiven Inhalte hoch geladen oder Ähnliches.

    Hat da jemand entsprechende Erfahrungen gemacht und einen Rat?
    … ich übrigens Laie … 😉

    Danke sehr und viele Grüße in die Runde!
    Matthias

Ansicht von 3 Antworten - 16 bis 18 (von insgesamt 18)
  • Thread-Ersteller mtriefenbach

    (@mtriefenbach)

    Hello again, ihr netten Menschen.
    Nachdem ich seit unserem jüngsten Austausch meinen Job fokussieren musste, hier nun die erbetenen, weiteren Informationen von mir:

    – Link zur Website: https://www.markenpower.com

    – Nochmals der komplette Statusbericht:

    
    ### wp-core ###
    
    version: 5.4.1
    site_language: de_DE
    user_language: de_DE
    timezone: +02:00
    permalink: /%postname%/
    https_status: true
    user_registration: 0
    default_comment_status: open
    multisite: false
    user_count: 1
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /mnt/web311/b1/87/58947387/htdocs/WordPress_SecureMode_01
    wordpress_size: 3,28 GB (3523267660 bytes)
    uploads_path: /mnt/web311/b1/87/58947387/htdocs/WordPress_SecureMode_01/wp-content/uploads
    uploads_size: 3,45 GB (3699306063 bytes)
    themes_path: /mnt/web311/b1/87/58947387/htdocs/WordPress_SecureMode_01/wp-content/themes
    themes_size: 15,97 MB (16740824 bytes)
    plugins_path: /mnt/web311/b1/87/58947387/htdocs/WordPress_SecureMode_01/wp-content/plugins
    plugins_size: 122,97 MB (128940536 bytes)
    database_size: 91,86 MB (96321536 bytes)
    total_size: 6,95 GB (7464576619 bytes)
    
    ### wp-active-theme ###
    
    name: Uncode (uncode)
    version: 2.2.8.1
    author: Undsgn
    author_website: http://www.undsgn.com
    parent_theme: none
    theme_features: automatic-feed-links, title-tag, post-thumbnails, custom-logo, custom-header, menus, html5, post-formats, custom-background, infinite-scroll, align-wide, widgets, editor-style
    theme_path: /mnt/web311/b1/87/58947387/htdocs/WordPress_SecureMode_01/wp-content/themes/uncode
    
    ### wp-themes-inactive (1) ###
    
    Twenty Twenty: version: 1.3, author: WordPress-Team
    
    ### wp-plugins-active (19) ###
    
    Akismet Anti-Spam: version: 4.1.6, author: Automattic
    Category Order and Taxonomy Terms Order: version: 1.5.7.2, author: Nsp-Code
    Contact Form 7: version: 5.1.9, author: Takayuki Miyoshi
    Cookie Notice: version: 1.3.2, author: dFactory
    Envato Market: version: 2.0.3, author: Envato
    Google Analytics Dashboard for WP (GADWP): version: 6.0.2, author: ExactMetrics
    LayerSlider WP: version: 6.10.2, author: Kreatura Media
    Related Posts for WordPress: version: 2.0.3, author: Never5
    Request Call Back: version: 1.4.1, author: Scott Salisbury
    Slider Revolution: version: 6.2.2, author: ThemePunch
    Uncode Core: version: 2.2.8, author: Undsgn
    Uncode Dave's WordPress Live Search (4.4.1): version: 1.0.3, author: Dave Ross
    Uncode Privacy: version: 2.1.1, author: Undsgn
    Uncode WPBakery Page Builder: version: 6.1.0, author: Michael M - WPBakery.com
    UpdraftPlus - Backup/Restore: version: 1.16.25, author: UpdraftPlus.Com, DavidAnderson
    VC Particles Background: version: 1.3, author: Boom-Apps
    WPBakery Page Builder (Visual Composer) Clipboard: version: 4.5.5.1, author: bitorbit
    WP Google Maps: version: 8.0.23, author: WP Google Maps
    WP YouTube Lyte: version: 1.7.11, author: Frank Goossens (futtta)
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_Imagick
    imagick_module_version: 1690
    imagemagick_version: ImageMagick 6.9.10-47 Q16 x86_64 2019-05-28 https://imagemagick.org
    imagick_limits: 
    	imagick::RESOURCETYPE_AREA: 765 GB
    	imagick::RESOURCETYPE_DISK: 9.2233720368548E+18
    	imagick::RESOURCETYPE_FILE: 192
    	imagick::RESOURCETYPE_MAP: 765 GB
    	imagick::RESOURCETYPE_MEMORY: 383 GB
    	imagick::RESOURCETYPE_THREAD: 1
    gd_version: bundled (2.1.0 compatible)
    ghostscript_version: not available
    
    ### wp-server ###
    
    server_architecture: SunOS localhost 5.10 Generic_150401-49 i86pc SunOS localhost 5.10 Generic_150401-49 i86pc SunOS localhost 5.10 Generic_150401-49 i86pc
    httpd_software: Apache/2.4.41 (Unix)
    php_version: 7.3.18
    php_sapi: cgi-fcgi
    max_input_variables: 4000
    time_limit: 240
    memory_limit: 256M
    max_input_time: 60
    upload_max_size: 64M
    php_post_max_size: 76M
    curl_version: 7.54.0 OpenSSL/1.0.2k
    suhosin: false
    imagick_availability: true
    htaccess_extra_rules: false
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 5.6.42-log
    client_version: 5.5.54
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /mnt/web311/b1/87/58947387/htdocs/WordPress_SecureMode_01/wp-content
    WP_PLUGIN_DIR: /mnt/web311/b1/87/58947387/htdocs/WordPress_SecureMode_01/wp-content/plugins
    WP_MAX_MEMORY_LIMIT: 256M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_LOCAL_DEV: undefined
    DB_CHARSET: utf8
    DB_COLLATE: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    
    

    – Lediglich eine empfohlene Verbesserung wird angezeigt: „You are using Manual UA code output. We highly recommend authenticating with ExactMetrics so that you can access our new reporting area and take advantage of new ExactMetrics features.“
    > Ist das relevant?

    – Hier die wp-config.php (die entsprechende Zeile ist darin korrekt notiert):

    <?php
    /**
     * The base configuration for WordPress
     *
     * The wp-config.php creation script uses this file during the
     * installation. You don't have to use the web site, you can
     * copy this file to "wp-config.php" and fill in the values.
     *
     * This file contains the following configurations:
     *
     * * MySQL settings
     * * Secret keys
     * * Database table prefix
     * * ABSPATH
     *
     * @link https://codex.wordpress.org/Editing_wp-config.php
     *
     * @package WordPress
     */
    
    // ** MySQL settings - You can get this info from your web host ** //
    /** The name of the database for WordPress */
    define('DB_NAME', 
    
    /** MySQL database username */
    define('DB_USER', 
    
    /** MySQL database password */
    define('DB_PASSWORD', 
    
    /** MySQL hostname */
    define('DB_HOST', 
    
    /** Database Charset to use in creating database tables. */
    define('DB_CHARSET', 
    
    /** The Database Collate type. Don't change this if in doubt. */
    define('DB_COLLATE', '');
    
    /**#@+
     * Authentication Unique Keys and Salts.
     *

    – Auch der Strato-Service hatte bislang „nur“ den Tipp bzgl. des Einfügens jener Zeile define( ‚WP_MEMORY_LIMIT‘, ‚256M‘ );
    Ich hake da nochmal nach.

    – Hier die aktuellen Error Logfiles:

    05.06.2020 08:46:00 markenpower.com [client 92.74.34.0] AH01215: : /home/strato/http/power/rid/73/87/58947387/htdocs/WordPress_SecureMode_01/wp-admin/post.php
    05.06.2020 08:46:00 markenpower.com [client 92.74.34.0] AH01215: mmap() failed: [: /home/strato/http/power/rid/73/87/58947387/htdocs/WordPress_SecureMode_01/wp-admin/post.php
    05.06.2020 08:46:00 markenpower.com [client 92.74.34.0] AH01215: 12] Not enough space: /home/strato/http/power/rid/73/87/58947387/htdocs/WordPress_SecureMode_01/wp-admin/post.php
    05.06.2020 08:46:00 markenpower.com [client 92.74.34.0] AH01215: : /home/strato/http/power/rid/73/87/58947387/htdocs/WordPress_SecureMode_01/wp-admin/post.php
    05.06.2020 08:46:00 markenpower.com [client 92.74.34.0] AH01215: mmap() failed: [12] Not enough space: /home/strato/http/power/rid/73/87/58947387/htdocs/WordPress_SecureMode_01/wp-admin/post.php
    05.06.2020 08:46:00 markenpower.com [client 92.74.34.0] AH01215: PHP Fatal error:  Out of memory (allocated 159383552) (tried to allocate 36864 bytes) in /mnt/web311/b1/87/58947387/htdocs/WordPress_SecureMode_01/wp-includes/wp-db.php on line 1989: /home/strato/http/power/rid/73/87/58947387/htdocs/WordPress_SecureMode_01/wp-admin/post.php

    – Im System Status des Themes steht zu lesen:
    WP Memory Limit: 256 MB
    PHP Max Input Vars: 4000
    PHP Max Input Vars (allowed): 4000

    Mehr fällt mir aktuell nicht ein 😉

    Vielen Dank und beste Grüße
    Matthias

    • Diese Antwort wurde geändert vor 1 Jahr, 1 Monat von Bego Mario Garde. Grund: Formatierung
    Thread-Ersteller mtriefenbach

    (@mtriefenbach)

    Hallo zusammen,
    ich muss den Faden abermals aufnehmen, nachdem ich die Zeit fand, mittels des Plugins ‚Health Check‘ im Problembehandlungsmodus die einzelnen Plugins nacheinander zu überprüfen. Sprich, zu prüfen, welche das Problem hervorrufen, dass ich die Startseite (und nur die Startseite) meiner Website nicht bearbeiten kann.

    Folgende Plugins habe ich identifiziert:
    – Slider Revolution
    – Updraft Plus
    – Google Maps

    Sind diese 3 Plugins aktiviert, erscheint beim Versuch einer Bearbeitung der Startseite die Meldung „Es gab einen kritischen Fehler auf deiner Website. Bitte überprüfe den Posteingang deiner Website-Administrator-E-Mail-Adresse für weitere Anweisungen.“

    Nachdem ich den Problembehandlungsmodus wieder abgeschaltet hatte und zum Normalmodus zurückgekehrt war, deaktivierte ich jene 3 Plugins in meiner Benutzeroberfläche und versuchte abermals, die Startseite zu bearbeiten. Doch wieder bzw. weiterhin erschien die Fehlermeldung.

    What to do now?

    Alle hier zuvor gemachten Angaben zu den Error-Logfiles etc. sind weiterhin aktuell.

    Dank und herzliche Grüße
    Matthias

    versuche einmal die Revisionen in WP zu löschen. Ich nutze WP-Rocket, da geht das sehr einfach. Hatte Dein Problem ähnlich vor kurzem.
    Und btw, Strato ist eine echt schlechte Wahl, bei den 2 Kunden die unbedingt bei Strato bleiben wollen benötigen z.B. WP-updates im Schnitt 3x so lange wie bei den all-inkl-gehostete Seiten.

Ansicht von 3 Antworten - 16 bis 18 (von insgesamt 18)
  • Das Thema „„PHP Fatal error: Out of memory“ – aber nur meine Startseite betreffend“ ist für neue Antworten geschlossen.