Support » Allgemeine Fragen » PHP Fatal error

  • Gelöst morphi54

    (@morphi54)


    Hallo zusammen, ich brauche bitte dringend Hilfe. Seit gestern kann ich nicht mehr auf meine Seite zugreifen. Habe seit gestern diese Fehler-Meldung:
    Warning: require(/homepages/43/d795325489/htdocs/puma/wp-includes/post.php): failed to open stream: Permission denied in /homepages/43/d795325489/htdocs/puma/wp-settings.php on line 175

    Fatal error: require(): Failed opening required ‚/homepages/43/d795325489/htdocs/puma/wp-includes/post.php‘ (include_path=‘.:/usr/lib/php7.3′) in /homepages/43/d795325489/htdocs/puma/wp-settings.php on line 175

    Wenn ich die Rechte von post.php von 200 auf 604 oder 644 ändere (Seite wird zwar kurzzeitig angezeigt ist aber fehlerhaft) setzt diese sich nach ein paar Minuten automatisch wieder zurück auf 200.

    Kann mir da bitte jemand helfen.

Ansicht von 8 Antworten - 1 bis 8 (von insgesamt 8)
  • Wenn ich die Rechte von post.php von 200 auf 604 oder 644 ändere (Seite wird zwar kurzzeitig angezeigt ist aber fehlerhaft) setzt diese sich nach ein paar Minuten automatisch wieder zurück auf 200.

    Verzeichnisse sollten auf 755, Dateien auf 644 gesetzt werden. Wenn die Dateirechte aber ohne dein Zutun auf einen niedrigeren Wert zurückgesetzt werden, solltest du mit dem Support deines Webhosters telefonieren. Vielleicht haben sie einen Schadcode entdeckt und deshalb „die Notbremse gezogen“ – frag mal nach.

    Thread-Ersteller morphi54

    (@morphi54)

    Danke für die schnelle Antwort Mario.
    Du hattest recht. Ich habe die Datei post.php und wp-vcd.php gelöscht und neu hochgeladen, so wie es Ionos beschrieben hat. Jetzt habe ich aber andere Fehlermeldungen.
    http://www.puma.sc-berndorf.com

    Die URL scheint nicht zu stimmen: „Server nicht gefunden“.

    Thread-Ersteller morphi54

    (@morphi54)

    Das schöne an Fehlermeldungen ist, dass sie einem manchmal die Ursache gleich mitliefern:

    Warning: include(/homepages/43/d12345/htdocs/xyz/wp-content/themes/wp-store/functions.php): failed to open stream: Permission denied in /homepages/43/d12345/htdocs/xyz/wp-settings.php on line 497

    Also: weiter an den Berechtigungen arbeiten. 🙂

    Bei ionos kannst du wohl auch per SSH auf die Dateien zugreifen und rekursiv die Rechte korrigieren:

    find /homepages/43/d12345/htdocs/xyz/ -type d -exec chmod 755 {} \;
    find /homepages/43/d12345/htdocs/xyz/ -type f -exec chmod 644 {} \;
    

    (den Pfad musst du wieder anpassen)

    Thread-Ersteller morphi54

    (@morphi54)

    Danke für die Hilfe.
    Hat funktioniert.

    Danke für die Rückmeldung.

    Die Haupt-Domain ist „nicht deine Baustelle“?

    Thread-Ersteller morphi54

    (@morphi54)

    Doch die Haupt-Domain ist auch meine Baustelle.
    Aber da bin ich noch nicht so weit 🙂

Ansicht von 8 Antworten - 1 bis 8 (von insgesamt 8)
  • Das Thema „PHP Fatal error“ ist für neue Antworten geschlossen.