Support » Allgemeine Fragen » PHP-Fehler

  • Ich habe seit gestern oder vorgestern nach diversen Änderungen im PHP-Code folgende Fehlermeldung in meinem Error-Log:

    PHP Warning: call_user_func_array() [function.call-user-func-array]: First argument is expected to be a valid callback, ‚feed_links_extra‘ was given in /home/polkomm/htdocs/blog/wp-includes/plugin.php on line 339

    In Zeile 339, die sich innerhalb der function do_action befindet, steht:

    call_user_func_array($the_[‚function‘], array_slice($args, 0, (int) $the_[‚accepted_args‘]));

    Ich habe meine Änderungen alle (ich hoffe es jedenfalls) rückgängig gemacht. Auf Rat meines Server-Providers habe ich auch das einzige Plugin Akismet (gegen Spam-Postings) deaktiviert. Aber der Fehler bleibt. Ich habe nun fast das Gefühl, dass mein Code nicht das Problem ist.

    Kann mir jemand hier ein wenig weiterhelfen?

    Gruß
    Tom

Ansicht von 2 Antworten - 1 bis 2 (von insgesamt 2)
  • Je nach dem wie dein Englisch ist schau mal hier nach:
    http://wordpress.org/support/topic/285389

    Thread-Ersteller captaintomberlin

    (@captaintomberlin)

    Oh, danke! Englisch kein Problem. Der Artikel betrifft exakt meinen Fehler, allerdings geht es dort eher um einen Workaround und leider nicht um eine Fehlerbeseitgung.

    Ich habe jetzt die Zeile

    add_action(‚wp_head‘, ‚feed_links_extra‘, 3);

    in ./wp-includes/default-filters.php (Zeile 172) auskommentiert. Nun ist der Fehler weg. Ob auch irgendeine Funktionalität weg ist, die ich benötige, ist mir auf den ersten Blick nicht aufgefallen.

Ansicht von 2 Antworten - 1 bis 2 (von insgesamt 2)
  • Das Thema „PHP-Fehler“ ist für neue Antworten geschlossen.