Support » Allgemeine Fragen » PHP Versions Update (7.4 -> 8.*) // keine Chance

  • Gelöst Mephisto86

    (@mephisto86)


    Moin liebe Community,

    meine Seiten (ich hab 2 unabhängige Instanzen) liegen bei Strato.
    Strato stellt demnächst per Zwang auf mindestens PHP 8.0 um.

    Ich habe die Migration getestet und laufe bei beiden WordPress-Seiten auf Fehler.
    Mir fehlt jeglicher Ansatz, woran es noch liegen könnte.
    Was habe ich schon versucht? Natürlich ist WordPress nebst Plugins und Theme up to date.
    Dann habe ich:
    – alle Plugins deaktiviert
    – auch die Themes deaktiviert
    – standard Theme versucht
    – WordPress-Core komplett neu hochgeladen, Theme komplett neu hochgeladen
    – DebugModus aktiviert

    Ab Umstellung auf PHP 8.0 wird die typische „Kritischer Fehler“-Meldung angezeigt. Trotz Debugmodus. Es werden keine Debuginfos ausgegeben. So langsam bin ich am verzweifeln. Denn es betrifft ja letztlich ZWEI unabhängige WordPress-Versionen.
    Beide liegen auf dem selben Server, laufen aber sonst autark.

    Kann es sein, dass ich noch irgendwas an der Datenbank machen muss?
    Bitte um eure Hilfe! Danke im Voraus!!!

    PS: wie gesagt, egal welches Theme ich verwende, der Fehler bleibt!

    WordPress 6.1.1 | PHP 7.4.33 | Apache/2.4.54 (Unix) | MySQL 5.7.38

    • Dieses Thema wurde geändert vor 1 Woche, 3 Tage von Mephisto86.

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 13 Antworten - 1 bis 13 (von insgesamt 13)
  • Moderator Bego Mario Garde

    (@pixolin)

    Du kannst das Plugin WP Debugging installieren und dann unter Werkzeuge > Debug festlegen, ob Debug-Meldungen angezeigt werden. (Die bei der Installation empfohlenen weiteren Plugins brauchst du nicht zu installieren.)

    Alternativ kannst du auch den Error-Log aktivieren und schauen, was protokolliert wird. Schau dir dazu die Informationen deines Webhosters an.

    Wenn du trotz Deaktivieren der Plugins und Aktivieren eines Standard-Themes („Twenty …“) weiterhin einen Fehler angezeigt bekommst, ist die Wahrscheinlichkeit hoch, dass der Fehler in der Konfigurationsdatei wp-config.php liegt.
    Poste bitte mal hier den Inhalt der Datei, lösch aber aus deiner Antwort vor dem Absenden die Zeilen mit den Zugangsdaten und SALT-Keys komplett raus – wir wollen niemanden zum Hacken deiner Website einladen.

    Und schon wieder Strato und ursächlich vermutlich wp-config.php

    Ich würde fast wetten, dass in dieser Datei wieder die folgenden Einträge zu finden sind (wobei die letzte Zeile variieren kann):

    define( 'WP_ALLOW_MULTISITE', true );
    define ('FS_METHOD', 'direct');
    define( "WP_AUTO_UPDATE_CORE", minor );

    @mephisto86
    teste doch einmal das, was @hage dort vorgeschlagen hat:
    https://de.wordpress.org/support/topic/wp-6-1-1-laeuft-nicht-mit-php-8-0-minimalinstallation/#post-140441

    Eine wp-config-sample.php liegt jedem WordPress-Download-Paket bei (oben rechts blauer Button), falls du diese nicht auf deinem Server finden solltest.

    Nutze für die Bearbeitung auf jeden Fall einen geeigneten Texteditor, z. B. Notepad++ (nicht zu verwechseln mit notepad von Windows) oder Brackets (für Windows und Mac).

    Thread-Starter Mephisto86

    (@mephisto86)

    Hallo ihr beiden und erstmal vielen lieben Dank für eure Hilfe!

    @ Mario, ich hab meine Datenbankcredentials und die Salts weggelassen, der Rest meiner wp-config sieht so aus:

    $table_prefix  = 'wp_';
    
    /**
    
     * For developers: WordPress debugging mode.
    
     *
    
     * Change this to true to enable the display of notices during development.
    
     * It is strongly recommended that plugin and theme developers use WP_DEBUG
    
     * in their development environments.
    
     */
    
    define( 'WP_DEBUG', true );
    
    define( 'WP_DEBUG_LOG', true );
    define( 'SCRIPT_DEBUG', true );
    define( 'SAVEQUERIES', true );
    /* That's all, stop editing! Happy blogging. */
    
    /** Absolute path to the WordPress directory. */
    
    if ( !defined('ABSPATH') )
    
    	define('ABSPATH', dirname(__FILE__) . '/');
    
    /** Sets up WordPress vars and included files. */
    
    require_once(ABSPATH . 'wp-settings.php');
    
    /*Update ausschalten*/
    
    define('AUTOMATIC_UPDATER_DISABLED', false);
    
    

    @mephisto86

    Magst du noch testen, was ich oben bzw. was @hage vorgeschlagen hatte und uns das Ergebnis mitteilen?

    Bitte auch immer Browser- und ggf. Cache von Plugins löschen.

    Thread-Starter Mephisto86

    (@mephisto86)

    Hey Angelika,

    habe ich bereits, Danke auch dir.
    Die Seite läuft dann mit 8.0 – allerdings bekomme ich dann den kritischen Fehler beim Login ins Backend. Bzw. beim Aufwurf von wp-admin.

    Das muss aber ein Fehler im Theme sein…
    Denn mit dem twenty-nine geht das…

    Fatal error: Uncaught Error: Call to a member function group_register() on null in /mnt/web317/a0/54/54129054/htdocs/2k15/wp-content/themes/envision 2.0/includes/theme/theme.setup.php:12 Stack trace: #0 /mnt/web317/a0/54/54129054/htdocs/2k15/wp-content/themes/envision 2.0/includes/theme/theme.setup.php(6): cloudfw_register_shortcode_groups() #1 /mnt/web317/a0/54/54129054/htdocs/2k15/wp-content/themes/envision 2.0/cloudfw/cloudfw.loader.php(141): require('...') #2 /mnt/web317/a0/54/54129054/htdocs/2k15/wp-content/themes/envision 2.0/functions.php(35): require('...') #3 /mnt/web317/a0/54/54129054/htdocs/2k15/wp-settings.php(585): include('...') #4 /mnt/web317/a0/54/54129054/htdocs/2k15/wp-config.php(137): require_once('...') #5 /mnt/web317/a0/54/54129054/htdocs/2k15/wp-load.php(50): require_once('...') #6 /mnt/web317/a0/54/54129054/htdocs/2k15/wp-admin/admin.php(34): require_once('...') #7 /mnt/web317/a0/54/54129054/htdocs/2k15/wp-admin/index.php(10): require_once('...') #8 {main} thrown in /mnt/web317/a0/54/54129054/htdocs/2k15/wp-content/themes/envision 2.0/includes/theme/theme.setup.php on line 12
    Es gab einen kritischen Fehler auf deiner Website. Bitte überprüfe den Posteingang deiner Website-Administrator-E-Mail-Adresse für weitere Anweisungen.
    • Diese Antwort wurde geändert vor 1 Woche, 3 Tage von Mephisto86.

    Das ist dann wieder ein anderes Problem, das erste Problem ist auf jeden Fall gelöst.

    Die Fehlermeldung im Backend betrifft das Theme Envision.

    Bitte öffne dafür einen neuen Thread -> Aus unseren Foren-Regeln:

    Punkt A) 8.

    Eine Frage = Ein Thread (Thema)
    Bitte nutzt einen eigenen Thread für neue Fragen. Auch wenn das Thema gleich erscheint. Es gibt nur ein „Gelöst“ pro Thread.

    Damit wir dir ggf. bei dem neuen Problem helfen können, benötigen wir weitere Infos (im neuen Thread).

    Siehe dort

    ——-
    💡 I. Welche Informationen wir von dir benötigen
    ——-

     

    Ich befürchte allerdings, dass „Envision“ ein Kauftheme ist? bei dem wir wenig weiterhelfen können und der Entwickler des Themes gefragt werden sollte.

    Ich setze diesen Thread für dich auf gelöst.

    Thread-Starter Mephisto86

    (@mephisto86)

    Aber ich habe dank euch einen Ansatz gefunden! Vielen lieben Dank!!!

    Thread-Starter Mephisto86

    (@mephisto86)

    Hallo Angelika,

    du schriebst gestern „und schon wieder Strato“. Ist das ein generelles Problem mit Strato das es bei anderen nicht gibt? Sollte man hier Strato mal ins Gebet nehmen?
    Der Support wollte da jedenfalls nicht helfen.

    Moderator Bego Mario Garde

    (@pixolin)

    Wir möchten uns hier nach Möglichkeit neutral verhalten und die Leistungen von Webhostern nicht kommentieren. Es fällt aber auf, dass einige Webhoster sich bei Fragen zu WordPress sehr schnell nicht zuständig fühlen und auf den Support hier verweisen. Das wäre auch soweit nachvollziehbar, wenn Strato nicht einige Besonderheiten hätte:

    • Bei automatisierten Installationen („One-Click-Installation“) werden automatische Updates abgeschaltet.
      Der Grund ist angeblich, dass ein eigenes Team neue Versionen erst prüfen möchte, um dann ein Update über das Kundenmenü anzubieten. Während also Sicherheitslücken bei anderen WordPress-Installationen im Idealfall noch gleichtägig durch ein Update behoben werden, muss sich bei Strato erst einmal ein Team anschauen, was eigentlich geändert wurde und ob und wie sich das auf das Webhosting auswirkt?
    • Strato hat einen Schutzmechanismus für Gästebuch-Einträge, der bekannterweise bei POST-Request einen Fehler „503 – Service unavailable“ auslöst. Das ist auch bekannt und es gibt eine Hilfeseite dazu. Wieso man den Quatsch nicht als Standard abschaltet, obwohl POST-Requests nichts unanständiges sind?
    • Wir bekommen im Moment recht viele Anfragen, weil zwangsweise die PHP-Version auf 8.0 umgestellt wurde. WordPress, Standard-Themes und gängige Plugins kommen damit auch zurecht. Wer aber seine Website länger nicht aktualisiert hat, kann unter Umständen durch einen bisher als nicht kritisch bewerteten Programmierfehler der Zugriff auf seine Website verlieren. Ich weiß nicht, wie weit Strato die Maßnahme zumindest angekündigt hat und Nutzer die Gelegenheit hatten, ihre Website zu prüfen, aber andere Webhoster sind da flexibler und bieten einen Legacy-Support an, der zwar kostenpflichtig ist, aber vor bösen Überraschungen schützt.

    Für das Support-Team ist es ann „schon wieder Strato“, da nützt auch die nette Fernsehwerbung für WordPress-Websites nichts. Die Kritikpunkte sind dem Webhoster bekannt, „ins Gebet nehmen“ wird wenig helfen, aber ein Wechsel zu einem anderen Anbieter ist auch nicht so furchtbar kompliziert.

    Wer aber seine Website vorab auf Kompatibilität mit PHP8 getestet hat, die Installation nicht per Kundenmenü gemacht oder zumindest automatische Aktualisierungen (re-)aktiviert hat und den Gästebuch-Spamfilter ausschaltet, kommt sicher auch weiterhin mit Strato zurecht.

    Hallo @mephisto86

    Deine Anfrage war die dritte oder vierte (die ich persönlich mitgelesen habe) mit einem ähnlich gelagerten Problem beim Upgrade auf PHP 8.x

    Bei allen waren Einträge in der Datei wp-config.php ursächlich, die von den Websitebetreibern laut eigener Aussagen nicht selbst hinzugefügt wurden und dieser Fehler ist bislang nur in Zusammenhang mit diesem Provider aufgetaucht.

    Meine Bemerkung war pragmatischer Natur und eher als Hinweis für die Moderation gedacht, diese Problematik als mögliche Ursache im Hinterkopf zu behalten.

    Momentan stellen einige Provider auf PHP 8.x um. Wie sich herausstellt, nimmt es PHP 8.x viel genauer, was exakten Code betrifft, es ist weniger interpretierfreundlich als ältere Versionen. Ein Beispiel: Wo in PHP 7.x noch Anführungszeichen (statt eigentlich korrekter Hochkommata) fehlerfrei funktionierten, wirft PHP 8.x hier einen (u. U. auch fatal) Error aus.

    Hallo,

    Ich weiß nicht, wie weit Strato die Maßnahme zumindest angekündigt hat und Nutzer die Gelegenheit hatten, ihre Website zu prüfen, aber andere Webhoster sind da flexibler und bieten einen Legacy-Support an, der zwar kostenpflichtig ist, aber vor bösen Überraschungen schützt.

    Ich habe das ebenfalls speziell bei Strato schon einige Male erlebt.
    Es gibt übrigens Webhoster, bei denen man die Umstellung auf PHP 7.4 wieder kostenfrei einstellen kann, wenn noch Probleme auftauchen sollten.
    Dann kann man in Ruhe sehen, in welcher Form man das Problem erledigen kann.

    Viele Grüße
    Hans-Gerd

    Es gibt übrigens Webhoster, bei denen man die Umstellung auf PHP 7.4 wieder kostenfrei einstellen kann, wenn noch Probleme auftauchen sollten.
    Dann kann man in Ruhe sehen, in welcher Form man das Problem erledigen kann.

    Zwar auch etwas OffTopic, aber in diesem Zusammenhang ist vielleicht dieser Artikel von mir ganz informativ, der die Frage behandelt, wieso einige Provider noch ältere PHP-Versionen anbieten obwohl diese Versionen offiziell EOL (End of Life) und somit vermeintlich unsicher sind.

    Thread-Starter Mephisto86

    (@mephisto86)

    Ich danke euch. Das mit den Post-Requests kann ich von Berufswegen nachvollziehen; ich arbeite in der Cybersecurity.

    Aber eine gewisse Gleichgültigkeit habe ich auch empfunden (seitens meines Hosters) und werde zumindest meinen Unmut nochmal wiederspiegeln…

    Eine Vorwarnung gab es nur in der Form, dass ich jetzt eine Deadline bekommen habe (wie wohl jeder) … und dadurch darauf aufmerksam gemacht wurde.

    Danke für euren Support!

Ansicht von 13 Antworten - 1 bis 13 (von insgesamt 13)