Support » Allgemeine Fragen » phpMyAdmin – id_2 home fehlt

  • In meiner Datenbank fehlt die Zeile id_2 home
    Die Seite ist überhaupt nicht mehr aufrufbar, und einloggen kann ich mich auch nicht mehr.
    Ursprünglich hatte ich den typischen Fehler gemacht, die WordPress URL zu verändern, und hatte dann wie hier beschrieben in wp-config.php „define(‚RELOCATE‘,true);“ eingefügt.

    Wie es dazu kam, dass nun auf einmal „home“ fehlt, kann ich leider nicht nachvollziehen.

    Kann man diese Zeile einfach neu einfügen? Geht es dann wieder?

    • Dieses Thema wurde geändert vor 2 Wochen, 4 Tage von behandlung.

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 15 Antworten - 16 bis 30 (von insgesamt 31)
  • Die Einträge für siteurl und home sollten beide mit Schema eingegeben werden, also z.B. https://sehens-wert.com.

    Was ist im Kundenmenü des Webhosters als Web-Stammverzeichnis der Domain zugewiesen? Rufe ich die URL https://sehens-wert.com/readme.html auf, wird mir die Readme-Datei der WordPress-Installation angegeben. Die WordPress-Dateien scheinen also in dem Verzeichnis zu liegen, dass der Domain als Web-Stammverzeichnis zugewiesen ist. Dann müsste daber auch der Eintrag siteurl auf https://sehens-wert.com lauten.

    Thread-Ersteller behandlung

    (@behandlung)

    https:// hab ich korrigiert, dann hab ich /_2014_sehenswert_WP bei siturl gelöscht.
    Nun zeigt es mir lustigerweise die Startseite, aber sobald man auf Unterseiten geht, kommt wieder Fehler 500.

    Wenn ich WP-admin eingebe kommt:

    Fatal error: Cannot redeclare retrieve_password() (previously declared in /kunden/381206_82515/webseiten/_2014_sehenswert_WP/wp-login.php:362) in /kunden/381206_82515/webseiten/_2014_sehenswert_WP/wp-includes/user.php on line 2834

    https:// hab ich korrigiert, dann hab ich /_2014_sehenswert_WP bei siturl gelöscht. Nun zeigt es mir lustigerweise die Startseite, …

    Das ist ein erster Fortschritt.

    Kannst du die .htaccess bitte mal in no.htaccess umbenennen?
    Was passiert dann? Kannst du dich im Backend anmelden?

    Verwendest du das Plugin All in One WP Security & Firewall?

    Thread-Ersteller behandlung

    (@behandlung)

    erledigt.

    Oh Freude – ich kann zumindest die Unterseiten wieder aufrufen.
    Aber wp-admin geht nicht, die selbe Fehlermeldung wie vorhin

    Fatal error: Cannot redeclare retrieve_password() (previously declared in /kunden/381206_82515/webseiten/_2014_sehenswert_WP/wp-login.php:362) in /kunden/381206_82515/webseiten/_2014_sehenswert_WP/wp-includes/user.php on line 2834

    ++ Nachtrag – das genannte Plugin ist nicht installiert, auch kein anderes Cache- oder Firewall Plugin o.ä +++

    • Diese Antwort wurde geändert vor 2 Wochen, 4 Tage von behandlung.

    OK. Nochmal die (nachgeschobene) Frage:
    Verwendest du das Plugin All in One WP Security & Firewall?

    Thread-Ersteller behandlung

    (@behandlung)

    Sorry, hab´s oben grad nachgetragen – Nein, ist nicht im Einsatz, auch kein anderes Cache oder Firewall plugin etc.

    Hm, OK. Probier doch bitte trotzdem mal, was passiert, wenn du das Verzeichnis wp-content/plugins in wp-content/no.plugins umbenennst.

    Du hattest meine Frage, was passiert wenn du die .htaccess umbenennst, nicht beantwortet. Deshalb nochmal die Rückfrage: hast du die Datei umbenannt?

    Thread-Ersteller behandlung

    (@behandlung)

    Ja – hatte ich umbenannt. Danach konnte ich die Unterseiten sehen.
    (Hab nur „erledigt“ geschrieben)

    Jetzt hab ich plugins in no.plugins umbenannt, aber da gibt es keine Änderung im Verhalten.

    • Diese Antwort wurde geändert vor 2 Wochen, 4 Tage von behandlung.
    Thread-Ersteller behandlung

    (@behandlung)

    zur Fehlermeldung “
    Fatal error: Cannot redeclare retrieve_password() (previously declared in /kunden/381206_82515/webseiten/_2014_sehenswert_WP/wp-login.php:362) in /kunden/381206_82515/webseiten/_2014_sehenswert_WP/wp-includes/user.php on line 2834″

    Ich seh grad…. das Problem haben noch mehr mit der Version 5.7
    https://wordpress.org/support/topic/cannot-redeclare-retrieve_password/

    • Diese Antwort wurde geändert vor 2 Wochen, 4 Tage von behandlung.

    Ich seh grad…. das Problem haben noch mehr mit der Version 5.7

    Stimmt, da geht es aber immer auch um das Plugin „All In One WP Security & Firewall“, welches du ja nicht installiert haben willst.

    Thread-Ersteller behandlung

    (@behandlung)

    Hier https://wordpress.org/support/topic/after-automatic-update-i-cant-log-in-to-wordpress/

    Da schreibt einer:
    „(temporary)
    SOLUTION:
    disable the rename of the admin login page feature (under brute force)“

    Aber da weiß ich nicht wie das geht.

    Ein anderer schreibt, man soll WordPress downgraden.
    Ich denke, das probier ich mal

    Wenn du auf einem Apache-Server die .htaccess umbenennst und damit die Weiterleitungsregeln entfernst, dürfte der Aufruf von Webseiten mit Pretty Permalinks nicht funktionieren. Irgendwas stimmt da also nicht … Es gibt auch Fälle, bei denen versehentlich mehrere WordPress-Installationen ineinander verschachtelt wurden und dann Änderungen an der falschen Stelle vorgenommen werden.

    Eine Alternative wäre, den Webhoster um eine Wiederherstellung zu bitten. Das ist vermutlich effektiver, als hier weiter zu raten, was die Ursache sein könnte.
    Alternativ kommt „Alles-löschen-WP-neu-installieren-Backup-wiederherstellen“ in Frage – vorausgesetzt, du kannst dich felsenfest auf das vorhandene Backup verlassen. Das wäre allerdings keine Vorgehensweise, die ich Einsteigern empfehlen möchte (ich kann deinen Wissensstand nicht beurteilen).

    Da schreibt einer: „(temporary) SOLUTION: …

    Der hat aber (wie @bscu schon angemerkt hat) auch Probleme mit dem Plugin, das du angeblich gar nicht verwendest.

    Ein anderer schreibt, man soll WordPress downgraden.
    Ich denke, das probier ich mal

    Dann drücke ich die Daumen.

    Thread-Ersteller behandlung

    (@behandlung)

    Danke euch!
    Das Plugin ist wirklich nicht installiert.
    Da ist nur der Classic Editor, Layer Slyder, updraft plus und Yoast drauf. Sonst nix.

    Um Wiederherstellung hab ich bereits vor 6 Tagen gebeten, aber Domainfactory kommt nicht in die Gänge, obwohl sie 5,- € dafür verlangt haben. Grrr…

    Die Webseiteninhaberin, der ich helfe (helfen wollte), ist schon mit den Nerven am Ende.

    Aber jetzt hab ich mir wenigstens die Texte und Bilder rauskopiert, dann kann ich es komplett neu machen, es ist eh nur eine Demoversion von einem Theme mit eigenen Inhalten bestückt.

    Das mit dem Downgrade probier ich noch, und wenn das nicht klappt, gebe ich auf.

    Vielen Dank erst mal für eure Hilfe!

    Thread-Ersteller behandlung

    (@behandlung)

    Jetzt geht´s – aber nur sehr eingeschränkt.
    Wenn ich wp-admin aufrufe kommt nur eine ganz weiße Seite.
    Gehe ich über https://sehens-wert.com/readme.html kann ich mich einloggen.
    Da kommt zwar auch alles weiß, aber wenn ich dann die normale Seite aufrufe, erscheint oben der schwarze Balken, und ich kann auf z.B. „neuer Beitrag“ gehen, und komme so in´s Dashboard.
    Sehr ominös das ganze.
    Aber egal, jetzt hab ich wenigstens die Sachen wieder da.

    Frage: Da ich keine Lust habe, jetzt noch mehr rumzupopeln…
    Macht es Sinn, dass ich das jetzt mit Updraft plus nochmal sichere, und dann alles komplett runterschmeiße und WordPress neu installiere? Oder hab ich dann wieder den Fehler drin?

    Vielen Dank!

Ansicht von 15 Antworten - 16 bis 30 (von insgesamt 31)