Support » Allgemeine Fragen » Plötzlich kaum noch Besucher auf meinem Webblog

  • rolandmhorn

    (@rolandmhorn)


    Hallo,

    seit etwa zwei Wochen zählt WP Statistics kaum noch Besucher auf meinem Blog. Der Niedergang kam abrupt, und Versuche mit Matomo Analytics und Burst Statistics ergaben eher noch niedrige Besucherzahlen. Nach einigen Tagen wurde es etwas (aber nicht wirklich) besser und nach etlichen Versuchen gestern mit Einstellungen und dem Aktivieren und Deaktivieren von Plugins werden nur noch tröpfchenweise Besucher angezeigt.

    Der Bericht über meinen Webseiten-Zustand lautet folgendermaßen:

    
    ### wp-core ###
    
    version: 6.1.1
    site_language: de_DE
    user_language: de_DE
    timezone: Europe/Berlin
    permalink: /%year%/%monthnum%/%day%/%postname%/
    https_status: true
    multisite: false
    user_registration: 0
    blog_public: 1
    default_comment_status: open
    environment_type: production
    user_count: 1154
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /www/htdocs/w018e8db/blog-roland-m-horn.de
    wordpress_size: 1,13 GB (1213806603 bytes)
    uploads_path: /www/htdocs/w018e8db/blog-roland-m-horn.de/wp-content/uploads
    uploads_size: 651,51 MB (683161230 bytes)
    themes_path: /www/htdocs/w018e8db/blog-roland-m-horn.de/wp-content/themes
    themes_size: 12,79 MB (13411726 bytes)
    plugins_path: /www/htdocs/w018e8db/blog-roland-m-horn.de/wp-content/plugins
    plugins_size: 182,00 MB (190839161 bytes)
    database_size: 160,02 MB (167790823 bytes)
    total_size: 2,11 GB (2269009543 bytes)
    
    ### wp-dropins (1) ###
    
    advanced-cache.php: true
    
    ### wp-active-theme ###
    
    name: Pages (pages)
    version: 1.1.2
    author: Bryan Hadaway
    author_website: https://calmestghost.com/
    parent_theme: none
    theme_features: core-block-patterns, widgets-block-editor, title-tag, custom-logo, custom-header, custom-background, post-thumbnails, responsive-embeds, automatic-feed-links, html5, woocommerce, menus, widgets
    theme_path: /www/htdocs/w018e8db/blog-roland-m-horn.de/wp-content/themes/pages
    auto_update: Deaktiviert
    
    ### wp-themes-inactive (2) ###
    
    Courage: version: 1.5.7, author: ThemeZee, Automatische Aktualisierungen aktiviert
    Twenty Sixteen: version: 2.8, author: WordPress-Team, Automatische Aktualisierungen deaktiviert
    
    ### wp-mu-plugins (2) ###
    
    burst_rest_api_optimizer.php: author: (undefined), version: (undefined)
    Health Check Troubleshooting Mode: author: (undefined), version: 1.7.2
    
    ### wp-plugins-active (30) ###
    
    Advanced Database Cleaner: version: 3.1.1, author: Younes JFR., Automatische Aktualisierungen deaktiviert
    Advanced Editor Tools (previously TinyMCE Advanced): version: 5.6.0, author: Automattic, Automatische Aktualisierungen deaktiviert
    Akismet Anti-Spam: version: 5.0.2, author: Automattic, Automatische Aktualisierungen deaktiviert
    Antispam Bee: version: 2.11.1, author: pluginkollektiv, Automatische Aktualisierungen deaktiviert
    Autoptimize: version: 3.1.4, author: Frank Goossens (futtta), Automatische Aktualisierungen deaktiviert
    Better Search Replace: version: 1.4.2, author: WP Engine, Automatische Aktualisierungen deaktiviert
    Classic Editor: version: 1.6.2, author: WordPress Contributors, Automatische Aktualisierungen deaktiviert
    Classic Widgets: version: 0.3, author: WordPress Contributors, Automatische Aktualisierungen deaktiviert
    Code Snippets: version: 3.2.2, author: Code Snippets Pro, Automatische Aktualisierungen deaktiviert
    Complianz - Terms and Conditions: version: 1.1.3, author: Really Simple Plugins, Automatische Aktualisierungen deaktiviert
    Complianz | GDPR/CCPA Cookie Consent: version: 6.3.9, author: Really Simple Plugins (latest version: 6.4.0), Automatische Aktualisierungen deaktiviert
    Header and Footer Scripts: version: 2.2.1, author: Digital Liberation, Automatische Aktualisierungen deaktiviert
    Health Check & Troubleshooting: version: 1.5.1, author: The WordPress.org community, Automatische Aktualisierungen deaktiviert
    Impressum: version: 2.0.0, author: Epiphyt, Automatische Aktualisierungen deaktiviert
    Jetpack Boost: version: 1.7.0, author: Automattic - Jetpack Site Speed team, Automatische Aktualisierungen deaktiviert
    LightStart - Maintenance Mode, Coming Soon and Landing Page Builder: version: 2.6.2, author: Themeisle, Automatische Aktualisierungen deaktiviert
    MailPoet: version: 4.5.0, author: MailPoet, Automatische Aktualisierungen deaktiviert
    Modern Footnotes: version: 1.4.13, author: Prism Tech Studios, Automatische Aktualisierungen deaktiviert
    Open External Links in a New Window: version: 1.44, author: WebFactory Ltd, Automatische Aktualisierungen deaktiviert
    Prosodia VGW OS: version: 3.25.3, author: Prosodia – Verlag für Musik und Literatur, Automatische Aktualisierungen deaktiviert
    Shariff Wrapper: version: 4.6.9, author: Jan-Peter Lambeck & 3UU, Automatische Aktualisierungen deaktiviert
    Simple Custom CSS: version: 4.0.6, author: John Regan, Automatische Aktualisierungen deaktiviert
    TRUSTED-BLOGS: version: 1.0.3, author: trusted blogs GmbH, Automatische Aktualisierungen deaktiviert
    Unsplash: version: 1.0.1, author: Unsplash, Automatische Aktualisierungen deaktiviert
    UpdraftPlus - Backup/Restore: version: 1.22.24, author: UpdraftPlus.Com, DavidAnderson, Automatische Aktualisierungen deaktiviert
    WP Image Borders: version: 2.02, author: Compete Themes, Automatische Aktualisierungen deaktiviert
    WP Statistics: version: 13.2.15, author: VeronaLabs, Automatische Aktualisierungen aktiviert
    WP Super Cache: version: 1.9.2, author: Automattic, Automatische Aktualisierungen deaktiviert
    Yoast SEO: version: 19.14, author: Team Yoast, Automatische Aktualisierungen aktiviert
    Zero Spam for WordPress: version: 5.4.4, author: Highfivery LLC, Automatische Aktualisierungen deaktiviert
    
    ### wp-plugins-inactive (10) ###
    
    Advanced Custom Fields: version: 6.0.6, author: WP Engine, Automatische Aktualisierungen deaktiviert
    Burst Statistics - Privacy-Friendly Analytics for WordPress: version: 1.3.2, author: Really Simple Plugins, Automatische Aktualisierungen deaktiviert
    Gravity Forms Zero Spam: version: 1.2.3, author: GravityKit, Automatische Aktualisierungen deaktiviert
    iframe: version: 4.5, author: webvitaly, Automatische Aktualisierungen deaktiviert
    Inline Tweet Sharer: version: 2.5.3, author: Winwar Media, Automatische Aktualisierungen deaktiviert
    Matomo Analytics - Ethical Stats. Powerful Insights.: version: 4.13.0, author: Matomo, Automatische Aktualisierungen deaktiviert
    TablePress: version: 2.0.3, author: Tobias Bäthge, Automatische Aktualisierungen deaktiviert
    TinyPNG - JPEG, PNG & WebP image compression: version: 3.4.1, author: TinyPNG, Automatische Aktualisierungen deaktiviert
    WP-Optimize - Clean, Compress, Cache: version: 3.2.10, author: David Anderson, Ruhani Rabin, Team Updraft, Automatische Aktualisierungen deaktiviert
    WP External Links: version: 2.57, author: WebFactory Ltd, Automatische Aktualisierungen deaktiviert
    
    ### code-snippets (5) ###
    
    snippet-1: name: Beispiel HTML Shortcode, scope: global, tags: [shortcode]
    snippet-2: name: Beispiel CSS Snippet , scope: front-end, tags: [css]
    snippet-3: name: Beispiel JavaScript Snippet, scope: front-end, tags: [javascript]
    snippet-4: name: Order snippets by name, scope: admin, tags: [code-snippets-plugin]
    snippet-5: name: Order snippets by date, scope: admin, modified: 2020-01-26 08:43:48, tags: [code-snippets-plugin]
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_Imagick
    imagick_module_version: 1687
    imagemagick_version: ImageMagick 6.9.7-4 Q16 x86_64 20170114 http://www.imagemagick.org
    imagick_version: 3.7.0
    file_uploads: File uploads is turned off
    post_max_size: 200M
    upload_max_filesize: 200M
    max_effective_size: 200 MB
    max_file_uploads: 20
    imagick_limits: 
    	imagick::RESOURCETYPE_AREA: 31 GB
    	imagick::RESOURCETYPE_DISK: 1.84467440737E+19
    	imagick::RESOURCETYPE_FILE: 786432
    	imagick::RESOURCETYPE_MAP: 31 GB
    	imagick::RESOURCETYPE_MEMORY: 16 GB
    	imagick::RESOURCETYPE_THREAD: 1
    imagemagick_file_formats: 3FR, AAI, AI, ART, ARW, AVI, AVS, BGR, BGRA, BGRO, BIE, BMP, BMP2, BMP3, BRF, CAL, CALS, CANVAS, CAPTION, CIN, CIP, CLIP, CMYK, CMYKA, CR2, CRW, CUR, CUT, DATA, DCM, DCR, DCX, DDS, DFONT, DJVU, DNG, DOT, DPX, DXT1, DXT5, EPDF, EPI, EPS, EPS2, EPS3, EPSF, EPSI, EPT, EPT2, EPT3, ERF, EXR, FAX, FILE, FITS, FRACTAL, FTP, FTS, G3, G4, GIF, GIF87, GRADIENT, GRAY, GROUP4, GV, H, HALD, HDR, HISTOGRAM, HRZ, HTM, HTML, HTTP, HTTPS, ICB, ICO, ICON, IIQ, INFO, INLINE, IPL, ISOBRL, ISOBRL6, JBG, JBIG, JNG, JNX, JPE, JPEG, JPG, JPS, JSON, K25, KDC, LABEL, M2V, M4V, MAC, MAGICK, MAP, MASK, MAT, MATTE, MEF, MIFF, MKV, MNG, MONO, MOV, MP4, MPC, MPEG, MPG, MRW, MSL, MSVG, MTV, MVG, NEF, NRW, NULL, ORF, OTB, OTF, PAL, PALM, PAM, PANGO, PATTERN, PBM, PCD, PCDS, PCL, PCT, PCX, PDB, PDF, PDFA, PEF, PES, PFA, PFB, PFM, PGM, PICON, PICT, PIX, PJPEG, PLASMA, PNG, PNG00, PNG24, PNG32, PNG48, PNG64, PNG8, PNM, PPM, PREVIEW, PS, PS2, PS3, PSB, PSD, PTIF, PWP, RADIAL-GRADIENT, RAF, RAS, RAW, RGB, RGBA, RGBO, RGF, RLA, RLE, RMF, RW2, SCR, SCT, SFW, SGI, SHTML, SIX, SIXEL, SPARSE-COLOR, SR2, SRF, STEGANO, SUN, SVG, SVGZ, TEXT, TGA, THUMBNAIL, TIFF, TIFF64, TILE, TIM, TTC, TTF, TXT, UBRL, UBRL6, UIL, UYVY, VDA, VICAR, VID, VIFF, VIPS, VST, WBMP, WMF, WMV, WMZ, WPG, X, X3F, XBM, XC, XCF, XPM, XPS, XV, XWD, YCbCr, YCbCrA, YUV
    gd_version: 2.2.5
    gd_formats: GIF, JPEG, PNG, WebP, BMP, XPM
    ghostscript_version: 9.26
    
    ### wp-server ###
    
    server_architecture: Linux 4.15.0-196-generic x86_64
    httpd_software: Apache
    php_version: 8.1.13 64bit
    php_sapi: fpm-fcgi
    max_input_variables: 3000
    time_limit: 30
    memory_limit: 256M
    max_input_time: 60
    upload_max_filesize: 200M
    php_post_max_size: 200M
    curl_version: 7.58.0 OpenSSL/1.1.1
    suhosin: false
    imagick_availability: true
    pretty_permalinks: true
    htaccess_extra_rules: true
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 5.7.37-nmm1-log
    client_version: mysqlnd 8.1.13
    max_allowed_packet: 67108864
    max_connections: 500
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /www/htdocs/w018e8db/blog-roland-m-horn.de/wp-content
    WP_PLUGIN_DIR: /www/htdocs/w018e8db/blog-roland-m-horn.de/wp-content/plugins
    WP_MEMORY_LIMIT: 40M
    WP_MAX_MEMORY_LIMIT: 256M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: true
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_ENVIRONMENT_TYPE: Nicht definiert
    DB_CHARSET: utf8
    DB_COLLATE: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    mu-plugins: writable
    
    

    Vielleicht kann mir jemand helfen?

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 25)
  • Moderator Bego Mario Garde

    (@pixolin)

    Unter Werkzeuge > Website-Zustand werden dir Hinweise angezeigt, wie du deine Website optimieren kannst. Diese solltest du zuerst erledigen.

    Im Support-Forum des Plugins gibt es einen Hinweis zu einer Änderung im Plugin, die Ursache für die geänderte Statistik sein könnte:

    Wir haben vor kurzem eine neue Funktion zur Verbesserung des Datenschutzes eingeführt, die „Do Not Track“ heißt und an folgender Stelle zu finden ist:

    Dashboard > Statistik > Einstellungen > Datenschutz

    Wenn sowohl die „Do Not Track“-Option deines Browsers als auch unsere Funktion aktiviert sind, werden keine Besucherdaten erfasst. Es ist möglich, dass diese Option die Ursache für das von Ihnen erwähnte Problem ist.

    (Quelle: Support-Forum, übersetzt mit http://www.DeepL.com/Translator)

    Thread-Starter rolandmhorn

    (@rolandmhorn)

    Hallo Bego,

    ich habe die die Einstellung „Do not track“ unter den Statistik-Einstellungen unter „Privatsphäre“ gefunden und probeweise mal deaktiviert und warte nun mal ab.

    Vielen Dank und Gruß
    Roland

    Thread-Starter rolandmhorn

    (@rolandmhorn)

    Hallo Bego und alle,

    leider hat diese Maßnahme nichts gebracht. Hat jemand noch ’ne andere Idee?

    Gruß
    Roland

    Thread-Starter rolandmhorn

    (@rolandmhorn)

    Hallo alle,

    ich habe mal andere Statistikprogramme ausprobiert und festgestellt, dass auch mit Matomo, Burst und Jetpack nur wenige Besucher/Hits angezeigt werden. Kann es sein, dass irgendeine WP-Funktion oder ein Plugin jegliche Art von statistischer Erfassung stört oder muss ich davon ausgehen, dass tatsächlich von einem auf den anderen Tag deutlich weniger Besucher kamen?

    Gruß
    Roland

    Hallo,

    Kann es sein, dass irgendeine WP-Funktion oder ein Plugin jegliche Art von statistischer Erfassung stört oder muss ich davon ausgehen, dass tatsächlich von einem auf den anderen Tag deutlich weniger Besucher kamen?

    Ich kann mir nicht vorstellen, dass ein Plugin dafür verantwortlich ist.
    Sicher hast du auch schon geprüft, ob unter Einstellungen > Lesen die „Sichtbarkeit für Suchmaschinen“ nicht angekreuzt ist („Suchmaschinen davon abhalten, diese Website zu indexieren“).

    Ich habe mir gerade die Werte deiner Website in der developer console (Aufruf mit F12 in Chrome) und dann Test unter „Lighthouse“ angesehen. Insbesondere die Werte unter „Performance“ sind ziemlich mau. Da würde ich nachbessern. Es könnte unter Umständen auch sein, dass Google die Bewertung der Website im Hinblick auf die Performance geändert hat und dementsprechend sich eine Änderung bei den Suchergebnissen für deine Website ergibt.
    Schau doch mal bitte, ob deine Website bei den für dich (und inbesondere für deine Leser) interessanten Suchbegriffe an welcher Stelle bei Google als Treffer genannt werden.

    Viele Grüße
    Hans-Gerd

    Thread-Starter rolandmhorn

    (@rolandmhorn)

    Hallo Hans-Gerd,

    erstmal vielen Dank!

    Ja, das mit der Performance ist mir auch aufgefallen. Deshalb habe ich jetzt bei Einstellungen > Lesen die „Blogseiten zeigen maximal [] Beiträge“ von 1000 auf 20 runtergeschraubt. Die Performancewerte, die ich jetzt gemessen habe, sind gut. Ich hätte halt gern die Möglichkeit, dass der Leser auch auf die anderen (älteren) Seiten sehen kann und nach einer Möglichkeit gesucht, unter die ersten 20 einen Navigationsfeil einzusetzen, der die nächsten 20 anzeigt usw. Habe einiges ausprobiert, funktioniert aber nicht.

    Tatsächlich kann ich unter Google unter solchen Einträgen gar keine Verweise auf meinen Blog finden! Kann man da etwas machen?

    “ Suchmaschinen davon abhalten, diese Website zu indexieren“ ist übrigens nicht angekreuzt

    Gruß
    Roland

    • Diese Antwort wurde geändert vor 1 Woche, 4 Tage von rolandmhorn.
    • Diese Antwort wurde geändert vor 1 Woche, 4 Tage von rolandmhorn.

    Hallo,
    ich gehe mal davon aus, dass du die Website bei der Google Search Console angemeldet hast – dann würde ich da auch mal prüfen, wie deine Seite funktioniert. Dazu hier ein Link.

    Evtl. solltest du auch noch alle Einstellungen bei YOAST prüfen, Beitrag siehe hier.

    Viele Grüße
    Hans-Gerd

    Thread-Starter rolandmhorn

    (@rolandmhorn)

    Hallo,

    ich habe mir die Artikel mal durchgelesen und etwas an YOAST Seo herumgeschraubt. Was den ersten Link betrifft, so steh ich etwas auf dem Schlauch. Wo finde ich denn diese Acquisition > All Traffic > Channels section?

    Grundsätzlich habe ich immer noch Zweifel, ob diese Google-Geschichte die alleinige Erklärung für das Phänomen ist. Bis vor etwas 14 Tagen hatte ich, nachdem ich einen neuen Artikel gepostet und ich den sozialen Netzwerken, also über Quellen außerhalb des Google-Universums, geteilt habe, nach einer halben Stunde etwa 9 Besucher, die den Artikel angeklickt hatten. In den letzten 14 Tagen kann ich froh sein, wenn *einer* angezeigt wird. Meistens sind es null.

    Vollkommen ernüchternd ist die Matoma-Anzeige. Da wird bei fast allen von den wenigen Besuchern angezeigt, dass sie nur auf einer Seite waren, und das genau 0 Sekunden waren. Ist diese Angabe zuverlässig?

    Tja, jetzt hatte ich es vor kurzem endlich geschafft, aus der Kategorie 50-100 auf 100-150 zu klettern, und jetzt hab‘ ich noch allerhöchstens 25 Besucher pro Tag (wenn die Anzeige stimmt), und das ist sehr hoch gegriffen. 🙁

    Gruß
    Roland

    Moderator Bego Mario Garde

    (@pixolin)

    Hast du mal die Complianz-Einstellungen durchgeschaut? Gut möglich, dass ohne ausdrückliche Einwilligung alles blockiert wird. Mein Ad-Blocker blendet das Cookie-Banner aus und das JavaScript für Matomo und stats.wp wird gar nicht erst geladen.

    Thread-Starter rolandmhorn

    (@rolandmhorn)

    Hallo Bego,

    die Complianz-Einstellungen bin ich mehrmals durchgegangen und habe auch entsprechende „verdächtige“ Funktionen umgestellt. Aber eine Änderung hat sich leider nicht ergeben. Ich guck‘ jetzt aber nochmal.

    Gruß
    Roland

    Moderator Bego Mario Garde

    (@pixolin)

    Naja, es ist eben so, dass ich als Besucher nicht gezählt werde, wenn weder von Matomo noch von stats.wp das JavaScript verwendet wird – was allgemein das Problem von solchen Analysetools ist.

    Du kannst Matomo sowohl mit Cookies als auch mit JavaScript betreiben. Wenn du keine Cookies setzt und die Besucher-IP-Adresse anonymisierst (Matomo-Plugin „PrivacyManager“), brauchst du nach meinen Informationen (ich bin kein Anwalt) in Complianz dafür keine Genehmigung der Webseitenbesucher einholen; es reicht, wenn du die statistische Erfassung in der Datenschutzerklärung angibst. An der Auswertung der Website-Besuche ohne Speicherung persönlicher Merkmale hast du ein berechtigtes Interesse.

    Thread-Starter rolandmhorn

    (@rolandmhorn)

    Hallo Bego,

    ich habe nun Matomo wieder deaktiviert. Ich hatte es ohnehin nur zu Vergleichszwecken installiert. Auf Dauer will ich mit WP-Statistik arbeiten. Außerdem kann ich bei Complianz bei „Erstellst du Statistiken über deiner Website?“ nur entweder WP-Statistiks oder Matomo ankreuzen.

    Gruß
    Roland

    Hallo,
    hast du mal statify (datenschutzkonform) oder Koko Analytics (kann datenschutzkonform eingerichtet werden) getestet?
    Vielleicht brauchst du dann auch kein Compliance mehr.
    Viele Grüße
    Hans-Gerd

    Thread-Starter rolandmhorn

    (@rolandmhorn)

    Hallo Hans-Gerd,

    ich habe mal Statify eingesetzt und verzeichne dort heute 106 Aufrufe. Bei WP-Statistics sind es dagegen 9 (!) bei 6 Besuchern. Muss ich daraus schließen, dass der Fehler dort bei WP-Statistics liegt? Grundsätzlich würde ich gern mit diesem Plugin weiter arbeiten,denn Statify ist mir doch zu spartanisch.

    Complianz habe ich deaktiviert und deinstalliert – auch aus dem Grund, dass sich neulich jemand beschwert hat, meine Cookie-Richtlien seien nicht DSGVO-kompatibel. Ich habe das Plugin jetzt durch eine eine mit dem Datenschutz-Generator von Dr. Schwenke erstellte Datenschutzerklärung und dem Plugin „GDPR Cookie Compliance“ ersetzt. Ich hoffe, das reicht. Im Stillen habe ich ja gehofft, dass mit Complianz auch mein Statistik-Problem verschwindet – aber das war leider nicht der Fall.

    Gruß
    Roland

    Hallo,
    schau dir mal bitte zu Statify die Erweiterungen an.
    Insbesondere mit Statify – Erweiterte Auswertung hast du wesentlich mehr Auswertungsmöglichkeiten.

    Viele Grüße
    Hans-Gerd

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 25)