• Hallo zusammen,

    in meinem letzten Post hier ging es um einen plötzlichen Besuchereinbruch auf meiner Page – dieses Mal ist das Gegenteil der Fall. WP Statistics zeigt mir seit etwa zwei Tagen über 1000 anstatt meiner üblichen etwa 100 Besucher an. (Könnte zeitlich mit einem WP-Statistics-Update zusammenfallen.)

    Da die zusätzlichen Besucher von einem chinesischen Server kommen, geh ich von Referrer-Spam aus. Ich habe dann auch gleich mehrere Plugins geholt, als da wären:

    • WP Armour – Honeypot Anti Spam
    • Solid Security Basic
    • Analytics Spam Blocker
    • Blackhole for Bad Bots

    Doch alles hat nichts gefruchtet. Dann habe ich noch bei WP Statistics eine Einstellung geändert – bei IP Detection „Sequential IP Detection (Recommended)“ eingestellt.

    Doch auch das hat nichts gebracht.

    Möglicherweise hat das Ganze tatsächlich etwas mit WP Statistics zu tun, denn Burst und Google Analytics zeigten deutlich weniger Besucher an – weniger als die bei WP Statistic bei mir üblichen etwa 100. Das war auch vorher schon so.

    Akismet wird als ungetestet meiner meiner WordPress-Version (6.5.2) bezeichnet.

    Ich arbeite mit Windows 10.

    Vielleicht hat hier ja jemand eine Idee.

    Gruß

    Roland



    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 11 Antworten – 1 bis 11 (von insgesamt 11)
  • Die von dir installierten neuen Plugins helfen nicht gegen einen statistischen Wert den ein anderes Plugin (WP Statistik) ausgibt. Ich würde empfehlen die Plugins wieder zu deinstallieren, wenn du sie nicht wirklich unbedingt brauchst. Denn wild Plugins zu installieren, kann auch gut nach hinten losgehen.

    WP Armour bringt dir z.B. gar nichts da ich keine Formulare auf deiner Webseite sehe die geschützt werden müssten.

    Solid Security ist zumindest ganz ordentlich um dein Web abzusichern gegen Angriffe, wird aber an der Statistik auch nichts ändern. Zumindest das solltest Du behalten falls Du nicht bereits ein Sicherheitsplugin installiert hast.

    Bei solchen statistischen Auswertungen kann es Phasen geben in denen mal mehr, mal weniger Los ist. Es gibt Zeiten da versuchen die Bot-Betreiber ihre „Bot-Farmen“ möglichst intensiv andere Webseiten aufzurufen, dann gibt es auch wieder ruhigere Zeiten. Man sollte sich nur dadurch nicht verrückt machen lassen. Beobachte es, aber versuche nicht zu viele Rückschlüsse daraus zu ziehen. Schau dir bei Solid Security mal die Protokolle nach einigen Tagen an, aber auch hier: nicht verrückt machen lassen. Was man dort sieht ist leider der alltägliche Wahnsinn im Internet.

    Übrigens bin ich erfreut dich hier zu sehen. Wir hatten vor vielen Jahren mal im Grenzwissen-Forum miteinander zu tun. Die Welt ist sehr klein 🙂

    Thread-Starter rolandmhorn

    (@rolandmhorn)

    Danke für die Antwort, Threadi,

    das ist natürlich sehr beruhigend, aber es bleibt das Problem, das ich nicht weiß, wie viele „menschliche“ Besucher in etwa wirklich auf meinen Blog kommen. Gibt es da keine Möglichkeit, die Bots irgendwie auszusperren?

    Gruß
    Roland

    PS: Ich habe Dir auf Instagram ein paar Zeilen geschrieben…

    Alle Bots auszuschließen ist technisch sehr aufwendig und würde u.a. dazu führen, dass deine Webseite gar nicht mehr gefunden wird. Dir geht es aber eher darum sie aus der Statistik auszuschließen. WP Statistik hat dazu in den Einstellungen (Statistik > Einstellungen) eine Seite namens „Filtering & Exceptions“. Dort gibt es einen Abschnitt namens „Robot Exclusions“ der schon Grundeinstellungen zum Rausfiltern mitbringt.

    Da Du von chinesischen Zugriffen sprichst, könntest Du die in dem Abschnitt „GeoIP-Ausnahmen“ vermutlich ausschließen. Gib bei „Excluded Countries“ das Kürzel für China ein: cn – die Einstellungsmöglichkeiten sind auch hier dokumentiert: https://wp-statistics.com/resources/filtering-exceptions-settings/

    Wenn du weißt, dass die Zugriffe von einem „chinesischen Server“ kommen, kannst du die IP mit der .htaccess aussperren. Siehst du in den Zugriffslogs den User-Agenten? Wenn dieser „speziell“ ist, kannst du auch diesen blockieren.

    Wenn man an die Einstellungen der Firewall des Servers kommt, kann man auch darüber IP-Adressen bzw. IP-Bereiche sperren, dann hat man dieses Problem auch nicht. Einziger Nachteil: die Liste der geblockten IP-Adressen wird immer länger 😉

    Wenn man an die Einstellungen der Firewall des Servers kommt

    dann könnte man noch ganz andere Dinge tun, z.B. fail2ban. Kann man bei shared Hosting leider nicht.

    Thread-Starter rolandmhorn

    (@rolandmhorn)

    Hallo und vielen Dank für Eure zahlreichen Hilfsangebote!

    Thready: „Gib bei „Excluded Countries“ das Kürzel für China ein: cn.“ Dann würde ich aber auch potentielle „menschliche“ Besucher aus China ausschließen bzw. auch „menschliche“ Zugriffe aus China würden von der Statistik nicht mehr erfasst, oder?

    hupe13 und bscu: Leider sind die IP-Adressen der Zugriffe vollkommen unterschiedlich.

    Gruß

    Roland


    • Diese Antwort wurde geändert vor 2 Monaten, 4 Wochen von rolandmhorn.

    Jap, die wären auch ausgeschlossen. Erwartest Du denn Besucher aus China? Deine Webseite ist komplett deutsch, da ist auch eine Sprachbarriere beim Anschauen da. Einen Tot muss man an der Stelle dann sterben 😉

    geh ich von Referrer-Spam aus

    Ist der Referrer eindeutig? Dann könntest du den über die .htaccess aussperren.

    Thread-Starter rolandmhorn

    (@rolandmhorn)

    Ist der Referrer eindeutig? Dann könntest du den über die .htaccess aussperren.

    hupe13

    Leider werden zum Referrer keine Angaben gemacht. Da ist nur ein einziger Strich…

    threadi: Dann werd‘ ich „die Chinesen“ mal versuchsweise aussperren…

    Gruß

    Roland

    Thread-Starter rolandmhorn

    (@rolandmhorn)

    So, jetzt sind „die Chinesen“ ein paar Tage draußen und schon habe ich wieder meine gewohnten mickrigen knapp 100 Besucher täglich…

Ansicht von 11 Antworten – 1 bis 11 (von insgesamt 11)