Support » Plugins » Plugin Fehlermeldung

  • Gelöst blackwoods

    (@blackwoods)


    Hallo zusammen,

    ich bin relativ neu auf dem Gebiet WordPress und baue aktuell unsere Homepage für den Sportverein.
    Es handelt sich hierbei um einen Baseballverein. Nun gibt es die Möglichkeit die Spielpläne und Ligatabellen direkt mit der Liga zu verknüpfen. Hierzu wird auf der Homepage speziell ein Plugin für WordPress angeboten.
    Dieses Plugin habe ich heruntergeladen und bereits installiert.
    Leider bekomme ich bei der Aktivierung folgende Fehlermeldung und kann damit leider nicht all zu viel anfangen:
    Parse error: syntax error, unexpected token „match“, expecting „:“ in /var/www/vhosts/hosting108619.a2f39.netcup.net/wordpress.buehl-blackwoods.de/wp-content/plugins/bsm-wordpress-plugin/bsm/data/Api.php on line 427

    Kann mir evtl. jemand einen Tipp geben, wie ich den Fehler beheben kann?

    Liebe Grüße

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 15)
  • In unserem angehefteten Beitrag

    Bevor du ein neues Thema (Thread) erstellst

    haben wir beschrieben, welche Informationen wir benötigen, um dir bei einem Problem zu helfen. Dazu gehört die URL deiner Website und der Website-Bericht, der uns mit wichtigen Eckdaten zu deiner Website versorgt. Du kannst den Website-Bericht ganz bequem per Button kopieren und hier in einer Antwort einfügen. Du findest den Button unter WerkzeugeWebsite-Zustand im Tab „Bericht“. Warte bitte mit dem Klick auf den Button, bis die Zustandsanzeige abgeschlossen ist.

    Ich rate mal: es wird PHP 8.x eingesetzt. Wenn das so ist, solltest du im Control-Panel des Webspaces auf eine PHP-Version 7.x umstellen, dann wird es wieder funktionieren.

    Thread-Ersteller blackwoods

    (@blackwoods)

    Die aktuelle PHP ist 7.2, denke daher wird das Problem damit nicht gelöst…

    Anbei der Zustandsbericht

    
    ### wp-core ###
    
    version: 5.8.3
    site_language: de_DE
    user_language: de_DE
    timezone: +00:00
    permalink: undefined
    https_status: true
    multisite: false
    user_registration: 0
    blog_public: 0
    default_comment_status: open
    environment_type: production
    user_count: 1
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /var/www/vhosts/hosting108619.a2f39.netcup.net/wordpress.buehl-blackwoods.de
    wordpress_size: 114,17 MB (119721016 bytes)
    uploads_path: /var/www/vhosts/hosting108619.a2f39.netcup.net/wordpress.buehl-blackwoods.de/wp-content/uploads
    uploads_size: 17,30 MB (18143320 bytes)
    themes_path: /var/www/vhosts/hosting108619.a2f39.netcup.net/wordpress.buehl-blackwoods.de/wp-content/themes
    themes_size: 21,15 MB (22175376 bytes)
    plugins_path: /var/www/vhosts/hosting108619.a2f39.netcup.net/wordpress.buehl-blackwoods.de/wp-content/plugins
    plugins_size: 18,13 MB (19014853 bytes)
    database_size: 21,47 MB (22511616 bytes)
    total_size: 192,23 MB (201566181 bytes)
    
    ### wp-active-theme ###
    
    name: Sports Club Lite (sports-club-lite)
    version: 2.0
    author: Grace Themes
    author_website: https://gracethemes.com/
    parent_theme: none
    theme_features: core-block-patterns, widgets-block-editor, automatic-feed-links, html5, post-thumbnails, title-tag, responsive-embeds, align-wide, wp-block-styles, custom-logo, custom-background, menus, editor-style, woocommerce, wc-product-gallery-zoom, wc-product-gallery-lightbox, wc-product-gallery-slider, custom-header, infinite-scroll, widgets
    theme_path: /var/www/vhosts/hosting108619.a2f39.netcup.net/wordpress.buehl-blackwoods.de/wp-content/themes/sports-club-lite
    auto_update: Deaktiviert
    
    ### wp-themes-inactive (8) ###
    
    CloudPress Dark: version: 0.9, author: spicethemes, Automatische Aktualisierungen deaktiviert
    CloudPress: version: 2.4.7, author: Spicethemes, Automatische Aktualisierungen deaktiviert
    OnePress: version: 2.2.8, author: FameThemes, Automatische Aktualisierungen deaktiviert
    SpicePress Dark: version: 0.9, author: spicethemes, Automatische Aktualisierungen deaktiviert
    SpicePress: version: 2.0, author: spicethemes, Automatische Aktualisierungen deaktiviert
    Twenty Nineteen: version: 2.1, author: WordPress-Team, Automatische Aktualisierungen deaktiviert
    Twenty Twenty: version: 1.8, author: WordPress-Team, Automatische Aktualisierungen deaktiviert
    Twenty Twenty-One: version: 1.4, author: WordPress-Team, Automatische Aktualisierungen deaktiviert
    
    ### wp-plugins-active (3) ###
    
    Contact Form 7: version: 5.5.4, author: Takayuki Miyoshi, Automatische Aktualisierungen deaktiviert
    FG Joomla to WordPress: version: 3.92.0, author: Frédéric GILLES, Automatische Aktualisierungen deaktiviert
    SpiceBox: version: 1.9, author: Spicethemes, Automatische Aktualisierungen deaktiviert
    
    ### wp-plugins-inactive (4) ###
    
    Akismet Anti-Spam: version: 4.2.1, author: Automattic, Automatische Aktualisierungen deaktiviert
    BSM: version: 1.8.19, author: Andreas Schön / <a href='mailto:ralf.fasora@bwbsv.de'>Ralf Fasora</a>, Automatische Aktualisierungen deaktiviert
    Hello Dolly: version: 1.7.2, author: Matt Mullenweg, Automatische Aktualisierungen deaktiviert
    Spice Post Slider: version: 0.6, author: Spicethemes, Automatische Aktualisierungen deaktiviert
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_Imagick
    imagick_module_version: 1687
    imagemagick_version: ImageMagick 6.9.7-4 Q16 x86_64 20170114 http://www.imagemagick.org
    imagick_version: 3.6.0
    file_uploads: File uploads is turned off
    post_max_size: 128M
    upload_max_filesize: 128M
    max_effective_size: 128 MB
    max_file_uploads: 20
    imagick_limits: 
    	imagick::RESOURCETYPE_AREA: 122 MB
    	imagick::RESOURCETYPE_DISK: 1073741824
    	imagick::RESOURCETYPE_FILE: 393216
    	imagick::RESOURCETYPE_MAP: 512 MB
    	imagick::RESOURCETYPE_MEMORY: 256 MB
    	imagick::RESOURCETYPE_THREAD: 1
    imagemagick_file_formats: 3FR, AAI, AI, ART, ARW, AVI, AVS, BGR, BGRA, BGRO, BIE, BMP, BMP2, BMP3, BRF, CAL, CALS, CANVAS, CAPTION, CIN, CIP, CLIP, CMYK, CMYKA, CR2, CRW, CUR, CUT, DATA, DCM, DCR, DCX, DDS, DFONT, DJVU, DNG, DOT, DPX, DXT1, DXT5, EPDF, EPI, EPS, EPS2, EPS3, EPSF, EPSI, EPT, EPT2, EPT3, ERF, EXR, FAX, FILE, FITS, FRACTAL, FTP, FTS, G3, G4, GIF, GIF87, GRADIENT, GRAY, GROUP4, GV, H, HALD, HDR, HISTOGRAM, HRZ, HTM, HTML, HTTP, HTTPS, ICB, ICO, ICON, IIQ, INFO, INLINE, IPL, ISOBRL, ISOBRL6, J2C, J2K, JBG, JBIG, JNG, JNX, JP2, JPC, JPE, JPEG, JPG, JPM, JPS, JPT, JSON, K25, KDC, LABEL, M2V, M4V, MAC, MAGICK, MAP, MASK, MAT, MATTE, MEF, MIFF, MKV, MNG, MONO, MOV, MP4, MPC, MPEG, MPG, MRW, MSL, MSVG, MTV, MVG, NEF, NRW, NULL, ORF, OTB, OTF, PAL, PALM, PAM, PANGO, PATTERN, PBM, PCD, PCDS, PCL, PCT, PCX, PDB, PDF, PDFA, PEF, PES, PFA, PFB, PFM, PGM, PICON, PICT, PIX, PJPEG, PLASMA, PNG, PNG00, PNG24, PNG32, PNG48, PNG64, PNG8, PNM, PPM, PREVIEW, PS, PS2, PS3, PSB, PSD, PTIF, PWP, RADIAL-GRADIENT, RAF, RAS, RAW, RGB, RGBA, RGBO, RGF, RLA, RLE, RMF, RW2, SCR, SCT, SFW, SGI, SHTML, SIX, SIXEL, SPARSE-COLOR, SR2, SRF, STEGANO, SUN, SVG, SVGZ, TEXT, TGA, THUMBNAIL, TIFF, TIFF64, TILE, TIM, TTC, TTF, TXT, UBRL, UBRL6, UIL, UYVY, VDA, VICAR, VID, VIFF, VIPS, VST, WBMP, WMF, WMV, WMZ, WPG, X, X3F, XBM, XC, XCF, XPM, XPS, XV, XWD, YCbCr, YCbCrA, YUV
    gd_version: bundled (2.1.0 compatible)
    gd_formats: GIF, JPEG, PNG, WebP, BMP, XPM
    ghostscript_version: 9.26
    
    ### wp-server ###
    
    server_architecture: Linux 4.19.0-0.bpo.17-amd64 x86_64
    httpd_software: Apache
    php_version: 8.0.14 64bit
    php_sapi: cgi-fcgi
    max_input_variables: 4000
    time_limit: 180
    memory_limit: 512M
    max_input_time: 60
    upload_max_filesize: 128M
    php_post_max_size: 128M
    curl_version: 7.52.1 OpenSSL/1.0.2u
    suhosin: false
    imagick_availability: true
    pretty_permalinks: true
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 8.0.25
    client_version: mysqlnd 8.0.14
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /var/www/vhosts/hosting108619.a2f39.netcup.net/wordpress.buehl-blackwoods.de/wp-content
    WP_PLUGIN_DIR: /var/www/vhosts/hosting108619.a2f39.netcup.net/wordpress.buehl-blackwoods.de/wp-content/plugins
    WP_MEMORY_LIMIT: 40M
    WP_MAX_MEMORY_LIMIT: 512M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_LOCAL_DEV: undefined
    DB_CHARSET: utf8
    DB_COLLATE: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable

    Die HP ist noch am totalen Anfang, daher nicht mit Inhalt oder ähnlichem gefüllt. Ich wollte zuerst das Plugin versuchen, da ich ja im schlimmsten Fall eine andere Lösung finden muss.

    Die aktuelle PHP ist 7.2,

    Nö. Ist sie nicht. Siehe Website-Bericht:

    ### wp-server ###

    server_architecture: Linux 4.19.0-0.bpo.17-amd64 x86_64
    httpd_software: Apache
    php_version: 8.0.14 64bit
    php_sapi: cgi-fcgi

    Thread-Ersteller blackwoods

    (@blackwoods)

    Dann nutzt die Subdomain eine neuere Version als die Hauptdomain…wenn ich in den Einstellungen der hauptdomain schaue wird mir 7.2 angezeigt

    ¯\_(ツ)_/¯ und nun?

    Thread-Ersteller blackwoods

    (@blackwoods)

    Werde ich schauen, dass ich das geändert bekomme. Wenn ich dir zu viele Fragen stelle, tut es mir leid aber du musst ja nicht darauf antworten 😉
    Wie ich oben schrieb, bin ich noch relativ neu in der Materie:)


    Wenn ich dir zu viele Fragen stelle, tut es mir leid aber du musst ja nicht darauf antworten

    Moderatoren können echt lästig sein. 😄

    Werde ich schauen, dass ich das geändert bekomme.

    Klingt nach einem guten Plan.

    Thread-Ersteller blackwoods

    (@blackwoods)

    @bscu danke für deine Hilfreiche Antwort 😉😊

    Soll heißen, Problem wurde durch Umstellung auf PHP 7.4 gelöst?

    @pixolin

    Moderatoren können echt lästig sein.

    Aber sowas von….
    Permanent Fragen beantworten! Wo kommen wir denn hin, wenn das jeder macht? 😀 😀 😀

    Thread-Ersteller blackwoods

    (@blackwoods)

    @pixolin nein soll es nicht heißen 😉

    @blackwoods
    Du bist dir aber jetzt sicher, dass nicht doch PHP 8 eingesetzt wird?

    Thread-Ersteller blackwoods

    (@blackwoods)

    @bscu ja jetzt bin ich mir sicher, habe nicht daran gedacht, dass die Subdomain eine andere Version nutzen kann, als die Hauptdomain. Ich habe jetzt mal auf 7.4 umgestellt und werde es später testen, danke schonmal

    Thread-Ersteller blackwoods

    (@blackwoods)

    Thema kann geschlossen werden.
    Nachdem ich PHP auf 7.4 gestellt habe, kann ich das Plugin aktivieren.
    Danke für die Hilfe @bscu

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 15)