Support » Allgemeine Fragen » Plugin hat Kommentarfunktion komplett gelöscht.

  • Hallo,

    ich habe ein kleines Problem. Zunächst einmal wollte ich die WP Kommentarfunktion durch die von Elementor ersetzen. Dabei wurden mir dann zwei Kommentarfelder auf der Seite angezeigt. Danach habe ich das Plugin „Webcraftic Disable Comments“ installiert und dadurch die Kommentare dauerhaft ausgeschaltet. Ich hatte die Hoffnung, dass dies nur die WP Kommentarfunktion betrifft, die Kommentare erhalten bleiben und das Elementor-Widget dann einfach auf die Kommentare zugreifen kann.

    Dem ist nicht so. Elementor zeigt mir an, dass die Kommentarfunktion aktiviert sein muss, nur das ist jetzt nicht mehr möglich. Unter Einstellungen > Diskussion kann ich die Kommentarfunktion zwar anschalten, aber das ändert nichts. Auf der Bearbeitungsseite der erstellten Seiten fehlt die Option „Kommentare erlauben“ nun vollständig.

    Ich muss noch dazu sagen, dass ich beim „Disable Comments“ Plugin eine Option gewählt habe, in der ich zuvor gewarnt wurde.

    „This will make persistent changes to your database – comments will remain closed even if you later disable the plugin! You should not use it if you only want to disable comments temporarely.“

    Tja, toller Mist. Ich dachte, das würde nur eintreten, wenn man die Option deaktiviert und dann das Plugin disabled. Aber die Option ist dauerhaft verschwunden.

    Gibt es eine Möglichkeit die wiederzubekommen?

    Vielen Dank für eure Hilfe schonmal!

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 15)
  • Backup wiederherstellen.

    Thread-Ersteller dsieve

    (@dsieve)

    danke für die antwort erstmal.

    da hab ich so gar keine erfahrungen mit… könnte mir wer sagen, wie das am besten funktionieren könnte?

    Bevor du solche gravierenden Änderungen vorgenommen hast, hast du doch sicher hoffentlich ein Backup gemacht? Dieses Backup wiederherzustellen wäre die einfachste Möglichkeit, die Website auf den vorherigen Zustand zu bringen.

    Du hast kein Backup gemacht? Dann frag beim Webhoster nach, ob der regelmäßig Backups macht und das ggf. wiederherstellen kann.

    Wenn du nicht weißt, wie man ein Backup wiederherstellt, stellt sich mir die Frage, ob du überhaupt ein Backup erstellt hast. Falls nicht, solltest du deinen Hoster kontaktieren und hoffen, dass der ein Backup hat und es dir einspielen kann.

    Edit: wieder mal zu langsam 🙁

    • Diese Antwort wurde geändert vor 3 Monaten, 4 Wochen von bscu.

    @bscu

    Edit: wieder mal zu langsam 🙁

    Nein, gar nicht – ist doch nicht verkehrt, das von zwei unterschiedlichen Anwendern in sehr ähnlicher Form mitgeteilt zu bekommen. Kein Wettbewerb, wir schätzen deine Antworten hier sehr.

    Thread-Ersteller dsieve

    (@dsieve)

    shit, ne, habe ich nicht… hätte nicht erwartet, dass das so eine gravierende änderung ist und ich die einfach ausprobieren und die kommentare ein- und ausschalten kann, solange ich das plugin nicht deaktiviere 🙁

    gibt es nicht sonst eine möglichkeit irgendwie wieder eine kommentarfunktion auf die seite zu bekommen? eventuell mit einem anderen plugin (die seite ist noch neu und es gab erst einen kommentar, das wäre nicht so wild). oder wäre es möglich, wordpress allgemein wieder zurückzusetzen oder eine ältere version zu installieren, welche die kommentarfunktion wiederherstellt und meine daten behält? und dann vielleicht danach wieder auf die aktuellste aktualisieren?

    WPdiscuz hab ich auch schon ausprobiert, das plugin funktioniert auch nicht ohne ohne das ich kommentare erlaube…

    eieiei, da hab ich wohl echt mist gebaut.

    Tja, es gilt immer noch das alte Sprichwort: „Never touch a running system“, wenn man kein Backup hat. Ich würde es über den Hoster versuchen.

    Du kannst normalerweise in Einstellungen > Diskussion global festlegen, ob Kommentare erlaubt sind. Das lässt sich aber individuell für Seiten und Beiträge durch ein Häkchen in der Editor-Sidebar ändern. Die individuelle Einstellung überschreibt die globale Einstellung.

    Ich verstehe den Plugin-Code nun so, dass direkt in der Datenbank unabhängig von den Einstellungen im Editor der Status für „Kommentare und Pingbacks erlauben“ auf geschlossen gesetzt wird. Diese Einstellung nimmt das Plugin auch nicht mehr zurück, weil sonst zwischengespeichert werden müsste, für welche Seiten und Beiträge der Eintrag geändert wurde. (Deshalb der Warnhinweis im Plugin.)

    Setze ich in den Plugin-Einstellungen der Status für „Disable Comments“ auf „Not disable“ oder deaktiviere ich das Plugin, kann ich aber wieder global oder einzeln festlegen, welche Beiträge und Seiten kommentiert werden dürfen. Das einzige Problem dass ich hier sehe ist, dass dieser Schritt nicht automatisch für die Beiträge rückgängig gemacht werden kann, bei denen vorher Kommentare erlaubt waren.

    Bevor du in jeden einzelnen Beitrag gehst, das Häkchen setzt und den Beitrag neu speicherst, wäre eine Massenbearbeitung sinnvoll:

    Menü Beiträge > Pulldown „Anpassen“ oben rechts > Anzahl der angezeigten Beiträge auf einen hohen Wert setzen (z.B. 200 statt 20).

    Im Pulldown-Menü Massenbearbeitung auf Bearbeiten gehen,
    alle Beiträge, die kommentiert werden sollen, anklicken, Button übernehmen.
    Pulldown bei Kommentare und Pings von „Keine Änderung“ auf „erlauben“ ändern,
    aktualisieren.
    In einem neuen, privaten Browserfenster die Beiträge stichprobenartig prüfen.

    Nun sollte alles wieder wie vorher sein. Nur mit einer Erfahrung extra.

    Thread-Ersteller dsieve

    (@dsieve)

    bei beiträgen gibt es die funktion der kommentare noch, da ich das nur für statische seiten ausprobiert habe. dort hab ich allerdings gar nicht mehr die möglichkeit, kommentare individuell pro beitrag zu erlauben. auch wenn ich eine neue seite erstelle, kann ich keine kommentarfunktion mehr hinzufügen. geschweige denn, alle auf einmal wieder herzustellen. als wäre die gesamte funktion für seiten komplett aus wp rausgelöscht worden von dem plugin (ist es ja vielleicht auch… 🙁 )

    aber danke nochmal für deine zeit und mühe!

    Ich sehe nach Deaktivieren des Plugins auch für Seiten in der Sidebar ein Kästchen Diskussion > Kommentare. Prüf bitte über das Kebab-Menü ganz oben rechts > Voreinstellungen, ob das Häkchen bei Diskussion gesetzt ist:

    Screenshot Einstellungen
    (zum Vergrößern anklicken)

    Thread-Ersteller dsieve

    (@dsieve)

    die schaltfläche „diskussion“ gibt es da einfach nicht mehr bei mir… 🙁 nur noch permalink, template, beitragsbild und seiten-attribute.

    das is echt n scheiß plugin, dass ich da genutzt habe, einmal falsch klicken und schon die kommentarfunktion für immer weg für seiten in wordpress? das hätte ich echt nicht erwartet.

    Den Browser-Cache hast du zwischendurch mal geleert?
    Oder einen anderen Browser verwendet?

    Ich habe das Plugin in einer Testumgebung ausprobiert und kann solche gravierenden Änderungen nicht reproduzieren.

    Thread-Ersteller dsieve

    (@dsieve)

    den browser habe ich gerade mal gewechselt… immer noch das gleiche. hast du bei deinem test die kommentarfunktion disabled oder das gespeichert im plugin oder das nur installiert und wieder deaktiviert?

    mir ist gerade auch aufgefallen, dass ich auch in den globalen einstellungen nur noch die möglichkeit habe, die kommentare für beiträge zu erlauben, nicht für seiten, wobei ich mir gerade auch nicht sicher bin, ob es für seiten dort überhaupt eine extra option gab. falls ja, is auch die weg.

    also wirklich alles was mit kommentaren zu tun hat auf seiten ist komplett verschwunden.

    • Diese Antwort wurde geändert vor 3 Monaten, 4 Wochen von dsieve.
    Thread-Ersteller dsieve

    (@dsieve)

    aber naja, ist egal. ich werd mich da morgen nochmal weiter mit beschäftigen. will deine zeit auch nicht überstrapazieren 😉 vielen vielen dank für deine hilfe aber! 🙂

    Ich hab’s jetzt nochmal ausprobiert:
    Plugin installiert,
    Kommentare für alle Beitragsarten dauerhaft („persistent“) deaktiviert,
    vorhandene Kommentare gelöscht,
    Plugin deaktiviert und deinstalliert.

    Ergebnis:
    Die Kommentare sind dauerhaft weg.
    Wo vorher Kommentare erlaubt waren, sind sie jetzt nicht mehr erlaubt.
    Ich kann beim Bearbeiten von Seiten und Beiträgen Kommentare manuell erlauben.
    Ich kann über eine Massenbearbeitung für Seiten und Beiträge Kommentare erlauben.
    Ich kann global Kommentare erlauben, was sich aber nur auf künftige Seiten und Beiträge auswirkt.

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 15)