Support » Plugins » Plugin Suchfunktion fehlt – WP Update kann nicht gemacht werden

  • Gelöst tinaneumann

    (@tinaneumann)


    Hallo zusammen,

    Meine Suchfunktion bei den Plugins ist verschwunden.
    Es gibt auch keine Untermenus zu den Plugins.
    Löschen, kann ich Plugins ebenfalls nicht. Nur deaktivieren.

    Ein Update für WordPress kann ich nicht machen und Strato macht leider auch seit Version 5.3.2 kein Update mehr.
    Ich wäre euch sehr verbunden wenn ihr mir helfen könntet.

    • Dieses Thema wurde geändert vor 5 Monaten, 3 Wochen von Bego Mario Garde. Grund: Unser Forum unterstützt keinen BBCode
    • Dieses Thema wurde geändert vor 5 Monaten, 3 Wochen von tinaneumann.

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 12 Antworten - 1 bis 12 (von insgesamt 12)
  • Hallo,
    du findest unter Werkzeuge > Websitezustand > Info einen Bericht zur Website und kannst den Bericht über den Button „Bericht in die Zwischenablage kopieren“ und anschließend hier posten. Evtl. ergeben sich dann weitere Anhaltspunkte, ob und wo das Problem liegt.
    Wenn du dann noch die URL oben einträgst, dann können wir uns das auch ansehen und dir sicher besser helfen.
    Viele Grüße
    Hans-Gerd

    Ist das eine One-Click-Installation bei Strato?
    (Also nur auf einen Link im Kundenmenü geklickt?)

    Soviel ich weiß, ändert Strato WordPress so, dass automatische Aktualisierungen nicht möglich sind und nur über das Kundenmenü durchgeführt werden können.

    Website-Zustand:

    
    ### wp-core ###
    
    version: 5.3.2
    site_language: de_DE
    user_language: de_DE
    timezone: +00:00
    permalink: /%postname%/
    https_status: true
    user_registration: 0
    default_comment_status: open
    multisite: false
    user_count: 1
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /mnt/web324/a1/52/58185552/htdocs/WordPress_SecureMode_05
    wordpress_size: 118,46 MB (124212610 bytes)
    uploads_path: /mnt/web324/a1/52/58185552/htdocs/WordPress_SecureMode_05/wp-content/uploads
    uploads_size: 120,31 MB (126152540 bytes)
    themes_path: /mnt/web324/a1/52/58185552/htdocs/WordPress_SecureMode_05/wp-content/themes
    themes_size: 5,98 MB (6275667 bytes)
    plugins_path: /mnt/web324/a1/52/58185552/htdocs/WordPress_SecureMode_05/wp-content/plugins
    plugins_size: 15,67 MB (16428029 bytes)
    database_size: 12,67 MB (13287424 bytes)
    total_size: 273,09 MB (286356270 bytes)
    
    ### wp-active-theme ###
    
    name: Neve (neve)
    version: 2.6.3 (latest version: 2.6.6)
    author: ThemeIsle
    author_website: https://themeisle.com
    parent_theme: none
    theme_features: hfg_support, title-tag, post-thumbnails, automatic-feed-links, custom-logo, html5, customize-selective-refresh-widgets, custom-background, themeisle-demo-import, align-wide, editor-color-palette, fl-theme-builder-headers, fl-theme-builder-footers, header-footer-elementor, lifterlms-sidebars, lifterlms, service_worker, menus, widgets
    theme_path: /mnt/web324/a1/52/58185552/htdocs/WordPress_SecureMode_05/wp-content/themes/neve
    
    ### wp-plugins-active (3) ###
    
    Disable Emojis (GDPR friendly): version: 1.7.2, author: Ryan Hellyer
    Elementor: version: 2.9.6, author: Elementor.com (latest version: 2.9.8)
    myStickymenu: version: 2.3.8, author: Premio (latest version: 2.3.9)
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_GD
    imagick_module_version: Nicht verfügbar
    imagemagick_version: Nicht verfügbar
    gd_version: bundled (2.1.0 compatible)
    ghostscript_version: not available
    
    ### wp-server ###
    
    server_architecture: SunOS localhost 5.10 Generic_150401-49 i86pc SunOS localhost 5.10 Generic_150401-49 i86pc SunOS localhost 5.10 Generic_150401-49 i86pc
    httpd_software: Apache/2.4.41 (Unix)
    php_version: 7.3.16
    php_sapi: cgi-fcgi
    max_input_variables: 4000
    time_limit: 240
    memory_limit: 256M
    max_input_time: 60
    upload_max_size: 64M
    php_post_max_size: 76M
    curl_version: 7.54.0 OpenSSL/1.0.2k
    suhosin: false
    imagick_availability: false
    htaccess_extra_rules: false
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 5.6.42-log
    client_version: 5.5.54
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /mnt/web324/a1/52/58185552/htdocs/WordPress_SecureMode_05/wp-content
    WP_PLUGIN_DIR: /mnt/web324/a1/52/58185552/htdocs/WordPress_SecureMode_05/wp-content/plugins
    WP_MAX_MEMORY_LIMIT: 256M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_LOCAL_DEV: undefined
    DB_CHARSET: utf8
    DB_COLLATE: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    
    

    Bego Mario Garde
    Das kann ich nicht genau beantworten.
    Die Anwendung und Installation läuft über Strato. Ich bin nicht besonders firm in FTP-Angelegenheiten.

    Hallo,
    zunächst solltest du ein Standardtheme wie z. B. twenty nineteen zusätzlich installieren, wenn das möglich ist. Das Theme solltest du aber nicht aktivieren, sondern Neve sollte aktiviert bleiben.
    Falls du noch Plugins installieren kannst, kannst du ja mal nach einer Sicherung das plugin Health Check & Troubleshooting installieren. Zusätzlich ist als theme dann twenty nineteen aktiviert. Dann kannst du sehen, ob die beschriebenen Probleme noch weiterhin auftauchen. Aktiviere dann Plugin für Plugin im Problembenhandlungsmodus und schaue anschließend, ob das Problem noch besteht. Eventuell wird das Problem durch einen Konflikt ausgelöst. Vorteil dabei ist, dass der Leser deines Blogs die Seite weiter mit allen Infos und plugins sieht, während nur für dich alle plugins deaktiviert sind.
    Lies dir dazu auch mal die Informationen in dem Beitrag Health Check durch.
    Viele Grüße
    Hans-Gerd

    Ja, das ist das Problem. Auch die Suchfunktion der Themes ist nicht vorhanden. Und da ich nicht nach Plugins suchen kann, kann ich ja auch kein Healthcheck-Plugin installieren.

    Edit: Das Healthcheck Plugin konnte ich nun via FTP installieren. Geht das mit Themes auch? Wo müsste ich das dann ablegen? (ich weiß, sehr sehr laienhaft, aber irgendwie muss man ja anfangen)

    Ich danke euch schon mal für eure bisherigen, sehr schnellen Antworten.

    • Diese Antwort wurde geändert vor 5 Monaten, 3 Wochen von tinaneumann.

    (ich weiß, sehr sehr laienhaft, aber irgendwie muss man ja anfangen)

    kein Problem, jeder hat mal angefangen.
    Du kannst ein theme im Prinzip genauso per FTP installieren:

    • Theme auf wordpress.org suchen und ZIP-Datei runterladen
    • auf dem lokalen Rechner entpacken
    • per FTP den gesamten entpackten Theme-Ordner unter …\wp-content\themes hochladen

    Nachtrag:
    Hier noch ein Link mit einer Anleitung, wie man themes installiert

    Das hat schon mal geklappt, danke. Gar nicht mal so schwierig.

    Nur „Werkzeug“ -> „Site Health“ spricht immer noch von folgenden Problemen:

    https://www.bilder-upload.eu/bild-380e60-1588172383.png.html

    Und das sind nur die kritischen.

    Auch alles weitere (Suchfunktion etc.) funktioniert nach wie vor nicht, auch kein Update.

    In der WordPress-Konfigurationsdatei wp-config.php ist zumindest eine Zeile define( 'DISALLOW_FILE_MODS', true ); die Änderungen an Dateien ausschließt – dazu gehört auch die Installation von Themes und Plugins. Das kannst du mit einem geeigneten Code-Editor (z.B. VS Code oder Notepad++, beide kostenlos erhältlich) auskommentieren (zwei Schrägstriche // vor die Zeile).

    Deine Installation ist aber im sogenannten „Secure Mode“ gemacht worden, bei dem es bestimmte Einschränkungen gibt. Frag doch mal beim Support von Strato nach.

    dann ist jetzt einiges klarer:

    Disable Plugin and Theme Update and Installation #Disable Plugin and Theme Update and Installation
    This will block users being able to use the plugin and theme installation/update functionality from the WordPress admin area. Setting this constant also disables the Plugin and Theme editor (i.e. you don’t need to set DISALLOW_FILE_MODS and DISALLOW_FILE_EDIT, as on its own DISALLOW_FILE_MODS will have the same effect).

    Die Einstellung
    define( 'DISALLOW_FILE_MODS', true );
    in der wp-config.php verhindert Installation und Update von Plugins und Themes.
    Um das zu ändern machst Du …. das, was gerade Bego geschrieben hat.
    Der Bego war mal wieder schneller :-))

    Klappt!
    Eine riesengroße imaginäre Haribo-Tüte für euch. (Gefühlte) Milliarden Stunden und 2 Striche später läuft alles wieder. Danke für eure Hilfe Jungs, mir ist jetzt einiges klarer geworden. Zum Beispiel, dass ich noch viel Lernen kann.

    Strato habe ich bereits kontaktiert. Sie hatten mir empfohlen, die Plugins via FTP zu löschen. Mehr Hilfe kann ich von da offenbar nicht erwarten.

    Wünsche euch noch einen schönen Abend!

    super – freut mich 🙂

    Mehr Hilfe kann ich von da offenbar nicht erwarten.

    hmpf – dazu sage ich jetzt nichts 😉
    Dir auch einen schönen Abend

Ansicht von 12 Antworten - 1 bis 12 (von insgesamt 12)