Support » Allgemeine Fragen » Plugin Updates nicht mehr möglich.

  • Hallo,
    Leider kann ich keines meiner installierten Plugins mehr Updaten. Unter Installierte Plugins wird mir weder angezeigt das ein Plugin Update verfügbar ist noch kann ich wenn ich auf aktualisieren gehe anstoßen das nach Updates gesucht wird.

    Wenn ich mir jedoch das Plugin auf deren Website ansehen merke ich das es schon viele neue Versionen gibt. Ich würde meine Plugins gerne auf einen aktuellen stand bringen leider geht das nicht solange ich nicht mal die verfügbaren Updates sehe.

    hatte jemand von euch schon mal dieses Problem?

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 16)
  • Hallo verlegerverlag,
    kannst du uns mitteilen, welche Plugins du updaten möchtest?
    Ist das eine 1-click Instllation von 1und1?

    Ich würde eher bei 1und1 mal nach Unterstützung fragen.
    Kann sein, das die Updates von wp geblocked sind.

    Gruß Nikolai

    Hallo @verlegerverlag und willkommen im Forum,

    wir bräuchten, um das Problem beurteilen zu können, erst einmal viel mehr Informationen zu deiner Website und dem Problem.

    Wo wird deine Website gehostet?
    Hast du Admin-Rechte?
    Welche Fehlermeldungen werden angezeigt?
    Kannst du noch Bilder hochladen und neue Beiträge erstellen?
    Was ist mit der Aktualisierung von WordPress selbst – die verwendete Version enthält Fehler, die von Angreifern missbraucht werden könnten.

    Darüber hinaus bräuchten wir die üblichen Debugging-Informationen wie PHP-Version, PHP-Memory-Limit, verwendete Plugins, … Am einfachsten ist es, wenn du dazu das Plugin Health Check installieren würdest – vorausgesetzt natürlich, dein Problem bezieht sich nur auf Updates.

    Thread-Starter verlegerverlag

    (@verlegerverlag)

    Hallo,
    @grafruessel
    ja es ist eine 1 und 1 ein klick Installation.

    @pixolin
    Den Health Check habe ich jetzt installiert.
    Hier das ergebnis: https://verleger-verlag.com/wp-content/uploads/2018/07/screenshot-verleger-verlag.com-2018.07.31-15-55-06.png

    Admin Rechte habe ich.
    Fehlermeldung bekomme ich keine ich bekomme nur keine Meldung das ein Update bereitsteht auch wenn es ein Update gibt.
    Bilder Hochladen, Beiträge erstellen und alle Funktionalitäten sind voll gegeben.
    Wordpress Version 4.9.5. ist bei mir installiert eine neuere Version kann ich nicht updaten. Es wird angezeigt das Sie auf dem neusten Stand ist.
    Diese Plugins sind Installiert. hier sieht man auch den Widerspruch das mir oben angezeigt wird das ich das Newsletter Plugin updaten soll aber beim Plugin selbst ist davon nichts vermerkt.
    https://verleger-verlag.com/wp-content/uploads/2018/07/screenshot-verleger-verlag.com-2018.07.31-16-01-20.png

    Ich muss nochmal nachfragen: Handelt es sich um ein so genanntes „Managed WordPress“-Webhosting? In dem Fall wird die Aktualisierung von WordPress, Themes und Plugins durch den Webhoster erledigt, während der Kunde sich um diese Details nicht kümmern soll. Dann wäre es allerdings verwunderlich, dass nicht die aktuelle WordPress-Version verwendet wird.

    Ich kenne das Managed-WordPress-Hosting von 1&1 nicht im Detail. Hast du die Möglichkeit, im Kundenmenü Aktualisierungen anzustoßen?

    Welches Plugin hast du da installiert? Nicht das Health Check, das wir im verlinkten Beitrag genannt haben?

    Thread-Starter verlegerverlag

    (@verlegerverlag)

    Es ist zwar ein Managed Server ab kein Managed WordPress.
    Ja ich hatte ein anders Plugin installiert mit selben namen. Ich habe jetzt mal eures verwendet und wenn ich da in den Troubleshoot Modus gehe werden mir alle Updates angezeigt plötzlich siehe Anhang.
    Die anderen daten die mir das Plugin Anzeigt habe ich auch angehängt.
    https://verleger-verlag.com/wp-content/uploads/2018/07/screenshot-verleger-verlag.com-2018.07.31-16-33-37.png
    https://verleger-verlag.com/wp-content/uploads/2018/07/screenshot-verleger-verlag.com-2018.07.31-16-33-37.png
    https://verleger-verlag.com/wp-content/uploads/2018/07/screenshot-verleger-verlag.com-2018.07.31-16-37-20.png
    https://verleger-verlag.com/wp-content/uploads/2018/07/screenshot-verleger-verlag.com-2018.07.31-16-38-29.png

    Laut Plugin sind automatische Updates deaktiviert.
    Schau mal, ob du in der wp-config.php folgende Zeile findest:
    define( 'AUTOMATIC_UPDATER_DISABLED', true );

    Den Wert müsstest du bitte auf false ändern (oder die Zeile mit zwei vorangestellten Schrägstrichen // auskommentieren).

    Falls du in der wp-config.php diese Zeile nicht findest, kannst du die Plugins auch einzeln wieder zuschalten und schauen, ob weiterhin Updates angezeigt werden.

    Du hast im Moment recht üppig Plugins installiert. Es wäre nicht unwahrscheinlich, wenn der zugewiesene Arbeitsspeicher (memory_limit) nicht ausreicht. Mehrere Cache-Plugins zu verwenden macht auch keinen Sinn. Schauch doch mal, ob du da nicht ausdünnen kannst.

    Künftig wäre es schön, wenn du statt Screenshots den Inhalt der Debugging-Informationen über den angebotenen Button teilst. Wenn du die Screenshots löschst, kann hier keiner mehr nachvollziehen, um was es ging. Das Support-Forum soll aber nicht einem/einer Einzelnen dienen, sondern möglichst vielen TeilnehmerInnen hier.

    Thread-Starter verlegerverlag

    (@verlegerverlag)

    Danke für die Info. Werde ich gleich umsetzen.
    Sorry das nächste mal werde ich die Daten über die Buttons teilen.
    Es war mein erster Beitrag hier und ich komme noch nicht mit allem zurecht.

    Danke auf jeden Fall für die Hilfe.

    Thread-Starter verlegerverlag

    (@verlegerverlag)

    Leider finde ich die Zeile nicht die komplette Datei sieht so aus:

    <?php
    define('WP_CACHE', true);
    define( 'WPCACHEHOME', '/homepages/21/d732114650/htdocs/clickandbuilds/WordPress/VerlegerVerlag/wp-content/plugins/wp-super-cache/' );
    define('FS_METHOD', 'direct');
    define('FORCE_SSL_ADMIN', true);
    /**
     * The base configuration for WordPress
     *
     * The wp-config.php creation script uses this file during the
     * installation. You don't have to use the web site, you can
     * copy this file to "wp-config.php" and fill in the values.
     *
     * This file contains the following configurations:
     *
     * * MySQL settings
     * * Secret keys
     * * Database table prefix
     * * ABSPATH
     *
     * @link https://codex.wordpress.org/Editing_wp-config.php
     *
     * @package WordPress
     */
    // ** MySQL settings ** //
    /** The name of the database for WordPress */
    define( 'DB_NAME', '***' );
    /** MySQL database username */
    define( 'DB_USER', '***' );
    /** MySQL database password */
    define( 'DB_PASSWORD', '***' );
    /** MySQL hostname */
    define( 'DB_HOST', 'db734264703.db.1and1.com' );
    /** Database Charset to use in creating database tables. */
    define( 'DB_CHARSET', 'utf8' );
    /** The Database Collate type. Don't change this if in doubt. */
    define( 'DB_COLLATE', '' );
    /**
     * Authentication Unique Keys and Salts.
     *
     * Change these to different unique phrases!
     * You can generate these using the {@link https://api.wordpress.org/secret-key/1.1/salt/ WordPress.org secret-key service}
     * You can change these at any point in time to invalidate all existing cookies. This will force all users to have to log in again.
     *
     * @since 2.6.0
     */
    
    [Auth Keys gelöscht Grüße, Bego]
    
     * WordPress Database Table prefix.
     *
     * You can have multiple installations in one database if you give each
     * a unique prefix. Only numbers, letters, and underscores please!
     */
    $table_prefix = 'hkhded2urj';
    /* That's all, stop editing! Happy blogging. */
    /** Absolute path to the WordPress directory. */
    if ( ! defined( 'ABSPATH' ) )
    	define( 'ABSPATH', dirname( __FILE__ ) . '/' );
    /** Sets up WordPress vars and included files. */
    require_once ABSPATH . 'wp-settings.php';
    • Diese Antwort wurde geändert vor 4 Jahre, 4 Monaten von verlegerverlag.
    Thread-Starter verlegerverlag

    (@verlegerverlag)

    Ich habe die Updates jetzt über das Health tool gemacht.
    Da ist mir aufgefallen das es wie es aussieht am Theme liegt.
    Sobald ich das Theme ColorMag Pro aktiv habe geht das Plugin Update nicht mehr.

    Hallo @verlegerverlag,
    teste mal noch, ob alle wichtigen Plugins aktiviert mit einem anderen Theme auch gehen, um auszuschliessen, dass es nicht doch einen anderen Grund geben kann.

    Und poste lieber nicht deine ganzen MySQL Daten hier rein, schliesslich übergibst du hier gerade Passwörter zu deiner Webseite. Am besten ändere gleich mal dein MySQL Passwort in Backend von 1und1 und dann in deiner wp-config.php.

    Gruß Nikolai

    Thread-Starter verlegerverlag

    (@verlegerverlag)

    Danke für den Tipp. Anfängerfehler.

    Die Plugins gehen auch mit den anderen Themes.

    Dummerweise komme ich jetzt nicht mehr in mein WordPress rein nachdem ich bei der MySQL Datenbank das PW geändert habe kommt jetzt diese Fehlermeldung.

    Fehler beim Aufbau einer Datenbankverbindung
    Das bedeutet entweder, dass die Information über den Benutzernamen und das Passwort in deiner wp-config.php Datei nicht korrekt ist, oder wir können den Datenbank-Server auf db734264703.db.1and1.com nicht erreichen. Es könnte sein, dass der Datenbank-Server deines Hostings ausgefallen ist.

    Bist du sicher, dass Benutzername und Passwort korrekt sind?
    Bist du sicher, dass du den richtigen Hostnamen eingegeben hast?
    Bist du sicher, dass der Datenbank-Server läuft?
    Wenn du unsicher bist, was diese Begriffe bedeuten, solltest du lieber den Support deines Webhostings kontaktieren. Wenn du dann weiterhin Hilfe benötigst, kannst du stets die WordPress-Support-Foren besuchen.

    Thread-Starter verlegerverlag

    (@verlegerverlag)

    Nächstes mal weis ich erst das PW bei WP ändern dann bei der Datenbank

    Du kannst doch per FTP (oder zur Not über die Dateiverwaltung im Kundenmenü deines Webhosters) auf die wp-config.php zugreifen. Wenn du das Passwort für die Datenbank änderst, bitte mit einem geeigneten Programmier-Editor (nicht Notepad oder Textedit) arbeiten – z.B. Atom Editor.

    Der Eintrag define('FS_METHOD', 'direct'); ist übrigens häufig ein Hinweis auf Probleme mit den Dateirechten. Aber ich würde erst einmal nach der genannten Konstante AUTOMATIC_UPDATER_DISABLED suchen. Kann gut sein, dass der/die EntwicklerIn da etwas in die functions.php den (Child-)Themes gepackt hat.

    Thread-Starter verlegerverlag

    (@verlegerverlag)

    Danke. Das hat geklappt

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 16)
  • Das Thema „Plugin Updates nicht mehr möglich.“ ist für neue Antworten geschlossen.