Support » Plugins » Plugins updaten nicht mehr automatisch

  • Gelöst Martin

    (@surgicalexperts)


    Hallo, seit 1 Monat sehe ich keine automatischen Updates der Plugins mehr. Es wird auch so keine verfügbares Update der Plugins angezeigt. Habe hier schon gesucht im Forum, aber leider nicht gefunden, dass weiterhelfen könnte. Jemand eine Idee?

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 17)
  • Bekommen wir auch noch den Website-Bericht? 🙂

    Geh bitte auf Werkzeuge > Website-Zustand > Bericht, klick auf den Button und füge den Bericht mit Strg-V unverändert in deine Antwort ein.

    Thread-Starter Martin

    (@surgicalexperts)

    Habe den Button „Bericht“ nicht bei mir auf Site Health. Nur Trouble shooting, Info, Tools, und Status

    Hallo,

    Habe den Button „Bericht“ nicht bei mir auf Site Health. Nur Trouble shooting, Info, Tools, und Status

    Das würde mich wundern – es sei denn, du hast die Rechte nicht. Schau doch bitte noch mal nach. Ohne Bericht werden wir kaum helfen können.

    Du findest unter Werkzeuge > Website-Zustand > Info einen Bericht zur Website. Warte bitte einen Moment bis die Ladeanzeige ganz oben abgeschlossen ist und kopiere dann per Button den Website-Bericht in deine Zwischenablage. Über den Button „Bericht in die Zwischenablage kopieren“ kannst du den Bericht unverändert (bitte mit den Akzentzeichen am Anfang und Ende) einfügen und anschließend hier posten. Evtl. ergeben sich dann weitere Anhaltspunkte, ob und wo das Problem liegt.
    Hier ein Screenshot dazu (bei Klick auf das Bild, wird das Bild vergrößert):
    Website-Bericht

    Und mit z. B. STRG V in die Antwort bei diesem Thema einfügen.

    Mehr Infos zum Website-Zustand findest du z. B. in dem folgenden Video

    Viele Grüße
    Hans-Gerd

    Habe den Button „Bericht“ nicht bei mir auf Site Health. Nur Trouble shooting, Info, Tools, und Status

    Dann hast du vermutlich das Plugin Health Check installiert und siehst dir die Website auf Englisch an. Unter Tools > Site-Health > Info solltest du den Button finden, um den Bericht zu kopieren.

    Thread-Starter Martin

    (@surgicalexperts)

    So habe es:

    ` wp-core
    
    version: 6.5.3
    site_language: en_US
    user_language: en_US
    timezone: Europe/Berlin
    permalink: /%postname%/
    https_status: true
    multisite: false
    user_registration: 0
    blog_public: 1
    default_comment_status: undefined
    environment_type: production
    user_count: 3
    dotorg_communication: true wp-paths-sizes
    
    wordpress_path: /home/www/wordpress
    wordpress_size: 258.59 MB (271154436 bytes)
    uploads_path: /home/www/wordpress/wp-content/uploads
    uploads_size: 199.01 MB (208674368 bytes)
    themes_path: /home/www/wordpress/wp-content/themes
    themes_size: 32.97 MB (34573741 bytes)
    plugins_path: /home/www/wordpress/wp-content/plugins
    plugins_size: 106.32 MB (111484171 bytes)
    database_size: 510.73 MB (535543808 bytes)
    total_size: 1.08 GB (1161430524 bytes) wp-dropins (1)
    
    advanced-cache.php: true wp-active-theme
    
    name: Health Center (health-center)
    version: 30.1
    author: Vamtam
    author_website: http://vamtam.com
    parent_theme: none
    theme_features: core-block-patterns, widgets-block-editor, post-thumbnails, automatic-feed-links, post-formats, title-tag, customize-selective-refresh-widgets, menus, wpv-reduced-ajax-single-response, wpv-ajax-siblings, wpv-page-title-style, wpv-centered-text-divider, widgets
    theme_path: /home/www/wordpress/wp-content/themes/health-center
    auto_update: Enabled wp-mu-plugins (1)
    
    Health Check Troubleshooting Mode: author: (undefined), version: 1.9.0 wp-plugins-active (18)
    
    Catch IDs: version: 2.7, author: Catch Plugins, Auto-updates enabled
    Classic Editor: version: 1.6.3, author: WordPress Contributors, Auto-updates enabled
    Classic Widgets: version: 0.3, author: WordPress Contributors, Auto-updates enabled
    Contact Form 7: version: 5.9.4, author: Takayuki Miyoshi, Auto-updates enabled
    CookieYes | GDPR Cookie Consent: version: 3.1.8, author: CookieYes, Auto-updates enabled
    Copy & Delete Posts: version: 1.4.5, author: Copy Delete Posts, Auto-updates enabled
    Easy Table of Contents: version: 2.0.62, author: Magazine3, Auto-updates enabled
    FooBox Image Lightbox: version: 2.7.27, author: FooPlugins, Auto-updates enabled
    FooGallery: version: 2.4.9, author: FooPlugins, Auto-updates enabled
    Health Check & Troubleshooting: version: 1.7.0, author: The WordPress.org community, Auto-updates enabled
    Rank Math SEO PRO: version: 3.0.62, author: Rank Math, Auto-updates enabled
    Rank Math SEO with AI Best SEO Tools: version: 1.0.219, author: Rank Math, Auto-updates enabled
    ShortPixel Adaptive Images: version: 3.8.2, author: ShortPixel, Auto-updates enabled
    Site Kit by Google: version: 1.120.0, author: Google, Auto-updates enabled
    UpdraftPlus - Backup/Restore: version: 1.23.16, author: UpdraftPlus.Com, DavidAnderson, Auto-updates enabled
    Vamtam Push Menu: version: 2.0.19, author: Vamtam, Auto-updates enabled
    WP Mail SMTP: version: 3.11.1, author: WP Mail SMTP, Auto-updates enabled
    WP Rocket: version: 3.10.7, author: WP Media, Auto-updates disabled wp-plugins-inactive (2)
    
    Temporary Login Without Password: version: 1.8.3, author: StoreApps, Auto-updates enabled
    WP-Optimize - Clean, Compress, Cache: version: 3.3.0, author: David Anderson, Ruhani Rabin, Team Updraft, Auto-updates enabled wp-media
    
    image_editor: FooGallery_Thumb_Image_Editor_Imagick
    imagick_module_version: 1691
    imagemagick_version: ImageMagick 6.9.11-60 Q16 x86_64 2021-01-25 https://imagemagick.org
    imagick_version: 3.7.0
    file_uploads: 1
    post_max_size: 800M
    upload_max_filesize: 800M
    max_effective_size: 800 MB
    max_file_uploads: 20
    gd_version: 2.3.3
    gd_formats: GIF, JPEG, PNG, WebP, BMP, XPM
    ghostscript_version: 9.53.3 wp-server
    
    server_architecture: Linux 5.10.0-26-amd64 x86_64
    httpd_software: Apache
    php_version: 7.4.33 64bit
    php_sapi: apache2handler
    max_input_variables: 1000
    time_limit: 30
    memory_limit: 1024M
    max_input_time: -1
    upload_max_filesize: 800M
    php_post_max_size: 800M
    curl_version: 7.74.0 OpenSSL/1.1.1w
    suhosin: false
    imagick_availability: true
    pretty_permalinks: true
    htaccess_extra_rules: true
    current: 2024-05-23T06:55:12+00:00
    utc-time: Thursday, 23-May-24 06:55:12 UTC
    server-time: 2024-05-23T08:55:08+02:00 wp-database
    
    extension: mysqli
    server_version: 10.11.4-MariaDB-1:10.11.4+maria~deb11-log
    client_version: mysqlnd 7.4.33
    max_allowed_packet: 134217728
    max_connections: 350 wp-constants
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /home/www/wordpress/wp-content
    WP_PLUGIN_DIR: /home/www/wordpress/wp-content/plugins
    WP_MEMORY_LIMIT: 512M
    WP_MAX_MEMORY_LIMIT: 1024M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: true
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_ENVIRONMENT_TYPE: Undefined
    WP_DEVELOPMENT_MODE: undefined
    DB_CHARSET: utf8mb4
    DB_COLLATE: undefined wp-filesystem
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    mu-plugins: writable google-site-kit
    
    version: 1.120.0
    php_version: 7.4.33
    wp_version: 6.5.3
    reference_url: https://germanyhealth.de
    amp_mode: no
    site_status: connected-site
    user_status: authenticated
    verification_status: verified-non-site-kit
    connected_user_count: 1
    active_modules: site-verification, search-console, analytics, analytics-4, pagespeed-insights
    recoverable_modules: none
    required_scopes:
    openid: ✅
    https://www.googleapis.com/auth/userinfo.profile: ✅
    https://www.googleapis.com/auth/userinfo.email: ✅
    https://www.googleapis.com/auth/siteverification: ✅
    https://www.googleapis.com/auth/webmasters: ✅
    https://www.googleapis.com/auth/analytics.readonly: ✅
    https://www.googleapis.com/auth/tagmanager.readonly: ✅
    capabilities:
    googlesitekit_authenticate: ✅
    googlesitekit_setup: ✅
    googlesitekit_view_posts_insights: ✅
    googlesitekit_view_dashboard: ✅
    googlesitekit_manage_options: ✅
    googlesitekit_update_plugins: ✅
    googlesitekit_view_splash: ✅
    googlesitekit_view_authenticated_dashboard: ✅
    googlesitekit_view_wp_dashboard_widget: ✅
    googlesitekit_view_admin_bar_menu: ✅
    googlesitekit_view_shared_dashboard: ⭕
    googlesitekit_read_shared_module_data::["search-console"]: ⭕
    googlesitekit_read_shared_module_data::["analytics-4"]: ⭕
    googlesitekit_read_shared_module_data::["pagespeed-insights"]: ⭕
    googlesitekit_manage_module_sharing_options::["search-console"]: ✅
    googlesitekit_manage_module_sharing_options::["analytics-4"]: ✅
    googlesitekit_manage_module_sharing_options::["pagespeed-insights"]: ✅
    googlesitekit_delegate_module_sharing_management::["search-console"]: ✅
    googlesitekit_delegate_module_sharing_management::["analytics-4"]: ✅
    googlesitekit_delegate_module_sharing_management::["pagespeed-insights"]: ⭕
    enabled_features:
    adsModule: ⭕
    audienceSegmentation: ⭕
    gm3Components: ⭕
    search-console_shared_roles: none
    search-console_management: owner
    analytics-4_shared_roles: none
    analytics-4_management: owner
    pagespeed-insights_shared_roles: none
    pagespeed-insights_management: all_admins
    search_console_property: https://germanyhealth.de/
    analytics_account_id: 1099•••••
    analytics_property_id: none
    analytics_profile_id: none
    analytics_use_snippet: yes
    analytics_4_property_id: 3178364••
    analytics_4_web_data_stream_id: 3612••••••
    analytics_4_measurement_id: G-WY••••••••
    analytics_4_use_snippet: yes
    analytics_4_available_custom_dimensions: none wp_mail_smtp
    
    version: 3.11.1
    license_key_type: lite
    debug: No debug notices found.
    lite_install_date: Aug 2, 2023 @ 5:18pm
    Moderator Bego Mario Garde

    (@pixolin)

    Abgesehen von einer veralteten PHP-Version ist da nichts auffällig. (PHP 7.4 sowie noch ältere Versionen werden von offizieller Stelle nicht mehr mit Sicherheits-Updates versorgt. Es ist aber durchaus denkbar, dass Provider Sicherheits-Patches einspielen, da müsstest bzw. solltest du unbedingt nachfragen, für den Fall, dass dir eine PHP-Umstellung derzeit noch nicht möglich ist. Grundsätzlich empfehlen wir aber, das Webhosting-Paket auf eine aktuelle PHP-Version (derzeit mindestens 8.1.x) umzustellen.)

    Poste bitte den Inhalt der wp-config.php. Lösche in deiner Antwort die Zeilen mit den Zugangsdaten und Sicherheitsschlüsseln. Sie sind hier für eine Behandlung des Problems irrelevant und wir wollen niemand einladen, deine Datenbank aufzurufen.

    Moderator Hans-Gerd Gerhards

    (@hage)

    Hallo,
    ich gehe davon aus, dass du ein Backup vor den folgenden Maßnahmen erstellst, das auf jeden Fall wiederhergestellt werden kann.

    Deaktiviere doch zunächst bitte alle Plugins und aktiviere dann Plugin für Plugin. Teste danach jeweils, ob das Problem behoben ist. Sobald es dann nach Aktivierung eines Plugins das beschriebene Problem gibt, weißt du, welches Plugin das Problem verursacht.

    Zum Website-Bericht:
    Site Kit by Google: Das Plugin ist meines Wissens ohne entsprechende Maßnahmen datenschutzrechtlich problematisch.
    PHP 7.4 sowie noch ältere Versionen werden von offizieller Stelle nicht mehr mit Sicherheits-Updates versorgt. Es ist aber durchaus denkbar, dass Provider Sicherheits-Patches einspielen, da müsstest bzw. solltest du unbedingt nachfragen, für den Fall, dass dir eine PHP-Umstellung derzeit noch nicht möglich ist.
    Grundsätzlich empfehlen wir aber, das Webhosting-Paket auf eine aktuelle PHP-Version (derzeit mindestens 8.1.x) umzustellen.

    Nachtrag: Bego war flotter 🚀 und hat ähnliche Dinge vorgeschlagen.

    Viele Grüße
    Hans-Gerd

    Moderator Bego Mario Garde

    (@pixolin)

    Deaktiviere doch zunächst bitte alle Plugins und aktiviere dann Plugin für Plugin.

    🤔 Hm, ob damit die ausbleibende Aktualisierung der Plugins behoben wird?
    Ich tippe eher auf eine Konstante in der wp-config.php – deshalb meine Bitte, die Datei hier zu posten.

    Thread-Starter Martin

    (@surgicalexperts)

    <?php
    define( 'WP_CACHE', true ); // Added by WP Rocket
    
    //Begin Really Simple SSL session cookie settings
    @ini_set('session.cookie_httponly', true);
    @ini_set('session.cookie_secure', true);
    @ini_set('session.use_only_cookies', true);
    //END Really Simple SSL
    /**
    
    Grundeinstellungen für WordPress
    *
    
    Zu diesen Einstellungen gehören:
    *
    
    * MySQL-Zugangsdaten,
    
    * Tabellenpräfix,
    
    * Sicherheitsschlüssel
    
    * und ABSPATH.
    *
    
    Mehr Informationen zur wp-config.php gibt es auf der
    
    {@link https://codex.wordpress.org/Editing_wp-config.php wp-config.php editieren}
    
    Seite im Codex. Die Zugangsdaten für die MySQL-Datenbank
    
    bekommst du von deinem Webhoster.
    *
    
    Diese Datei wird zur Erstellung der wp-config.php verwendet.
    
    Du musst aber dafür nicht das Installationsskript verwenden.
    
    Stattdessen kannst du auch diese Datei als wp-config.php mit
    
    deinen Zugangsdaten für die Datenbank abspeichern.
    *
    
    @package WordPress
    */
    // ** MySQL-Einstellungen ** //
    /** Diese Zugangsdaten bekommst du von deinem Webhoster. / /
    
    Ersetze datenbankname_hier_einfuegen
    
    mit dem Namen der Datenbank, die du verwenden möchtest.
    / define('DB_NAME', 'xxxx'); /*
    
    Ersetze benutzername_hier_einfuegen
    
    mit deinem MySQL-Datenbank-Benutzernamen.
    / define('DB_USER', 'xxxx); /*
    
    Ersetze passwort_hier_einfuegen mit deinem MySQL-Passwort.
    / define('DB_PASSWORD', 'xxxx); /*
    
    Ersetze localhost mit der MySQL-Serveradresse.
    / define('DB_HOST', 'xxxx'); /*
    
    Der Datenbankzeichensatz, der beim Erstellen der
    
    Datenbanktabellen verwendet werden soll
    / define('DB_CHARSET', 'utf8mb4'); /*
    
    Der Collate-Type sollte nicht geändert werden.
    / define('DB_COLLATE', ''); define( 'WP_MEMORY_LIMIT', '512M' ); /*#@+
    
    Sicherheitsschlüssel
    *
    
    Ändere jeden untenstehenden Platzhaltertext in eine beliebige,
    
    möglichst einmalig genutzte Zeichenkette.
    
    Auf der Seite {@link https://api.wordpress.org/secret-key/1.1/salt/ WordPress.org secret-key service}
    
    kannst du dir alle Schlüssel generieren lassen.
    
    Du kannst die Schlüssel jederzeit wieder ändern, alle angemeldeten
    
    Benutzer müssen sich danach erneut anmelden.
    *
    
    @since 2.6.0
    
    /**
    
    WordPress Datenbanktabellen-Präfix
    *
    
    Wenn du verschiedene Präfixe benutzt, kannst du innerhalb einer Datenbank
    
    verschiedene WordPress-Installationen betreiben.
    
    Bitte verwende nur Zahlen, Buchstaben und Unterstriche!
    / $table_prefix = 'gowp_'; /*
    
    Für Entwickler: Der WordPress-Debug-Modus.
    *
    
    Setze den Wert auf „true“, um bei der Entwicklung Warnungen und Fehler-Meldungen angezeigt zu bekommen.
    
    Plugin- und Theme-Entwicklern wird nachdrücklich empfohlen, WP_DEBUG
    
    in ihrer Entwicklungsumgebung zu verwenden.
    *
    
    Besuche den Codex, um mehr Informationen über andere Konstanten zu finden,
    
    die zum Debuggen genutzt werden können.
    *
    
    @link https://codex.wordpress.org/Debugging_in_WordPress
    / define('WP_DEBUG', false); / Das war’s, Schluss mit dem Bearbeiten! Viel Spaß beim Bloggen. / / That's all, stop editing! Happy blogging. / /* Der absolute Pfad zum WordPress-Verzeichnis. / if ( !defined('ABSPATH') ) define('ABSPATH', dirname(FILE) . '/'); /* Definiert WordPress-Variablen und fügt Dateien ein. */
    require_once(ABSPATH . 'wp-settings.php');
    • Diese Antwort wurde geändert vor 3 Wochen von Bego Mario Garde. Grund: Code formatiert
    Moderator Hans-Gerd Gerhards

    (@hage)

    Hm, ob damit die ausbleibende Aktualisierung der Plugins behoben wird?

    die Wahrscheinlichkeit, dass das Problem über die wp-config.php ausgelöst wird, ist sicher größer. Das wäre auch die erste Maßnahme. Wobei sich die Frage stellt, warum das vorher funktioniert hat.

    Moderator Bego Mario Garde

    (@pixolin)

    Entgegen meiner Vermutung enthält die wp-config.php allerdings keine Konstante, mit der Updates unterbunden werden.

    @surgicalexperts Kannst du bitte unter Dashboard > Aktualisierungen den Button „WordPress 6.5.3 erneut installieren“ anklicken? Kommen dann irgendwelche Fehlermeldungen?

    Wenn du ins Menü Plugins gehst, steht dann in der rechten Spalte jeweils ein Link „Automatische Aktualisierungen deaktivieren“? (Falls nicht, solltest du über eine Mehrfachaktion alle Plugins auswählen und die „Automatische Aktualisierung aktivieren“.)

    Thread-Starter Martin

    (@surgicalexperts)

    Habe ich bereits gemacht. Da kam keine Fehlermeldung.

    Thread-Starter Martin

    (@surgicalexperts)

    Fehler gefunden. Habe Optimize, Copy&Paste sowie das Temporary plugin gelöscht. Irgendeiner der Dreien hat das Problem verursacht.

    Herzlichen Dank für euren Support und dass ihr euch Gedanken gemacht habt.

    Moderator Bego Mario Garde

    (@pixolin)

    Ohhhhkay. Dann hatte Hans-Gerd doch mal wieder recht und ich keine Ahnung. 🥲

    Danke für die Rückmeldung, freut mich dass es wieder läuft. Und 10 Punkte an <del>Griffindor</del> Hans-Gerd.

    Moderator Hans-Gerd Gerhards

    (@hage)

    @pixolin
    naja, meistens ist es ja umgekehrt 😀

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 17)