Support » Plugins » Plugins weg aus Backend nach Änderung Datenbank-Passwort

  • Gelöst shitesite

    (@shitesite)


    Hallo! Meine Seite war gestern offline, nach Kontaktaufnahme mit meinem Hosting-Anbieter hat dieser all meine Plugins deaktiviert (weil als Ursache ein Kompatibiliätsproblem mit PHP8 vermutet wurde). Zudem hat mir der Support-Mitarbeiter empfohlen, das Passwort für meine Datenbank zu ändern. Das habe ich gemacht und das neue Passwort auch in der wp-config.php hinterlegt. Die Seite läuft wieder, allerdings sind die Plugins nicht nur deaktiviert, sondern aus dem Backend komplett verschwunden (es sieht aus, als hätte ich nie Plugins installiert gehabt). In der Datenbank sind die Plugins aber noch da, wie ich über FTP (Filezilla) sehen kann. Wenn ich versuche, die Plugins erneut zu installieren, erscheint die Fehlermeldung „Installation fehlgeschlagen: Verzeichnis konnte nicht angelegt werden.“ Diese erscheint auch, wenn ich versuche, neue Plugins (die ich bisher nicht genutzt hatte) zu installieren. Wo kann der Fehler liegen?

    Ich bin sehr dankbar für jegliche Tipps!

    Hier der Bericht zum Website-Zustand:

    wp-core
    
    version: 6.2
    site_language: de_DE
    user_language: de_DE
    timezone: +00:00
    permalink: /%postname%/
    https_status: false
    multisite: false
    user_registration: 0
    blog_public: 1
    default_comment_status: open
    environment_type: production
    user_count: 1
    dotorg_communication: true wp-paths-sizes wordpress_path: /data/web/1/000/026/237/66810/htdocs
    wordpress_size: loading…
    uploads_path: /data/web/1/000/026/237/66810/htdocs/wp-content/uploads
    uploads_size: loading…
    themes_path: /data/web/1/000/026/237/66810/htdocs/wp-content/themes
    themes_size: loading…
    plugins_path: /data/web/1/000/026/237/66810/htdocs/wp-content/plugins
    plugins_size: loading…
    database_size: loading…
    total_size: loading… wp-active-theme name: Bam (bam)
    version: 1.2.7
    author: ThemezHut
    author_website: https://themezhut.com/
    parent_theme: none
    theme_features: core-block-patterns, widgets-block-editor, custom-header, editor-style, automatic-feed-links, title-tag, post-thumbnails, menus, html5, custom-background, customize-selective-refresh-widgets, wp-block-styles, editor-styles, responsive-embeds, custom-logo, widgets
    theme_path: /data/web/1/000/026/237/66810/htdocs/wp-content/themes/bam
    auto_update: Deaktiviert wp-themes-inactive (1) Twenty Twenty-Three: version: 1.1, author: Das WordPress-Team, Automatische Aktualisierungen deaktiviert wp-media image_editor: WP_Image_Editor_Imagick
    imagick_module_version: 1692
    imagemagick_version: ImageMagick 6.9.12-62 Q16-HDRI amd64 17430 https://legacy.imagemagick.org
    imagick_version: 3.7.0
    file_uploads: File uploads is turned off
    post_max_size: 200M
    upload_max_filesize: 200M
    max_effective_size: 200 MB
    max_file_uploads: 20
    imagick_limits:
    imagick::RESOURCETYPE_AREA: 64 GB
    imagick::RESOURCETYPE_DISK: 9.2233720368548E+18
    imagick::RESOURCETYPE_FILE: 705044
    imagick::RESOURCETYPE_MAP: 64 GB
    imagick::RESOURCETYPE_MEMORY: 32 GB
    imagick::RESOURCETYPE_THREAD: 1
    imagick::RESOURCETYPE_TIME: 9.2233720368548E+18
    imagemagick_file_formats: 3FR, 3G2, 3GP, AAI, AI, APNG, ART, ARW, AVI, AVIF, AVS, BGR, BGRA, BGRO, BIE, BMP, BMP2, BMP3, BRF, CAL, CALS, CANVAS, CAPTION, CIN, CIP, CLIP, CMYK, CMYKA, CR2, CR3, CRW, CUR, CUT, DATA, DCM, DCR, DCX, DDS, DFONT, DJVU, DNG, DOT, DPX, DXT1, DXT5, EPDF, EPI, EPS, EPS2, EPS3, EPSF, EPSI, EPT, EPT2, EPT3, ERF, EXR, FAX, FILE, FITS, FPX, FRACTAL, FTP, FTS, G3, G4, GIF, GIF87, GRADIENT, GRAY, GRAYA, GROUP4, GV, H, HALD, HDR, HEIC, HISTOGRAM, HRZ, HTM, HTML, HTTP, HTTPS, ICB, ICO, ICON, IIQ, INFO, INLINE, IPL, ISOBRL, ISOBRL6, J2C, J2K, JBG, JBIG, JNG, JNX, JP2, JPC, JPE, JPEG, JPG, JPM, JPS, JPT, JSON, K25, KDC, LABEL, M2V, M4V, MAC, MAGICK, MAP, MASK, MAT, MATTE, MEF, MIFF, MKV, MNG, MONO, MOV, MP4, MPC, MPEG, MPG, MRW, MSL, MSVG, MTV, MVG, NEF, NRW, NULL, ORF, OTB, OTF, PAL, PALM, PAM, PANGO, PATTERN, PBM, PCD, PCDS, PCL, PCT, PCX, PDB, PDF, PDFA, PEF, PES, PFA, PFB, PFM, PGM, PGX, PICON, PICT, PIX, PJPEG, PLASMA, PNG, PNG00, PNG24, PNG32, PNG48, PNG64, PNG8, PNM, POCKETMOD, PPM, PREVIEW, PS, PS2, PS3, PSB, PSD, PTIF, PWP, RADIAL-GRADIENT, RAF, RAS, RAW, RGB, RGBA, RGBO, RGF, RLA, RLE, RMF, RW2, SCR, SCT, SFW, SGI, SHTML, SIX, SIXEL, SPARSE-COLOR, SR2, SRF, STEGANO, SUN, SVG, SVGZ, TEXT, TGA, THUMBNAIL, TIFF, TIFF64, TILE, TIM, TTC, TTF, TXT, UBRL, UBRL6, UIL, UYVY, VDA, VICAR, VID, VIDEO, VIFF, VIPS, VST, WBMP, WEBM, WEBP, WMF, WMV, WMZ, WPG, X3F, XBM, XC, XCF, XPM, XPS, XV, YCbCr, YCbCrA, YUV
    gd_version: 2.3.3
    gd_formats: GIF, JPEG, PNG, WebP, BMP, AVIF, XPM
    ghostscript_version: 9.56.1 wp-server server_architecture: FreeBSD 13.1-RELEASE-p3 amd64
    httpd_software: Apache
    php_version: 8.1.14 64bit
    php_sapi: apache2handler
    max_input_variables: 5000
    time_limit: 240
    memory_limit: 128M
    admin_memory_limit: 256M
    max_input_time: 60
    upload_max_filesize: 200M
    php_post_max_size: 200M
    curl_version: 7.85.0 OpenSSL/1.1.1s
    suhosin: false
    imagick_availability: true
    pretty_permalinks: true
    htaccess_extra_rules: true wp-database extension: mysqli
    server_version: 5.7.38
    client_version: mysqlnd 8.1.14
    max_allowed_packet: 16777216
    max_connections: 1000 wp-constants WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /data/web/1/000/026/237/66810/htdocs/wp-content
    WP_PLUGIN_DIR: /data/web/1/000/026/237/66810/htdocs/wp-content/plugins
    WP_MEMORY_LIMIT: 40M
    WP_MAX_MEMORY_LIMIT: 256M
    WP_DEBUG: true
    WP_DEBUG_DISPLAY: false
    WP_DEBUG_LOG: true
    SCRIPT_DEBUG: false
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_ENVIRONMENT_TYPE: Nicht definiert
    DB_CHARSET: utf8
    DB_COLLATE: undefined wp-filesystem wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: not writable
    themes: writable

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 5 Antworten - 1 bis 5 (von insgesamt 5)
  • Hallo,

    In der Datenbank sind die Plugins aber noch da, wie ich über FTP (Filezilla) sehen kann.

    In die Datenbank kannst du nicht mit Filezilla schauen, sondern mit phpMyAdmin.
    Vielleicht war das einfach nur ein Schreibfehler.
    Das Plugin-Verzeichnis ist nicht beschreibbar: plugins: not writable. Da stimmen wohl die Rechte nicht (mehr).

    Viele Grüße
    Hans-Gerd

    • Diese Antwort wurde geändert vor 1 Jahr, 1 Monat von Hans-Gerd Gerhards. Grund: Tippfehler
    Moderator Michi91

    (@michi91)

    Oder der Ordner heißt nicht mehr plugins sondern plugins_ oder ähnliches..

    Moderator Bego Mario Garde

    (@pixolin)

    @hage

    In die Datenbank kannst du nicht mit Filezilla schauen, sondern mit phpMyAdmin.

    Schon richtig, aber … bei manchen Webhostern liegt auf dem Server eine SQL-Datei der Datenbank – und die ist dann zumindest per FTP-Client sichtbar. 🤓

    Thread-Starter shitesite

    (@shitesite)

    @michi91 Vielen Dank für den Hinweis! Der Ordner hieß tatsächlich „plugins_“. Ich habe ihn umbenannt und die Plugins sind wieder sichtbar im Backend, wo ich sie jetzt aktivieren kann.

    @hage Ebenfalls vielen Dank für die Unterstützung!

    super – freut uns. Danke für die Rückmeldung.

    Denkst du bitte beim nächsten Mal daran, das Thema dann auch als gelöst zu markieren, wenn das Thema für dich erledigt ist. Danke.
    Gelöst
    Die Option findest du rechts in der Sidebar. Das habe ich jetzt schon gemacht.

Ansicht von 5 Antworten - 1 bis 5 (von insgesamt 5)
  • Das Thema „Plugins weg aus Backend nach Änderung Datenbank-Passwort“ ist für neue Antworten geschlossen.