Support » Plugins » Post-Einstellungen von Stackable im Gutenberg-Editor funktionieren nicht

  • Gelöst tmey

    (@tmey)


    Hallo zusammen,

    auf einer Website (WP 5.4) wird der Gutenberg-Editor genutzt. Hierzu sind verschiedene Erweiterungs-Plugins installiert worden, u.a. Stackable, mit der die Posts angezeigt werden sollen.

    Im Backend werden in der Vorschau alle Einstellungen korrekt angezeigt. In der Live-Frontend-Version werden jedoch Einstellungen ignoriert. Hierbei handelt es sich z.B. zum einen um die Wort-Anzahl vom Excerpt (eingestellt sind 20, im Frontend wird erst nach ca. 100 Wörtern abgebrochen) oder auch die Einstellung über die Kategorie (angezeigt werden sollen nur Beiträge einer Kategorie, es werden aber Beiträge aller Kategorien gezeigt).

    Ist das Problem und vor allem eine Lösung bekannt?

    Es sind diverse weitere Plugins installiert, ggf. harmoniert da etwas nicht?
    Z.B. jeweils in aktueller Version …
    Atomic Blocks – Gutenberg Block-Sammlung
    Block Lab
    Ghost Kit
    Custom Classes
    UpdraftPlus
    Yoast SEO

    Vorab vielen Dank!
    Viele Grüße
    Tim

Ansicht von 5 Antworten - 1 bis 5 (von insgesamt 5)
  • Geh doch bitte mal auf Werkzeuge > Website-Zustand > Bericht, klick dort auf den Button und füge den Bericht unverändert (mit den Akzentzeichen am Anfang und Ende) in eine Antwort hier ein. Dann haben wir einen etwas vollständigeren Bericht über deine Website.

    Moin,

    hier der Bericht:

    
    ### wp-core ###
    
    version: 5.4
    site_language: de_DE
    user_language: de_DE
    timezone: Europe/Berlin
    permalink: /%postname%/
    https_status: true
    user_registration: 0
    default_comment_status: open
    multisite: false
    user_count: 3
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /kunden/xx/sc_wp_2019
    wordpress_size: 365,31 MB (383051990 bytes)
    uploads_path: /kunden/xx/sc_wp_2019/wp-content/uploads
    uploads_size: 102,34 MB (107312559 bytes)
    themes_path: /kunden/xx/sc_wp_2019/wp-content/themes
    themes_size: 15,17 MB (15911361 bytes)
    plugins_path: /kunden/xx/sc_wp_2019/wp-content/plugins
    plugins_size: 105,67 MB (110799000 bytes)
    database_size: 4,93 MB (5169634 bytes)
    total_size: 593,42 MB (622244544 bytes)
    
    ### wp-active-theme ###
    
    name: sc
    version: 1.2
    author: XX
    author_website: XX
    parent_theme: none
    theme_features: automatic-feed-links, title-tag, post-thumbnails, menus, html5, custom-logo, customize-selective-refresh-widgets, wp-block-styles, align-wide, editor-styles, editor-style, editor-font-sizes, editor-color-palette, responsive-embeds, widgets
    theme_path: /kunden/xx/sc_wp_2019/wp-content/themes/sc
    
    ### wp-themes-inactive (3) ###
    
    Twenty Nineteen: version: 1.3, author: WordPress-Team (latest version: 1.5)
    Twenty Seventeen: version: 2.1, author: WordPress-Team (latest version: 2.3)
    Twenty Sixteen: version: 1.9, author: WordPress-Team (latest version: 2.1)
    
    ### wp-mu-plugins (1) ###
    
    WP Migrate DB Compatibility: version: 1.2, author: Delicious Brains
    
    ### wp-plugins-active (17) ###
    
    Add From Server: version: 3.3.3, author: Dion Hulse
    Atomic Blocks - Gutenberg Blocks Collection: version: 2.8.0, author: atomicblocks
    Autoptimize: version: 2.6.2, author: Frank Goossens (futtta)
    Block Lab: version: 1.5.4, author: Block Lab
    Contact Form 7: version: 5.1.7, author: Takayuki Miyoshi
    Cookie Notice: version: 1.3.1, author: dFactory
    Custom Classes: version: 1.0.0, author: Justin Tadlock
    Duplicate Post: version: 3.2.4, author: Enrico Battocchi
    Ghost Kit: version: 2.12.1, author: nK
    Header and Footer Scripts: version: 2.1.1, author: Digital Liberation
    Responsive Lightbox & Gallery: version: 2.2.2, author: dFactory
    Smart Slider 3 Pro: version: 3.3.15, author: Nextend (latest version: 3.3.28)
    Stackable - Gutenberg Blocks: version: 2.4.0, author: Gambit Technologies, Inc
    Stylist: version: 0.2.6, author: StylistWP
    UpdraftPlus - Backup/Restore: version: 1.16.23, author: UpdraftPlus.Com, DavidAnderson
    WP Migrate DB: version: 1.0.13, author: Delicious Brains
    Yoast SEO: version: 13.5, author: Team Yoast
    
    ### wp-plugins-inactive (1) ###
    
    TRX News Footer: version: 1.0, author: XX
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_GD
    imagick_module_version: Nicht verfügbar
    imagemagick_version: Nicht verfügbar
    gd_version: bundled (2.1.0 compatible)
    ghostscript_version: 9.25
    
    ### wp-server ###
    
    server_architecture: Linux 3.18.114-pvops-xen-x64 x86_64
    httpd_software: Apache/2.4.41
    php_version: 7.2.19
    php_sapi: cgi-fcgi
    max_input_variables: 1000
    time_limit: 300
    memory_limit: 256M
    max_input_time: -1
    upload_max_size: 8M
    php_post_max_size: 8M
    curl_version: 7.55.1 OpenSSL/1.0.2l
    suhosin: false
    imagick_availability: false
    htaccess_extra_rules: true
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 5.6.19-67.0-log
    client_version: mysqlnd 5.0.12-dev - 20150407 - $Id: 3591daad22de08524295e1bd073aceeff11e6579 $
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /kunden/xx/sc_wp_2019/wp-content
    WP_PLUGIN_DIR: /kunden/xx/sc_wp_2019/wp-content/plugins
    WP_MAX_MEMORY_LIMIT: 256M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_LOCAL_DEV: undefined
    DB_CHARSET: utf8mb4
    DB_COLLATE: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    mu-plugins: writable
    
    

    Du verwendest Autoptimize – schönes, leistungsfähiges Plugin, aber leider bei falschen Benutzereinstellungen auch schon mal Ursache für Probleme. Du kannst schauen, ob sich etwas ändert, indem du an die URLs ?ao_noptimize=1 anhängst oder du deaktivierst das Plugin mal vorübergehend.

    • Dein WordPress-Verzeichnis ist unerwartet groß. Sind da noch andere Webanwendungen reingerutscht?
    • Die PHP-Version ist nicht ganz aktuell und der Support läuft bald aus.
    • Brauchst du WP Migrate DB noch? Würde ich sonst löschen.
    • Zu deinem Theme kann ich nichts sagen.

    Vielleicht fragst du auch mal direkt bei den Entwicklern des Plugins nach?
    Das Supportforum findest du hier: https://wordpress.org/support/plugin/stackable-ultimate-gutenberg-blocks/

    Moin,

    vielen Dank für Deine Rückmeldung! Das WP-Verzeichnis ist mir auch schon aufgefallen, warte noch auf ftp-Zugang (habe die Seite nicht selbst ertsellt und nicht in eigener Verwaltung, übernehme nur ganz frisch den Support, das Theme ist ein selbstgetsricktes von einem Programmierer). PHP-Version schaue ich mir auch mal an, guter Hinweis, danke!

    Autoptimize habe ich deaktiviert, verändert hedoch nichts.
    Supportforum vom Plugin habe ich jetzt entdeckt und da mal angefragt.

    Danke bis hierhin!

    Hallo zusammen,
    ich konnte den Fehler ausfindig machen – Problem waren individuelle Overrides des Them-Entwicklers.

    Danke für eure Bemühungen!

Ansicht von 5 Antworten - 1 bis 5 (von insgesamt 5)
  • Das Thema „Post-Einstellungen von Stackable im Gutenberg-Editor funktionieren nicht“ ist für neue Antworten geschlossen.