Support » Allgemeine Fragen » Posts tauchen nicht im Blog auf

  • Ich bin momentan dabei meine Webseite zu erstellen und nutze das Theme „Astra“.

    Ich habe im Dashboard unter Posts zwei Test Posts erstellt und gepublisht. Nun möchte ich, dass sie unter einer eigenen Page, nämlich „Blog“ zu sehen sind. Dafür habe ich unter Pages eine neue Page „Blog“ als Posts Page erstellt und unter Appearence die Page dem Menu hinzugefügt.

    Anschließend habe ich unter Settings „A static page“ aktiviert und als Homepage „Home“ und als Posts Page „Blog ausgewählt. Dann habe ich die Änderungen gespeichert.

    Wenn ich dann allerdings unter visit Site nachschaue erscheinen die Posts trotzdem nicht unter der Page „Blog“.

    Habe ich iwo einen denkfehler?

    Viele Grüße,
    Rapha

Ansicht von 7 Antworten - 1 bis 7 (von insgesamt 7)
  • WordPress „vergisst“ schon mal bei Installation oder Update fehlerhaft programmierter Plugins die Permalink-Einstellungen. Geh mal in das Einstellungen > Permalinks. Dort brauchst du auch nichts weiter machen, die Permalinks werden bereits durch Aufruf des Menüs neu eingelesen. Ändert sich dann was?

    Bitte gib auch eine URL zur Website an. Außerdem brauchen wir mehr Informationen über deine Website. Geh bitte auf Werkzeuge > Website-Zustand > Bericht, warte einen Moment bis die Ladeanzeige ganz oben abgeschlossen ist. Klick auf den Button „Bericht in die Zwischenablage kopieren“. Den Bericht kannst du dann hier in einer neuen Antwort mit Strg-V (Mac: Cmd-V) unverändert einfügen (also bitte ohne weitere Formatierung, aber mit den Akzentzeichen ` am Anfang und Ende).

    Dass du deine Website auch auf Deutsch umstellen kannst ist dir bekannt?

    Thread-Ersteller raphav

    (@raphav)

    Hallo,

    leider hat sich durch aufrufen der Einstellungen > Permalinks nichts getan.
    Die URL lautet: http://box5877.temp.domains/~ersonbc3/

    Aktuell hangle ich mich durch ein englisches Tutorial, daher ist die Sprache noch auf englisch eingestellt.

    Bericht folgt

    Thread-Ersteller raphav

    (@raphav)

    
    ### wp-core ###
    
    version: 5.6
    site_language: de_DE
    user_language: de_DE
    timezone: +00:00
    permalink: /%postname%/
    https_status: false
    multisite: false
    user_registration: 0
    blog_public: 1
    default_comment_status: open
    environment_type: production
    user_count: 1
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /home1/ersonbc3/public_html
    wordpress_size: 272,94 MB (286194566 bytes)
    uploads_path: /home1/ersonbc3/public_html/wp-content/uploads
    uploads_size: 10,16 MB (10658154 bytes)
    themes_path: /home1/ersonbc3/public_html/wp-content/themes
    themes_size: 17,57 MB (18422244 bytes)
    plugins_path: /home1/ersonbc3/public_html/wp-content/plugins
    plugins_size: 143,35 MB (150318529 bytes)
    database_size: 8,73 MB (9158656 bytes)
    total_size: 452,76 MB (474752149 bytes)
    
    ### wp-dropins (2) ###
    
    db-error.php: true
    maintenance.php: true
    
    ### wp-active-theme ###
    
    name: Astra (astra)
    version: 3.0.1
    author: Brainstorm Force
    author_website: https://wpastra.com/about/
    parent_theme: none
    theme_features: core-block-patterns, astra_hooks, align-wide, automatic-feed-links, title-tag, post-thumbnails, html5, post-formats, custom-logo, customize-selective-refresh-widgets, editor-style, woocommerce, amp, infinite-scroll, wc-product-gallery-zoom, wc-product-gallery-lightbox, wc-product-gallery-slider, widgets, menus
    theme_path: /home1/ersonbc3/public_html/wp-content/themes/astra
    auto_update: Aktiviert
    
    ### wp-themes-inactive (4) ###
    
    Sinatra: version: 1.1.6, author: Sinatra Team, Automatische Aktualisierungen aktiviert
    Twenty Nineteen: version: 1.9, author: WordPress-Team, Automatische Aktualisierungen aktiviert
    Twenty Twenty: version: 1.6, author: WordPress-Team, Automatische Aktualisierungen aktiviert
    Twenty Twenty-One: version: 1.1, author: WordPress-Team, Automatische Aktualisierungen aktiviert
    
    ### wp-mu-plugins (2) ###
    
    Endurance Page Cache: version: 2.0.6, author: Mike Hansen
    SSO: version: 0.3, author: Garth Mortensen, Mike Hansen
    
    ### wp-plugins-active (11) ###
    
    All-in-One WP Migration: version: 7.33, author: ServMask, Automatische Aktualisierungen aktiviert
    Bluehost: version: 2.5.3, author: Bluehost, Automatische Aktualisierungen aktiviert
    Creative Mail by Constant Contact: version: 1.3.1, author: Constant Contact, Automatische Aktualisierungen aktiviert
    Elementor: version: 3.1.0, author: Elementor.com, Automatische Aktualisierungen aktiviert
    Elementor - Header, Footer & Blocks: version: 1.5.6, author: Brainstorm Force, Nikhil Chavan, Automatische Aktualisierungen aktiviert
    Google Analytics for WordPress by MonsterInsights: version: 7.15.1, author: MonsterInsights, Automatische Aktualisierungen aktiviert
    Jetpack by WordPress.com: version: 9.3.1, author: Automattic, Automatische Aktualisierungen aktiviert
    OptinMonster: version: 2.1.1, author: OptinMonster Team, Automatische Aktualisierungen aktiviert
    Starter Templates: version: 2.4.0, author: Brainstorm Force, Automatische Aktualisierungen aktiviert
    WooCommerce: version: 4.9.2, author: Automattic, Automatische Aktualisierungen deaktiviert
    WPForms Lite: version: 1.6.4.1, author: WPForms, Automatische Aktualisierungen aktiviert
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_Imagick
    imagick_module_version: 1690
    imagemagick_version: ImageMagick 6.9.10-68 Q16 x86_64 2020-12-15 https://imagemagick.org
    file_uploads: File uploads is turned off
    post_max_size: 516M
    upload_max_filesize: 512M
    max_effective_size: 512 MB
    max_file_uploads: 20
    imagick_limits: 
    	imagick::RESOURCETYPE_AREA: 115 GB
    	imagick::RESOURCETYPE_DISK: 9223372036854775807
    	imagick::RESOURCETYPE_FILE: 12288
    	imagick::RESOURCETYPE_MAP: 48 MB
    	imagick::RESOURCETYPE_MEMORY: 48 MB
    	imagick::RESOURCETYPE_THREAD: 1
    gd_version: bundled (2.1.0 compatible)
    ghostscript_version: 9.25
    
    ### wp-server ###
    
    server_architecture: Linux 4.14.146-225.ELK.el7.x86_64 x86_64
    httpd_software: Apache
    php_version: 7.4.14 64bit
    php_sapi: cgi-fcgi
    max_input_variables: 1000
    time_limit: 30
    memory_limit: 256M
    max_input_time: 60
    upload_max_filesize: 512M
    php_post_max_size: 516M
    curl_version: 7.74.0 OpenSSL/1.1.1i
    suhosin: false
    imagick_availability: true
    pretty_permalinks: true
    htaccess_extra_rules: true
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 5.7.23-23
    client_version: mysqlnd 7.4.14
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /home1/ersonbc3/public_html/wp-content
    WP_PLUGIN_DIR: /home1/ersonbc3/public_html/wp-content/plugins
    WP_MAX_MEMORY_LIMIT: 256M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_LOCAL_DEV: undefined
    DB_CHARSET: utf8
    DB_COLLATE: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    mu-plugins: writable
    
    ### jetpack ###
    
    site_id: false
    ssl_cert: No
    time_diff: false
    version_option: 9.3.1:1611660473
    old_version: 9.3.1:1611660473
    public: Private
    master_user: Kein Masterbenutzer festgelegt.
    current_user: #1 hello
    tokens_set: None
    blog_token: Not set.
    user_token: Not set.
    version: 9.3.1
    jp_plugin_dir: /home1/ersonbc3/public_html/wp-content/plugins/jetpack/
    plan: free
    protect_header: false
    full_sync: {"started":"Thu, 01 Jan 1970 00:00:00 +0000","finished":"Thu, 01 Jan 1970 00:00:00 +0000","progress":[],"config":[]}
    sync_size: undefined
    sync_lag: 0 seconds
    full_sync_size: undefined
    full_sync_lag: 0 seconds
    idc_urls: {"home":"http:\/\/box5877.temp.domains\/~ersonbc3\/","siteurl":"http:\/\/box5877.temp.domains\/~ersonbc3\/","WP_HOME":"","WP_SITEURL":""}
    idc_error_option: false
    idc_optin: true
    cxn_tests: All Pass.
    
    ### wpforms ###
    
    version: 1.6.4.1
    lite: Jan 26, 2021 @ 11:28am
    upload_dir: Not writable
    db_tables: qLl_wpforms_tasks_meta
    total_forms: 1
    total_submissions: undefined
    
    

    Durch den Maintenance-Bildschirm kann ich mir da nicht viel ansehen.
    Der Website-Bericht gibt auch keine Anhaltspunkte.
    Ich würde unter Einstellungen > Lesen (bzw. Settings > Reading) nochmal die Einstellung der Start- und Blog-Seiten prüfen.

    Thread-Ersteller raphav

    (@raphav)

    Ok danke, das habe ich bereits gemacht und alle Einstellungen waren entsprechend korrekt. Vll kommt mir iwann die zündende Idee woran es hängt, aber momentan habe ich keine Lösung-

    Thread-Ersteller raphav

    (@raphav)

    was muss ich denn ändern, damit du auf dem maintenance bildschirm mehr sehen kannst?

    Das Maintenance-Plugin verhindert, dass sich Webseitenbesucher während der Wartung (engl. Maintenance) die Website ansehen dürfen. Deaktivierst du das Plugin, ist auch wieder ein Zugriff möglich.

Ansicht von 7 Antworten - 1 bis 7 (von insgesamt 7)