Support » Installation » Private Blogseite ist sichtbar wenn man die URL kennt

  • Gelöst myheart61

    (@myheart61)


    Hallo lieber Support,
    ich finde keine Antwort auf meine Frage !
    Wenn ich meine Beitragsseite auf „Privat“ stelle, damit sie nur für angemeldete Redakteure sichtbar ist, so ist sie dennoch für andere User sichtbar, die zwar nicht angemeldet sind, aber die URL kennen.
    Ist das normal ?

Ansicht von 10 Antworten - 1 bis 10 (von insgesamt 10)
  • Moderator Bego Mario Garde

    (@pixolin)

    Nein, das ist nicht normal.

    Wenn du eine etwas ausführlichere Antwort erwartest: dazu bräuchten wir mehr Informationen über deine Website (Werkzeuge > Website-Zustand > Bericht, klick auf den Button und füge den Bericht mit Strg-V unverändert in deine Antwort ein) und idealerweise einen Link zu einem (unkritischen) Beispiel.

    Thread-Ersteller myheart61

    (@myheart61)

    Danke,
    hier ist schon einmal der Bericht:

    
    ### wp-core ###
    
    version: 5.7.1
    site_language: de_DE
    user_language: de_DE
    timezone: +00:00
    permalink: /%postname%/
    https_status: true
    multisite: false
    user_registration: 0
    blog_public: 0
    default_comment_status: open
    environment_type: production
    user_count: 3
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /volume1/vhost_WP_2/Wordpress
    wordpress_size: 46,05 MB (48290052 bytes)
    uploads_path: /volume1/vhost_WP_2/Wordpress/wp-content/uploads
    uploads_size: 24,17 MB (25345728 bytes)
    themes_path: /volume1/vhost_WP_2/Wordpress/wp-content/themes
    themes_size: 3,45 MB (3614397 bytes)
    plugins_path: /volume1/vhost_WP_2/Wordpress/wp-content/plugins
    plugins_size: 3,69 MB (3866832 bytes)
    database_size: 13,48 MB (14139392 bytes)
    total_size: 90,84 MB (95256401 bytes)
    
    ### wp-active-theme ###
    
    name: Twenty Twenty-One (twentytwentyone)
    version: 1.3
    author: WordPress-Team
    author_website: https://de.wordpress.org/
    parent_theme: none
    theme_features: core-block-patterns, automatic-feed-links, title-tag, post-formats, post-thumbnails, menus, html5, custom-logo, customize-selective-refresh-widgets, align-wide, editor-styles, editor-style, editor-font-sizes, custom-background, editor-color-palette, editor-gradient-presets, responsive-embeds, custom-line-height, experimental-link-color, custom-spacing, custom-units, widgets
    theme_path: /volume1/vhost_WP_2/Wordpress/wp-content/themes/twentytwentyone
    auto_update: Deaktiviert
    
    ### wp-plugins-active (2) ###
    
    Twentig: version: 1.2.8, author: Twentig, Automatische Aktualisierungen deaktiviert
    User Menus: version: 1.2.5, author: Code Atlantic, Automatische Aktualisierungen deaktiviert
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_Imagick
    imagick_module_version: 1690
    imagemagick_version: ImageMagick 6.9.10-27 Q8 x86_64 2021-03-02 https://imagemagick.org
    file_uploads: File uploads is turned off
    post_max_size: 32M
    upload_max_filesize: 32M
    max_effective_size: 32 MB
    max_file_uploads: 20
    imagick_limits: 
    	imagick::RESOURCETYPE_AREA: 11 GB
    	imagick::RESOURCETYPE_DISK: 1.844674407371E+19
    	imagick::RESOURCETYPE_FILE: 768
    	imagick::RESOURCETYPE_MAP: 11 GB
    	imagick::RESOURCETYPE_MEMORY: 6 GB
    	imagick::RESOURCETYPE_THREAD: 2
    gd_version: bundled (2.1.0 compatible)
    ghostscript_version: not available
    
    ### wp-server ###
    
    server_architecture: Linux 4.4.59+ x86_64
    httpd_software: Apache/2.4.43 (Unix)
    php_version: 7.4.9 64bit
    php_sapi: fpm-fcgi
    max_input_variables: 1000
    time_limit: 240
    memory_limit: 128M
    admin_memory_limit: 256M
    max_input_time: 60
    upload_max_filesize: 32M
    php_post_max_size: 32M
    curl_version: 7.54.0 OpenSSL/1.0.2u
    suhosin: false
    imagick_availability: true
    pretty_permalinks: true
    htaccess_extra_rules: false
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 10.3.24-MariaDB
    client_version: mysqlnd 7.4.9
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /volume1/vhost_WP_2/Wordpress/wp-content
    WP_PLUGIN_DIR: /volume1/vhost_WP_2/Wordpress/wp-content/plugins
    WP_MEMORY_LIMIT: 40M
    WP_MAX_MEMORY_LIMIT: 256M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_LOCAL_DEV: undefined
    DB_CHARSET: utf8mb4
    DB_COLLATE: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    
    
    Thread-Ersteller myheart61

    (@myheart61)

    und auch der Passwort-Schutz funktioniert auf dieser Seite nicht. Auf anderen Seiten dagegen schon.

    Moderator Bego Mario Garde

    (@pixolin)

    Hast du mal versucht, das Plugin „User Menus“ zu deaktivieren, um es als mögliche Fehlerursache auszuschließen?

    Bis auf eine fehlerhaft eingestellte Systemzeit (richtig wäre bei Zeitzone „Berlin“) finde ich in diesem Bericht nichts, was einen solchen Fehler erklären würde. Leider hast du auch keinen Link zu einem Beispiel-Beitrag angegeben.

    Moderator Bego Mario Garde

    (@pixolin)

    … gerade nochmal getestet, auch mit den von dir verwendeten Plugins und Twenty Twenty One. Ich kann den Fehler nicht reproduzieren.

    Thread-Ersteller myheart61

    (@myheart61)

    ja das ist sehr komisch
    hier ist der Link zu einer Probeseite

    die Menüunlte Familienreisen und Neuigkeiten sind beide privat, aber die Blog-Seite „Neuigkeiten“ ist trotzdem zugänglich

    Danke für die Hilfe !

    • Diese Antwort wurde geändert vor 5 Monaten von Bego Mario Garde. Grund: Link korrigiert
    Moderator Bego Mario Garde

    (@pixolin)

    Die Seite „Neuigkeiten“ wurde in Einstellungen > Lesen als Platzhalter für die Beitragsübersichtsseite festgelegt und wird deshalb auch angezeigt.

    Die Seite „Familienreisen“ wird als „Nicht vorhanden“ angeziegt – genau so, wie es bei „privaten“ Seiten und Beiträgen sein soll.

    Thread-Ersteller myheart61

    (@myheart61)

    ok danke.
    Ich dachte, dass ich die eingestellte Beitragsseite auch auf diese Weise ausblenden kann, ausser für admin. Aber gut.

    Vielen Dank für die schnelle Hilfe !

    Moderator Bego Mario Garde

    (@pixolin)

    Gern geschehen.

    Markierst du bitte den Thread noch als „gelöst“?

    Thread-Ersteller myheart61

    (@myheart61)

    ok
    schönen Tag noch

Ansicht von 10 Antworten - 1 bis 10 (von insgesamt 10)