Support » Installation » Problem bei der Einrichtung von WordPress scheitere an account Anlegung Admin

  • Gelöst eikemerch

    (@eikemerch)


    Schönen guten Abend,

    ich habe folgendes Problem, und zwar ich habe mir die Deutsche Version von WordPress heruntergeladen und auf meinem Root Server versucht zu installieren leider scheitere ich an dem Anlegen des Admin-Accounts ich erhalte folgende Fehler Meldung:

    Deine Passwörter stimmen nicht überein. Bitte versuche es nochmal.

    Es steht da das, dass password sicher ist aber ich habe ja nur ein Feld zur password Eingabe davor müsste ich ja die MySQL Daten eingeben dort habe ich ein andres password benutzt habe WordPress bereits 2 Mal neu aufgesetzt und scheitere an diesem Problem habt ihr da eine Lösung für?

    Mit freundlichen Grüßen und bleibt gesund!

    Eikemerch

Ansicht von 14 Antworten - 31 bis 44 (von insgesamt 44)
  • Habe gerade nichts großartiges zu tun gehabt, falls es jemand brauchen kann:

    <!DOCTYPE html>
    <html lang="de">
      <head>
        <meta charset="utf-8">
        <meta name="viewport" content="width=device-width, initial-scale=1.0">
        <title>Datenbank prüfen</title>
        <style>
          #container {
              width:500px;
              margin: 0 auto;
          }
          input[type=text], input[type=password] {
              width: 250px;
          }
        </style>
      </head>
      <body>
      <div id="container">
    <?php
      if (isset($_POST['hostname']))
      {
          if (empty($_POST['hostname']) || empty($_POST['user']) || empty($_POST['password']) || empty($_POST['database']))
              die ("Nicht alle Felder ausgefüllt");
          
          $link = mysqli_connect($_POST['hostname'], $_POST['user'], $_POST['password']);
    
          if (mysqli_connect_errno()) 
             printf("Connect failed: %s\n", mysqli_connect_error());
          else
          {
             mysqli_select_db($link, $_POST['database'])
               or die ("Datenbank " . $_POST['database'] . " existiert nicht");
               
             $query = "show tables";
        
             $result = mysqli_query($link, $query)
                       or  die ("Fehler mit $query<br>: " . mysqli_error($link));
        
             if (mysqli_num_rows($result))
             {
                echo "<h3>Folgende Tabellen sind vorhanden:</h3>";
              
                while ($table = mysqli_fetch_row($result))
                {
                    $output = $table[0];
                    
                    if (isset($_POST['count']))
                    {
                        $query = "select count(*) from backtick" . $table[0] . "backtick";
                        
                        $result1 = mysqli_query($link, $query)
                             or  die ("Fehler mit $query<br>: " . mysqli_error($link));
                        
                        $count = mysqli_fetch_row($result1)[0];
                        
                        $output .= ", Anzahl Datensätze: $count";
                    }
                                
                    echo "$output<br>";
                }
             }
             else
                echo "Keine Tabellen vorhanden";
         }
      }
      else
      {
    ?>
    <h3>Daten für Datenbankzugriff eingeben</h3>
    <form action="" method="post">
      <label for="hostname">Hostname:</label><br>
      <input type="text" id="hostname" name="hostname" required ><br><br>
      <label for="user">Benutzer</label><br>
      <input type="text" id="user" name="user" required ><br><br>
      <label for="password">Passwort</label><br>
      <input type="password" id="password" name="password" required ><br><br>
      <label for="database">Datenbank</label><br>
      <input type="text" id="database" name="database" required ><br><br>
      <input type="checkbox" id="count" name="count">
       <label for="count">Anzahl Datensätze anzeigen</label><br><br>
      <input type="submit" value="Submit">
    </form>
    <?php
      }
    ?>
    </div>
    </body>
    </html>

    Backticks mag das Forum aber nicht wirklich 🙁
    Das Wort Backtick durch ` ersetzen

    • Diese Antwort wurde geändert vor 2 Wochen, 6 Tage von bscu.
    • Diese Antwort wurde geändert vor 2 Wochen, 6 Tage von bscu.

    @bscu in der Tat: noch besser 👍

    @bscu

    Ich überlege gerade, ob wir das in die FAQ packen.
    Falls ja, sollten die Eingaben bei der Ausgabe nicht noch bereinigt (sanitized) werden? Es könnte ja sein, dass Anwender/-innen vergessen, das Skript nach erfolgreicher Prüfung wieder zu löschen.
    Wenn wir das übernehmen: wie steht’s mit Lizenz- und Urheber-Angaben?

    Ich überlege gerade, ob wir das in die FAQ packen.

    Kannst du gerne machen

    Falls ja, sollten die Eingaben bei der Ausgabe nicht noch bereinigt (sanitized) werden? Es könnte ja sein, dass Anwender/-innen vergessen, das Skript nach erfolgreicher Prüfung wieder zu löschen.

    Wer es vergiss, ist es selber schuld 😀 😀 Viel kann man mit dem Script ja sowieso nicht anfangen, du musst ja schon die genauen Daten kennen. Auf Sicherheit ist das Script jetzt nicht wirklich ausgelegt. 😉

    Wenn wir das übernehmen: wie steht’s mit Lizenz- und Urheber-Angaben?

    Kannst du vergessen, das Script ist ja keine Raketenwissenschaft und nix besonderes. Habe ich ja auf die Schnelle zusammengeschraubt. 😉

    Thread-Ersteller eikemerch

    (@eikemerch)

    Guten Tag, ich hoffe mal das alle gut auf sind wegen dem Wasser was da grad los ist

    hier einmal der Bericht:

    
    ### wp-core ###
    
    version: 5.7.2
    site_language: de_DE
    user_language: de_DE
    timezone: Europe/Berlin
    permalink: /%postname%/
    https_status: false
    multisite: false
    user_registration: 0
    blog_public: 1
    default_comment_status: open
    environment_type: production
    user_count: 1
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /var/www/html/wordpress
    wordpress_size: loading...
    uploads_path: /var/www/html/wordpress/wp-content/uploads
    uploads_size: loading...
    themes_path: /var/www/html/wordpress/wp-content/themes
    themes_size: loading...
    plugins_path: /var/www/html/wordpress/wp-content/plugins
    plugins_size: loading...
    database_size: loading...
    total_size: loading...
    
    ### wp-active-theme ###
    
    name: Twenty Twenty-One (twentytwentyone)
    version: 1.3
    author: WordPress-Team
    author_website: https://de.wordpress.org/
    parent_theme: none
    theme_features: core-block-patterns, automatic-feed-links, title-tag, post-formats, post-thumbnails, menus, html5, custom-logo, customize-selective-refresh-widgets, wp-block-styles, align-wide, editor-styles, editor-style, editor-font-sizes, custom-background, editor-color-palette, editor-gradient-presets, responsive-embeds, custom-line-height, experimental-link-color, custom-spacing, custom-units, widgets
    theme_path: /var/www/html/wordpress/wp-content/themes/twentytwentyone
    auto_update: Deaktiviert
    
    ### wp-themes-inactive (1) ###
    
    Twenty Nineteen: version: 2.0, author: WordPress-Team, Automatische Aktualisierungen deaktiviert
    
    ### wp-plugins-active (2) ###
    
    Akismet Anti-Spam: version: 4.1.10, author: Automattic, Automatische Aktualisierungen deaktiviert
    Hello Dolly: version: 1.7.2, author: Matt Mullenweg, Automatische Aktualisierungen deaktiviert
    
    ### wp-plugins-inactive (1) ###
    
    Gutenberg: version: 11.0.0, author: Gutenberg Team, Automatische Aktualisierungen deaktiviert
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_GD
    imagick_module_version: Nicht verfügbar
    imagemagick_version: Nicht verfügbar
    file_uploads: File uploads is turned off
    post_max_size: 8M
    upload_max_filesize: 2M
    max_effective_size: 2 MB
    max_file_uploads: 20
    gd_version: 2.2.4
    ghostscript_version: not available
    
    ### wp-server ###
    
    server_architecture: Linux 4.9.0-16-amd64 x86_64
    httpd_software: Apache/2.4.25 (Debian)
    php_version: 7.0.33-0+deb9u11 64bit
    php_sapi: apache2handler
    max_input_variables: 1000
    time_limit: 30
    memory_limit: 128M
    admin_memory_limit: 256M
    max_input_time: 60
    upload_max_filesize: 2M
    php_post_max_size: 8M
    curl_version: 7.52.1 OpenSSL/1.0.2u
    suhosin: false
    imagick_availability: false
    pretty_permalinks: true
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 10.1.48-MariaDB-0+deb9u2
    client_version: mysqlnd 5.0.12-dev - 20150407 - $Id: b5c5906d452ec590732a93b051f3827e02749b83 $
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /var/www/html/wordpress/wp-content
    WP_PLUGIN_DIR: /var/www/html/wordpress/wp-content/plugins
    WP_MEMORY_LIMIT: 40M
    WP_MAX_MEMORY_LIMIT: 256M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_LOCAL_DEV: undefined
    DB_CHARSET: utf8
    DB_COLLATE: undefined
    
    ### wp-filesystem ###
    
    wordpress: not writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    
    

    Mit Freundlichen grüßen

    Eikemerch

    • Diese Antwort wurde geändert vor 2 Wochen, 6 Tage von eikemerch.

    Danke für den Bericht, aber um was geht es denn nun konkret?

    Thread-Ersteller eikemerch

    (@eikemerch)

    nun erhalte ich folgende Fehler Meldung wenn ich eine Seite bearbeite:

    Aktualisierung fehlgeschlagen. Die Antwort ist keine gültige JSON-Antwort.

    darum geht’s

    Offensichtlich ist der Server noch nicht richtig konfiguriert.
    Abgesehen von der reichlich veralteten PHP-Version (7.4 wäre optimal, aktuell nutzt du 7.0) musst du in deinem Apache-Webserver das Modul mod_rewrite aktivieren und in der Virtual Host Datei Änderungen der Serverkonfiguration per .htaccess erlauben, sinngemäß also :

    <Directory /var/www/html/>
      Options Indexes FollowSymLinks
      AllowOverride all
      Require all granted
    </Directory>

    Danach einen Neustart des Apache-Servers nicht vergessen.

    Thread-Ersteller eikemerch

    (@eikemerch)

    Danke sehr aber wenn ich versuche auf 7.4 zu updaten geht es nicht.

    Hallo,
    dann sprich am besten mal den Support des Hosters an, ob die dir helfen können.
    Viele Grüße
    Hans-Gerd

    @hage

    dann sprich am besten mal den Support des Hosters an

    auf meinem Root Server

    eikemerch ist sein eigener Support 😀

    Thread-Ersteller eikemerch

    (@eikemerch)

    Wie lustig @bscu

    @hage kann man Leute hier Blockieren so das sie nicht mehr kommentieren können ?

    denn ich finde sowas unpassend und nicht hilfreich

    @eikemerch

    Entspann dich mal. Wer statt einem normalen Webhosting einen Root-Server aufsetzt, aber PHP 7.4 nicht installieren kann, muss sich auch ein wenig Häme gefallen lassen. Sie das nicht so bierernst, wir versuchen ja trotzdem, dir zu helfen.

    Wir blockieren nur Teilnehmende, die ganz erheblich gegen Forenrichtlinien verstoßen. Eher schließen wir den Thread, weil Dinge wie Serverkonfiguration hier off topic sind – dafür gibt es andere Foren.

    Kannst du auf PHP 7.3 updaten? Das wäre ja auch schon besser als 7.0. Du willst ja nicht gleich mit Sicherheitslücken anfangen. Dass du bei einem Root-Server selber für alle Updates zuständig bist, ist dir aber schon klar?

    @eikemerch

    Wie lustig

    Ehrlich? Ich finde das überhaupt nicht lustig. Wenn man nicht über ein fundiertes Wissen in der Konfiguration von Servern hat, sollte man besser die Finger davon lassen. Denn wenn die Kiste gehackt wird und zu einer Spamschleuder wird, dann bist du der Dumme, das fällt dann auf dich zurück. Alternativ kann man Control-Panels w.z.B. Plesk einsetzen, die nehmen einem schon viele Dinge ab. Aber trotzdem bist du für den Server verantwortlich, und da sollte man PHP auch updaten können.

Ansicht von 14 Antworten - 31 bis 44 (von insgesamt 44)