Support » Installation » Problem bei Neuinstallation nach Löschen

  • Gelöst lisavetka

    (@lisavetka)


    Hallo,
    ich bin neu hier, bin eine relative Anfängerin und habe ein Problem mit der Neuistallation von wordpress auf dem ftp-server.
    Nach hochladen der entpackten wordpressdaten über filezilla und aufrufen der entsprechenden Seite erscheint eine weiße Seite. Ich kann die Admindaten nicht eingeben und mich nicht anmelden.
    Hintergrund: ich habe eine html-seite, die läuft und vor ca. zwei Jahren habe ich testweise auf dem ftp-server unter html ein unterverzeichnis wordpress angelegt und alles mögliche mit verschiedenen Themes ausprobiert. Jetzt habe ich einfach mit dem Hintergedanken Alles zu bereinigen, das gesamte Verzeichnis wordpress gelöscht auch die Einträge in der phpDatenbank.
    Ich wollte einfach tabula rasa machen, um mich dann ernsthaft mit der neuen WordPressversion zu starten.
    Ich bin echt am verzweifeln. Kann mir jemand einen Tipp geben, wie ich an die Admin-Maske komme um wordpress ins Laufen zu bringen?
    Vielen Dank.

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 60)
  • Wenn du alles gelöscht hast, solltest du auch alle Tabellen in der Datenbank löschen und nicht nur die Einträge. Bei einer frisch auf den Server kopieren Version sollte dann eigentlich das Setup kommen, wenn du die Seite aufrufst. Dazu musst du am Anfang auch nicht gleich in den Admin-Bereich gehen.

    Also, lösche alles aus der Datenbank, lösche vielleicht auch nochmal alle Dateien per FTP und kopiere noch einmal eine frische WordPress-Version auf den Server.

    @bscu
    danke für die Info, aber ich habe tatsächlich bereits alle Daten aus der Datenbank gelöscht und sie ist leer. Danach habe ich eine aktuelle Version wordpress in ein Unterverzeichnis unter html => „wordpress“ hochgeladen. Wenn ich dann meine URL aufrufe, dann kommt jetzt bei /install.php eine leere Seite ohne Fehlermeldungen.
    Woran könnte es noch liegen?
    Hast du noch eine Idee?

    • Diese Antwort wurde geändert vor 10 Monate, 1 Woche von lisavetka.

    Eine Idee habe ich noch:
    Mal einen Blick in das Log-File von PHP werfen, ob darin eine Fehlermeldung zu finden ist.

    hmmm und wie mache ich das, bin ja Anfängerin 🙂 …wo finde ich dieses log-file

    Ein weißer Bildschirm kann entweder bedeuten, dass es einen fatalen PHP-Fehler gibt (z.B. wenn nicht alle Dateien von WordPress korrekt hochgeladen wurden) oder dass es Probleme bei der Kommunikation mit der Datenbank gibt. Wenn du eine bereits vorhandene wp-config.php verwendest, in der aber die falschen Zugangsdaten zur Datenbank eingetragen sind, kann es deshalb sein, dass du nur einen leeren Bildschirm angezeigt bekommst.

    Lösch deshalb mal die wp-config.php (du kannst sie ja vorher auf deinen eigenen PC herunterladen, wenn du ganz sicher sein möchtest).
    Du solltest dann beim nächsten Aufruf deiner Webadresse im Browser einen Hinweis erhalten, dass keine Konfigurationsdatei vorliegt, du aber automatisiert eine neue Konfigurationsdatei erstellen kannst. Dabei wirst du im nächsten Schritt nach den Zugangsdaten zur Datenbank gefragt (Benutzername, Passwort, Name der Datenbank). Bei manchen Providern (z.B. Strato, 1&1) musst du auch angeben, auf welchem Server die Datenbank liegt (Datenbank-Host); bei allen anderen kannst du localhost übernehmen. Im nächsten Schritt werden diese Zugangsdaten geprüft und du bekommst einen Hinweis, wenn es bei der Kommunikation mit der Datenbank ein Problem gibt.
    Bekommst du nach dem Löschen der wp-config.php weiterhin nur einen leeren Bildschirm angezeigt, stimmt vermutlich an deinen WordPress-Dateien oder der Serverkonfiguration etwas nicht.

    @pixolin
    vielen Dank für die Antwort:
    Bis gestern lief ja wordpress und ließ sich bearbeiten. Dann habe ich ein weiteres Test-Theme und das dazugehörige Plugin installiert und dann kam ein Fehler mit dem ich nichts anfangen konnte. Deshalb habe ich gedacht: o.k. dann lösche ich einfach Alles und istalliere die neue Version WordPress und starte ganz neu. Das war so meine Idee. Also habe ich wordpress mit allen Inhalten gelöscht. Habe mir die aktuelle Version von wordpress heruntergeladen , entpackt und mit filezilla in ein unter „html“ angelegtes Verzeichnis „wordpress“ die entpackten Dateien hochgeladen. Nachdem ich dann keinen Erfolt hatte, habe ich dummerweise die Inhalte der Datenbank mit allen wp-daten gelöscht, weil da ja die alten Daten standen. Das war wahrscheinlich der Fehler? Die Datenbank ist vorhanden, aber leer. Ich dachte, dass mit der Installation von WordPress die Inhalte automatisch gefüllt werden.
    Ich weiß jetzt nicht mehr weiter.

    Wenn ich die wp-config.php lösche, erscheint unter der entsprechenden URL eine leere Seite mit der URL …/wordpress/wp-admin/setup-config.php => vielleicht ist das für euch Profis ein Hinweis?
    …und ich erhalte keine Hinweise, dass keine Config vorliegt und auch sonst keine Anmeldemasken oder sonstiges…

    Die WordPress-Dateien müssten stimmen, da ich die aktuellste Version gestern heruntergeladen habe und diese dann entpackt immer wieder versucht habe ins Laufen zu bringen. Oder soll ich eine Vorversion 4.9 mal versuchen?

    Nachdem die alte Version und meine Testdaten bis gestern liefen, weiß ich nicht, was bei Serverkonfiguration nicht stimmt. (eine Anfrage an den Anbieter habe ich auch schon geschickt)

    • Diese Antwort wurde geändert vor 10 Monate, 1 Woche von lisavetka.
    • Diese Antwort wurde geändert vor 10 Monate, 1 Woche von lisavetka.
    • Diese Antwort wurde geändert vor 10 Monate, 1 Woche von lisavetka.

    Versuch mal, die vorhandenen WordPress-Dateien per FTP-Client zu löschen. Erst wenn wirklich alles im Verzeichnis /wordpress gelöscht ist, lädst du WordPress nochmal hier neu herunter, entpackst es und überträgst die Dateien aus deinem lokalen Verzeichnis wordpress in das Verzeichnis wordpress auf deinem Webserver.

    Prüf bitte auch mal im Kundenmenü deines Webhoster, ob du verschiedene PHP-Versionen auswählen kannst. PHP 7.2 wäre optimal. Falls du dazu keine Angaben findest, erstellst du eine eigene PHP-Datei mit dem Namen phpinfo.php und dem einzigen Inhalt

    
    <?php phpinfo();
    

    Die Datei lädst du in dein WordPress-Verzeichnis und rufst sie dann im Browser auf. Du solltest dann ablesen können, welche PHP-Version aktuell verwendet wird. Danach solltest du die Datei auf dem Server wieder löschen.

    Vielleicht kann dir dein Webhoster aber auch ein Backup deiner funktionierenden WordPress-Installation wiederherstellen? Dazu müsstest du dessen Support mal auf Backups ansprechen (falls es nicht bereits eine entsprechende Möglichkeit im Kundenmenü gibt).

    @pixolin
    Habe jetzt deine Hinweise befolgt und die phpinfo erstellt und hochgeladen. Es handelt sich um die Version PHP Version 5.3.26

    bei Eingabe meiner URL:www.meine-domain.de/wordpress/wp-admin => erscheint wieder eine leere Seite mit http://www.meine-domain.de/wordpress/wp-admin/setup-config.php

    Guck mal im Kundenmenü deines Webhoster, ob du da an das Log-File von PHP kommst.

    Ich bin jetzt mit meinen Nerven am Ende….im Kundenbereich habe gesehen, dass ich 3 Datenken zur Verfügung habe und habe dann einfach eine neue Datenbank angelegt, dann die wp-config.php manuell mit den neuen Angaben gespeichert und in das wordpress-verzeichnis hochgeladen und bekomme trotzdem eine leere Seite …wordpress/wp-admin/install.php …

    es ist echt zum Verzweifeln….

    Wenn du alles neu auf den Server kopiert hast, dann lösche die wp-config.php, die wird bei der Installation neu angelegt.

    Danke für den Hinweis, aber leider passiert gar nichts, nachdem ich zum x-ten Mal versucht habe wordpress neu wieder hochzuladen. Die Installation funktioniert ja gar nicht. Entweder mache ich irgendwo einen Fehler oder ich habe da im ftp-Bereich irgendwas zerstört.

    Ich bin jeweils so vorgegangen:
    => wordpress-dateien auf dem ftp-server gelöscht
    => neue wordpressdatei downgeloadet, entpackt lokal
    => unter html auf dem ftp-server ein Unterverzeichnis mit dem Titel: wordpress erstellt
    => mit FileZilla alle entpackten Dateien in das angelegte Unterverzeichnis hochgeladen
    => die Anbindung an eine Datenbank ist vorhanden
    => meine URL im Browser angegeben mit dem Zusatz /wordpress/wp-admin/
    und da bekomme ich die leere Seite mit /setup-config.php
    Die Installation läuft nicht, wie ich das von früher kenne mit all den Abfragen.
    wp-config.php wird nicht erstellt => von daher habe ich diese versucht manuell zu erstellen, aber auch da kommt nur eine weiße Seite 🙁

    Ich kann immer wieder nur wiederholen: PHP-Logfile

    PHP-Logfile <- gute Idee.

    Außerdem:

    Wo liegt der Ordner HTML? Handelt es sich dabei um das Stammverzeichnis?

    Falls „HTML“ nicht das Stammverzeichnis ist, müsstest du „HTML“ als Unterordner des Verzeichnisses anlegen, auf das deine funktionierende Domain verweist.

    Wie sind die Verzeichnisrechte des Ordners, in den du WordPress hochgeladen hast? Ich nehme an, dieser Ordner heißt bei dir wordpress?

    Hast du wirklich alles gelöscht? Ist Filezilla so eingerichtet, dass es auch versteckte Dateien anzeigt?

    Hast du im Ordner, auf den deine Domain verweist, eine .htaccess-Datei liegen?
    Hast du im Ordner, in der das entpackte WordPress liegt, eine .htaccess-Datei liegen?

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 60)
  • Das Thema „Problem bei Neuinstallation nach Löschen“ ist für neue Antworten geschlossen.