Support » Installation » Problem bei Neuinstallation nach Löschen

  • Gelöst lisavetka

    (@lisavetka)


    Hallo,
    ich bin neu hier, bin eine relative Anfängerin und habe ein Problem mit der Neuistallation von wordpress auf dem ftp-server.
    Nach hochladen der entpackten wordpressdaten über filezilla und aufrufen der entsprechenden Seite erscheint eine weiße Seite. Ich kann die Admindaten nicht eingeben und mich nicht anmelden.
    Hintergrund: ich habe eine html-seite, die läuft und vor ca. zwei Jahren habe ich testweise auf dem ftp-server unter html ein unterverzeichnis wordpress angelegt und alles mögliche mit verschiedenen Themes ausprobiert. Jetzt habe ich einfach mit dem Hintergedanken Alles zu bereinigen, das gesamte Verzeichnis wordpress gelöscht auch die Einträge in der phpDatenbank.
    Ich wollte einfach tabula rasa machen, um mich dann ernsthaft mit der neuen WordPressversion zu starten.
    Ich bin echt am verzweifeln. Kann mir jemand einen Tipp geben, wie ich an die Admin-Maske komme um wordpress ins Laufen zu bringen?
    Vielen Dank.

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 15 Antworten - 46 bis 60 (von insgesamt 60)
  • Moderator Angelika Reisiger

    (@la-geek)

    Okay, ich konnte gerade eine Fehlermeldung unter deine-domain.de/wordpress sehen:

    Warning: require_once() [function.require-once]: Unable to access /srv/www/htdocs/web160/html/wordpress/wp-includes/load.php in /srv/www/htdocs/web160/html/wordpress/wp-load.php on line 49
    
    Warning: require_once(/srv/www/htdocs/web160/html/wordpress/wp-includes/load.php) [function.require-once]: failed to open stream: No such file or directory in /srv/www/htdocs/web160/html/wordpress/wp-load.php on line 49
    
    Fatal error: require_once() [function.require]: Failed opening required '/srv/www/htdocs/web160/html/wordpress/wp-includes/load.php' (include_path='.:/usr/share/php') in /srv/www/htdocs/web160/html/wordpress/wp-load.php on line 49

    Hast du eine wp-config.php erstellt, falls ja, wie sind deren Dateirechte?

    Erstens das mit der wp-config.php und dann auch noch hier eine mögliche Lösung:
    https://discussion.dreamhost.com/t/what-kind-of-fatal-error-is-this/63585/2

    lisavetka

    (@lisavetka)

    nachdem ich wordpress in das Verzeichnis content geschoben habe und dann wieder zurück – habe ich eine Fehlermeldung gehabt und habe wordpress wieder runter und jetzt wieder rauf.
    bei Eingabe meiner domain.de/wordpress => erscheint wieder leeres Blatt http://meine-domain.de/wordpress/wp-admin/setup-config.php

    ich habe jetzt aktuell keine wp-config.php erstellt und es ist auch keine da

    • Diese Antwort wurde geändert vor 10 Monate von lisavetka.
    lisavetka

    (@lisavetka)

    Mir reicht es jetzt für heute. Falls du @la-geek noch irgendwelche Ideen hast, werde ich diese dann erst morgen umsetzen können. ich habe gestern die halbe Nacht und heute den ganzen Tag damit zugebracht zu recherchieren und Möglichkeiten auszuprobieren, jetzt bin ich erschlagen.
    Vielen Dank Euch für die Tipps und für die Unterstützung.
    🙂

    Moderator Angelika Reisiger

    (@la-geek)

    Und was kommt, wenn du die index.php aus dem HTML-Verzeichnis entfernt hast, für eine Meldung, wenn du deine-domain.de/wordpress aufrufst?

    lisavetka

    (@lisavetka)

    ich habe ja unter html eine index.php und in wordpress auch
    wenn ich die aus dem html-Verzeichnis llösche, dann habe ich eine leere Seite ohne irgendwelche Installationsanweisungen von wordpress.
    wenn ich die index php unter wordpress lösche kommt die Meldung:

    „Zugriff verweigert! Der Zugriff auf das angeforderte Verzeichnis ist nicht möglich. Entweder ist kein Index-Dokument vorhanden oder das Verzeichnis ist zugriffsgeschützt.
    Sofern Sie dies für eine Fehlfunktion des Servers halten, informieren Sie bitte den Webmaster hierüber.
    Error 403
    Sat Apr 27 23:43:33 2019
    Apache „

    Moderator Angelika Reisiger

    (@la-geek)

    Also, wenn du die index.php im HTML-Verzeichnis löschst und dann deine-domain.de/wordpress aufrufst kommt eine leere Seite?

    Und noch einen letzten Versuch. Klick in Filezilla mit der rechten Maustaste auf den Ordner „wordpress“, dann klick auf „Dateiberechtigungen“, im Pop-up-Fenster setze die Einstellungen so wie auf dem Screenshot und klicke auf den Button OK.

    Das wiederholst du dann noch einmal mit diesen Einstellungen im Pop-up-Fenster:

    PS: Die index.php aus dem WordPress-Verzeichnis solltest du nicht löschen (das musst du wieder rückgängig machen), ich schrieb ja „aus dem HTML-Verzeichnis“.

    Daher nochmal die Frage: die index.php im HTML-Verzeichnis ist gelöscht, die index.php im WordPress-Verzeichnis ist vorhanden, was kommt für eine Meldung, wenn du deine-domain.de/wordpress aufrufst?

    lisavetka

    (@lisavetka)

    Angelika, ich habe die index.php wieder zurück, das war klar. Ich habe jetzt die Attribute wie du geschrieben hast geänert und erhalten trotzdem eine weiße Seite http://meine-domain.de/wordpress/wp-admin/setup-config.php

    lisavetka

    (@lisavetka)

    die index.php in wordpress ist da, die index.php unter html gelöscht => ich gebe meine domain.de/wordpress ein und es kommt eine leere Seite und als URL: http://meine-domain.de/wordpress/wp-admin/setup-config.php

    Moderator Angelika Reisiger

    (@la-geek)

    lisavetka

    (@lisavetka)

    hallo Angelika,
    ich habe mir deinen letzten post gerade durchgelesen und daraufhi neine wp-config.php manuell erstellt und auf den server geladen. wp_debug habe ich auf true gestellt. Wo sehe ich denn die Fehlermeldungen?

    Moderator Bego Mario Garde

    (@pixolin)

    Wenn du in der wp-config.php

    define('WP_DEBUG', true);

    eingefügt hast, sollten Fehlermeldungen statt des weißen Bildschirms angezeigt werden.

    Hast du denn mal geschaut, ob dein Webhoster für die MySQL-Datenbank einen anderen Datenbank-Host angibt (statt localhost)?

    Die PHP-Version ist ebenfalls antiquiert. Hast du mal geschaut, ob du das im Kundenmenü auf eine zeitgemäßere Version (PHP >7) umstellen kannst?

    Moderator Bego Mario Garde

    (@pixolin)

    Eine Anleitung zum Ändern der PHP-Version bei 1Blu findest du hier:
    https://faq.1blu.de/content/480/981/de/wie-kann-ich-meine-php-version-aendern-.html

    Hier gibt es außerdem Informationen, wie du PHP-Einstellungen wie das Memory_limit anpassen kannst:
    https://faq.1blu.de/content/480/960/de/wie-kann-ich-meine-php_einstellungen-ueber-die-datei-%22userini%22-aendern.html

    z.B.

    upload_max_filesize = 150M
    max_execution_time = 300
    memory_limit = 256M

    Error Logs kannst du bei 1Blu selbst akitivieren:
    https://faq.1blu.de/content/480/970/de/wie-kann-ich-error-logs-in-php-aktivieren.html

    lisavetka

    (@lisavetka)

    @pixolin
    Hurraaa! Wow, nach etlichen Stunden funktioniert ees! Ich bin dir sehr dankbar!
    Das lag tatsächlich an dem Memory-Limit, ich habe die .user.ini mmit deinen Angaben erstellt und auf den FTP-server hochgeladen und siehe da, wordpress läuft!
    Vielen vielen Dank!
    nur noch eine Frage: die Datei .user.ini lasse ich jetzt dort oder?
    …und wp_debug stelle ich wieder auf false?

    Danke danke danke!

    Moderator Bego Mario Garde

    (@pixolin)

    Richtig, die .user.ini musst du bestehen lassen und den Wert für WP_DEBUG solltest du wieder auf false setzen. Schön, dass es jetzt wieder klappt.

    lisavetka

    (@lisavetka)

    Vielen Dank nochmal!

Ansicht von 15 Antworten - 46 bis 60 (von insgesamt 60)
  • Das Thema „Problem bei Neuinstallation nach Löschen“ ist für neue Antworten geschlossen.