Support » Installation » Problem Bilde Upload

  • Gelöst WoodBro

    (@supchiemsee)


    Hallo,

    Ich habe seit heute ein Problem mit den hochladen von Bildern in die Mediatek. Wenn ich eins hoch lade, kommt nur ein Platzhalter Blau mit „?“. Keine ahnung warum das nicht geht. Berrechtigungen sind auf 755 bzw 640 gestellt. Es kommt der fehler in der konsole: fail to Load resource: the server responded with a Status of 404.
    Was kann ich tun? Vielen Dank

    • Dieses Thema wurde geändert vor 2 Jahren, 3 Monaten von WoodBro.

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 12 Antworten - 16 bis 27 (von insgesamt 27)
  • Hallo,

    Kann ich hier auch screenshots teilen?

    ja, siehe in unserer FAQ: Kann ich hier auch screenshots teilen?.

    Versuche doch mal, ob du vielleicht Erfolg hast, wenn du unter Dashboard > Aktualisierungen auf den Button „Version 5.9 erneut installieren“ klickst.

    Sonst wie gesagt: Alles sichern (z. B. mit UpdraftPlus), dann lokale Entwicklungsumgebung erstellen (s. o.), Sicherung (am besten erst mal lokal) wiederherstellen. Eine Alternative wäre auch das Plugin Duplicator. Einen schönen Beitrag dazu findest du hier. Dann in Ruhe alles testen.

    Hilfreich könnte auch die Aktivierung des Debug-Modus sein. Damit Fehler ausgelesen werden können, müssen die Fehler in eine Log-Datei auf dem Server geschrieben werden, auf die man dann per FTP (oder auch SSH) zugreifen kann.
    Sichere bitte zunächst die wp-config.php auf deinem lokalen Rechner.
    Gib dann bitte mit einem geeigneten Programmier-Editor (z. B. Notepad++) in der wp-config.php oberhalb von /* That’s all, stop editing! Happy blogging. */ folgendes ein:

    define( 'WP_DEBUG', true );
    define( 'WP_DEBUG_DISPLAY', false);
    define( 'WP_DEBUG_LOG', true );

    Achte darauf, dass du define('WP_DEBUG', false); überschreibst, falls die Zeile bereits in der wp-config.php steht. Wenn versucht wird, diese Konstante ein zweites mal zu definieren, gibt es einen Fehler, was deine Seite lahmlegen würde.
    Mit diesen drei Codezeilen sagen wir WordPress, dass der Debug-Modus aktiviert werden soll. Die Fehlermeldungen sollen aber nicht direkt angezeigt werden, sondern in die Datei /wp-content/debug.log geschrieben werden.
    Wenn der Fehler gefunden wurde bzw. wenn die Fehler nicht mehr in die debug.log geschrieben werden sollen, dann musst du daran denken, die Variable
    define( 'WP_DEBUG_LOG', true );
    wieder auf false zu setzen:
    define( 'WP_DEBUG_LOG', false);
    Einen entsprechenden Beitrag, wie man das auch mit Verwendung eines Plugins macht, findest du hier.

    Viele Grüße
    Hans-Gerd

    Thread-Starter WoodBro

    (@supchiemsee)

    Hi Michi,

    danke für den Tipp.

    Das steht im File:

    04.02.2022 15:08:34 pronaturdesign.com [client 146.241.93.0] PHP Warning: filesize(): stat failed for /mnt/web211/d1/51/53421551/htdocs/STRATO-apps/wordpress_02/app/wp-content/uploads/2022/01/pronaturdesign-kunden-ohyes.png in /mnt/web211/d1/51/53421551/htdocs/STRATO-apps/pronaturdesign/app/wp-content/plugins/wordpress-seo/src/builders/indexable-link-builder.php on line 312

    Ich hab keinen Ahnung was das bedeutet, vielleicht kannst du etwas erkennen… Danke

    Thread-Starter WoodBro

    (@supchiemsee)

    Hallo,

    danke für die Tipps.

    Das ist was die Konsole Sagt:

    Failed to load resource: the server responded with a status of 404 ()

    Das ist was das LogFile sagt:

    04.02.2022 15:08:34 pronaturdesign.com [client 146.241.93.0] PHP Warning: filesize(): stat failed for /mnt/web211/d1/51/53421551/htdocs/STRATO-apps/wordpress_02/app/wp-content/uploads/2022/01/pronaturdesign-kunden-ohyes.png in /mnt/web211/d1/51/53421551/htdocs/STRATO-apps/pronaturdesign/app/wp-content/plugins/wordpress-seo/src/builders/indexable-link-builder.php on line 312

    Was bedeutet das jetzt genau? Danke

    Moderator Michi91

    (@michi91)

    Hmm, das sieht schon etwas komisch aus..
    Ein Script unter htdocs/STRATO-apps/pronaturdesign/app/ versucht auf eine Datei unter htdocs/STRATO-apps/wordpress_02 zuzugreifen..

    Hast du irgendwas in den strato app Einstellungen geändert?
    Hab gerade nochmal in deinen health Bericht geschaut und auch dort sind seltsamerweise Getrennte Pfade für WordPress und file upload angegeben…

    Kannst du per FTP schauen welche unterordner es in htdocs/STRATO-apps/ gibt

    pronaturdesign-kunden-ohyes.png – – >
    War dass die Datei die du hochladen wolltest?

    Du könntest mal testweise das WordPress seo plugin deaktivieren, glaube allerdings nicht dass es daran liegt

    enthält die wp-config.php einen benutzerdefinierten Upload-Pfad wie z. B. define('UPLOADS', '/some/custom/path'); ?

    Thread-Starter WoodBro

    (@supchiemsee)

    Also /STRATO-apps/wordpress_02 ist der alte Pfad gewesen weil da auch ein weitere 01 war und hab mir die umbeschriftet damit ich sie wie die Seiten benenne.

    Das bild ist pronaturdesign-nachhaltig-monika01

    Plugin hatte ich schon aus war auch kein unterschied.

    in der config.php steht davon nix

    <?php
    /**
     * The base configuration for WordPress
     *
     * The wp-config.php creation script uses this file during the installation.
     * You don't have to use the web site, you can copy this file to "wp-config.php"
     * and fill in the values.
     *
     * This file contains the following configurations:
     *
     * * MySQL settings
     * * Secret keys
     * * Database table prefix
     * * ABSPATH
     *
     * @link https://wordpress.org/support/article/editing-wp-config-php/
     *
     * @package WordPress
     */
    
    // ** MySQL settings - You can get this info from your web host ** //
    /** The name of the database for WordPress */
    define( 'DB_NAME', '' );
    
    /** MySQL database username */
    define( 'DB_USER', '3' );
    
    /** MySQL database password */
    define( 'DB_PASSWORD', '' );
    
    /** MySQL hostname */
    define( 'DB_HOST', 'rdbms.strato.de' );
    
    /** Database charset to use in creating database tables. */
    define( 'DB_CHARSET', 'utf8' );
    
    /** The database collate type. Don't change this if in doubt. */
    define( 'DB_COLLATE', '' );
    
    /**#@+
     * Authentication unique keys and salts.
     *
     * Change these to different unique phrases! You can generate these using
     * the {@link https://api.wordpress.org/secret-key/1.1/salt/ WordPress.org secret-key service}.
     *
     * You can change these at any point in time to invalidate all existing cookies.
     * This will force all users to have to log in again.
     *
     * @since 2.6.0
     */
    define('AUTH_KEY',         'KSVymgMXPjt1BxzoyNoNFfuhDt80HNnAiZWU1L9DifRUixHW5Z1nbMe7aMQ5Cczk');
    define('SECURE_AUTH_KEY',  '6aC5MZ58amH8rBQsA0H3Y29uixmEaklQfikKBq5YFBzfQJueud8dhyjJdqtbjaMH');
    define('LOGGED_IN_KEY',    'OsOzO8pMCSJVUWdgvVk7H5Qlu4ULajnuAzATwtEi9240xcC5Cgs6qO7NiasorEI6');
    define('NONCE_KEY',        '6cTgoOV4UqQKedoGGJCSRTgl52BgfygslTRa5SEcHFH7efYZuNfmz7T1OyfwpP7X');
    define('AUTH_SALT',        'yKkvLHDTt1R8nl3SzJvv7XBnCPtkntFU1Rk2YYd1oxOcgScLWheWPrw5vtmdaNzI');
    define('SECURE_AUTH_SALT', 'tjOaUPq7aG5XfM8TvdACb609s62qcqIzs7QgtoQLQJ9gJ4RZFO7AgfayeHfTyFNV');
    define('LOGGED_IN_SALT',   'TDmGerIxjyWVyPLDncEXQ7fMaEFVkj00GOCXRi1JHI9ui7xao7dRC77qf2uu2aeu');
    define('NONCE_SALT',       'Q6LzdyQiqtCvccVLWfNyjQPeJ2SZ8bW46xqwwPre45MKZrGp2ZXbkCmc4a414JDF');
    
    /**
     * Other customizations.
     */
    define('FS_METHOD','direct');
    define('FS_CHMOD_DIR',0755);
    define('FS_CHMOD_FILE',0644);
    define('WP_TEMP_DIR',dirname(__FILE__).'/wp-content/uploads');
    
    /**#@-*/
    
    /**
     * WordPress database table prefix.
     *
     * You can have multiple installations in one database if you give each
     * a unique prefix. Only numbers, letters, and underscores please!
     */
    $table_prefix = 'cwig_';
    
    /**
     * For developers: WordPress debugging mode.
     *
     * Change this to true to enable the display of notices during development.
     * It is strongly recommended that plugin and theme developers use WP_DEBUG
     * in their development environments.
     *
     * For information on other constants that can be used for debugging,
     * visit the documentation.
     *
     * @link https://wordpress.org/support/article/debugging-in-wordpress/
     */
    define( 'WP_DEBUG', true );
    define( 'WP_DEBUG_DISPLAY', false);
    define( 'WP_DEBUG_LOG', true );
    /* Add any custom values between this line and the "stop editing" line. */
    
    /* That's all, stop editing! Happy publishing. */
    
    /** Absolute path to the WordPress directory. */
    if ( ! defined( 'ABSPATH' ) ) {
    	define( 'ABSPATH', __DIR__ . '/' );
    }
    
    /** Sets up WordPress vars and included files. */
    require_once ABSPATH . 'wp-settings.php';
    
    define( "WP_AUTO_UPDATE_CORE", true );

    Debug hab ich eingetragen nur das log.file dazu wird nicht erstellt.

    Moderatorenhinweis: Bitte keine Zugangsdaten veröffentlichen und die bereits veröffentlichten Zugangsdaten umgehend ändern.

    • Diese Antwort wurde geändert vor 2 Jahren, 3 Monaten von WoodBro.
    • Diese Antwort wurde geändert vor 2 Jahren, 3 Monaten von Hans-Gerd Gerhards.
    Thread-Starter WoodBro

    (@supchiemsee)

    das ist der log von Strato. Also ich vorhin versucht hab das bild hoch zu laden…

    pronaturdesign.com anon-146-241-221-41.eolo.it - - [04/Feb/2022:20:12:55 +0100] "GET /wp-content/uploads/2022/02/pronaturdesign-nachhaltig-monika01.png HTTP/1.1" 404 67886 "https://pronaturdesign.com/wp-admin/upload.php?item=2851" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_7) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/15.3 Safari/605.1.15"
    pronaturdesign.com anon-146-241-221-41.eolo.it - - [04/Feb/2022:20:13:28 +0100] "POST /wp-admin/admin-ajax.php HTTP/1.1" 200 73 "https://pronaturdesign.com/wp-admin/upload.php?item=2851" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_7) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/15.3 Safari/605.1.15"
    pronaturdesign.com anon-146-241-221-41.eolo.it - - [04/Feb/2022:20:14:39 +0100] "GET /kontakt/ HTTP/1.1" 200 17432 "https://pronaturdesign.com/" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_7) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/15.3 Safari/605.1.15"
    pronaturdesign.com anon-146-241-221-41.eolo.it - - [04/Feb/2022:20:14:40 +0100] "GET /wp-content/uploads/2022/02/www.pronaturdesign.com_.png HTTP/1.1" 404 67875 "https://pronaturdesign.com/kontakt/" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_7) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/15.3 Safari/605.1.15"
    pronaturdesign.com anon-146-241-221-41.eolo.it - - [04/Feb/2022:20:14:40 +0100] "GET /wp-content/uploads/2022/02/pronaturdesign-christin-hume-unsplash.png HTTP/1.1" 404 67889 "https://pronaturdesign.com/kontakt/" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_7) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/15.3 Safari/605.1.15"
    pronaturdesign.com anon-146-241-221-41.eolo.it - - [04/Feb/2022:20:14:43 +0100] "POST /wp-admin/admin-ajax.php HTTP/1.1" 200 73 "https://pronaturdesign.com/wp-admin/upload.php?item=2851" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_7) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/15.3 Safari/605.1.15"
    Moderator Michi91

    (@michi91)

    Okay,
    Also gefühlt darf der Upload-Pfad nicht auf das alte Verzeichnis verweisen.

    Da in der wp-config der Pfad nicht gesetzt ist, müssen wir nun schauen wo die Option sonst gesetzt sein könnte.

    Eventuell unter Einstellungen -> Media

    Schau doch mal und falls dort der falsche Pfad steht, auf den korrekten ändern.

    Thread-Starter WoodBro

    (@supchiemsee)

    Kan das ein Problem sein?

    Wenn ich per ftp die Bild Dateien anschaue und die Berechtigung prüfe steht in den Dateien 755…nicht 644. Vielleicht ist das ein Konflikt?

    define(‚FS_METHOD‘,’direct‘);
    define(‚FS_CHMOD_DIR‘,0755);
    define(‚FS_CHMOD_FILE‘,0644);
    define(‚WP_TEMP_DIR‘,dirname(__FILE__).’/wp-content/uploads‘);

    Thread-Starter WoodBro

    (@supchiemsee)

    Krass du bist gut… Ja das war das Problem. OMG was wir heute schon alles ausprobiert haben.

    Wow vielen Dank. Jetzt hab ich sauber was dazu gelernt.

    Ich wünsche euch allen einen wunderschönen Abend und vielen vielen lieben dank für euren Hammer Support

    Sehr geil….Ich Feier euch….

    Moderator Michi91

    (@michi91)

    Klaro gerne!
    Bitte thread als gelöst markieren 🙂 und das Passwort aus der zitierten WP Config entfernen 😉 (sehe das jetz nicht als Risiko, aber besser is ohne).

    Thread-Starter WoodBro

    (@supchiemsee)

    Danke mache ich

Ansicht von 12 Antworten - 16 bis 27 (von insgesamt 27)
  • Das Thema „Problem Bilde Upload“ ist für neue Antworten geschlossen.