Support » Allgemeine Fragen » Problem, Blog-Content zu migrieren

  • Gelöst cduerr

    (@cduerr)


    Hallo,

    mein alter Server ist in den ewigen Jagdgründen. Backup existiert, sogar eine lauffähige VM mit den Daten, sodass ich noch modifizieren könnte (DB+Files). Alter Stand: WP5.7.2, PHP5.6 und mysql 5.5.62. So habe ich alle Plugins deaktivieren können. Mit dem wordpress-backup-restore (Github) habe ich ein Backup von DB+Files erstellt und meiner Meinung nach korrekt auf dem neuen Server restoriert. Allerdings erhalte ich beim Aufruf meiner Webseite „There has been a critical error on this website. Please check your site admin email inbox for instructions.“. In der FAQ finde ich, dass ich die Plugins deaktivieren soll, auch das habe ich gemacht (und bin überrascht, dass da überhaupt noch ein Plugin aktiv war).

    Was kann ich machen, um das Problem mit dem „critical error“ zu fixen (die Plugins scheinen ja nicht der Grund zu sein)?

    • Dieses Thema wurde geändert vor 1 Monat, 1 Woche von cduerr.
    • Dieses Thema wurde geändert vor 1 Monat, 1 Woche von cduerr.
Ansicht von 8 Antworten - 1 bis 8 (von insgesamt 8)
  • Da könnten viele Probleme auftreten.

    PHP 5.6 wird auf dem neuen Server wohl eher nicht mehr laufen
    WP 5.7.2 und PHP 8 könnte ein weiteres Problem sein.
    MySQL 5.5 ist auch veraltet, die Migration auf eine neuere MySQL-Version könnte auch schief gelaufen sein.

    Stehen eventuell Hinweise in der Server-Logfiles?

    Thread-Starter cduerr

    (@cduerr)

    ich kann alles besorgen – was hättest Du gerne?

    Das finde ich für einen Aufruf von https://<Domain>/wp-admin:

    - - [14/Apr/2024:16:40:52 +0000] "GET /wp-admin/ HTTP/1.1" 500 6500 "-" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_7) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/17.4.1 Safari/605.1.15"

    Auf dem neuen Server läuft MariaDB 10.11.6 und PHP8.2.7. Läuft WP 5.7.2 nicht mehr mit diesen Komponenten?

    Migriert habe ich bewusst nichts, nur das Backup restoriert. Aber ich finde im Posteingang den Hinweis auf „Deine Website wurde auf WordPress 6.5.2 aktualisiert“.

    • Diese Antwort wurde geändert vor 1 Monat, 1 Woche von cduerr.
    • Diese Antwort wurde geändert vor 1 Monat, 1 Woche von cduerr.
    • Diese Antwort wurde geändert vor 1 Monat, 1 Woche von cduerr.
    • Diese Antwort wurde geändert vor 1 Monat, 1 Woche von cduerr.
    • Diese Antwort wurde geändert vor 1 Monat, 1 Woche von cduerr.

    Die Error-Logs von PHP wären interessant.

    Hilfreich könnte auch die Aktivierung des Debug-Modus sein. Damit Fehler ausgelesen werden können, müssen die Fehler in eine Log-Datei auf dem Server geschrieben werden, auf die man dann per FTP (oder auch SSH) zugreifen kann.
    Sichere bitte zunächst die wp-config.php auf deinem lokalen Rechner.
    Gib dann bitte mit einem geeigneten Programmier-Editor (z. B. Notepad++) in der wp-config.php oberhalb von

    /* That’s all, stop editing! Happy blogging. */

    folgendes ein:

    define( 'WP_DEBUG', true );
    define( 'WP_DEBUG_DISPLAY', false);
    define( 'WP_DEBUG_LOG', true );

    Achte darauf, dass du define(‚WP_DEBUG‘, false); überschreibst, falls die Zeile bereits in der wp-config.php steht.`

    WordPress 5.7.2 ist nicht mit PHP 8.2 kompatibel, siehe https://make.wordpress.org/core/handbook/references/php-compatibility-and-wordpress-versions/

    Ein manuelles Update könnte helfen: https://www.hosteurope.de/faq/webhosting/skripte/wp_upd_ftp

    • Diese Antwort wurde geändert vor 1 Monat, 1 Woche von bscu.
    • Diese Antwort wurde geändert vor 1 Monat, 1 Woche von bscu.
    Thread-Starter cduerr

    (@cduerr)

    ich danke Dir tausend Mal! In dem debug.log finde ich Fehler zu wp-super-cache (das war ein altes, aber deaktiviertes Plugin).

    Danach hattest Du noch geschrieben, die Dateien einer neuen WordPress-Version gem. Anleitung zu überschreiben. Das habe ich getan (und auch die alte wp-config.php übertragen in die wp-config-sample.php, die ich danach umbenannt habe).

    Die Fehlermeldung jetzt im debug.log:

    [14-Apr-2024 17:21:36 UTC] PHP Fatal error:  Uncaught mysqli_sql_exception: Access denied for user 'root'@'localhost' in /var/www/blog/wp-includes/wp-db.php:1653
    Stack trace:
    #0 /var/www/blog/wp-includes/wp-db.php(1653): mysqli_real_connect()
    #1 /var/www/blog/wp-includes/wp-db.php(632): wpdb->db_connect()
    #2 /var/www/blog/wp-includes/load.php(545): wpdb->__construct()
    #3 /var/www/blog/wp-settings.php(124): require_wp_db()
    #4 /var/www/blog/wp-config.php(91): require_once('...')
    #5 /var/www/blog/wp-load.php(37): require_once('...')
    #6 /var/www/blog/wp-admin/admin.php(34): require_once('...')
    #7 /var/www/blog/wp-admin/index.php(10): require_once('...')
    #8 {main}
      thrown in /var/www/blog/wp-includes/wp-db.php on line 1653
    

    Ist das Problem jetzt ein scheiterndes Login zur DB? Überrascht mich irgendwie, die Credentials sind korrekt.

    • Diese Antwort wurde geändert vor 1 Monat, 1 Woche von cduerr.
    • Diese Antwort wurde geändert vor 1 Monat, 1 Woche von cduerr.
    • Diese Antwort wurde geändert vor 1 Monat, 1 Woche von cduerr.
    • Diese Antwort wurde geändert vor 1 Monat, 1 Woche von cduerr.

    Meldest Du dich wirklich mit root als Nutzer am MySQL an? Prüfe nochmal genau was in der wp-config.php steht und was funktionieren sollte.

    Thread-Starter cduerr

    (@cduerr)

    ja, steht da. Und hat auch funktioniert. Wenn ich’s dann mal funktionierend bekäme, wäre ich auch gerne bereit, das zu ändern.

    Update: Stinkt mich etwas an. Ich habe einen weiteren User hinzugefügt, dem Zugriff auf alle Tabellen der WP-DB gegeben, das Passwort gesetzt und die wp-config.php entsprechend angepasst – und jetzt bin ich drin. Es gibt kaum etwas was mich mehr aufregt als undokumentierte Änderungen, die schlicht „root“ verbieten und das nicht einmal als Fehlermeldung bringen. Aber gut, vielen Dank, jetzt komme ich weiter.

    • Diese Antwort wurde geändert vor 1 Monat, 1 Woche von cduerr.

    Schön wenn du es lösen konntest. Sind damit auch alle anderen Fehlermeldungen weg? Gerne kannst Du das Topic noch auf gelöst setzen.

    Thread-Starter cduerr

    (@cduerr)

    danke für die Nachfrage… nein, es ist eine einzige große Baustelle. Aber dafür mache ich dann andere Fragen auf, denke ich. Character-Encoding von Umlauten (Zeichensatz war vorher und jetzt auch utf8… WTF), Perma-Link über Year/Month/Day/Name geht iwie nicht (.htaccess?), … irre.

Ansicht von 8 Antworten - 1 bis 8 (von insgesamt 8)