Support » Allgemeine Fragen » Problem mit html code einbinden

  • Gelöst efo12

    (@efo12)


    Guten Abend habe folgendes Problem ich möchte gerne mein live Chat Einbinden
    und habe alles versucht ging leider nicht habe WordPress Version 5.2
    mit Html Code es muss bei Body eingetragen sein
    diesen Code geht mit Standard Anwendung fürs web sonn

    hier den html Code:

    <!-- PASS THRU DATA OBJECT -->
    <script type="text/javascript">
    var lz_data = {overwrite:false,website:'https://allgaeuer-fotowelt.synology.me'};
    </script>
    <!-- PASS THRU DATA OBJECT -->
    
    <!-- livezilla.net PLACE SOMEWHERE IN BODY -->
    <script type="text/javascript" id="1e8a1c929ef6f8d211444c150a993b0a" src="//chat.allgaeuer-fotowelt.synology.me/chat/livezilla/script.php?id=1e8a1c929ef6f8d211444c150a993b0a" defer></script>
    <!-- livezilla.net PLACE SOMEWHERE IN BODY -->

    Moderatorenhinweis: Bitte Quellcode als ‘Code’ auszeichnen.

Ansicht von 14 Antworten - 1 bis 14 (von insgesamt 14)
  • Du findest solche Optionen bei manchen themes. Schau mal unter Design > Customizer.
    Mehr Infos können wir bei so wenigen Infos nicht geben, siehe FAQ und hier.

    Thread-Starter efo12

    (@efo12)

    Ich habe und der Widgets HTML ausgewählt und den Code platziert und habe footer 1 ausgewählt

    Könnten du vieleicht wenn du weitere infos
    Brauchst weitere Hinweise geben

    Thread-Starter efo12

    (@efo12)

    Meine Webseite heisst https://allgaeuer-fotowelt.synology.me/
    Mein Server ist von 6:30-22:50 aktiv

    Mit dem Plugin Code Snippets kannst du auch mal rasch eigenen Code einbauen:

    
    function allgaeuer_fotowelt_header() { ?>
    <!-- PASS THRU DATA OBJECT -->
    <script type="text/javascript">
    var lz_data = {overwrite:false,website:'https://allgaeuer-fotowelt.synology.me'};
    </script>
    <!-- PASS THRU DATA OBJECT -->
    <? }
    add_action( 'wp_head', 'allgaeuer_fotowelt_header' );
    
    function allgaeuer_fotowelt_footer() { ?>
    <!-- livezilla.net PLACE SOMEWHERE IN BODY -->
    <script type="text/javascript" id="1e8a1c929ef6f8d211444c150a993b0a" src="//chat.allgaeuer-fotowelt.synology.me/chat/livezilla/script.php?id=1e8a1c929ef6f8d211444c150a993b0a" defer></script>
    <!-- livezilla.net PLACE SOMEWHERE IN BODY -->
    <? }
    add_action( 'wp_footer', 'allgaeuer_fotowelt_footer' );
    
    Thread-Starter efo12

    (@efo12)

    Dieser Chat Zeigt es mir nur in der Mobilen Ansicht an
    ich habe das ausprobiert das gleich ergebniss

    • Diese Antwort wurde geändert vor 2 Jahre, 5 Monaten von efo12.

    Das Laden scheint aus irgendwelchen Gründen fehlzuschlagen – vielleicht stimmt der Code nicht?

    In deiner Webseite ist der Code aber.

    Der Versuch, das JavaScript per https zu laden schlägt fehl, weil es für die Subdomain kein Zertifikat gibt.

    Thread-Starter efo12

    (@efo12)

    ich versuche das Problem zu Lössen so bald ich herausgefunden habe melde ich mich

    Das Problem ist

    src="//chat.allgaeuer-fotowelt.synology.me/chat/livezilla/script.php?

    Da kein Schema (https) angegeben ist, wird das Schema der Website genommen. Für die Subdomain Domain chat.allgaeuer-fotowelt.synology.me existiert aber wohl kein SSL-Zertifikat. Deshalb wird das Script nicht geladen.

    Thread-Starter efo12

    (@efo12)

    ich versuche es morgen oder die nächsten tage
    Heute beantworte ich nicht mehr

    Hallo,
    je nach Theme einfach per ftp die footer-Datei suchen und dort in den body den Code implementieren, das funktioniert.

    Demnach die footer-Datei des Themes herunterladen, den body mit dem livezilla-Code ergänzen, speichern und dann hochladen.

    Das sollte funktionieren!

    Viel Erfolg.

    Thread-Starter efo12

    (@efo12)

    Danke für die Hilfe
    es dauert noch bis ich eine Rückmeldung geben kann
    versuche gerade ein kosten freies Zertifikat zu besorgen und installieren
    wenn ich weiter gekommen bin melde ich mich wieder

    Thread-Starter efo12

    (@efo12)

    Danke für die Hilfe
    es lag daran das das Zertifikat gefehlt hat
    ich habe eine neue Adresse und Zertifikat angelegt und funktioniert

    Schön, dass du eine Lösung gefunden hast.

    Da wäre ja auch nie jemand drauf gekommen.
    Oder vielleicht doch? 😉

Ansicht von 14 Antworten - 1 bis 14 (von insgesamt 14)
  • Das Thema „Problem mit html code einbinden“ ist für neue Antworten geschlossen.