Support » Allgemeine Fragen » Problem mit https

  • Hallo,

    ich habe auf einmal von jetzt auf gleich ein Problem mit dem Aufruf meiner Seite.
    per http://llcomputer.de wird Sie einigermaßen richtig angezeigt.
    Möchte ich aber wie davor per https://llcomputer.de darauf zugreifen ist die Seite total verschoben. Schaut aber am besten selbst.

    Auf mein Dashboard kann ich nicht zugreifen da er mich hier immer auf https umleitet.
    Habe auch schon den plugins und mu-plugins ordner umbenannt trotzdem der gleiche fehler.

    Wo kann ich noch den weiteren Fehler suchen oder am besten beheben?

    Hätte auch noch eine Sicherung mit UpdraftPlus von vor 7 Tagen und von vor ein paar Stunden. ob der Fehler jetzt vor der Letzten Sicherung war oder danach kann ich nicht sagen.

    Serverprovider ist Strato die Hauptdomain llcomputer.de liegt auf Server 1 und leitet danach weiter als Proxy auf Server 2 ll-computer.marketing-boehm.de.
    Auf beiden Domains ist SSL aktiv.

    Ich weiß nicht mehr weiter.

    Edit: Alte wp-config.php hochladen brachte auch keine Verbesserung.

    Gruß Markus

    • Dieses Thema wurde geändert vor 6 Monaten, 1 Woche von .

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 2 Antworten - 1 bis 2 (von insgesamt 2)
  • Hallo,
    warum das jetzt plötzlich aufgetreten ist, kann ich nicht sagen.
    In der developer console (F12) tauchen reichlich Fehler auf, die auf mixed content hinweisen.
    Mixed Content bedeutet, dass eine Website, die verschlüsselt über HTTPS aufgerufen wird, Inhalte teilweise unverschlüsselt über HTTP ausliefert.
    Das kannst du sehen, wenn du z. B. über Chrome in die developer console schaust (Shortcut für Developer Console: F12).
    Du kannst deine Seite aber auch mal auf der folgenden Webseite prüfen und siehst dann die Fehler.
    Diese Fehler lassen sich z. B. über das Plugin „Better Search and Replace“ korrigieren (ersetzen von http://example.com/ durch https://example.com/).
    Vorher aber bitte auf jeden Fall eine Sicherung der Datenbank erstellen.

    Wenn du allerdings nicht mehr auf das Dashboard zugreifen kannst, dann sind möglicherweise unter Einstellungen die siteurl und home nicht mehr korrekt eingetragen. Dann gibt es mehrere Möglichkeiten:

    • entweder gehst du im Kundenmenü deines Webhosters in die Datenbankverwaltung (üblicherweise phpMyAdmin) und überprüfst dort in der für WordPress genutzten Datenbank in der Tabelle wp_options für die Felder siteurl und home die URL
    • oder indem du per FTP in der Konfigurationsdatei wp-config.php mit einem geeigneten Code-Editor (z.B. VS Code oder Notepad++, beide kostenlos erhältlich) die Zeile define( 'RELOCATE', true ); oberhalb von /* That's all, stop editing! Happy blogging. */ einfügst. Danach solltest du dich über wp-login.php anmelden und unter Einstellungen > Allgemein die URL ändern können. Vorsichtshalber sollte danach noch die in der wp-config.phpeingefügte Zeile wieder entfernt oder die Konstante auf false gesetzt werden: define( 'RELOCATE', false );

    Viele Grüße
    Hans-Gerd

    Thread-Ersteller Markus Böhm

    (@markusboehm)

    So wie es bisher aussieht wird das SSL Zertifikat nicht mehr akzeptiert sobald eine Proxy-Weiterleitung erstellt wird. Habe jetzt die Seite direkt über https://marketing-boehm.de zum ansprechen abgelegt und Sie funktioniert wieder.

    Sieht so aus als müsste ich die Domains auf den Server 2 umziehen und ohne Umleitung realisieren.

    Per define( 'RELOCATE', true ); bin ich zumindest wieder ins dashboard gekommen nachdem ich in der DB unter wp_options Datenbank auch die direkte ZielURL angegeben habe.

    Scheint wirklich ein SSL Problem zu sein mit Weiterleitung an einen zweiten Server.

Ansicht von 2 Antworten - 1 bis 2 (von insgesamt 2)
  • Das Thema „Problem mit https“ ist für neue Antworten geschlossen.