Support » Plugins » Problem mit Plugin Widget Options

  • Gelöst bscu

    (@bscu)


    Hallo zusammen,

    ich hatte auf einer Internet-Seite bisher das Plugin „AH Widgets“ benutzt, allerdings wird das nicht mehr weiterentwickelt und macht mit WordPress 6.x Probleme. Auf Empfehlung habe ich dann das Plugin „Widget Options“ installiert und „AH-Widgets“ gelöscht.
    Danach habe ich allen Widgets die Seite, auf der es angezeigt werden soll, neu zugewiesen. Tja, leider klappt das nicht so ganz, denn ich bekomme alle Widgets auf jeder Seite angezeigt, und somit habe ich eine extremm lange Navigation auf der rechten Seite, die natürlich so völliger Quatsch ist.

    Hat jemand eine Idee, womit das zusammenhängen kann?

    Wie immer gewünscht, der Webseiten-Bericht:

    
    ### wp-core ###
    
    version: 6.4.2
    site_language: de_DE
    user_language: de_DE
    timezone: Europe/Berlin
    permalink: /%postname%/
    https_status: true
    multisite: false
    user_registration: 0
    blog_public: 1
    default_comment_status: closed
    environment_type: production
    user_count: 3
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /homepages/29/d848196104/htdocs/www2.xxxxxx.de
    wordpress_size: 319,53 MB (335046402 bytes)
    uploads_path: /homepages/29/d848196104/htdocs/www2.xxxxxx.de/wp-content/uploads
    uploads_size: 30,92 MB (32424252 bytes)
    themes_path: /homepages/29/d848196104/htdocs/www2.xxxxxx.de/wp-content/themes
    themes_size: 14,70 MB (15414151 bytes)
    plugins_path: /homepages/29/d848196104/htdocs/www2.xxxxxx.de/wp-content/plugins
    plugins_size: 66,61 MB (69848282 bytes)
    database_size: 247,72 MB (259751936 bytes)
    total_size: 679,48 MB (712485023 bytes)
    
    ### wp-active-theme ###
    
    name: xxxxxx GmbH (xxxxxx)
    version: 1.0
    author: xxxxxx GmbH
    author_website: https://www.xxxxxx.de
    parent_theme: Ample (ample)
    theme_features: core-block-patterns, widgets-block-editor, automatic-feed-links, title-tag, align-wide, post-thumbnails, woocommerce, wc-product-gallery-zoom, wc-product-gallery-lightbox, wc-product-gallery-slider, menus, html5, custom-background, custom-logo, customize-selective-refresh-widgets, custom-header, widgets, editor-style
    theme_path: /homepages/29/d848196104/htdocs/www2.xxxxxx.de/wp-content/themes/xxxxxx
    auto_update: Deaktiviert
    
    ### wp-parent-theme ###
    
    name: Ample (ample)
    version: 1.3.5
    author: ThemeGrill
    author_website: https://themegrill.com
    theme_path: /homepages/29/d848196104/htdocs/www2.xxxxxx.de/wp-content/themes/ample
    auto_update: Deaktiviert
    
    ### wp-themes-inactive (3) ###
    
    Twenty Twenty-Four: version: 1.0, author: Das WordPress-Team, Automatische Aktualisierungen deaktiviert
    Twenty Twenty-One: version: 2.0, author: Das WordPress-Team, Automatische Aktualisierungen deaktiviert
    Twenty Twenty-Three: version: 1.3, author: Das WordPress-Team, Automatische Aktualisierungen deaktiviert
    
    ### wp-mu-plugins (2) ###
    
    Health Check Troubleshooting Mode: author: (undefined), version: 1.7.2
    WP Migrate DB Compatibility: version: 1.2, author: Delicious Brains
    
    ### wp-plugins-active (15) ###
    
    Advanced Editor Tools: version: 5.9.2, author: Automattic, Automatische Aktualisierungen deaktiviert
    Advanced WP Columns: version: 2.0.6, author: Vladica Savic, Automatische Aktualisierungen deaktiviert
    Classic Editor: version: 1.6.3, author: WordPress Contributors, Automatische Aktualisierungen deaktiviert
    Contact Form 7: version: 5.8.5, author: Takayuki Miyoshi, Automatische Aktualisierungen deaktiviert
    FileBird Lite: version: 5.6.0, author: Ninja Team, Automatische Aktualisierungen deaktiviert
    Health Check & Troubleshooting: version: 1.7.0, author: The WordPress.org community, Automatische Aktualisierungen deaktiviert
    Max Mega Menu: version: 3.3, author: megamenu.com, Automatische Aktualisierungen deaktiviert
    Popup Builder: version: 4.2.6, author: Looking Forward Software Incorporated., Automatische Aktualisierungen deaktiviert
    Smart Slider 3: version: 3.5.1.21, author: Nextend, Automatische Aktualisierungen deaktiviert
    Widget Options: version: 3.9.6, author: Widget Options Team, Automatische Aktualisierungen deaktiviert
    WPGlobus: version: 2.12.2, author: WPGlobus, Automatische Aktualisierungen deaktiviert
    WP Migrate Lite: version: 2.6.9, author: WP Engine, Automatische Aktualisierungen deaktiviert
    WP Statistics: version: 14.3.4, author: VeronaLabs, Automatische Aktualisierungen deaktiviert
    XML Sitemap Generator for Google: version: 4.1.17, author: Auctollo, Automatische Aktualisierungen deaktiviert
    Yoast SEO: version: 21.8, author: Team Yoast, Automatische Aktualisierungen deaktiviert
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_GD
    imagick_module_version: Nicht verfügbar
    imagemagick_version: Nicht verfügbar
    imagick_version: Nicht verfügbar
    file_uploads: 1
    post_max_size: 64M
    upload_max_filesize: 64M
    max_effective_size: 64 MB
    max_file_uploads: 20
    gd_version: 2.2.5
    gd_formats: GIF, JPEG, PNG, WebP, BMP, XPM
    ghostscript_version: 9.27
    
    ### wp-server ###
    
    server_architecture: Linux 4.4.302-icpu-192 x86_64
    httpd_software: Apache
    php_version: 8.1.27 64bit
    php_sapi: cgi-fcgi
    max_input_variables: 5000
    time_limit: 50000
    memory_limit: -1
    max_input_time: -1
    upload_max_filesize: 64M
    php_post_max_size: 64M
    curl_version: 7.64.0 OpenSSL/1.1.1n
    suhosin: false
    imagick_availability: false
    pretty_permalinks: true
    htaccess_extra_rules: true
    current: 2024-01-10T09:54:42+00:00
    utc-time: Wednesday, 10-Jan-24 09:54:42 UTC
    server-time: 2024-01-10T10:54:39+01:00
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 5.7.42-log
    client_version: mysqlnd 8.1.27
    max_allowed_packet: 67108864
    max_connections: 3000
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /homepages/29/d848196104/htdocs/www2.xxxxxx.de/wp-content
    WP_PLUGIN_DIR: /homepages/29/d848196104/htdocs/www2.xxxxxx.de/wp-content/plugins
    WP_MEMORY_LIMIT: 40M
    WP_MAX_MEMORY_LIMIT: -1
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_ENVIRONMENT_TYPE: Nicht definiert
    WP_DEVELOPMENT_MODE: undefined
    DB_CHARSET: utf8mb4
    DB_COLLATE: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    mu-plugins: writable
    
    

    Danke und Gruß
    bscu

    PS: Einen Link zur Seite kann ich nicht schreiben, denn die Seite liegt aktuell in einem geschützen Bereich, man kommt also nicht auf die Seite

    • Dieses Thema wurde geändert vor 1 Monat, 3 Wochen von bscu.
Ansicht von 4 Antworten - 1 bis 4 (von insgesamt 4)
  • Hallo,
    ich habe das gerade bei dem Theme GeneratePress getestet. Da funktioniert das einwandfrei:

    Hier ein Screenshot dazu (bei Klick auf das Bild, wird das Bild vergrößert):

    Screenshot Einstellungen

    Der Block „Neueste Beiträge“ wird in dem Fall auf der Startseite nicht und sonst auf allen anderen Seiten und Beiträgen gezeigt.

    Ob das mit dem aktivierten Classic Editor und ggfs. mit den klassischen Widgets zusammenhängt, kann ich leider nicht sagen, weil ich den Classic Editor nicht mehr verwende.

    Sonst musst Du Dich evtl. an die Entwickler des Plugins wenden.

    Viele Grüße
    Hans-Gerd

    Thread-Starter bscu

    (@bscu)

    @hage
    Danke für die Antwort. Ich befürchte, dass das etwas mit dem zuvor installiertem Plugin „AH Widgets“ zu tun hat. Wenn man mit dem alten Plugin die Einstellungen kontrolliert hatte, waren alle Navigationsmenüs nicht mehr einer Seite zugeordnet, obwohl beim Aufruf der Seiten selbst noch alles in Ordnung ist. Ich bin gerade dabei, in „AH Widgets“ alle Zuweisungen zu setzen, und dann noch einmal „Widget Options“ installieren. Da ich ja vorher ein Backup erstellt habe, komme ich ja immer wieder auf die alte Version zurück.

    Thread-Starter bscu

    (@bscu)

    Hallo,

    ich habe selber noch etwas getestet und eine Lösung gefunden. Ich habe alle Widgets einmal entfernt und danach wieder neu angelegt. Danach funktioniert es scheinbar wie gewollt. Bei 69 Widgets ist das kein Vergnügen, aber wohl nicht zu ändern.

    Danke und Gruß
    bscu

    Hallo @bscu
    na, dann ist ja wieder alles super 😊
    Danke für die Rückmeldung und „Gelöst“-Markieren.

    Viele Grüße
    Hans-Gerd

Ansicht von 4 Antworten - 1 bis 4 (von insgesamt 4)