Support » Allgemeine Fragen » Problem mit Seitendarstellung / Glossar

  • Gelöst Wieselweb

    (@wieselweb)


    Hallo zusammen,

    heute ist mir aufgefallen, dass meine Seiten in meinem Lexikon (erstellt mit dem Plugin My Glossar) nicht mehr im Frontend aufgerufen werden können. Wenn ich auf einen Begriff in der folgenden Übersicht klicke https://www.laufschuhkauf.de/laufschuh-lexikon/#A kommt immer eine leere Seite mit (kein Titel).

    Im Backend sehe ich den Text und ggf. auch die Bilder. Sobald ich hier aber in die Seitenvorschau gehen will lande ich wieder bei der leeren Seite. Das letzte Update des Plugins liegt 5 Monate zurück. Danach hat es auf jeden Fall noch funktioniert.

    Wie kann ich das lösen? Das Plugin ist leider kaum supported :-/ aber so einfach und dadurch gut.

    Vielen Dank für eure Hilfe.

    Viele Grüße Wiesel

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 5 Antworten - 1 bis 5 (von insgesamt 5)
  • Hallo,
    schwer zu sagen, wie das Problem zustande kommt. Es könnte evtl. auch sein, dass das Problem durch einen Konflikt zwischen Plugins verursacht wird.
    Du kannst ja mal nach einer Sicherung das plugin Health Check & Troubleshooting installieren. Wenn du auf den Button „Problembehandlungsmodus aktivieren“ unter Problembehandlung klickst, werden alle plugins deaktiviert und als Standardtheme (wenn vorhanden) twenty twenty oder Twenty Twenty-One aktiviert. Dann kannst du sehen, ob die beschriebenen Probleme noch weiterhin auftauchen. Aktiviere dann Plugin für Plugin im Problembehandlungsmodus und schaue jeweils nach Aktivierung eines Plugins, ob das Problem noch besteht. Auf diese Weise kannst du möglicherweise ein Plugin finden, dass das Problem verursacht. Vorteil dabei ist, dass der Leser deines Blogs die Seite weiter mit allen Infos und plugins sieht, während nur für dich alle plugins deaktiviert sind.
    Lies dir dazu bitte auch mal die Informationen in dem Beitrag zu Health Check durch.
    Viele Grüße
    Hans-Gerd

    Thread-Ersteller Wieselweb

    (@wieselweb)

    Hallo Hans-Gerd,

    habe das mal durchgespielt. Das Plugin NextGEN Gallery wurde vor 3 Tagen geupdatet und es verursacht das Problem. Sobald es inaktiv ist läuft das Lexikon wieder. Also liegt es gar nicht an Simple Glossary.

    Des weiteren kommt über den Browser folgende Fehlermeldung:

    Warning: array_key_exists(): The first argument should be either a string or an integer in …./wp-content/themes/graphene/inc/loop.php on line 841

    Damit kann ich nur gar nichts anfangen und die Frage ist ob es überhaupt was damit zu tun hat?

    Aber durch deinen Tipp weiß ich zumindest mal woran es hängt und bin ich mal auf die Plugin Supportseite von Next Gen Gallery. Da scheints einige Probleme nach dem letzten Update zu geben.

    Mit laufenden Grüßen Wiesel

    • Diese Antwort wurde geändert vor 1 Jahr, 2 Monaten von Wieselweb.

    Hallo,
    ich vermute mal, dass die Warnung nichts mit dem genannten Problem zu tun hat, weil die Warnung definitiv mit deinem Theme zusammenhängt. Eine Warnung ist zwar erst mal nicht ein großes Problem, trotzdem würde ich die Meldung an den Entwickler des Themes weitergeben.
    Bezogen auf das Problem mit Netxgen Gallery musst du wohl oder übel die weitere Entwicklung abwarten.
    Viele Grüße
    Hans-Gerd

    Thread-Ersteller Wieselweb

    (@wieselweb)

    Hallo Hans-Gerd,

    das habe ich auch direkt mal gemacht.

    Das Lexikon läuft wieder. Rollback auf die vorherige Version oder auch die gestern veröffentlichte Beta Version löst das Problem.

    Danke dir und schönes Wochenende.

    Mit laufenden Grüßen Wiesel

    Hallo,
    freut mich – danke für die Rückmeldung.
    Viele Grüße und ein schönes Wochenende
    Hans-Gerd

Ansicht von 5 Antworten - 1 bis 5 (von insgesamt 5)
  • Das Thema „Problem mit Seitendarstellung / Glossar“ ist für neue Antworten geschlossen.