Support » Allgemeine Fragen » Probleme bei Galerie pro Beitrag (ohne extra Plugins)

  • Website: http://www.vom-feuertanz.de
    WP: 3.5.2
    Plugins: keine extra Galerie-Plugins

    —————–

    Hallo,

    die neue Medienfunktion und das damit verbundene einfuegen von Galerien finde ich klasse. Nur leider stosse ich dabei auf ein kleines Problem.

    Auf der o.g. Seite habe ich in jedem Beitrag eine neue Galerie erstellt. (Dateien hinzufuegen > Galerie erstellen …). Der Shortcode fuer die einzelenen Galerien sieht wie folgt aus „[gallery link="file" ids="xxx,xxx,xxx"]“ Die Anzeige der Galerien erscheint auf den ersten Blick richtig.

    Waehlt man nun eine Galerie aus, dann oeffnet sich das entsprechende Bild. Aber in der LightBox werden immer alle Bilder aus allen Beitraegen angezeigt.

    Wie erstellt man pro Beitrag eine Galerie die nicht alle Bilder aus allen anderen Beitraegen beinhaltet. Am besten ohne extra Plugin

    Da ich diese Handhabung der Galerieerstellung sehr angenehm finde, wuerde ich mich freuen wenn es zu meinem Problem eine Loesung gibt … ohne extra Plugin.

    Danke!

Ansicht von 7 Antworten - 16 bis 22 (von insgesamt 22)
  • Hallo,

    jetzt hab ich auch die Lightbox – hing wohl irgendwie im Cache.
    Und man muss der Galerie ein link=“File“ mitgeben.

    Auf der Übersichtsseite hab ich 2 Posts und in jedem ist eine Galerie.

    Die Bilder des ersten Post haben
    rel=“prettyPhoto[gallery 10 ]„

    und die des zweiten haben
    rel=“prettyPhoto[gallery 5 ]„

    jeweils in ihren A Tags und damit ist alles Prima.
    Hab nur in der Funktions.php wie von mir oben geschrieben ergänzt.

    Gruß
    Frank

    Thread-Ersteller iata

    (@iata)

    Hallo Frank,

    nun hat es bei mir auch funktioniert. Beim kopieren ist wohl etwas verloren gegangen.

    Vielen Dank fuer die schnelle und erfolgreiche Hilfe!

    Bitte sehr.

    Ach so, evt magst du das ja noch an die Themeentwickler weiterleiten. Das Problem dürfte ja jeder haben.

    Frank

    Thread-Ersteller iata

    (@iata)

    Entwickler ist informiert

    Super. Danke.

    Moderator espiat

    (@espiat)

    Mal so in die Runde gefragt:

    get_the_ID() in der functions.php ist eher nicht so optimal, weil das eine template variable ist- oder irre ich mich da?

Ansicht von 7 Antworten - 16 bis 22 (von insgesamt 22)
  • Das Thema „Probleme bei Galerie pro Beitrag (ohne extra Plugins)“ ist für neue Antworten geschlossen.