Support » Installation » Probleme beim Update von Version 4.9.11 auf Version 5.2.3

  • Hallo,

    beim Aktualisieren von WordPress von Version 4.9.11 auf Version 5.2.3 kommt bei mir folgende Meldung:

    Herunterladen der Aktualisierung von https://downloads.wordpress.org/release/de_DE/wordpress-5.2.3.zip
    Entpacken der aktualisierten Version …
    Die Datei konnte nicht kopiert werden.: wordpress/wp-includes/class-wp-customize-widgets.php
    Die Installation ging schief

    Ich bin da nicht so der Computerfachmann…hat jemand eine Idee, wie’s funktioniert?

    • Dieses Thema wurde geändert vor 8 Monaten von z2zt.
Ansicht von 5 Antworten - 1 bis 5 (von insgesamt 5)
  • Nico

    (@winningsolutions)

    Hi! Ich würde erstmal mit einem FTP Client die Schreibrechte prüfen.
    Offizielle WordPress Doku dazu:

    Also der Ordner muss auf 755 gesetzt werden und die Dateien auf 644.
    Sieht dann zB. so aus: https://share.winning-solutions.eu/jkrwe

    Als FTP Client kannst du zB Filezilla nehmen.
    Hilft dir das weiter?

    Hallo @z2zt,
    hast Du mal versucht, ein manuelles Update von WP durchzuführen ? – Eine sehr gute Anleitung dazu findest Du hier.
    Das würde ich allerdings nur empfehlen, wenn Du eine Sicherung erstellt hast.
    Viele Grüße
    Hans-Gerd

    Moderator Bego Mario Garde

    (@pixolin)

    Backups sind immer gut. 🙂
    Deshalb steht der Hinweis auch in meiner Anleitung.

    Ich würde aber erst einmal auf „erneut aktualisieren“ klicken und schauen, ob die gleiche Fehlermeldung auftaucht. Vielleicht ist ja auch nur der Datensatz für das Update fehlerhaft übertragen worden?

    Wenn das nicht geht, würde ich mir vor allem die in der Fehlermeldung genannte Datei wp-includes/class-wp-customize-widgets.php per FTP anschauen: Rechtsklick auf die Datei > Eigenschaften > Dateirechte. Die sollten auf 644 (-rw-r–r–) gesetzt sein und der Datei-Besitzer sollte den anderen Dateien entsprechen.

    Eine andere Möglichkeit, warum das nicht geht: Der Festplatten-Platz könnte erschöpft sein. Bitte prüfen!

    Hallo zusammen,

    vielen Dank für die Rückmeldungen!

    Mit etwas Gefummel hab ich die Dateirechte jetzt per FileZilla wie folgt verteilt:
    Ordner „wp-includes“:
    Besitzer: Lesen Schreiben Ausführen
    Gruppen: Lesen Ausführen
    Öffentlich: Lesen Ausführen
    Numerischer Wert: 755

    Dateiberechtigungen für alle Dateien in dem Ordner:
    Besitzer: Lesen Schreiben
    Gruppen: Lesen
    Öffentlich: Lesen
    Numerischer Wert: 644

    Platz ist noch genug auf der Festplatte

    Die Fehlermeldung beim Update bleibt leider gleich:

    Die Datei konnte nicht kopiert werden.: wordpress/wp-includes/class-wp-customize-widgets.php

    Die Installation ging schief

    … Tjo… Gibt’s da vielleicht nochwas zu beachten?

    Moderator Bego Mario Garde

    (@pixolin)

    Was war mit „erneut aktualisieren“? Oder kommst du nicht mehr ins Backend?
    Dann wäre ein manuelles Update die beste Lösung. Den Link zur Anleitung hatte dir Hans-Gerd bereits in seiner Antwort weiter oben genannt.

Ansicht von 5 Antworten - 1 bis 5 (von insgesamt 5)
  • Das Thema „Probleme beim Update von Version 4.9.11 auf Version 5.2.3“ ist für neue Antworten geschlossen.