Support » Themes » Probleme beim Zuschneiden eines Bildes

  • Hi, ich benutze Seedlet als Theme und beim Zuschneiden eines Bildes für Logo oder Icon bekomme ich imemr die fehlermeldung, dass beim Zuschneiden meines Bildes ein fehler aufgetreten ist, das passiert mit verschiedenen Bildern verschiedener Grösse.Wie kann man das beheben? danke!

Ansicht von 5 Antworten - 1 bis 5 (von insgesamt 5)
  • Bekommen wir auch noch den Website-Bericht? 🙂

    Geh bitte auf Werkzeuge > Website-Zustand > Bericht, klick auf den Button und füge den Bericht mit Strg-V unverändert in deine Antwort ein. Auch eine URL zur Website wäre hilfreich.

    Thread-Starter cineglobal

    (@cineglobal)

    http://www.cineglobal.de

    
    ### wp-core ###
    
    version: 6.1
    site_language: de_DE
    user_language: de_DE
    timezone: Europe/Berlin
    permalink: /%year%/%monthnum%/%day%/%postname%/
    https_status: true
    multisite: false
    user_registration: 0
    blog_public: 1
    default_comment_status: undefined
    environment_type: production
    user_count: 1
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /homepages/25/d4296050159/htdocs
    wordpress_size: 199,67 MB (209365538 bytes)
    uploads_path: /homepages/25/d4296050159/htdocs/wp-content/uploads
    uploads_size: 93,17 MB (97694093 bytes)
    themes_path: /homepages/25/d4296050159/htdocs/wp-content/themes
    themes_size: 16,31 MB (17100722 bytes)
    plugins_path: /homepages/25/d4296050159/htdocs/wp-content/plugins
    plugins_size: 331,27 kB (339223 bytes)
    database_size: 3,05 MB (3194880 bytes)
    total_size: 312,51 MB (327694456 bytes)
    
    ### wp-active-theme ###
    
    name: Seedlet (seedlet)
    version: 1.1.13
    author: Automattic
    author_website: https://automattic.com/
    parent_theme: none
    theme_features: core-block-patterns, widgets-block-editor, automatic-feed-links, title-tag, post-thumbnails, menus, html5, custom-logo, customize-selective-refresh-widgets, wp-block-styles, align-wide, editor-styles, editor-style, editor-font-sizes, editor-color-palette, editor-gradient-presets, responsive-embeds, custom-line-height, experimental-link-color, custom-spacing, custom-units, jetpack-global-styles, jetpack-content-options, widgets
    theme_path: /homepages/25/d4296050159/htdocs/wp-content/themes/seedlet
    auto_update: Deaktiviert
    
    ### wp-themes-inactive (5) ###
    
    Hello Elementor: version: 2.6.1, author: Elementor Team, Automatische Aktualisierungen deaktiviert
    Twenty Twenty: version: 2.0, author: WordPress-Team (latest version: 2.1), Automatische Aktualisierungen deaktiviert
    Twenty Twenty-One: version: 1.6, author: WordPress-Team (latest version: 1.7), Automatische Aktualisierungen deaktiviert
    Twenty Twenty-Three: version: 1.0, author: WordPress-Team, Automatische Aktualisierungen deaktiviert
    Twenty Twenty-Two: version: 1.2, author: WordPress-Team (latest version: 1.3), Automatische Aktualisierungen deaktiviert
    
    ### wp-plugins-inactive (3) ###
    
    Akismet Anti-Spam: version: 5.0, author: Automattic (latest version: 5.0.1), Automatische Aktualisierungen deaktiviert
    Hello Dolly: version: 1.7.2, author: Matt Mullenweg, Automatische Aktualisierungen deaktiviert
    Slim Maintenance Mode: version: 1.4.3, author: Johannes Ries, Automatische Aktualisierungen deaktiviert
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_GD
    imagick_module_version: Nicht verfügbar
    imagemagick_version: Nicht verfügbar
    imagick_version: Nicht verfügbar
    file_uploads: File uploads is turned off
    post_max_size: 64M
    upload_max_filesize: 64M
    max_effective_size: 64 MB
    max_file_uploads: 20
    gd_version: 2.2.5
    gd_formats: GIF, JPEG, PNG, WebP, BMP, XPM
    ghostscript_version: 9.27
    
    ### wp-server ###
    
    server_architecture: Linux 4.4.302-icpu-088 x86_64
    httpd_software: Apache
    php_version: 8.0.25 64bit
    php_sapi: cgi-fcgi
    max_input_variables: 5000
    time_limit: 50000
    memory_limit: -1
    max_input_time: -1
    upload_max_filesize: 64M
    php_post_max_size: 64M
    curl_version: 7.64.0 OpenSSL/1.1.1n
    suhosin: false
    imagick_availability: false
    pretty_permalinks: true
    htaccess_extra_rules: false
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 5.7.38-log
    client_version: mysqlnd 8.0.25
    max_allowed_packet: 67108864
    max_connections: 3000
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /homepages/25/d4296050159/htdocs/wp-content
    WP_PLUGIN_DIR: /homepages/25/d4296050159/htdocs/wp-content/plugins
    WP_MEMORY_LIMIT: 40M
    WP_MAX_MEMORY_LIMIT: -1
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_ENVIRONMENT_TYPE: Nicht definiert
    DB_CHARSET: utf8mb4
    DB_COLLATE: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    
    
    Thread-Starter cineglobal

    (@cineglobal)

    danke!

    Hm, mir ist bekannt dass IONOS keine Grafikbibliothek Imagemagick auf den Servern verwendet, aber dann sollte die (anscheinend installierte?) GD-Library funktionieren. Vielleicht kann @pfefferle oder @krafit von IONOS dazu etwas sagen?
    Ich bin da im Moment etwas überfragt.

    Hallo, an Imagemagick arbeiten wir gerade, aber GD sollte einwandfrei (als Fallback) funktionieren. Hast du das Problem generell oder ist das „nur“ im Kontext von dem Theme? Hast du mal probiert Bilder über die Media-Library zu verändern? Was mir auch auffällt ist, dass du bei ganz vielen Memory/Upload Werten -1 benutzt WP_MAX_MEMORY_LIMIT: -1 das hab ich vorher auch noch nie gesehen und ich würde empfehlen den Wert explizit zu setzen.

Ansicht von 5 Antworten - 1 bis 5 (von insgesamt 5)