Support » Allgemeine Fragen » Probleme mit htaccess und permalinks

  • Gelöst cocoonaw

    (@cocoonaw)


    Hallo zusammen,

    ich habe folgendes Problem: Ich habe WordPress installiert (in ein Unterverzeichnis) Das einzige installierte Plugin ist Elementor. Die zwei Standard Themes 2020 und 2021 sind installiert, 2021 ist aktiviert. Permalinks habe ich auf Beitragsname eingestellt. Sobald ich das gespeichert habe und auf einen anderen Menüpunkt gehe bekomme ich „Forbidden You don’t have permission to access this resource.“ Ich bin am verzweifeln, woran liegt das?

    Lösche ich die Datei .htacess geht alles wieder, aber das kann ja nicht Sinn und Zweck der Übung sein

    Danke schonmal für Tipps

    P.S. Will ich eine neue Seite erstellen, oder eine bestehende bearbeiten bekomme ich die Fehlermeldung Aktualisierung fehlgeschlagen. „Die Antwort ist keine gültige JSON-Antwort.“

    • Dieses Thema wurde geändert vor 2 Jahre von cocoonaw.
Ansicht von 12 Antworten - 1 bis 12 (von insgesamt 12)
  • Moderator Bego Mario Garde

    (@pixolin)

    Wo wird das denn gehostet? URL der Website? Webhoster?
    Ist das ein eigener Server?

    Was ist aktuell Inhalt der .htaccess?

    Thread-Starter cocoonaw

    (@cocoonaw)

    wird gehostet bei alfahosting

    # BEGIN WordPress
    # Die Anweisungen (Zeilen) zwischen „BEGIN WordPress“ und „END WordPress“ sind
    # dynamisch generiert und sollten nur über WordPress-Filter geändert werden.
    # Alle Änderungen an den Anweisungen zwischen diesen Markierungen werden überschrieben.
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
    RewriteBase /wordpress/
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /wordpress/index.php [L]
    </IfModule>
    
    # END WordPress
    Thread-Starter cocoonaw

    (@cocoonaw)

    die url ist hier

    • Diese Antwort wurde geändert vor 2 Jahre von cocoonaw.
    Moderator Bego Mario Garde

    (@pixolin)

    Die .htaccess ist soweit OK.
    Die Fehlermeldung „Die Antwort ist keine gültige JSON-Antwort.“ erscheint oft, wenn mit den Permalink-Einstellungen etwas nicht stimmt oder ein Plugin eine Fehlermeldung ausgibt, während der Beitrag/die Seite gespeichert werden soll. Elementor würde ich da aber eigentlich ausschließen – also doch eher die Permalinks.

    Du könntest mal den Support deines Webhosters ansprechen und sagen, dass du mit mod_rewrite Probleme hast und sie bitte die Servereinstellungen prüfen sollen. Andererseits machen die das nicht zum ersten Mal.

    Um das besser beurteilen zu können, gib bitte eine URL zur Website an. Außerdem brauchen wir mehr Informationen über deine Website. Geh bitte auf Werkzeuge > Website-Zustand > Bericht, warte einen Moment bis die Ladeanzeige ganz oben abgeschlossen ist. Klick auf den Button „Bericht in die Zwischenablage kopieren“. Den Bericht kannst du dann hier in einer neuen Antwort mit Strg-V (Mac: Cmd-V) unverändert einfügen (also bitte ohne weitere Formatierung, aber mit den Akzentzeichen ` am Anfang und Ende).

    Moderator Bego Mario Garde

    (@pixolin)

    Prüf bitte auch mal, ob du (theoretisch, ohne etwas zu ändern) unter Einstellungen > Allgemein eine andere Sprache wie Französisch oder Spanisch auswählen könntest.

    Thread-Starter cocoonaw

    (@cocoonaw)

    
    ### wp-core ###
    
    version: 5.6
    site_language: de_DE
    user_language: de_DE
    timezone: Europe/Berlin
    permalink: /%postname%/
    https_status: true
    multisite: false
    user_registration: 0
    blog_public: 1
    default_comment_status: open
    environment_type: production
    user_count: 1
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /var/www/web24956772/html/wordpress
    wordpress_size: loading...
    uploads_path: /var/www/web24956772/html/wordpress/wp-content/uploads
    uploads_size: loading...
    themes_path: /var/www/web24956772/html/wordpress/wp-content/themes
    themes_size: loading...
    plugins_path: /var/www/web24956772/html/wordpress/wp-content/plugins
    plugins_size: loading...
    database_size: loading...
    total_size: loading...
    
    ### wp-active-theme ###
    
    name: Twenty Twenty-One (twentytwentyone)
    version: 1.1
    author: WordPress-Team
    author_website: https://de.wordpress.org/
    parent_theme: none
    theme_features: core-block-patterns, automatic-feed-links, title-tag, post-formats, post-thumbnails, menus, html5, custom-logo, customize-selective-refresh-widgets, wp-block-styles, align-wide, editor-styles, editor-style, editor-font-sizes, custom-background, editor-color-palette, editor-gradient-presets, responsive-embeds, custom-line-height, experimental-link-color, custom-spacing, custom-units, widgets
    theme_path: /var/www/web24956772/html/wordpress/wp-content/themes/twentytwentyone
    auto_update: Deaktiviert
    
    ### wp-themes-inactive (1) ###
    
    Twenty Twenty: version: 1.6, author: WordPress-Team, Automatische Aktualisierungen deaktiviert
    
    ### wp-plugins-active (1) ###
    
    Elementor: version: 3.0.16, author: Elementor.com, Automatische Aktualisierungen deaktiviert
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_Imagick
    imagick_module_version: 1673
    imagemagick_version: ImageMagick 6.8.9-9 Q16 x86_64 2019-12-29 http://www.imagemagick.org
    file_uploads: File uploads is turned off
    post_max_size: 32M
    upload_max_filesize: 32M
    max_effective_size: 32 MB
    max_file_uploads: 20
    imagick_limits: 
    	imagick::RESOURCETYPE_AREA: 96 GB
    	imagick::RESOURCETYPE_DISK: -1
    	imagick::RESOURCETYPE_FILE: 6144
    	imagick::RESOURCETYPE_MAP: 96 GB
    	imagick::RESOURCETYPE_MEMORY: 48 GB
    	imagick::RESOURCETYPE_THREAD: 1
    gd_version: bundled (2.1.0 compatible)
    ghostscript_version: 9.26
    
    ### wp-server ###
    
    server_architecture: Linux 4.15.18-13-pve x86_64
    httpd_software: Apache
    php_version: 7.4.3 64bit
    php_sapi: cgi-fcgi
    max_input_variables: 1000
    time_limit: 60
    memory_limit: 256M
    max_input_time: 60
    upload_max_filesize: 32M
    php_post_max_size: 32M
    curl_version: 7.38.0 OpenSSL/1.0.1t
    suhosin: false
    imagick_availability: true
    pretty_permalinks: true
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 5.7.25
    client_version: mysqlnd 7.4.3
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /var/www/web24956772/html/wordpress/wp-content
    WP_PLUGIN_DIR: /var/www/web24956772/html/wordpress/wp-content/plugins
    WP_MAX_MEMORY_LIMIT: 256M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_LOCAL_DEV: undefined
    DB_CHARSET: utf8mb4
    DB_COLLATE: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    
    
    Thread-Starter cocoonaw

    (@cocoonaw)

    Prüf bitte auch mal, ob du (theoretisch, ohne etwas zu ändern) unter Einstellungen > Allgemein eine andere Sprache wie Französisch oder Spanisch auswählen könntest.

    Ja, das geht (also nur aus dem dropdown auswählen)

    Moderator Bego Mario Garde

    (@pixolin)

    Dann scheinen auch die Dateirechte zu stimmen.
    Wie gesagt: sprich bitte mal den Support des Webhosters an. Ich finde auch im Website-Bericht nichts, was den Fehler erklärt.

    Thread-Starter cocoonaw

    (@cocoonaw)

    OK, Danke

    Sollte `mod_rewrite‘ auf on oder off stehen? (steht auf off)

    Moderator Bego Mario Garde

    (@pixolin)

    Nein, das Modul muss natürlich eingeschaltet sein.
    Es sorgt dafür, dass URLs umgeschrieben werden können.

    Thread-Starter cocoonaw

    (@cocoonaw)

    Ich habe es gestern Abend noch gefunden, wo ich es einstellen kann. Habe es auf on umgestellt und heute funktioniert es.

    Herzlichen Dank für die Hilfe!

    Moderator Bego Mario Garde

    (@pixolin)

    Freut mich, dass es wieder läuft.
    Danke für die Rückmeldung. 🌻

Ansicht von 12 Antworten - 1 bis 12 (von insgesamt 12)
  • Das Thema „Probleme mit htaccess und permalinks“ ist für neue Antworten geschlossen.