Support » Allgemeine Fragen » Probleme mit Kategorien

  • transwarp2010

    (@transwarp2010)


    Hallo allerseits.
    Leider weiß ich mir derzeit nicht weiter zu helfen, daher erhoffe ich den ein oder anderen Tipp zu meinem Problem. Installiert ist die aktuelle WordPress-Version 5.5.1.

    Wir nutzen WordPress derzeit als ‚Knowledgebase‘ in unserer IT-Abteilung. In dieser lokalen WordPress-Installation werden die Themen in entsprechenden Kategorien sortiert. Nun habe ich das Problem, dass es zwar reichlich Einträge in gewissen Kategorien gibt, das ‚Kategorien‘-Widget aber einige Kategorien nicht anzeigt. In der Liste der Kategorie-Definitionen sehe ich dann, dass dort keine (0) Einträge für diese Kategorie verzeichnet sind. Suche ich jedoch nach Einträgen, finde ich sehr wohl Artikel, die der entsprechenden Kategorie zugeordnet sind.

    Ich habe verschiedene Lösungsversuche gemacht, darunter das Neuanlegen der Kategorie und auch das nachträgliche Zuweisen von Artikeln zu dieser Kategorie per Mehrfachbearbeitung. Leider alles ohne Erfolg. Teilweise sehe ich Kategorien mit nur ‚einem‘ (1) Eintrag, in Wirklichkeit sind jedoch 20 vorhanden. Die Funktion der einzelnen Artikel ist davon unbeeinträchtigt.

    Ich könnte schwören, dieses Problem vor dem letzten Update nicht gehabt zu haben, vielleicht ist es mir aber auch nicht aufgefallen. Die WordPress-Datenbank ist von mir über den ganz normalen manuellen Weg befüllt worden, Artikel für Artikel, also nicht über irgendeine Import-Variante. Die Installation läuft auf einem Windows-2016-Server mit IIs und MariaDb.

    Vielleicht kann ja jemand helfen. Danke im Voraus.

Ansicht von 3 Antworten - 1 bis 3 (von insgesamt 3)
  • Moderator Bego Mario Garde

    (@pixolin)

    Ich würde zuerst versuchen, mögliche Fehlerquellen einzugrenzen.

    Dazu kannst du das Plugin Health Check installieren und unter Werkzeuge > Website-Zustand den Problembehandlungsmodus aktivieren. Dadurch werden (nur für dich sichtbar) alle Plugins vorübergehend deaktiviert und ein Standard-Theme („Twenty …“) aktiviert. Prüf dann bitte, ob das Widget weiterhin die falsche Zahl ausgibt. Falls nicht, kannst du die Plugins einzeln wieder aktivieren und jedesmal prüfen, ob sich etwas verändert.

    Ansonsten ist das für uns hier schwer zu beurteilen. Anwendungsfehler (z.B. eine Verwechselung von Kategorien und einer Custom Taxonomy) wären genauso möglich wie ein Bug im Core.

    transwarp2010

    (@transwarp2010)

    @pixolin
    Danke für die Hinweise, die ich auch prompt versucht habe. Das Tool Healtch Check ist in der Tat recht hilfreich.
    Ich glaube aber nun den Grund für meine Probleme gefunden zu haben:

    Um administrative Artikel nicht jedem normalen Mitarbeiter zur Verfügung zu stellen, haben wir diese als ‚privat‘ deklariert. Laut WordPress-Beschreibung werden diese daher nur noch Redakteuren oder Usern mit administrativen Berechtigungen angezeigt.
    Augenscheinlich kommt das Widget ‚Kategorien‘ aber damit nicht gut zurecht, denn obwohl ich WordPress-Admin bin, werden dort alle ‚privaten‘-Beiträge unterschlagen. Setze ich alle Artikel auf ‚veröffenlicht‘, ist wieder alles gut.

    Frage:
    Gibt es eine andere Möglichkeit den Zugriff auf Artikel zu reglementieren? Evtl. per Plugin?

    Moderator Bego Mario Garde

    (@pixolin)

    Augenscheinlich kommt das Widget ‚Kategorien‘ aber damit nicht gut zurecht, denn obwohl ich WordPress-Admin bin …

    Das Widget ist dazu gedacht, normalen Webseitenbesuchern die Anzahl der unter verschiedenen Kategorien veröffentlichten und frei zugänglichen Beiträge anzuzeigen.

    Setze ich alle Artikel auf ‚veröffenlicht‘, ist wieder alles gut.

    Dann funktioniert das Widget so, wie es soll. Prima.

    Gibt es eine andere Möglichkeit den Zugriff auf Artikel zu reglementieren? Evtl. per Plugin?

    Es gibt für WordPress eine ganze Reihe von mehr odr weniger komplexen Membership-Plugins, bei denen nur bestimmten Nutzergruppen Zugriff auf festgelegte Inhalte gewährt wird.

Ansicht von 3 Antworten - 1 bis 3 (von insgesamt 3)