Support » Allgemeine Fragen » Probleme nach Update

  • Gelöst Rhoihess

    (@frankwgh)


    Hallo Zusammen,

    ich hab hier so ein paar Problemchen nach einem fehlgeschalgenen Update.
    Ich bekam nur noch einen weissen Bildrschirm im Frontend und Backend meiner Webseite, login nicht mehr möglich.
    Danach den Debugger aktiviert und bekam folgende Meldung:

    Fatal error: Call to undefined function wp_doing_ajax() in /var/www/html/web339/html/wp-includes/update.php on line 709

    Daraufhin bekam ich den Tipp WP manuell zu erneuern, habe ich versucht nach Anleitung, nun kommt diese Fehlermeldung:

    Fatal error: Class ‚wpdb‘ not found in /var/www/html/web339/html/wp-includes/load.php on line 404

    Bitte um weitere Vorschläge.

    Danke an alle

    Gruß

    Frank

Ansicht von 5 Antworten - 1 bis 5 (von insgesamt 5)
  • Hallo Frank,

    in der Anleitung, die du befolgt hast, ist der folgende Satz nicht ganz eindeutig:

    Jetzt die frisch heruntergeladenen und entpackten Dateien vom eigenen Computer auf den Webserver hochladen.

    Das umfasst auch die Ordner wp-includes und wp-admin aus dem entpackten Verzeichnis. Hast du die auch hochgeladen und vorher die alten Versionen gelöscht?
    Wie immer, vorheriges Backup nicht vergessen!

    • Diese Antwort wurde geändert vor 2 years, 11 months von  Flower33.
    Moderator espiat

    (@espiat)

    Hi.

    Da wir nicht wissen, nach welcher Anleitung du gegangen bist, hier mal ein Link zum manuellen Update:
    https://codex.wordpress.org/Updating_WordPress#Manual_Update

    Zudem der Hinweis, dass aktuell beim Update auf (WP 4.7 – es geht doch bei dir um ein WP Update?) W3TC und Genesis Theme Sidebar nicht mitspielen. Siehe: https://wordpress.org/support/topic/read-this-first-wordpress-4-7-master-list/#post-8521431

    Hallo @espiat,

    Da wir nicht wissen, nach welcher Anleitung du gegangen bist

    Bei meiner obigen Überlegung bin ich davon ausgegangen, dass Frank der ausführlichen Anleitung von Bego gefolgt ist, die ihm von Sören am Ende dieses älteren Threads empfohlen wurde, an den Frank seine Anfrage gestern zunächst angehängt hatte.

    Weil Bego in seiner schönen Anleitung an der oben zitierten Stelle nicht ganz eindeutig nur von hochzuladenden Dateien spricht, war meine Überlegung, ob Frank eventuell vegessen hatte, nach vorherigem Löschen auch die Ordner wp-includes und wp-admin neu hochzuladen.

    Warten wir mal Franks Rückmeldung mit weiteren Infos ab.

    • Diese Antwort wurde geändert vor 2 years, 11 months von  Flower33. Grund: Link hinzugefügt
    • Diese Antwort wurde geändert vor 2 years, 11 months von  Flower33. Grund: Tippfehler

    Nachtrag, an Frank gerichtet:

    In deiner ersten Anfrage, die du an den älteren Thread angehängt hattest, erwähnst du als bisher durchgeführte Maßnahmen lediglich das Löschen der Datei .maintenance und das Einschalten des Debug-Modus. Hattest du vor dem manuellen Update denn auch mal den Tipp im älteren Thread befolgt, per FTP das Verzeichnis wp-content/plugins umzubenennen (z.B. in wp-content/plugins-stopp)? Damit werden alle Plugins deaktiviert, sodass du, falls ein Plugin der Verursacher sein sollte, wieder ins Backend kommen könntest, um dann dort ein Plugin nach dem anderen wieder zu aktivieren und so den Schuldigen zu isolieren.

    • Diese Antwort wurde geändert vor 2 years, 11 months von  Flower33.

    Tach Zusammen,

    vielen Dank für die Unterstützung.
    Im 3. Anlauf hat es geklappt, es wurde eine Datei nicht richtig mit auf den Server kopiert.
    Daran hat es wohl gelegen.
    Also nochmals danke an alle und bis zum nächsten Mal

    Gruß

    Frank

Ansicht von 5 Antworten - 1 bis 5 (von insgesamt 5)
  • Das Thema „Probleme nach Update“ ist für neue Antworten geschlossen.