Support » Allgemeine Fragen » Probleme nach WordPress wiederherstellung

  • Hallo zusammen

    Habe ne Seite in WordPress 4.8.1 erstellt, nun war es leider der Fall dass die Datenbank abhanden gekommen ist: Den Proxmox-VM-Hostserver habe ich auf einen inoffiziellen Kernel geupdatet, 4.9.x, dies hatte zur Folge dass defekte Backups (vor einer Migration) erstellt wurden – eigentlich völlig schwachsinnig (!!!), was sollte der Kernel mit dem Erstellen von von irgendwelchen Backup-Archiven zu tun haben – das sind doch 2 völlig verschiedene OS-Layers, aber egal, wohl typisch Linux, nun bin ich halt auf Win7 Pro x64 in Kombination mit VirtualBoxWeb was sogar meinen LSI-Controller mit HW-RAID 10 unterstützt – alles schön zertifiziert und gesupportet im ggs. zu diesem Linux-Kram namens „ProxMox“! Des weiteren gefühlte 10x schneller!! 😉

    Jedoch habe ich vorher glücklicherweise MySQL-Dumps (Struktur UND Daten) der WordPress-Seite erstellt…

    Der PHP-Code ist bei einem Hoster, die DB bei mir zuhause. (Wegen Stored Procedures, welche der Hoster nicht zulässt) Nach dem Restore der DB zeigte mit WordPress aber nur eine Fehlermeldung an, in Englisch, dass keine Verbindung zur DB hergestellt werden kann. Dem war aber gar nicht so, der Port 3306 war nämlich verfügbar. (Ziemlich abstrus, eine solche Fehlermeldung..)

    Und folgende Zeilen in der config haben ebenfalls keine Wirkung, unter keinen Umständen:

    define('WP_DEBUG', true);
    define('WP_DEBUG_LOG', true);
    define('WP_DEBUG_DISPLAY', true);

    Also habe ich halt DB-mässig alles neu aufgesetzt, indem ich alle Tabellen von der DB gelöscht, und den Installationsvorgang neu durchgezogen habe. Danach war WordPress wieder im „default“-Zustand. So weit so gut, na ja…

    Danach habe ich wieder alle Tabellen (default) gelöscht, und wieder versucht das Backup (Mysql Dump, Daten & Struktur) zurückzuspielen. Hat halbwegs geklappt, jedoch habe ich nun das Problem dass mir

    a.) Sämtliche Bilder im WordPress-Admin-Bereich nicht mehr angezeigt werden (Bildvorschau) Darauf hin habe ich alle gelöscht was soweit geklappt hat

    b.) Beim erneuten Upload der Bilder erhalte ich nun aber die Fehlermeldung „Bei dem Upload ist ein Fehler aufgetreten. Versuche es später noch einmal.“

    Das upload-Verzeichnis hat die Berechtigung 0755 (0 am Anfang = Vererbung auf Unterverzeichnisse) was soweit stimmt. Auch werden die Bilder heraufgeladen, das WordPress-Admin-GUI zeigt mir nur solche komischen Fehlermeldungen an, dass ein Fehler aufgetreten sei… wenn ich aber im FTP-Client nachschaue, wurden die Bilder heraufgeladen ins Verzeichnis /uploads/JAHR/TAG

    Das ganze ist einfach total Strange, lohnt es sich überhaupt das zu reparieren oder komme ich evtl. scheller voran wenn ich die ganze Seite von Grund auf neu erstelle? Ist relativ klein, von daher..

    Wenn nicht werde ich ggf. über den Einsatz eines anderen CMS nachdenken, oder sogar selbst eine kleines CMS-Skript erstellen.

    (Tschuldigung, bin gerade total genervt über den ganzen Kram, aber echt!!)

    Danke für eure Feedbacks! 😉

    Nachtrag: Das hier hilft jedenfalls nicht weiter -> https://de.wordpress.org/support/topic/kein-upload-von-bildern-merh-moeglich/

    Grüsse, Jan

    • Dieses Thema wurde geändert vor 2 Monate, 1 Woche von  jmar83.
Ansicht von 9 Antworten - 1 bis 9 (von insgesamt 9)
  • Da ist wohl nix mehr zu machen…?

    Grüsse, Jan

    Moderator espiat

    (@espiat)

    Ich tippe auf ein Rechteproblem. Zwischen FTP und PHP Besitzer.

    jmar83

    (@jmar83)

    Hallo

    Danke für Dein Feedback. Du meinst wohl die Linux-Dateiberechtigungen oder wie?

    Gruss, Jan

    Die Gruppen-Berechtigung. Wenn deine Serverinstallation PHP als Modul ausführt. Nähere Erklärungen dort: http://seomensch.com/webhosting/wwwrun-und-apache/

    jmar83

    (@jmar83)

    Also wp-content hat 0755

    wp-content/uploads hat ebenfalls 0755 und sämtliche darin enthaltenen ordner haben ebenfalls 0755; die bilder jedoch, die haben 0644

    Des Weiteren habe ich ja bereits oben angetönt, dass es nicht daran liegt. („Das upload-Verzeichnis hat die Berechtigung 0755 (0 am Anfang = Vererbung auf Unterverzeichnisse) was soweit stimmt. Auch werden die Bilder heraufgeladen, das WordPress-Admin-GUI zeigt mir nur solche komischen Fehlermeldungen an, dass ein Fehler aufgetreten sei… wenn ich aber im FTP-Client nachschaue, wurden die Bilder heraufgeladen ins Verzeichnis /uploads/JAHR/TAG“, „Nachtrag: Das hier hilft jedenfalls nicht weiter -> https://de.wordpress.org/support/topic/kein-upload-von-bildern-merh-moeglich/„)

    Grüsse, Jan

    jmar83

    (@jmar83)

    An den files auf dem Webspace habe ich nämlich NIE was geändert, ausser die config gelöscht nach dem löschen sämtlicher Tabellen, um WordPress auf den „default“-Zustand zurückzusetzen..

    Grüsse,
    Jan

    Moderator espiat

    (@espiat)

    Ändere mal die permission der files auf 664 und wie gesagt, glaube ich, dass es an den Benutzerrechten zwischen ftp und php besitzer gibt. Prüfe dies. Was sagt der error log?

    jmar83

    (@jmar83)

    Bringt leider auch nichts von 644 nach 664 ändern, die Bilder werden weiterhin nicht angezeigt, nur weisse leere Rahmen…

    Was mir auch noch aufgefallen ist: In der Einstiegsseite habe ich folgende Fehlermeldung: [Duplicate entry ‚0‘ for key ‚PRIMARY‘]
    INSERT INTO wp_posts (post_author, post_date, post_date_gmt, post_content, post_content_filtered, post_title, post_excerpt, post_status, post_type, comment_status, ping_status, post_password, post_name, to_ping, pinged, post_modified, post_modified_gmt, post_parent, menu_order, post_mime_type, guid) VALUES (1, ‚2017-09-20 14:34:31‘, ‚0000-00-00 00:00:00‘, “, “, ‚Automatisch gespeicherter Entwurf‘, “, ‚auto-draft‘, ‚post‘, ‚open‘, ‚open‘, “, “, “, “, ‚2017-09-20 14:34:31‘, ‚0000-00-00 00:00:00‘, 0, 0, “, “)

    Grüsse,
    Jan

Ansicht von 9 Antworten - 1 bis 9 (von insgesamt 9)