Support » Allgemeine Fragen » Produktbilder fehlen auf der Produktseite

  • Gelöst woodbag

    (@woodbag)


    Hallo !
    Ich habe ein Problem. Nach einigen Aktuallisierungen von Plugins sind die Produktbilder (nur) auf der Produktseite nicht mehr sichtbar. Im Shop und in den Kategorien ist alles da und auch im Admin-Modus „Customizer“ sind die Bilder sichtbar.
    Geht man mit der Maus über die „leere“ Stelle ist die Alternativbezeichnung sichtbar und man kann die „leere“ Stelle auch anklicken. Dann erscheit das Bild auf einer neuen Seite.In der Mediatek ist alles oK – auch die Pfade stimmen. Der Fehler ist auch mit einem anderen Browser vorhanden. Da ich nicht der WordPress Guru bin, fehlt mir eine Idee.
    Kann jemand helfen?
    Danke vorab!

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 4 Antworten - 1 bis 4 (von insgesamt 4)
  • Moderator Bego Mario Garde

    (@pixolin)

    Deaktivier bitte mal Autoptimize – ich nehme an, dass hier eine Einstellung nicht stimmt und deshalb als Bildquelle zwei URLs kombiniert werden.

    Thread-Ersteller woodbag

    (@woodbag)

    Hallo,
    vielen lieben Dank – es hat funktioniert!!
    Sollte ich jetzt Autop. nicht mehr verwenden oder mal aktuallisieren?
    lg

    Moderator Bego Mario Garde

    (@pixolin)

    Autoptimize ist ein sehr gutes Optimierungs-Plugin, vor allem wenn auf dem Webserver noch HTTP/1.1 verwendet wird.

    Statt 32 CSS-Stylesheets einzeln und nacheinander abzurufen, fasst das Plugin die Stylesheets zusammen und verbessert (grob vereinfacht gesagt) dadurch die Performance. Durch eine Fehlerhafte Einstellung kann es aber zu Fehlern bei der Zusammenfassung kommen. Das Ergebnis hast du gesehen.

    Auf deinem Webserver wird bereits HTTP/2 verwendet. Der Webserver liefert dabei gleich mehrere Dateien asynchron aus – nebeneinander, statt nacheinander. Dadurch werden die Performanceverluste reduziert und es ist nicht mehr so wichtig, Dateien zusammenzufassen.
    Das Plugin Autoptimize enthält noch andere Optimierungen, ist deshalb also nicht völlig überflüssig, aber auch nicht mehr so wichtig, wie bei der Übertragung mit HTTP/1.1.

    Kurz: Autopimize macht weiterhin Sinn, dann musst du aber an den Einstellungen arbeiten. Wahrscheinlich wird dir aber kein signifikanter Unterschied in der Perfomance auffallen, wenn du es weglässt.

    Zur Performance-Optimierung würde ich eher ein Cache-Plugin wie WP Fastest Cache oder (wenn die Portokasse noch ein paar Euro hergibt) das kostenpflichtige WP-Rocket einsetzen. Wobei hier die Einstellungen mit besonderer Sorgfalt vorgenommen werden müssen – Kunden des Webshops soll ja nicht ein zwischengspeicherter Warenkorb eines anderen Kunden gezeigt werden.

    Thread-Ersteller woodbag

    (@woodbag)

    Vielen Dank nochmals. Ich werde mir dafür Zeit nehmen.

Ansicht von 4 Antworten - 1 bis 4 (von insgesamt 4)
  • Das Thema „Produktbilder fehlen auf der Produktseite“ ist für neue Antworten geschlossen.