Support » Allgemeine Fragen » Rätselhafte Fehlermeldung nach Umstellung auf 5.9.1

  • Gelöst wasissn

    (@wasissn)


    Guten Tag; liebe Foris.

    Ich hatte vor zwei Jahren schon mal das Problem, dass mir STRATO einen Support berechnet wegen veralteter PHP Version. Damals musste ich den CK-Editor wechseln (jetzt Classic) und bei Strato händisch umstellen.

    Dieses Mal habe ich festgestellt, dass mir diverse Fehlermeldungen auf meiner Internetseite nach Umstellung bei STRATO angezeigt wurden. Nach allen Aktualisierungen bei den Plugins leibt trotzdem folgende übrig – Ihr solltet Sie sehen können beim Aufruf der Internetseite:

    Warning: Trying to access array offset on value of type bool in /mnt/web308/b0/86/56536486/htdocs/wp-content/themes/vega/parts/header-logo.php on line 15

    Es sollte also eigentlich was mit dem Titelbild zu tun haben. Aber könnte es nicht sein, dass wieder ein PlugIn stört?

    Ich würde den kostenpflichtigen Support bei STRATO wieder aktualisieren, wenn der Forumsbeitrag angeneommen wird. Aber sobald ich auf höhere Versionen aktualisiere und den Support deaktiviere, wird eben oben stehende Fehlermeldung angezeigt.

    Any Ideas? Danke.

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 5 Antworten - 1 bis 5 (von insgesamt 5)
  • Thread-Ersteller wasissn

    (@wasissn)

    kleiner Nachtrag: Es wird jetzt auch ein Drittel des Bildes im Header nicht mehr angezeigt.

    … dass mir STRATO einen Support berechnet wegen veralteter PHP Version.

    Das ist auch richtig so.

    Die PHP-Community gibt jeder PHP-Version eine Lebensspanne, innerhalb der die Version mit Sicherheitsupdates versorgt wird. Irgendwann ist eine Version dann veraltet und wird nicht mehr weiterentwickelt, was für den Webhoster ein großes Sicherheitsproblem darstellt. Der Webhoster macht hier das Angebot, sich selber um Scherheitsupdates zu kümmern, verlangt aber für die Zusatzleistung einen zusätzlichen Betrag. Das weckt dann zumindest viele Kunden, die sich aus Unwissenheit oder Bequemlichkeit nicht mit einer Änderung der PHP-Version beschäftigt haben.

    Damals musste … bei Strato händisch umstellen.

    Im Moment läuft deine Website mit der wieder veralteten PHP-Version 7.3. Wir empfehlen im Moment, auf PHP 7.4 umzustellen, das noch bis November mit Sicherheitsupdates versorgt wird.

    Warning: Trying to access array offset on value of type bool in /mnt/web308/b0/86/56536486/htdocs/wp-content/themes/vega/parts/header-logo.php on line 15

    Ist, wie ganz am Anfang steht, eine Warnung – ein deutlicher Hinweis, dass ein Problem künftig Probleme bereiten könnte. Um solche Hinweise abzustellen, kannst du in der Konfigurationsdatei wp-config.php oberhalb von /* That's all, stop editing! Happy blogging. */ folgendes eintragen:

    define( 'WP_DEBUG', false );
    @ini_set( 'display_errors', 0 );

    Das ist dann natürlich reine Kosmetik, weil dadruch der Grund für den Hinweis nicht verschwindet. Du solltest das Problem ernst nehmen und nach einer Lösung suchen. Aber was ist nun das Problem? Das steht in der Fehlermeldung:

    Trying to access array offset on value of type bool in …/wp-content/themes/vega/parts/header-logo.php on line 15

    In der Datei header-logo.php deines Themes Vega gibt es also offensichtlich ein Problem, eine Variable auszulesen. (Mit deinen Plugins hat das herzlich wenig zu tun.)

    Die Chance, dass hier nachgebessert wird, ist aber eher gering: das Theme wurde sein 2019 nicht mehr aktualisiert. Ich würde mich da nach einem aktuelleren Theme umschauen, auch wenn der Umstieg ein bisschen Mühe macht. In der Zwischenzeit kannst du dich ja damit begnügen, den Warnhinweis auszublenden.

    Any Ideas?

    Wieso würden wir sonst ein Support-Forum betreiben? 🙂

    Achso, noch eine Idee: lies dir doch bitte nochmal den folgenden, angehefteten Beitrag durch:

    Bevor du ein neues Thema (Thread) erstellst

    Mit so einem Website-Bericht sparen wir viel Zeit und können dir viel effektiver helfen. 😉

    Thread-Ersteller wasissn

    (@wasissn)

    Vielen Dank, lieber Mario (wenn das Dein Name ist). Seit Jahren beantwortest Du mir meine Fragen. Es sind nicht viele, die ich gestellt habe, aber natürlich sind sie fast immer verzweifelt. Nahezu Alles, was ich von Dir an Antworten bekam, ließ sich umsetzen. So wird es auch diesmal sein, aber ich brauche etwas Zeit, um das auszuprobieren. Vermutlich kann ich das am Wochenende machen. Sollten sich daraus weitere Probleme ergeben, melde ich mich gerne wieder. Liebe Grüße, Klaus.

    Thread-Ersteller wasissn

    (@wasissn)

    Okiedokie. Thema kann geschlossen werden. Es hat sich soweit alles bewahrheitet: Neues Thema war nötig, viel Arbeit bei der Umstellung, PHP läuft auf 8.0, Support deaktiviert. Die Feinheiten mit den Farben, Menüs u.a. muss ich nach und nach angleichen. Danke.

    @wasissn
    danke für die Rückmeldung.
    denkst du bitte beim nächsten Mal daran, das Thema dann auch als gelöst zu markieren, wenn das Thema für dich erledigt ist. Danke.
    Gelöst
    Die Option findest du rechts in der Sidebar. Das habe ich jetzt schon gemacht.

Ansicht von 5 Antworten - 1 bis 5 (von insgesamt 5)