Support » Installation » Read more …

  • Gelöst Thobie

    (@thobie)


    Moin, Moin,

    bei den Teasern meiner Blogbeiträge steht der Button mit dem Text „Read more“. In Loco Translate ist er ins Deutsche übersetzt mit „Weiterlesen …“. Das Blog übernimmt die Übersetzung aber nicht. Wie löse ich das Problem? Gibt es noch eine andere Verfahrensweise?

    Grüße aus Hamburg

    Thobie

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 10 Antworten - 1 bis 10 (von insgesamt 10)
  • Moderator Bego Mario Garde

    (@pixolin)

    Das Theme ist bisher nur zu einem Bruchteil übersetzt worden. Die Aussage „In Loco Translate ist er ins Deutsche übersetzt mit „Weiterlesen …“. “ lässt sich für uns kaum prüfen. Ist das richtige Theme übersetzt worden?

    Thread-Ersteller Thobie

    (@thobie)

    Ja, das Child Theme von Magazine Basic.

    Wäre es da nicht sinnvoll, wenn du dir ein anderes Theme suchst? – das Theme Magazine Basic ist seit März 2017 nicht mehr upgedatet worden.
    Ansonsten musst du z. B. mit dem Programm Poedit im Ordner languages des Themes die deutsche Sprachdatei öffnen und die Begriffe oder Sätze übersetzen. Am besten lädst du die deutschen Sprachdateien lokal auf deinen Rechner, um die Übersetzung vorzunehmen. Die Übersetzungsdateien (mit der Erweiterung .mo und .po) musst du nach der Übersetzung wieder per FTP in den languages – Ordner des Themes hochladen.

    Thread-Ersteller Thobie

    (@thobie)

    Nein, das Theme passt hervorragend zu meinem Blog und hat mir bisher 10 Jahre sehr gute Dienste getan.

    Die Lösung, die Du vorschlägst, habe ich vermutlich auch beim alten Foodblog ausgeführt, nur hatte ich mich nicht mehr daran erinnert. Aber dieser Workaround sollte klappen.

    Ich berichte …

    Irgendwann gibt auch ein guter alter VW Käfer seinen Geist auf, es sei denn die anfälligen Teile werden ersetzt. Wenn du das allerdings nicht machst, dann bleibst du evtl. mit dem Wagen irgendwann mit einem Schaden liegen.
    Bezogen auf Themes oder Plugins: Ich vermute mal, dass du nicht informiert bist, ob bei dem Theme möglicherweise Sicherheitslücken bestehen, die du dann selbst bei entsprechenden Kenntnissen beheben könntest. Insofern riskierst du ein mehr oder weniger großes Problem, wenn du weiter mit einem veralteten Theme arbeitest, das ganz offensichtlich bereits seit fast 5 Jahren nicht mehr gepflegt wird.
    Es ist natürlich deine Entscheidung, wenn du das Risiko eingehen willst. Ich würde das jedenfalls nicht eingehen und mir ein Theme mit ähnlichen Features suchen.

    Thread-Ersteller Thobie

    (@thobie)

    Moin, Moin, Hans-Gerd, Offtopic: Gutes Beispiel mit dem VW-Käfer. Ich habe tatsächlich vor über 30 Jahren 13 Jahre lang einen alten VW Käfer 1200 gefahren. Irgendwann war Schluss im Schacht und ich blieb mit einem durchgebrannten Zylinder auf der Autobahn hängen. Die Gelder für eine Reparatur, bei der dann noch Schweißarbeiten an Teilen des durchgerosteten Unterbodens hätten durchgeführt werden sollten, hatte ich nicht. Also an einen Schrauber verkauft. Ironie der Geschichte: Ein KFZ-Mechaniker baut den Käfer derzeit originalgetreu mit Original-Ersatzteilen wieder auf, er hat mich übers Internet gefunden und per Facebook kontaktiert.

    Ich bleibe derzeit mal bei diesem Theme. Wie erwähnt hat es mir 10 Jahre lang gute Dienste geleistet. Sinnvoller wäre für mich vielleicht, auf die Bezahl-Pro-Version umzusteigen (mit Support).

    Und bei der Übersetzung fiel mir eben gerade folgendes ein: Ich habe ja den Webspace des alten Foodblogs auf den Webspace des neuen, provisorischen Foodblogs umgezogen. Und nur eine neue Datenbank angehängt. Also sind die Übersetzungsdateien noch in der WP-Installation vorhanden. Ich habe es eben auf meinem Mac mit Podedit einmal überprüft: „Read more …“ ist mit „Weiterlesen …“ korrekt übersetzt. Aber es wird nicht so angezeigt. Woran liegt es?

    Ich habe es eben auf meinem Mac mit Podedit einmal überprüft: „Read more …“ ist mit „Weiterlesen …“ korrekt übersetzt. Aber es wird nicht so angezeigt.

    Die Datei mit der deutschen Übersetzung des Themes hast du in den Ordner
    ...\wp-content\languages\themes
    kopiert?

    Thread-Ersteller Thobie

    (@thobie)

    Ich habe die Dateien:

    de_DE.mo
    de_DE.po
    de_DE_formal.mo
    de_DE_formal.po

    in die Ordner:

    …/wp-content/languages/themes
    …wp-content/themes/magazin-basic-child-01

    gelegt.

    Korrekt? Aber leider kein Erfolg.

    Moderator Bego Mario Garde

    (@pixolin)

    Ich würde eine Übersetzung des Parent Theme vornehmen, weil du sonst im Child-Theme die Sprachdateien erneut einbinden musst.

    Ob du eine formelle oder informelle Übersetzung verwendest, hängt davon ab, welche Sprache du in Einstellungen > Allgemein ausgewählt hast. Ist dort die informelle Übersetzung eingetragen, brauchst du keine formellen Übersetzungen hochladen.

    Die Übrersetzung sollte zwar im Verzeichnis wp-content/languages/themes liegen, der Dateiname muss dann aber den Namen des Themes enthalten, z.B. magazin-basic-de_DE.po und magazin-basic-de_DE.mo

    Thread-Ersteller Thobie

    (@thobie)

    Die Dateien

    magazine-basic-child-01-de_DE_formal.mo
    magazine-basic-child-01-de_DE_formal.po
    magazine-basic-de_DE_formal.mo
    magazine-basic-de_DE_formal.po

    liegen jetzt im Ordner …/wp-content/languages/themes. Ohne Erfolg.

    Ich habe über Loco Translate die Übersetzung des Parent-Themes geprüft, auch dort sind die Wörter übersetzt.

    Nachtrag: Gerade nochmal über Loco Translate geprüft, für Parent- und Child-Theme. Anscheinend fehlten die formellen Sprach-Dateien, denn „Formell“ habe ich in den Einstellungen gewählt. Diese Sprachdateien wurden erst jetzt, nachdem ich sie auf dem Webspace umbenannt und in den entsprechenden Ordner verschoben habe, angezeigt.

    Die Wörter werden nun im Frontend übersetzt. Danke. Problem gelöst.

    • Diese Antwort wurde geändert vor 4 Monaten von Thobie.
Ansicht von 10 Antworten - 1 bis 10 (von insgesamt 10)